Hinweise: Edimax EW-7811Un WLAN-Adapter

  • Der Edimax EW-7811Un WLAN-Adapter wird im Zusammenhang mit dem RaspberryPI ziemlich oft erwähnt / genutzt, allerdings gibt es ein paar Sachen die man beachten muss und die würde ich hier gerne zusammentragen :thumbs1:



    ihr könnt auch Allgemeine Hinweise zu anderen WLAN-Adapter aufführen - aber bitte keine Probleme diskutieren oder Fragen stellen



    [hr]



    Energiesparmodus


    Der Edimax EW-7811Un WLAN-Adapter hat (leider) einen Energiesparmodus der standardmäßig nach einiger Zeit aktiviert wird - der Stick kann dann nur vom PI aus wieder aufgeweckt werden, was oft zu Problemen führt...


    Zum Glück lässt sich der Treiber entsprechend anpassen um diesen Energiesparmodus zu deaktivieren. Dazu editiert ihr folgende Datei:

    Code
    sudo nano /etc/modprobe.d/8192cu.conf


    Und trag dort folgendes ein:

    Code
    options 8192cu rtw_power_mgnt=0 rtw_enusbss=0


    Anschließend den RaspberryPI neu starten :)

  • Ich habe festgestellt, dass, nicht nur beim Edimax, ab und zu die fest vergebene IP (via /etc/network/interfaces) vergessen wird und sich der Raspi eine neue vom DHCP server holt. Warum auch immer.


    Ich bin dazu übergegangen folgenden Eintrag in der /etc/network/interfaces für Systeme mit fixer IP-Adresse auszukommentieren:


    Aus

    Code
    iface default inet dhcp


    wird ein

    Code
    #iface default inet dhcp
  • Wenn Du die IP selbst fest eingetragen hast, ist der Eintrag auch nicht mehr sinnvoll.


    Wenn Du mit "fest eingetragen" die bisher vom DHCP Server vergebene IP meinst:
    Das könnte evtl. daran liegen, daß die Leasetime für die IP beim DHCP Server abgelaufen ist.
    Sollte eigentlich nur bei längerer Inaktivität passieren. Man müsste diese dann dort höher einstellen. Aber dann wäre Dein Vorschlag wiederum nicht sinnvoll. ;)


    Wie auch immer, mir sind fest zugeteilte IP's lieber, spart auch etwas Zeit beim Hochfahren und man muß in besonderen Fällen nicht erst "nachgucken".


    Gruß, mmi


    P.S.: Mit Kernel 3.12 gibt es das Modul "8192cu" nicht mehr, da gibt und funktioniert es auch mit "rtl8192cu" (welches ich bisher blackgelistet hatte).

  • mmi,


    bei mir haben alle Geräte eine statische IP-Aresse. Also fix eingetragen und nicht als Reservierung im Router...

  • [EDIT] Es wird doch das korrekte Kernel-Modul genutzt, dann muss es an was anderem liegen, was die ständigen DC verursacht; am Strom kann es nicht liegen, das der Dongle an einem externen aktiven USB-Hub läuft.


    Der Dongle lief bei mir eine ganze Zeit ohne Probleme, aktuell habe ich aber laufend Verbindungsabbrüche, Wenn ich es richtig sehe, nutz der dongle aktuell immer den rt2800usb Treiber. 8192cu ist weiterhin geladen, wird aber nicht verwendet. Kennt wer das Problem?


    Ich nutze XBian 1.0RC2 und einen zusätzlichen wlan-stick der im AP-Mode läuft


    Edited once, last by mdkeil ().

  • Ich konnte nirgends im Web eine info finden ob der stick openelec compatibel ist. Ich möchte hier klarstellen: JA!


    Es geht auf jeden fall:
    Raspbian,
    Raspbmc,
    Openelec

  • Das im EP genannte Problem scheint nicht nur auf den Edimax bezogen. Habe das auch auf einem 300er Pearl Stick gehabt (ebenfalls Realtek Chipsatz).


    Seit dem kommen mir nur noch verkabelte Pis zum Einsatz, da die oben genannte Lösung bei mir nicht funktionierte (mehrere Edimaxe getestet).

    ;) Gruß Outi :D
    Pis: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite) /
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Bullseye 64 Bit Lite (Webserver)) / Pi 400 (Bullseye 64 Bit) / 2x Pi Pico / 2x Pi Pico W
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Die im ersten Post erwähnte Lösung bezieht sich nur indirekt auf den Edimax EW-7811Un, sondern eigentlich auf alle WiFi Sticks in dem der 8192cu Chip zum Einsatz kommt und das sind etliche.


    Ob die Anpassung der /etc/modprobe.d/8192cu.conf Datei funktioniert hat kann man, nach einem Reboot oder neu laden des Modules (rmmod/insmod), mithilfe des folgenden Befehls prüfen:

    Code
    cat /sys/module/8192cu/parameters/rtw_power_mgnt


    Dort sollte 0 ausgegeben werden, um zu bestätigen dass das Power Management abgeschaltet ist.


    Die im ersten Post erwähnte Option rtw_enusbss=0 bewirkt außerdem das "USB autosuspend" abgeschaltet wird.


    In XBian ist diese Lösung übrigens bereits seit Mitte letzten Jahres Standard. (andere Distro's hab ich jetzt nicht geprüft)



    Eine weitere Ursache für Probleme kann aber auch zu wenig Strom sein, da der alte PI-B nur ca. 200-300mA (eher weniger als mehr) für USB-Geräte (ohne aktiven Hub) bereitstellen kann. Wer also neben dem WiFi-Stick auch noch andere USB-Geräte angeschlossen hat sollte es mal ohne diese probieren, also sodass nur noch der WiFi-Dongle angeschlossen ist, und auch nichts über GPIO usw.
    Auch kann die Qualität des Netzteils eine nicht zu verachtende Rolle spielen.



    Aber mehr in punkto Strom usw möchte ich hier ungerne weiter abhandeln - dazu gibt es bereit genug Threads, hier gehts nicht um Probleme sondern Lösungen. :danke_ATDE: