[help] led zu langsam

  • LED 8806 haben leichten delay von ca 0,4sec (112stück)
    um die 80% CPU auslastung
    mplayer2 ist installiert, jedoch keine Änderung zu mplayer
    Grabber -> STK1160 -> mumbi
    Netzteil mit 12A 5V wo alles dran hängt





    die auskommentierten waren nur zum testen drin, die Auflösungen wurden in der hyperion.config.json immer angepasst

    Edited once, last by rapio ().

  • Mein Problem ist das das Ambilight (Hyperion) einfach nicht mit dem Tv Bild Synchron läuft.
    Es hinkt einfach immer hinterher. Nicht schön.
    Diverse Anschauungsobjekte (Videos) im Netz beweisen aber das es möglich ist mir der Synchronität
    Zusätzlich habe ich eine CPU Auslastung von ca 80%. Das ist doch nicht normal oder?
    Andere schreiben sie hätten ca. 20% Auslastung.
    Ich bin schon am verzweifeln.
    Vielleicht hat jemand eine zündende Idee.

  • nun ich hab jetzt 15 FPS eingegeben.
    jetzt verzögert sich das Ambilight noch mehr ca. eine halbe sec.
    Woran erkenne ich ob der mplayer 2 installiert ist.
    Bei mir steht immer noch mplayer.
    Ich hab es wie vorgeschlagen installiert.
    Aktuell sieht es so aus.



    [font="Menlo"][font="Menlo"] 2267 root 20 0 79968 26m 12m S 48.8 6.0 3:05.27 mplayer [/font][/font]
    [font="Menlo"][font="Menlo"] 2152 root 20 0 89904 10m 7604 S 12.4 2.4 0:51.38 hyperiond [/font][/font]


    [font="Menlo"] [/font]


    Code
    /usr/bin/gpio2spi </dev/null >/dev/null 2>&1 &
    /usr/bin/mplayer -tv driver=v4l2:width=96:height=54:device=/dev/video0 -vo fbdev -fs -fps 15 -nosound tv:// </dev/null >/dev/null 2>&1 &


    [Blocked Image: http://www.bilderhoster.net/thumbs/gb3gb7fl.png]

  • Wieso nutzt du nicht einfach den Hyperion-internen Player?
    Hatte zwar in letzter Zeit nur wenig Zeit mich mit Hyperion zu beschäftigen, aber ich hab das mittlerweile seit 3 Wochen so laufen und bin - bis auf die Farbeinstellungen - sehr zufrieden damit!

  • Ich nutze das Image von Assispachtel.
    Danach hab ich Hyperion neu Installiert:



    Code
    wget -N raw.github.com/tvdzwan/hyperion/master/bin/install_hyperion.sh
    sudo sh ./install_hyperion.sh


    Und mit diesen Parametern in der rc.local wird dann der interne Player und eben nicht der Mplayer verwendet:



    Code
    /usr/bin/gpio2spi </dev/null >/dev/null 2>&1 &
    /usr/bin/hyperion-v4l2 --width 360 --height 288 --crop-width 5 --crop-height 10 --size-decimator 3 --frame-decimator 1 --signal-threshold 0.05 --skip-reply
    /usr/bin/hyperiond /etc/hyperion.config.json </dev/null >/dev/null 2>&1 &