USB Soundkarte konfigurieren

  • [size=1][font="Helvetica"]Hallo Zusammen,[/font][/size]
    [size=1][font="Helvetica"]ich bin gerade dabei meine USB Soundkarte zu konfigurieren.[/font][/size]


    [size=1][font="Helvetica"]Dabei habe ich nun das Problem, dass er diese nicht als Standard benutzen will.[/font][/size]


    [size=1][font="Helvetica"]Bei:[/font][/size]



    Code
    aplay /usr/share/sounds/alsa/Front_Center.wav



    [size=1][font="Helvetica"]spielt er die Datei ab, gibt sie jedoch über die interne Soundkarte aus.[/font][/size]


    [size=1][font="Helvetica"]In diesem Forum gibt es jedoch noch den Befehl:[/font][/size]

    Code
    aplay -D plug:hw:1 /usr/share/sounds/alsa/Front_Center.wav



    [size=1][font="Helvetica"]Wenn ich den ausführe, gibt er die Datei auch über die USB Soundkarte aus. Qualität ist auch gut.[/font][/size]


    [size=1][font="Helvetica"]Wie kann ich nun meine USB Soundkarte als erste Karte angeben?[/font][/size]


    [size=1][font="Helvetica"]aplay -l zeigt an:[/font][/size]


    Die alsa-base.conf sieht folgendermaßen aus:



    Ich hatte bereits die oberen Werte mal getauscht, aber es hat nicht funktioniert


    Weiß jemand, was ich einstellen muss, damit die USB Soundkarte richtig funktioniert?


    Gruß
    Mr_C

  • Moin,


    als erstes solltest du mal mit 'lsmod |grep snd' raus finden, wie die benutzten Kernelmodule heissen und ausserdem solltest du besser nicht alsa-base.conf editieren, weil diese Datei bei einem Update überschrieben werden könnte.


    Auf meinem Hauptrechner benutze ich z.B. 3 Soundkarten

    Code
    stefan@debian64:/tmp$ cat /proc/asound/cards
    0 [Intel ]: HDA-Intel - HDA Intel
    HDA Intel at 0xf9ff8000 irq 22
    1 [M2496 ]: ICE1712 - M Audio Audiophile 24/96
    M Audio Audiophile 24/96 at 0xec00, irq 17
    2 [Headset ]: USB-Audio - Logitech USB Headset
    Logitech Logitech USB Headset at usb-0000:00:1d.1-1, full speed


    Für diese Karten habe ich die Datei /etc/modprobe.d/alsa_local.conf mit folgendem Inhalt angelegt:

    Code
    alias snd-card-0 snd_hda_intel
    options snd_hda_intel index=0
    alias snd-card-1 snd-ice1712
    options snd-ice1712 index=1
    alias snd-card-2 snd_usb_audio
    options snd_usb_audio index=2


    Gruß
    Stefan

  • Hallo Stefan,
    irgendwie werde ich aber aus deinem Eintrag nicht schlau.


    Naja...ich hab mal lsmod eingegeben:



    Wobei ich da nicht schlau raus werde :huh:

    Edited once, last by Mr_C ().


  • Orginal steht der Eintrag options snd_usb_audio index auf -2 , damit werden USB Soundkarten ignoriert soweit mir bekannt ist.Damit die USB Soundkarte nicht ignoriert wird ändert man den Wert auf 0 . Was erreicht man , wenn das ganze auf 2 setzt ?

  • Morgen,


    Ich hänge mich da einfach mal mit an, gibt es die Möglichkeit eine usb soundkarte über die Oberfläche xbcm zu konfigurieren? Finde dafür kein Menü.


    Ist eine creativ soundblaster play soundkarte. Will diese zum laufen bringen damit ich musik hören kann obwohl der Fernseher aus ist.


    Schönen Tag