Copy & Paste ins Terminal Problem

  • pi@raspberrypi ~ $ sudo apt-get build-dep unrar-nonfree
    bash: $'sudo\302\240apt-get\302\240build-dep\302\240unrar-nonfree': command not found
    pi@raspberrypi ~ $



    eigentlich ist das ja kein ding, aber ich habe keine ahnung wieso so eine antwort kommt. Kann mir jemand helfen?

    Edited once, last by Bierdieb ().

  • habe schon apt-get und apt-get build via packetmanager neu / reinstalliert, ändert aber nix..
    wie kann man denn so etwas auf die schliche kommen?

  • Ich würde mal vermuten, dass das kein Problem von apt-get ist, sondern ein Problem mit dem Keyboard-Layout.


    Versuch doch mal was passiert, wenn du Putty (oder eine andere SSH Session) verwendest. Wenn es dann geht solltest du dein Keyboard-Layout anpassen. ;)

    "The best way to predict your future is to create it!"

    Edited once, last by s-e-a ().

  • Hallo.


    Das Keyboard layout ist korrket eingestellt.
    Aber bei jeder copy & paste operation von zb einer website in die konsole werden die <space> unsichtbar gegen irgend welche anderen Zeichen getauscht. im Bash test erscheint dann statt eines space 302/202 oder sowas. das ist sehr lästig, zumal das in der vorigen raspian installation nicht so war. ich habe schon die locales utf8 auf en und wieder zurück auf de gestellt.


    Wie kann man diesen käse umgehen? z.b. für build von xbmc müssen eine scheissladung libs eingetragen werden, die tipp ich doch nicht alle ab....


    Wenn ich in der konsole die spaces lösche und wieder einfüge funktioniert der code....


    Hilfe, bitte!


    putty ist für windoof, und mit ssh kenn ich mich noch nicht aus, das wäre schon wieder ein neues thema. dafür muss es doch eine andere lösung geben. ich hab schon gegoogled wie blöd, finde aber nix relevantes.

    Edited once, last by Bierdieb ().

  • Guten Morgen,


    ich habe folgendes gefunden:


    https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/218637


    Ich weiß das ist für ein anderes OS, aber der Fehler scheint gleich zu sein:


    Versuche mal über das Terminal folgenden Befehl:


    Code
    setxkbmap -option "nbsp:none"



    Oder optional kannst du auch deine xorg.conf editieren und unter der Sektion [font="monospace"]InputDevice folgendes hinzufügen:[/font]





    Code
    Option "XkbOptions"    "nbsp:none"




    Nicht vergessen... Wenn du vorher ein Backup der Datei machst, bist du auf der sicheren Seite! :D

    "The best way to predict your future is to create it!"

  • ich habe die beiden varianten ausprobiert. es ändert garnichts. ich kann nichts aus einer website kopieren und ins terminal pasten, alle " " (Spaces) werden dabei verpfuscht.
    ich werde noch kirre, das nervt voll! habe den ganzen tag google ausgequetscht aber nix hat gepasst.

  • Ich habe herausgefunden, dass \302\240 die Unicode Sequenz für "unbreakable space" ist. In einem Post wurde empfohlen folgendes commando in die shell einzugeben:


    setxkbmap -option "nbsp:none"


    oder


    Option "XkbOptions" "nbsp:none"


    in die xorg.conf


    Beides hatte keine Auswirkungen. Mein Keyboard Layout ist auf DE UTF8 eingestellt, die Location auch auf DE.


    Wäre klasse wenn mir dabei jemand helfen könnte.

  • So siehts bei mir aus und klappt.


    raspi:~$ locale -a
    C
    C.UTF-8
    POSIX
    en_US.utf8


    raspi:~$ echo $LANG
    C


    Deutsche Systemumgebung tu ich mir nicht an.


    Karlo

    Edited once, last by Karlo ().

  • Nachdem ich wheezy neu aufgesetzt hab funktioniert es wieder problemlos. keine Ahnung ob das durch irgendein paket das ich installiert habe oder eine Einstellung verursacht wurde. Doof wenns nochmal passiert und man noch immer nicht weiss wodurch.