Innerhalb welcher Spannung läuft der RasPi stabil?

  • edit
    Die Diskussion ergab: Die Eingangsspannung sollte zwischen 4,75V und 5,25V liegen



    Ich bin dabei, ein KIS Modul passend einzustellen, um es zur Spannungsversorgung zweier RasPis zu benutzen. Wie im Link zu sehen, sind Elkos (470µF) an Ein- und Ausgang vorhanden. Da diese Module hier im Forum in den höchsten Tönen gelobt wurden, ging ich von einer sehr stabilen Ausgangsspannung aus. Dem ist aber nicht so.


    Am Eingang stehen 12V mit 5A zur Verfügung. Ich habe das Modul auf 5,05V bei einer Last am Ausgang von rund 1A eingestellt. Reduziere ich die Last auf 0,3A, was in etwa einem einzelnen headless RasPi entspricht, dann steigt die Spannung auf rund 5,2V an.


    Wenn ich eine Last von rund 2A drauf gebe, was dem Verbrauch zweier RasPis mit etwas Peripherie entsprechen könnte, dann bricht die Spannung auf 4,9V ein.


    Meine Frage ist nun, ob der RasPi in diesem Spannungsbereich sauber läuft, oder ob es Probleme geben könnte.


    Die nächste Frage wäre, wie stabil die 3,3V Spannung onboard bleibt, wenn ich den RG2 gegen ein KIS-Modul tausche und es zu Lastwechseln kommt, weil externe Gerät angschlossen oder abgeklemmt werden.


  • Ich bin dabei, ein KIS Modul passend einzustellen, um es zur Spannungsversorgung zweier RasPis zu benutzen. Wie im Link zu sehen, sind Elkos (470µF) an Ein- und Ausgang vorhanden. Da diese Module hier im Forum in den höchsten Tönen gelobt wurden, ging ich von einer sehr stabilen Ausgangsspannung aus.


    Dem ist aber nicht so.


    ohne deine Verkabelung zu kennen wird das schwer, bist du sicher es liegt am KIS oder sind deine Kabel zu dünne ?
    Wo misst du ?


    Es kann natürlich auch mal ein schwacher KIS in einer Lieferung sein, von einem KIS würde ich nicht auf alle schliessen wollen.




    Wenn ich eine Last von rund 2A drauf gebe, was dem Verbrauch zweier RasPis mit etwas Peripherie entsprechen könnte, dann bricht die Spannung auf 4,9V ein.


    auch bei 2200µF Kondensator am Ausgang ? die Regel 1000µF pro A gilt zwar nur bei 50Hz aber kann bei Schaltregler auch nicht schaden :D
    Ich jedenfalls konnte sowas mit 1000µ am Ausgang nicht beobachten



    Am Eingang stehen 12V mit 5A zur Verfügung. Ich habe das Modul auf 5,05V bei einer Last am Ausgang von rund 1A eingestellt. Reduziere ich die Last auf 0,3A, was in etwa einem einzelnen headless RasPi entspricht, dann steigt die Spannung auf rund 5,2V an.


    150mV Änderung finde ich jetzt nicht so dramatisch vor allem nicht wenn ich nicht weiss welche Strippen wie und wo gemessen.



    Meine Frage ist nun, ob der RasPi in diesem Spannungsbereich sauber läuft, oder ob es Probleme geben könnte.


    da ich deine Beobachtung nicht gemacht habe hilft dir "ich habe keine Probleme seit Monaten" von mir wenig.



    Die nächste Frage wäre, wie stabil die 3,3V Spannung onboard bleibt, wenn ich den RG2 gegen ein KIS-Modul tausche und es zu Lastwechseln kommt, weil externe Gerät angschlossen oder abgeklemmt werden.


    Lastwechsel, auf den 3,3V unwahrscheinlich, wo sollen die im großen Maße herkommen, nur wenn du am GPIO dicke 3,3V Verbraucher an und ab steckst


    wie gesagt 2 PI mit KIS umbau RG2 laufen seit Monaten.


    PI3 muss ich noch umbauen da könnte ich das alles mit Strom hoch und runter vermessen auch mit den Auswirkungen 470µ 1000µ 2200µ


    sorry bin aber noch nicht soweit, viel zu tun und um die Ohren.



    PS. für 5V (und viele andere gilt +-5% wären als Obergrenze 5,25V und Untergrenze 4,75V der PI soll unterhalb 4,7V(oder höher ?) zicken können aber nur bei overclock und overvoltage

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Vielen Dank für die umfangreiche Antwort. Ich werde den Tip mit der Dimensionierung der Elkos heute Abend testen. Das zweite Modul zeigt übrigens die gleichen Probleme. Als Messleitungen dienen diese hier in verschiedenen Längen: http://www.reichelt.de/Laborle…624&artnr=MLN+25+25+AU+RT


    Netzteil - KISeingang --->KISausgang - PM2525 (Strom) - elektronische Last - KISausgang
    parallel zur elektronischen Last hängt ein 8050A (Spannung)


  • Vielen Dank für die umfangreiche Antwort. Ich werde den Tip mit der Dimensionierung der Elkos heute Abend testen. Das zweite Modul zeigt übrigens die gleichen Probleme. Als Messleitungen dienen diese hier in verschiedenen Längen: http://www.reichelt.de/Laborle…624&artnr=MLN+25+25+AU+RT


    Netzteil - KISeingang --->KISausgang - PM2525 (Strom) - elektronische Last - KISausgang
    parallel zur elektronischen Last hängt ein 8050A (Spannung)


    ja aber ohne Klemmen (was ja auch Schwachpunkte sind) kommt man ja mit Ampere ! nicht runter vom KIS


    genauer wird es mit min. 1,5mm² direkt am KIS Ausgang und GND angelötet !, der Kondensator sollte auch kurz an den KIS angelötet werden. Was nutzt die beste Messstrippe wenn die Klemme einen Minikontakt herstellt mit einigen 100mOhm bis Ohm.


    50mOhm Übergangswiderstand an 2A sind schon mal 100mV Verlust !

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Okay, auch das werde ich heute Abend passend umbauen und dann berichten. Ich denke dann wird es darauf hinaus laufen, dass ich ein KIS Modul direkt auf Lochraster löte und an Ein- und Ausgang direkt zum Kabel die Elkos anbringe.


    Könntest Du mir noch sagen, von wo nach wo welcher Widerstand gesetzt werden muss, damit ich von den 12V auf gut 5V komme? Waren das die 9,1K zwischen Adj. und GND?


    Für den Austausch von RG2 war kein Widerstand nötig, wenn ich das richtig in Erinnerung habe?!


  • Der PI benötigt mindestens 4,75 Volt, weniger führt zu instabilität


    na Klasse :thumbs1:


    damit sind meine +-5% ja bestätigt, ich hatte nur im Hinterkopf das einer bei 4,7x Probleme hatte.....


    gut das wäre die Grenze und an Grenzen ist es immer gefährlich :lol:




    .... auch die Maximalspannung?


    üblich gilt +5%


    aber viele Chips die für 5V ausgelegt sind gehen bis 6V einige bis 7V eine harte 5,25V Grenze gibt es nicht (nur ganz wenige Chips habe ich mit 5,4V gesehen als DC Grenze)


    für den PI habe ich im Leerlauffall 5,25V vorgesehen was bei Last eben weniger bedeutet.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Danke. Ihr seid spitze.


    http://31.media.tumblr.com/tum…n4zJ86A1rpp9doo1_1280.jpg


    Das Bild finde ich einfach allessagend...


    Ich bin ja echt mal gespannt, wie stabil die Ausgangsspannung bei 2000 - 3000µF sein wird. Ich habe (in akzeptabler Größe) nur maximal 2.200µF/13V rumliegen und würde den einfach parallel zu einem 1.000µF/13V löten.


    Würden die 470µF bei eingangsseitig 12V ausreichen oder sollte man da auch noch nachlegen?


  • Der PI benötigt mindestens 4,75 Volt, weniger führt zu instabilität


    Gilt das für den Stromeingang oder bei den Messpunkten auf dem Pi?


    Also ich hab Eingang 5v und bei den Messpunkten 4,61v.
    Er läuft aber stabil auch bei Pi (Zahl) Berechnungen.

    Edited once, last by sirmg ().

  • -> http://elinux.org/R-Pi_Trouble…leshooting_power_problems


    Quote

    You should see a voltage between 4.75 and 5.25 volts. Anything outside this range indicates that you have a problem with your power supply or your power cable.



    A multimeter only displays the average voltage. If there are very short-lived dips or spikes in the voltage, these will not be shown by the multimeter. It is best to measure voltage when Pi is busy.

  • Also wenn ich Ihn auslaste mit Pi Berechnung und omxplayer via s-video dann hat er 4,57v.
    Angeschlossen ist wifi und USB-Empfänger Keyboard.


    Laufen tut er trotzdem brav ^^ Vielleicht hab ich einfach glück....


  • Würden die 470µF bei eingangsseitig 12V ausreichen oder sollte man da auch noch nachlegen?


    kommt auf das Leistungsprodukt an


    ich "glaube" das reicht, aber mehr am KIS Eingang ist kein Fehler weil der dann sauberer schalten kann
    [hr]


    Also wenn ich Ihn auslaste mit Pi Berechnung und omxplayer via s-video dann hat er 4,57v.
    Angeschlossen ist wifi und USB-Empfänger Keyboard.


    Laufen tut er trotzdem brav ^^ Vielleicht hab ich einfach glück....


    ohne overvoltage kann das durchaus gut gehen !

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Vielleicht hab ich einfach glück....


    Das würde ich stark annehmen. Aber leider schreibst du nicht ob du ihn Übertaktest hast usw, aber das Spielt selbstverständlich auch ne Rolle


    Ich hab selber mal Probleme gehabt und dazu einige Recherchen getätigt, mit dem Resultat das der RPI bei 7 von 10 Fällen Probleme verursacht sobald die Spannung kurzfristig (millisekunden) unter 4.75V fällt....


    Ob das jetzt bei jedem hier im Forum der Fall ist wäre hierfür denk ich nebensächlich - der TE sollte einfach darauf achten möglichst nicht unter 4.75V zu kommen und damit wäre die Untergrenze geklärt.


    Als Obergrenze würde ich 5.25V anvisieren


    Noch mal mehr Details zu solchen "Strom Fragen" sind auch hier beschrieben: http://elinux.org/RPi_Hardware#Power_Supply_Problems



    Und hier steht übriegens auch noch was zum Thema PSU: http://elinux.org/RPi_5V_PSU_construction


  • Ich hab Ihn auf "medium" übertaktet.


    Übertaktung ist noch keine overvoltage wenn ich mich nicht irre :D


    wie gesagt kann ja gut gehen, vielleicht ist deine Messung auch falsch, das ist hier alles nur Rätselraten.


    Man sollte immer daran denken wer mißt mißt Mist und wer viel mißt mißt viel Mist.


    Die wenigsten Messgeräte taugen was und wer meist hobbymäßig unterwegs ist gönnt sich selten Messausrüstung in 4-5 stelliger € Preislage und dann sind so dynamische Verbraucher wie eine CPU oder andere Digitalchips ja nicht in jeder ns zu überwachen, was man allenfalls sieht ist eine Tendenz.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Nun bin ich doch noch dazu gekommen, es zu testen. Hier das Ergebnis:


    Ich habe ein einzelnes KIS-Modul (also keines der beiden genannten, fertig aufgebauten) seines Gehäuses entledigt, es auf eine Lochrasterplatine gesetzt, einen 1.000µF Elko am 12V Eingang, so wie einen 2.200µF Elko am 5V Ausgang gesetzt und von Adj. nach GND einen 9,52KOhm 1%er gelötet. Alle Lötstellen wurden mit reichlich Lötzinn bedacht, so dass es zumindest auf der Lötseite keine zu niedrigen Querschnitte gibt.


    Das Ergebnis ist erstaunlich. Der Versuchsaufbau ist identisch.


    0,0A - 5,16V
    0,3A - 5,15V
    1,0A - 5,10V
    1,5A - 5,07V
    2,0A - 5,04V


    Mit dem Ergebnis kann ich gut leben. Da geht die Spannung nicht zu stark in die Knie, aber auch nicht zu sehr in Richtung Obergrenze geht.


    Das KIS-Modul, dass ich direkt auf dem RasPi als Ersatz für RG2 gesetzt habe, liefert zwischen Pin1 und Pin9 3,26V. Der RasPi läuft allerdings auch im Leerlauf, ist nicht übertaktet und es sind weder Verbraucher an den USB Ports, noch externe Geräte angeschlossen. Den Elko am Mikro-USB-Port Stromeingang habe ich gegen einen mit 1000µF getauscht. Zusätzlich habe ich ebenfalls einen 1000µF Elko parallel zum Kondensator neben den USB-Ports gelötet.


    Wie starkt darf die 3,3V Schiene eigentlich schwanken? Gilt hier auch die +-5% Regel? Das wären dann 3,135V - 3,465V.


  • na super :thumbs1: ich habs auch nicht anders erwartet, ich finde die KIS geil, sauberes Design in der Aussenbeschaltung vorausgesetzt



    Das KIS-Modul, dass ich direkt auf dem RasPi als Ersatz für RG2 gesetzt habe, liefert zwischen Pin1 und Pin9 3,26V. Der RasPi läuft allerdings auch im Leerlauf, ist nicht übertaktet und es sind weder Verbraucher an den USB Ports, noch externe Geräte angeschlossen. Den Elko am Mikro-USB-Port Stromeingang habe ich gegen einen mit 1000µF getauscht. Zusätzlich habe ich ebenfalls einen 1000µF Elko parallel zum Kondensator neben den USB-Ports gelötet.
    Wie starkt darf die 3,3V Schiene eigentlich schwanken? Gilt hier auch die +-5% Regel? Das wären dann 3,135V - 3,465V.


    ich gehe auch mal von +-5% aus, auch die 3,3V kann man ja trimmen, von ADJ. nach 3,3V wer mag, aber 3,26V sieht doch nahezu perfekt aus rund 1% Abweichung ist fast nix, man könnte fast sagen Messgerätequalität !

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Nun bleibt noch die Frage, wie ich den Saft am sinnvollsten in den RasPi bekomme. Ich habe vor, zwei RasPis in ein 19" Gehäuse zu setzen. Von extern kommen 12V, die gehen durch ein KIS-Modul und werden zur 5V Versorgungsspannung für die RasPis


    Ich habe vor, die GPIOs per Pfostensteckerverbindung komplett auf eine externe Platine zu bringen, damit ich die externe Hardware vernünftig installieren kann.


    Meine ursprüngliche Idee war, die 5V vom KIS-Modul auf diese externe Platine zu legen und den RasPi über die GPIOs zu versorgen. Nach unserer Diskussion mache ich mir aber nun Gedanken darüber, ob der Querschnitt des Flachbandkabels überhaupt ausreichend ist. Sollte man besser direkt beide 5V GPIOs (Pin1 und Pin3) nehmen? Minus würde dann natürlich auch über zwei Leitungen zum RasPi geführt.


    Eine Versorgung über USB scheidet aus, da ich beide Ports frei haben möchte. Mikro-USB scheidet wegen der 1A Begrenzung aus. Dann bliebe höchstens noch das direkte Anlöten.


    Im Moment ist nicht absehbar, dass der RasPi mehr als 3 Watt benötigen wird, aber wer weiss, was für Ideen hier im Forum noch entwickelt werden, die dann nachgebaut werden wollen ;)


  • Nun bleibt noch die Frage, wie ich den Saft am sinnvollsten in den RasPi bekomme. Ich habe vor, zwei RasPis in ein 19" Gehäuse zu setzen. Von extern kommen 12V, die gehen durch ein KIS-Modul und werden zur 5V Versorgungsspannung für die RasPis


    Ich habe vor, die GPIOs per Pfostensteckerverbindung komplett auf eine externe Platine zu bringen, damit ich die externe Hardware vernünftig installieren kann.


    Meine ursprüngliche Idee war, die 5V vom KIS-Modul auf diese externe Platine zu legen und den RasPi über die GPIOs zu versorgen.


    Die Idee ist doch gut und ich mache es genauso und finde das den besten Weg !



    Nach unserer Diskussion mache ich mir aber nun Gedanken darüber, ob der Querschnitt des Flachbandkabels überhaupt ausreichend ist.


    Jeder Pin ist für rund 1A gut, auch im Flachkabel, aber ich habe Crimpkontakte gewählt weil ich die einzeln anschliessen kann nach Bedarf und für die Powerleitungen auf 0,25mm² statt 0,14mm² verstärken konnte.


    Eine Sicherung kann man ja vorschalten wer mag, 1,5A oder 2A


    nimm beide +5V Power Pins für + und 2 Power Pins für GND, je 2x 0,25mm² das reicht für die 5V Power
    wenn du RG2 zu KIS tauschst und 3,3V raussaugen willst gilt gleiches für die 3,3V auch doppelt nutzen und GND auch


    http://www.forum-raspberrypi.d…sensor?pid=40436#pid40436
    http://www.forum-raspberrypi.d…sensor?pid=42781#pid42781


    [Blocked Image: http://www.forum-raspberrypi.de/attachment.php?aid=1661]




    Eine Versorgung über USB scheidet aus, da ich beide Ports frei haben möchte. Mikro-USB scheidet wegen der 1A Begrenzung aus. Dann bliebe höchstens noch das direkte Anlöten.


    Ich bin ja noch in Planung die Microfuse durch passendes aber stärkeres zu ersetzen, habe schon Lieferanten gefunden, aber der Schwachpunkt microUSB bleibt da ja.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)