pilight - 433Mhz Funksteckdosen, Funkdimmer und mehr schalten und darstellen


  • Auch hier gilt die Formatierung ist grausam und nicht json konform, dann geht das nicht.
    Die config muss immer richtig formatiert und json konform sein. Am besten benutzt man unter Windows notepad++(Freeware), oder unter Linux (zb. Ubuntu) gedit. Die Editoren zeigen auch gleich Fehler in der Formatierung und um ganz sicher zu gehen unter jsonlint.com überprüfen.
    Probier mal die nachstehende config und passe den systemcode und unitcode an. Bitte in Zukunft Code Tags benutzen, das macht alles übersichtlicher und steht auch sicherlich so in den Forumregeln :)



    lcd4linux

    ___________________________________________________________________________________
    lcd4linux

    Edited once, last by lcd4linux ().

  • Super Tips! Vielen Dank, es läuft jetzt :)
    Zwar nicht mit dem Zusatz aus dem SHC, aber hier wurde mir geholfen und es läuft! Top, besten Dank :D

  • Hallo zusammen,


    vielleicht erspart es jemandem von euch ein paar Minuten:


    Ich verwende einen Empfänger am Pi der über 2x DATA verfügt (CEG006400).
    Auf der Rückseite sind die vier (!!) Pins (von links nach rechts) mit GRND, DATA und VCC gelabelt.


    Meinem B+ war mit "pilight-raw" vollkommen egal welchen DATA ich verwendet habe, "pilight-receive" hat allerdings nur auf den ganz rechten DATA reagiert (neben VCC).
    Ich habe mehrere dieser Sender & Empfänger hier liegen und bin fast daran verzweifelt……


    Gruß,
    Dominik

  • Hallo,
    muss nochmal nachfragen.


    schalten meiner REV Steckdosen geht ja inzwischen,


    einschalten: pilight-send -p cleverwatts -i 565951 -u 1 -t
    ausschalten: pilight-send -p cleverwatts -i 565951 -a 1 -f


    aber wie man sieht mit zwei unterschiedlichen Befehlen, gibt es da auch eine Möglichkeit das in die Config einzubauen, so das das auch mit der Web Gui funktioniert?

    Wenn ich den Parameter "a" oder "all" mit angebe, startet Pilight nicht mehr!

  • Hallo zusammen,


    pilight und pimatic liefen bei mir mit der stable von pilight eigentlich einwandfrei.
    Für das "elro_he_contact"-Protokoll (Türkontakt) habe ich nun aber die nightly von pilight installiert und seitdem will pimatic nicht mehr.


    Im Log steht folgendes:

    Quote


    19:41:10.423 [pimatic-pilight] warn: Lost connection to pilight-daemon
    19:41:10.484 [pimatic-pilight] info: pilight: trying to find pilight via SSDP
    19:41:10.652 [pimatic-pilight] info: pilight: found pilight server 192.168.178.32:43175, trying to connect


    … immer und immer wieder, irgendwann steigt der daemon aus wenn ich den Service nicht manuell beende.


    Folgende Version von pilight läuft gerade: pilight-daemon version 5.0, commit v5.0-167-g563e6d0


    Ist das ein grundsätzliches Problem mit den nightlies oder kann es unter Umständen mit dem nächsten commit schon behoben sein?



    Gruß,
    Dominik

  • Hallo,


    hab noch etwas gespielt, getestet mit meinen Rev Steckdosen,
    dabei eine Möglichkeit gefunden sie über die Web Gui aus zu schalten.


    ist zwar nicht ganz zufriedenstellend, aber es geht schon mal.
    einschalten mit als Switch und ausschalten mit der Funktion Program.



    seltsamer Weise muss ich den Befehl zum ausschalten bei start-command angeben.
    was ich bei stop-command angebe ist egal, da tut sich nichts.
    ich hatte gehofft ich könnte mit dem Program Befehl die Dose auch einschalten, aber das geht nicht, auch der Status bleibt immer auf stopped!


    Vieleicht hat noch jemand eine bessere Lösung?

  • :helpnew:


    Hallo,


    ich benutze pilight 5.0 stable und wollte mit pilight-raw und pilight-debug eine Funkfernbedienung auslesen, was jedoch nicht funktioniert.


    Ich erhalte folgende Fehlermeldung:

    Code
    pi@raspberrypi ~ $ [Jan 10 13:22:30:356562] pilight-raw: ERROR: pilight-daemon instance found (2158)


    Auch wenn ich den pilight service stoppe erhalte ich die Fehlermeldung.


    Woran kann das liegen?


    Danke im Vorraus.


  • Die Fehlermeldung zeigt, das noch der Daemon läuft. Gib mal folgendes ein:

    Code
    top


    und schaue ob noch eine Instanz von pilight läuft. Schließen kannst Du das Fenster mit


    Code
    Strg+c

    ___________________________________________________________________________________
    lcd4linux


  • Ja läuft noch. Habe versucht den den daemon mit kill 2158 zu beenden, aber der läuft einfach weiter.


    Habe jetzt einfach das Skript /etc/init.d/pilight kurz ins nach /home/pi/ kopiert und den Pi rebootet. Jetzt läuft pilight-debug.


    Wird dann nach hoffentlich erfolgreicher Arbeit wieder zurück kopiert.

  • ich habe mir piliight jetzt auch mal angetan.
    Haber version 5.0 aber meine config.json sieht ganz anders aus.
    irgendwie bilcke ich jetzt nicht mehr durch


    Wo muss ich jetzt was eintragen?


  • Schau mal in diesem Beitrag, da habe ich eine config nach dem neuen Format gepostet.

    ___________________________________________________________________________________
    lcd4linux

  • Hi,
    ich hoffe ich bin hier richtig.


    Ich bekomme es nicht hin, meine Mumbi FA500S Funksteckdosen über Pilight zu schalten.
    Die Funksteckdosen sind leider "selbstlernend", damit war mir klar, dass ich den Code den die FB sendet auslesen muss. Ich hatte gehofft, dass ich so schon nahe am Ziel bin und habe die einzelnen Protokolle per Pilight gesendet wie z.B

    Code
    sudo pilight-send -p home_easy_old -s 9 -u 4 -t


    Leider reagierte die Steckdose auf keines der gesendeten Protokolle...



    Das ist der per pilight-receive ausgelesene Code für die Taste B.


    Hat irgendwer evtl die gleiche Baugruppe und kann mir weiterhelfen?


    :danke_ATDE:


    Gruß Chrissi

  • Trage das was Du oben gesendet hast in die config ein, starte pilight, bringe die Funksteckdose in den Lernmodus und schalte in der Web Oberfläche die Steckdose. Nun sollte die Steckdose sowohl auf die Fernbedienung sowie auf pilight reagieren. Das entsprechende Protokoll gibt es noch nicht, wurde aber im pilight Forum schon diskutiert.

    ___________________________________________________________________________________
    lcd4linux

  • Danke für die schnelle Antwort.


    Ich scheitere irgendwie daran mehrere Protokolle mit einem Klick aus dem Web-GUI zu senden.


    Ich habe für den Anfang das Senden mit 2 Protokollen versucht.
    Fürs erste unabhängig vom Systemcode und Unitcode.


    Das war mein erster Versuch der lies sich nicht kompilieren.

    Code
    pilight-daemon: ERROR: config device #2 "lampe", duplicate
     failed!


    Der zweite Gedanke war mehre Protokolle nacheinander aufzuführen.


    Damit lässt sich die Config auch kompilieren, aber mit pilight-receive sieht es so aus, als wenn nur ein Protokoll gesendet wird.


    Was muss ich in die Config eintragen, so dass mehrere Protokolle auf einmal gesendet werden?
    Oder bietet es sich eher an sich nach Dipschalter Funksteckdosen umzusehen?


    Gruß Chrissi

  • Trage bitte nur ein Protokoll ein, das mit den Meisten "repeats" aus dem pilight-receive Output. Danach pilight starten, Webgui öffnen, Funkschalter in den Lernmodus versetzen und dann in der GUI schalten.

    ___________________________________________________________________________________
    lcd4linux

  • solangsam bekomme ich ne meise...
    jetzt habe ich alle daten per hand eingetragen mit Notepad++(utf-8, alles per hand)
    und ich bekomme ein:
    pilight-daemon: ERROR: config is not in a valid json format


    kann sich mal bitte einer mein config anschauen?



    zu not schicke ich sie auch per email
    [hr]
    Mist vergesste es
    nach dem ich den Code hier noch mal per cut&past über putty in die Datei eingefügt habte funzt das ganze

    Edited once, last by ProudSound12121 ().

  • Hallo,
    hat jemand Ahnung wie man ein Sendebefehl verlängern kann?
    mein Problem,
    hab mir jetzt von Intertechno die Rolladenschalter geholt, funktioniert soweit alles ganz gut.
    Nur manchmal schaltet der Rolladen dann doch nicht, ich denke die Sendedauer ist zu kurz.
    ich schalte aus einem PHP Script mit dem Befehl
    "sudo pilight-send -p intertechno_old -i 0 -u 2 -f"
    2 mal senden geht auch nicht, da der Schalter beim 2. mal der Rolladen stoppt, muss mindestens 2 Minuten Pause dazwischen sein.


    Edit:
    hab gerade noch mal nachgelesen und mir die settings.json nochmal angesehen.
    da ist ja die Zeile:


    "send-repeats": 10,


    kann ich den Wert erhöhen? ist das dann nur für die WebGui oder auch für den direkten Befehl ?
    sudo pilight-send -p intertechno_old -i 0 -u 2 -f

    Edited once, last by ws65 ().

  • Hallo,
    habe ein problem mi der Webgui/app. Ich kann meine Mumbi Steckdose anschalten, aber nicht wieder ausschalten. Hat einer eine Idee voran das Liegt?
    MfG Eragon