Stromzähler über IR-Sensor auslesen und über Volkszähler anzeigen

  • Nur mal zum Verständniss, ich habe die GPIO 4 und 18 jetzt in der vz konfiguriert.
    wenn ich die jetzt einfach mal mit nem Kabel gegen 3,3V oder Masse lege sollte er doch einen High bzw. Low registrieren oder?


    Danke
    Gruß

  • Das ist richtig. Du könntest den internen Pullup aktivieren und dann den GPIO gegen Masse legen. Wenn der interne Pullup nicht aktiv ist, musst Du einen externen Pullup vom GPIO auf 3,3V legen und dann den GPIO testweise gegen Masse schalten. Ist kein Pullup vorhanden, wirkt der GPIO wie eine Empfangsantenne und Du hast willkürliche Signale.


    Ist der interne Pullup aktiviert und Du installierst zusätzlich einen externen Pullup, dann nimm einen hohen Wert, denn es gilt dann die Formel der parallelen Schaltung von Widerständen.

  • Hallo,


    habe ich das richtig verstanden, das da eine gelbe LED blinkt, und die Impulse gezählt werden sollen ??


    wenn dem so ist, kanst Du jeden Fototransistor nehmen. Und den muß man nicht unbedingt kaufen. Und schon gar nicht wenn man keinen Laden vor der Tür hat.


    Solche Teile kan man z.B. aus einer alten Maus mit Kugel, einem Gabel-Optopopler aus einem alten Drucker, Fax oder Kopierer und vielen anderen Geräten ausbauen. Im Zweifel einfach mal in Onlinschop schauen, wie solche Teile aussehen und dan nach Elektronikschrott stöbern. Die Teile haben in der Regel nr 2 Anschlüsse, weil die Basis nicht herausgeführt ist. Wenn man nicht genau weiß, wie die Anschlüsse belegt sind, dan einfach ausprobieren.


    Einen 10- 47 KOhm Widersand an 3,3V das andere Ende des Widerstandes an den Fototransistor. Den 2. Anschluß des Transistors an Masse. Bei richtiger Polung bricht die Spannung am Transistor bei Licht zusammen. Wenn man den Transistor mit etwas lichtundurchlässigem abdunkelt, dann steigt die Spannung. Einfach probieren wie es am besten geht. Da kann auch weder was pasieren noch kaput gehen.


    Der Anschluß, der beim Test an Masse ist, kommt dann bei Raspi auch an Masse und der andere an den GPIO.

  • Herzlichen Dank für Deine Auführung. Ich werde es genau so einmal testen.
    Wie sieht es den mit der Programmierung der Eingänge aus.
    Ich wolte die Pins 4 und 18 verwenden. Wenn ich diese (Pin 4 oder 18) jetzt auf 3,3V lege oder auf GND sollte er doch einen Impuls anzeigen oder?
    Es kommt aber weiterhin no Data.


    Hier ein Auszu aus meiner zvconfig


    {
    "enabled": true,
    "allowskip": false,
    "interval": -1,
    "aggtime": -1,
    "aggfixedinterval": false,
    "channels": [
    {
    "uuid": "1cf6ee60-f373-11e6-b53c-15ed91e37610",
    "identifier": "Impulse",
    "api": "volkszaehler",
    "middleware": "http://127.0.0.1/middleware.php",
    "aggmode": "none",
    "duplicates": 0
    }
    ],
    "protocol": "s0",
    "gpio": 4,
    "configureGPIO": true,
    "debounce_delay": 0
    },


    -------------------------------------------------------------------------------------
    und in der rc.local:


    # GPIOs exportieren und Datenrichtung einstellen.
    echo 4 > /sys/class/gpio/export
    echo 18 > /sys/class/gpio/export
    echo out > /sys/class/gpio/gpio4/direction
    echo out > /sys/class/gpio/gpio18/direction

  • Servus,
    was hast Du denn jetzt genau gemacht?
    Zudem: Dein Zähler verfügt doch über eine S0 Schnittstelle ... es würde mich wundern, wenn Du an die physikalisch nicht drankommst. Das ist ja Sinn und Zweck der Geschichte ...
    Hast Du da mal genau nachgesehen bzw. Deinen Stromlieferanten kontaktiert? Das müssten zwei Anschlüsse sein, die (meistens) potentialfrei sind.


    cu
    -ds-

  • Halle dreamshader
    Ja das stimmt der hat eine s0 Leider aber unten bei den Anschlüssen die mit einer blombe versehen sind. Sprich da komme ich nicht dran.
    Das Hauptproblem aktuell ist ja auch eher das der vz nichts loggt. Denke ich habe die gipo nicht richtig programmiert.....



    Zur detektion habe ich mir jetzt mal ein paar fototransistoren mit einer Wellenlänge von 585-590 nm
    Besorgt. Mal testen welche gehen.
    Wollte aber vorher einfach mal mit einem Kabel zu 3.3v durchschalten um zu schauen ob überhaupt etwas geloggt wird.

  • Ich würde übrigens trotzdem mal beim Energieversorger anfragen ...


    Ok, weisst Du, wie so eine S0-Schnittstelle funktioniert?
    Das ist ja "normalerweise" (so was wie) ein Optokoppler ... d.h. vom Prinzip her wie ein Taster.
    Umgelegt auf Deinen Aufbau: -> http://www.forum-raspberrypi.d…s-ist-ein-pullup-pulldown


    Wenn Du das nach obigem Prinzip verdrahtest, sollten auch passende Pulse ankommen.


    //EDIT: bevor Du direkt mit einem Kabel von 3V3 / GND auf einen der GPIOs losgehst: schalte einen Widerstand > 1 kOhm zur Strombegrenzung dazwischen ... Dein Pi wird's Dir danken ;)


    cu,
    -ds-

  • Herzlichen Dank für den Hinweis, kann es also sein, dass ich mit den GPIO4 jetzt schon geschrottet habe ;(
    Hatte den mal wechselnd direkt auf GND und 3,3V gesteckt.
    Wie programmiere ich das ganze, also von der Beschaltung ist es mir jetzt soweit klar.


    Dann nehme ich jetzt einen anderen GPIO ;)

  • Einen einzelnen GPIO zu himmeln mag möglich sein, aber ich würde davon ausgehen, dann noch mehr dabei kaputt gehen würde.
    Ein einfacher Test mit Vorwiderstand und LED würde Klarheit bringen: https://www.raspberrypi.org/do…age/gpio-plus-and-raspi2/


    Vielleicht ist das Problem viel banaler. Hast Du wirklich den richtigen GPIO erwischt? Hier noch mal die Bezeichnungen:
    https://www.element14.com/comm…-gpio-40-pin-block-pinout

  • Hallo,


    Überspannung bringt fast immer das totale Aus. Ein Kurzschluß gegen Masse überlastet dagegen nur einen Transistor und kann einen einzigen GPIO abschießen.


    Zum basteln und probieren kann man sicher mit dem Raspi arbeiten, um nicht noch einen Raspi zu schrotten. Aber ob in der Zkunft nicht irgend welche Spätfolgen auftreten kann keiner garantieren. Für irgend welche Überwachungsaufgaben würde ich den nicht mehr einsetzen.

  • Hallo zusammen,


    ich habe mal folgendes probiert: Ich habe mir mal den Beitrag v on hier:
    https://blog.webernetz.net/201…m-raspberry-pi-auswerten/
    angeschaut und entsprechend meine installation gemacht.
    Wenn ich jetzt den GPIO 3 (habe ich jetzt verwendet)
    gegen Masse ziehe bekomme ich in der in der Anleitung beschriebenen Datei einen counter der tatsächlich hoch zählt.
    Also der GPIO3 geht!!!!! ;) Freu.


    Jetzt habe ich weiter gemacht und in der vzconfig alles auf GPIO 3 und in der rc.local auch auf 3 geändert.
    Leider bekomme ich immernoch keine grafische Ausgabe UUID stimmt usw ......


    Die Datei zählt aber fleißig weiter..... hmmmmmmmmmmmm