Komisches Problem nach dem WLAN-Stick Austausch

  • Hallo zusammen,


    mein Schwiegervater hat mir diesen WLAN-Stick geliehen: http://www.amazon.de/TP-Link-TL-WN727N-USB-Adapter-Wireless-N-Geschwindigkeit-WPA2-Verschl%C3%BCsselung/dp/B001WU2N1G (Affiliate-Link)
    Den hatte ich am PI angeschlossen und er war 2 Wochen im Betrieb. Ich konnte keine Probleme feststellen, PI hatte ihn erkannt und Treiber installiert. Alles funktionierte wunderbar. Der PI war die ganze Zeit an und per WLAN erreichbar.


    Ich habe beschlossen mir diesen WLAN-Stick zu kaufen: http://www.ebay.de/itm/271326384400


    Damit habe ich ein komisches Problem. Die Verbindung wird oft nach einer relativ kurzer Zeit Inaktivität unterbrochen. Manchmal dauert es länger, manchmal kürzer. Man kann sich an Pi nicht mehr per SSH connecten, nicht mehr anpingen. Nach dem Neustart bzw. Aus- und wieder Anschalten geht es wieder.


    Die FritzBox zeigt aber, dass das Gerät aktiv ist. Leider liegt die Datenrate im Bereich zwischen 13 und 43 Mbit/s, statt "mit bis zu 150 MBit/s". Der Abstand zwischen Pi und der FritzBox beträgt 6-7 Meter mit einer Wand dazwischen. Die Signalstärke ist 60%


    Kann man hier was nachbessern oder ist der Stick einfach "schlimmer" als der Stick vom Schwiegervater?


    Wenn ich jetzt wieder den Stick meines Schwiegervater anschließe, funktioniert alles wieder gut. Die Datenrate liegt sicher über 50 Mbit/s

    Edited once, last by olek07 ().


  • Damit habe ich ein komisches Problem. Die Verbindung wird oft nach einer relativ kurzer Zeit Inaktivität unterbrochen. Manchmal dauert es länger, manchmal kürzer. Man kann sich an Pi nicht mehr per SSH connecten, nicht mehr anpingen. Nach dem Neustart bzw. Aus- und wieder Anschalten geht es wieder.


    Die FritzBox zeigt aber, dass das Gerät aktiv ist.


    Wie ist auf deinem Pi, die Ausgabe von:

    Code
    ip neigh show


    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hallo rpi444


    hier die Ausgabe


    Code
    192.168.178.1 dev wlan0 lladdr c0:25:06:93:39:ed STALE
    192.168.178.118 dev wlan0 lladdr 00:1a:73:a3:48:37 REACHABLE

    Edited once, last by olek07 ().

  • Hi,


    wo hast Du den WLAN-Dongle angeschlossen? Direkt am RPi oder an einem USB-Hub mit eigener Stromversorgung?
    Was hängt sonst noch am/an den USB-Ports des RPi?


    Kann sein, dass Dein WLAN-Stick einfach nur mehr Strom zieht als der andere. Da die Stromversorgung über die Micro-USB Buchse - auch wenn sonst nichts am RPi angeschlossen ist - sowieso schon grenzwertig ist, kann es leicht möglich sein, dass Dir die Spannung einbricht.
    Und bitte jetzt nicht gleich wieder sagen "Ich hab' aber ein 2A Netzteil ...".
    Schau mal -> hier <- und dann reden wir weiter.


    cu,
    -ds-


  • ich habe ihn direkt angeschlossen, sonst sind keine USB-Geräte angeschlossen.

  • Ja ... das könnte dann die Ursache sein. Wenn der Stick jetzt mehr als 200 bis 300 mA zieht, dann reicht das schon.
    Hast Du keinen HUB der separat befeuert wird? Dann würde ich den Stick mal umstecken und dann probieren.
    Alternativ kannst Du mal zwichen TP1 und TP2 mit einem Multimeter die Spannung messen ( -> hier <- wird das ausführlich beschrieben).
    Dann bis dann,
    -ds-


  • hier die Ausgabe


    Code
    192.168.178.1 dev wlan0 lladdr c0:25:06:93:39:ed STALE
    192.168.178.118 dev wlan0 lladdr 00:1a:73:a3:48:37 REACHABLE


    Versuch mal Folgendes auf deinem Pi:

    Code
    sudo ip neigh flush all
    sudo arp -i wlan0 -s 192.168.178.1 c0:25:06:93:39:ed
    sudo arp -i wlan0 -s 192.168.178.118 00:1a:73:a3:48:37
    ip neigh show


    [hr]


    Die FritzBox zeigt aber, dass das Gerät aktiv ist.


    Wenn Du z. B. mit Freetz, einen ssh-Client auf deiner FritzBox hättest, dann könntest Du den Pi, per ssh von der FritzBox erreichen und pingen auch.


    EDIT:


    Evtl. musst Du auch auf deinem PC mit dem ssh-Client, einen entsprechenden statischen arp-cache-Eintrag für den Pi, machen.


    EDIT 2:


    Wenn das mit den statischen arp-cache-Einträgen hilft, dann kannst Du dir auch ein ausführbares Script schreiben, für z. B. das Verzeichnis "/etc/network/if-up.d/":

    Bash
    #!/bin/sh
    #
    /sbin/ip neigh flush all
    /usr/sbin/arp -i wlan0 -s 192.168.178.1 c0:25:06:93:39:ed
    /usr/sbin/arp -i wlan0 -s 192.168.178.118 00:1a:73:a3:48:37
    /usr/bin/logger `ip neigh show`


    Die Pfade für arp, ip und logger musst Du evtl. anpassen.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Das Problem schien an der Fritz Box zu liegen. Nachdem ich sie durchgestartet habe, funktioniert auch PI ordentlich.
    Danke an alle.


  • Nachdem ich sie durchgestartet habe, ...


    War das die einzige funktionierende Lösung? OK, wenn das nicht zu oft passiert, dann kann man das machen.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • ja, also das ganze war ganz merkwürdig. Der PI war online 2 Wochen lang. Ich habe ihn nicht ausgeschaltet, und er konnte IMMER ins Internet. Im lokalen Netzwerk war er nicht immer zugänglich, oder es hat sehr lange gedauert, bis das Login-Prompt kam. Über http war er ebenso nicht immer erreichbar.