Owncloud 5 Server installieren (Raspbian Wheezy) - Dropbox Alternative

  • Quote from Hallo zusammen,das Tutorial hat wirklich super funktioniert. Allerdings nur bis Schritt 9. Ich konnte auch mit dem Handy sofort OwnCloud nutzen usw.  Nach der SSL Geschichte bekomme ich die Zertifikatswarnung wenn ich versuche auf den Pi im Webinterface zuzugreifen, allerdings bleibt die Site dann weiss. Im Browser öffnet sich nichts. Auch können die Clients sich nicht mehr verbinden.Habe intern die 192.168.0.8 als IP. Was kann ich hier noch tun? Das conf file sieht bei mir so ausListen 192.168.0.8:80 schrieb:


    <IfModule mod_ssl.c>
    Listen 443
    Bin euch echt sehr dankbar für jeden RatschlagGrußdjm193

    Edited once, last by djm193 ().


  • Das ist ein Self-Sign-Zertifikat, das ist normal.
    Du könntest das Cert im Chrome über chrome://settings/ -> Advanced Setting -> HTTP/SSL hinzufügen.


    Hab ich gemacht. Interessiert aber Chrome auch nicht. Echt schade ...

  • Upload erhöhen ohne sperre von ownlcloud


    in der datei /var/www/owncloud/lib/filestorage/local.php


    nach dem eintrag "free_space" suchen und abändern
    von


    public function free_space($path) {
    return @disk_free_space($this->matador.$path);
    }


    abändern in


    public function free_space($path) {
    //return @disk_free_space($this->matador.$path);
    return 4194304000; //4000*1024*1024 (4GB)
    }


    und nicht vergessen in /etc/php5/apache2/php.ini das abzuändern


    upload_max_filesize = 4096M


    post_max_size = 4096M





    Viel Spaß !!! :)

    Edited once, last by HotAngel ().

  • Moin ich wollt grad anhand der Anleitung den Ownclod Ordner verschieben und bekomme folgende Meldung


    Code
    pi@LittleRedBox ~ $ sudo mv owncloud/* /var/www
    mv: cannot move `owncloud/apps' to `/var/www/apps': Read-only file system
    mv: cannot move `owncloud/db_structure.xml' to `/var/www/db_structure.xml': Read-only file system


    Welcher User hat denn jetzt recht für den Ordner bzw wie gebe ich mein User die rechte dafür ?


    :danke_ATDE:

  • Moin Community,


    Habe mein Pi nun seit zwei Tage und wollte nun das Cloudsystem installiern, scheitere aber leider schön relativ am anfang, denn ich Habe das Raspian mit NOOBS installiert und wenn ich nun die Größe an die SD karte anpassen will, kommt die Meldung das es leider nicht möglich ich wegen NOOBS.


    Weiß da jemand abhilfe oder darf ich dann nur das Raspian installieren ohne NOOBS?



    Gruß
    Krachbummente

  • Hallo,
    habe seit 2 Tagen auch denRaspberry Pi. Habe mir die Owncloud Version 5.0.11 erfolgreich nach der Anleitung installiert.(Raspbian Wheezy)
    Nun habe ich aber auch ein Problem mit dem SSL Zertifikat. Habe hier im Forum schon einen weiteren Beitrag gelesen, der so Ähnliche Probleme wie ich hat. Leider gab es da noch keine Antwort.
    Ich meine den Beitrag vom 12.08.2013, 22:27 von muhackl.
    Bei mir ist das Problem, das ich Intern über die IP mit http und https zu greifen kann. wenn ich es über das Internet probiere, funktioniert nur die http Verbindung.
    Normalerweise dürfte dies doch dann kein Problem mit dem Zertifikat sein, sondern mit einer Einstellung von der FritzBox (7390).


    Edit: Erledigt. War eine Weiterleitung an der FritzBox. Musste eine Weiterleitung TCP von Port 443 bis Port 433 an IP-Adresse 192.168.XXX.XX an Port 443 einrichten. Komme nun über HTTPS auf die Cloud. Habe bei Owncloud nun noch erzwinge HTTPS angehakt. Wenn ich nun die Seite mit HTTP aufrufe, kommt eine Fehlermeldung das die Seite nicht gefunden wird. (Ist mir eigentlich egal, weil ich eh nur mit HTTPS drauf zugreifen möchte)



    Das zweite Problem was ich noch habe ist mit der Meldung
    Dieser ownCloud Server kann die Ländereinstellung nicht auf en_US.UTF-8/en_US.UTF8 ändern. Dies bedeutet dass es Probleme mit bestimmten Zeichen in Dateinamen geben könnte. Wir empfehlen die für en_US.UTF-8/en_US.UTF8 benötigten Pakete auf ihrem System zu installieren.
    Hier habe ich in der Datei "/etc/locale.gen folgende Einstellung aktiviert en_US.UTF-8 UTF-8, die Meldung bleibt aber vorhanden.
    Vielleicht kann mir ja einer einen Wink mit dem Zaunpfahl geben :)

    Edited once, last by Thunder ().

  • Also die Ländereinstellungen ist ne einstellung des Pi an sich ich habe die selbe meldung das liegt daran das du die Terminal Tastatur auf deutsch gestellt hast, habe dies auch getan aber bislang dadurch kein nachteil gehabt.


    Und bei der FB musst du wirklich einfach nochmal über die portfreigabe checken.

  • Hallo,


    ich würde Owncloud gerne einsetzen, möchte vorher allerdings wissen, ob es auch einen gemeinsamen Space geben kann.


    Gruß,
    Drsascha

  • Wie ist das gemeint? Eine Freihochladzone wo alle user zeug reinwerfen können? Nein, sowas gibt es nicht. Allerdings kannst du es nach dem hochladen mit allen eingerichteten Usern teilen, dann wird ein Ordner "shared" angelegt im dem alles landet. Das dürfte deinem Wunsch am nächsten kommen.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Über die owncloud-Rechteverwaltung kann man die User auch einzelnen Gruppen zuordnen und dann Cloud-Verzeichnissen für diese Gruppen freigeben. Das finde ich auch ganz praktisch.

  • Hi,
    wie kann ich die Dateigrösseneinschränkung aufheben? Obwohl ich in der php.ini schon alles auf 20G (20 GB) gestellt habe, kann ich trotzdem nur max. 2 GB hochladen. Auch in den Admin-Einstellungen bei "Maximale Uploadgrösse" kann ich nur 2 GB einstellen.


    Wie kann ich das umstellen auf unlimitiert? (Also 20 GB muss ich schon auf 1 mal hochladen können.)


    Fehler bemerkt.

    Edited once, last by cocouna ().


  • Es läuft alles! Allerdings viel zu langsam. Ich bekomm noch nen rappel.
    (...)
    Allerdings häng ich zur Zeit bei 10s pro Seite. Und DAS geht eben nicht mehr :@


    Hi,
    wie schnell du deine Cloud aufrufen kannst, hängt von deiner Uploadgeschwindigkeit ab. Wenn du nur mit 70 kb/s hochlädst, dann geht es schon u. U. ca. 15 Sekunden. Wenn du jedoch eine Uploadgeschwindigkeit von ca 700 kb/s hast, dann geht es um die 3 Sekunden.


    Falls du ein schnelleres Internet möchtest, dann kauf dir doch ein Paket mit besserem Uploadspeed. ;)

  • Hey,
    ich verwende seit einiger Zeit meinen Raspberry als VPN Server. Nebenbei, würde ich jetz auch gerne noch Owncloud installieren. Diesbezüglich habe ich allerdings noch ein paar Fragen an euch. Ich habe SSH wie VPN über Zertifikate abgesichert, wie es hier schon in den Anleitungen empfohlen wurde. Was ich jetz nich so genau weis, ist wie sieht es mit der Sicherheit bei Owncloud aus? Ist dies auch möglich einfach Zertifikate zu verwenden, das nur die PCs mit Zertifikat verbinden können? Des weiteren habe ich in der Anleitung hier gelesen, dass für die SSL Verbindung ja den Standartport 443. Ich sehe aber bei mir in den Router Logs täglich dass Angriffe auf Port 80 wie auch Port 443 verhindert worden sind. Wenn auf Port 443 nun aber die Owncloud wartet, weis man ja schon das sich auf dem Port etwas befindet?


    Würde mich freuen, wenn ihr meine Fragen beantworten würdet.

  • Hallo.


    Kann mir jemand helfen, da ich nicht weiß was ich falsch mache, oder vergesse.
    Ich möchte gerne den USB Stick, den ich bisher für owncloud verwendet habe, austauschen gegen eine HDD.
    Ich habe die Schritte ab 8.2 wiederholt, aber beim erneuten Aufrufen von owncloud im heimnetz vom browser kommt dann zwar immer noch die owncloud seite, aber mit dem roten Hinweis unten die Datenbank wäre nicht erreichbar.


    :helpnew:


    Gruß,
    delHaye


  • Ich nutze zwar OC noch auf einem externen Server, will mir aber einen RPI zulegen um meinen eigenen OC-"Server" bei mir unterm Schreibtisch zu verstauen :thumbs1:


    Zu deinem Problem: Du musst das Zertifikat nicht im Chrome hinterlegen, sondern unter Windows den IE mit Adminrechten starten und dann im System ablegen. Mehr dazu findest du hier: http://www.filoo.de/faq/conten…at-zum-browser-hinzu.html





    Unter Linux hier: http://wiki.natenom.name/samme…nierte-zertifikate/chrome




    Danach wie immer neugestartet und siehe da, kein Fehler mehr!

    Edited once, last by Lampe ().

  • Quote


    Apache muss auf TCP Port 443 hören
    Ändert die Datei so dass alle '#' verschwinden, die dort nicht hingehören



    Code
    sudo nano /etc/apache2/ports.conf


    Code
    Listen 192.168.1.10:80
    <IfModule mod_ssl.c>
       Listen 443
    </IfModule>



    Ich habe diesen Schritt befolgt. Alles funktioniert. Nun möchte ich den Port 80 auf einen anderen legen! Dazu dachte ich mir, einfach die 80 oben in z.B. eine 88 zu ändern.
    Das fnktioniert aber nicht. Kann mir wer helfen?

    Edited once, last by digga ().