Raspberry und Ht.access

  • Sers Leute,


    hoffe ich hab die richtige Kategorie gewählt und auch das richtige Forum.


    Habe auf dem Raspberry den Apache Webserver installiert.
    Die Homepage ist schon fertig, hab auch ne Domain geholt, welche auf meinem lokalen Webserver connected ist. Alles ist perfekt eingerichtet und erledigt.


    Möchte ein Passwort für den Zugang der Homepage erstellen.
    Ich benutze dafür den htaccess.
    Habe jetzt dutzende Dinge versucht das ganze hinzukriegen, leider funzt nichts.
    Ich weiß, dass das sehr sehr einfach ist xD
    Irgenwo habe ich einen kleinen Fehler.


    In der htaccess Datei steht folgendes:


    AuthName "Bitte verifizieren"
    AuthType Basic
    AuthUserFile /var/www/htpasswd.txt
    AuthGroupFile /dev/null
    require valid-user


    In der htpasswd folgendes:


    Gast:$apr1$GqTFCVsn$gGOEqFWkZI2ZmZLflTXNs.



    Beim generieren der htpasswd Datei gibt er mir für das Passwort "Willkommen" diese Verschlüsselung.
    Wenn ich die Datei nochmal generiere, wird mir ein anderer Verschlüsselunsgcode angegeben.
    Der Benutzer soll Gast heißen und das Passwort Willkommen.


    Ich nehme an, dass das ganze an der AuthGroupFile liegt, dessen Benutzer alle in der /dev/null gespeichert sind.
    Falls es daran liegt, bräuchte ich die Befehle für das Lösen des Problems.


    Vielen Dank vorab für die Antworten :)


    Grüße

  • Bitte Forum Suche (oben rechts) nach: htaccess



    Es ist nicht sonderlich klug die passwd Datei im /var/www/ Ordner abzulegen, die kann standardmäßig jeder lesen - es sei denn man setzt die Dateirechte entsprechend dass das nicht mehr geht.


    Auch sind die Dateirechte für die .htaccess Datei wichtig (der Punkt am Anfang der Datei ist extrem wichtig!)


    Mehr dazu kannst du auch hier nachlesen:
    http://de.selfhtml.org/servercgi/server/htaccess.htm
    http://www.sysadminslife.com/l…ache-webserver-erstellen/




    PS: Bitte Überschrift im ersten Beitrag anpassen und " Ht.access " auf " htaccess " ändern

  • Du musst noch in der apache config
    /etc/apache2/sides-availabe/default
    Allow Override auf ALL setzen, steht default auf none.


    Die .htaccess generieren :
    Im Terminal :

    Code
    htpasswd -c /var/www/.htpasswd Gast


    -c generiert eine neue Datei, wenn du einen zusätzlichen User anlegen willst lass das weg.



    Die .htaccess so ändern :

    Apache Configuration
    AuthName "Bitte verifizieren"
    AuthType Basic
    AuthUserFile /var/www/.htpasswd
    require valid-user


    Grund : Files welche mit .ht beginnen werden vom Apache nicht ausgeliefert.
    Dein Passwortfile kann man mit http://<url>/htpasswd.txt auslesen.

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?


    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.


  • Die .htaccess generieren :
    Im Terminal :

    Code
    htpasswd -c /var/www/.htpasswd Gast


    -c generiert eine neue Datei, wenn du einen zusätzlichen User anlegen willst lass das weg.


    Das generiert nicht die .htaccess sondern nur das password File - aber ansonsten gute Tipps :)

  • Danke für die Antworten.


    Leider funktioniert es immernoch nicht.


    Habe alles genauso gemacht wie ihr es gesagt habt.
    Ich glaube es liegt an den Rechten der Dateien, weil wenn ich mich unter pi einlogge kann ich nichts auf /var/www verändern außer mit dem Terminal.
    Glaube daran liegt es.


    Wenn ich meine intere IP Adresse vom Raspberry eintippe, dann müsste er mich doch nach dem Passwort und Username fragen oder?


    Grüße

  • Welchem Benutzer gehören die Dateien im www ordner?


    Normalerweise sollten sie entweder dem Benutzer www-data oder einem Benutzer der in der Gruppe www-data ist gehören. Die .htaccess habe ich auf 755 gesetzt. Mit der Änderung der sites-avaiable/default ging es dann.
    Die nächste Idee die mir kommt hast du Virtuelle Hosts angelegt? Wenn ja muss du
    Allow Override in den Conf dateien des Hosts natürlich auch auf All setzen.

  • Nachdem du das "Allow Override" im vHost geändert hast musst du den Apache neu starten oder mindestens ein "sudo service apache2 reload" machen.
    Du musst es übrigens nicht auf All setzen, bitte Leute nicht immer die Schrotflinte als dne einzigen Weg darstellen!
    Es gibt eine Option genau für diesen Fall. zum gucken wo der Fehler ist, ist "All" natürlich ganz gut.


    Bloß das "Es muss auf All stehen" ist schlichtweg falsch. (Wenn es auf none steht, ist es aber auch falsch :P )

  • bitte poste die ausgabe des folgenden befehls, bitte in CODE


    Code
    ls -la /var/www



    Soweit ich weiß müssen die Dateirechte der .htaccess Datei auf 600 gestellt werden und die Datei muss dem Webserver-Benutzen www-data gehören




    PS: die einstellung heißt übrigens nicht "Allow Override" sondern AllowOverride ... zusammengeschrieben ... kleiner aber wichtiger unterschied!
    und in /etc/apache2/sites-available/default steht die einstellung 2x drin