HTML Proxy mit Android & IOS Mobilgeräten

  • Hallo,


    ich habe mit der Hilfe folgender Tutorials erfolgreich einen HTML Proxy incl. Adblock installiert:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Habe die HTML Proxy nun in Firefox integriert.
    Doch wie konfiguriere ich das Ganze für mein Android Smartphone & IOS Tablet? Ich finde bei meinem Browser (z.B. Android Dolphin oder Chrome) keinen passenden Eintrag in der Konfiguration.


    Vielen Dank im Voraus!

  • Für ein Android (bei mir SGS2) geht es folgendermaßen: Bei den Einstellungen -> WLAN -> $deinnetz -> Netzwerkkonfiguration -> Erweiterte Optionen.
    Gilt dann für das ausgewählte WLAN-Netz. Ansonsten wenn gerootet per ProxyDroid oder ähnlichem.

  • Hallo, erst mal Danke für die Antwort.


    Beim LG-G2 (kein Kitkat) musste ich das Netz entfernen und manuell meine SS-ID inkl. Proxy eintragen. (Option war etwas versteckt)


    Mit fällt aber auf, dass meine Verbindung sowohl beim Desktop PC (mit Firefox), als auch beim Android Gerät um gefühlte 30% langsamer ist. Der Adblocker funktioniert dagegen einwandfrei.


    Habe mal beim Desktop PC einen Speed Test gemacht:


    Bei Speedtest de


    Ohne Proxy:
    Download: 38,4 Mbits
    Upload: 4 Mbits
    Ping: 51 ms
    Connections 1548


    Mit Proxy:
    Download: 24,6 Mbits
    Upload: 2,8 Mbits
    Ping: 242 ms
    Connections: 464


    Der Geschwindigkeitsnachteil ist auch bei integriertem Proxy auf dem Android Gerät bemerkbar.


    Ist das normal? Woran liegt es? Kann ich das fixen?


    Infio: Raspbian, per LAN verbunden, SD Karte: SanDisk Class 2 (4GB), Raspbian frisch aufgesetzt (bisher nur VPN und Proxy installiert).


    LG

  • Keiner eine Idee? =)


    Liegt es vielleicht am begrenzten Datendurchfluss des LAN Ports vom Rpi?


    Was bringt mir dann noch die Proxy für Vorteile, wenn ich danach Geschwindigkeitseinbuẞen habe?


    LG