Bluetooth Lautsprecher an Pi

  • Hallo Leute,


    ich wollte mir mit MPD und meinem Bluetooth Lautsprecher n kleines Webradio bauen, allerdings bin ich am verzweifeln was die Lautsprecher angeht.


    Folgendes hab ich bisher gemacht :
    Raspbian frisch auf die SD Karte kopiert
    -update und -upgrade durchgefgührt
    bluetooth bluez-utils bluez-alsa installiert
    den benutzer pi zur Bluetoothgruppe hinzugefügt
    sudo hciconfig hci0 up um das ganze nochmal sicherheitshalber zu starten
    nach geräten gescannt und den Lautsprecher gefunden
    /usr/bin/bluez-simple-agent


    “KeyboardDisplay” mit “DisplayYesNo” ersetzt da sonst die Fehlermeldung
    Creating device failed: org.bluez.Error.AuthenticationRejected: Authentication Rejected kam


    mit bluez-simple-agent hci0 <hadware_id> das Gerät gepairt
    mit bluez-test-device trusted <hardware id> yes dem Gerät vertraut


    so und jetzt fangen die Probleme an.


    wen ich mit bluez-test-audio connect <hardware_id> die Funktion testen möchte kommt erst garnix. Der Lautsprecher gibt keinen mucks von sich und in der Konsole Springt das ganze nach ein paar sec. auf eine neue Zeile.
    Wird der Befehl nun nocheinmal ausgeführt kommt folgendes:


    Traceback (most recent call last):
    File "/usr/bin/bluez-test-audio", line 40, in <module>
    audio.Connect()
    File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
    File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
    File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
    dbus.exceptions.DBusException: org.bluez.Error.AlreadyConnected: Already Connected


    Bin hier echt am verzweifeln :wallbash:
    Hoffe mir kann da wer helfen...

  • Hallo MinniMe


    Hast du bereits eine lösung gefunden die Musik über bluetooth am Lautsprecher wiederzugeben? Ich versuche dies bereits seit längerem aber ohne Erfolg.

  • wow und ich dachte es liegt an mir, versucht pulse audio zu installieren, ein Paket ist wohl nicht sauber


    suche nun nach restore Lösungen um wenigstens den alten Stand wieder zubekommen.


    jetzt ist auch in der x11 Oberfläche das BT Icon weg =(

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • juhu ich habe es geschafft :bravo2::rolleyes::):cool:
    (raspbian wheezy)


    nach
    sudo apt-get update
    sudo apt-get upgrade


    noch ein paar kleine Hürden, Fehlermeldungen lesen, ein Paket fehlte oder passte nicht


    apt-get install -y bluetooth bluez-utils blueman


    hat es mit
    http://www.raspberrypi.org/forums/viewtopic.php?t=68779
    geklappt


    momentan "quakt" dieser hier ganz brauchbar
    http://www.amazon.de/tec-Smart-Musikbox-Tragbarer-Lautsprecher/dp/B00CMQMWLK?tag=httpwwwforumr-21 (Affiliate-Link)


    habe gleich noch einen bestellt, weil der so toll ist und auch ein brauchbarer BT Empfänger mit Klinkenausgang ist für meine richtigen Aktivboxen :)

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • so nun kann ich auch über putty gepairte und getrustete BT Verbindungen connecten


    Code
    bt-audio -c xx:xx:xx:xx:xx:xx


    mit der richtigen BT mac Slave Adresse (hier die von der BT_Smartbox)
    somit läuft auch per rdp z.B. Musik zu starten, belastet den PI weniger als x11vnc, bleibt aber auf dem PI Monitor unsichtbar, aber das Ergebnis hört man am BT Brüllwürfel


    allerdings ist bei mir aufgefallen das beim reset oder restart nicht alle USB Verbindungen erfolgen, lsusb meldet alle Teile vorhanden, aber im Desktop taucht der BT Adapter nicht auf, im Filemanager der USB Stick, werde noch mal die Kondensatoren verstärken, vermutlich ein Spannungsproblem wenn nach dem Reboot oder power on nicht gleich alle Devices arbeiten (passiver HUB !).


    Wenn das nicht klappt werde ich wohl die besagten USB Teile verzögert einschalten müssen was ja dem einzel Stecken entspricht, damit klappt das !

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().