Posts by s0nny

    Also ich hab mich jetzt an dem Shellscript versucht und scheitere leider.
    Hier nochmal der link: https://github.com/Schamper/hyperion-switcher
    Ich habe irgendwie die Vermutung, dass das Script gar nicht läuft. In der Config ist ein Pfad für die log-Datei angegeben. Die existiert schonmal nicht.
    Wenn ich wie auf GitHub beschrieben "killall -9 hyperion-switcherd.sh" eingebe um ihn abzuschießen steht da: "killall: hyperion-switch.sh: no process killed".
    Wenn ich pstree eingebe sehe ich auch nichts von dem Script.
    Wenn ich die Zeile die in die autostart.sh eingefügt werden muss manuell ausführe, passiert auch nix.
    Habe auch schon verschiedene Werte für src_grabber probiert, nix.


    Wie kann ich denn testen, ob das Script zumindest erstmal startet? Wenn ich mir sicher bin, dass es überhaupt läuft, dann kann man ja weiter sehen warum es nicht funktioniert.


    EDIT:
    OK, laufen tut es jetzt. Hab mich wohl beim runterladen vertippt bzw statt hyperion-switcherd.sh nur hyperion-switcher.sh geschrieben...
    Funktionieren tut es trotzdem nicht. Einmal hat es komischerweise funktioniert, das stand dann auch im Logfile. Keine ahnung warum bzw. warum die anderen male nicht


    Ihr könntet Euch auch einen HDMI Verteiler/Switch/Matrix oder wie die alle heißen besorgen und alle Geräte (auch den Pi mit Kodi) anschließen. Dann am HDMI Ausgang den Converter/Splitter dazwischen.
    Dann laufen alle Geräte als externe Quelle (auch der Pi mit Kodi) und ihr könnt mit einer Hyperion Config arbeiten.
    Ich habe das bei mir mit dem ATEN VE829 Wireless HDMI 5x2 Extender laufen, der hat 4 HDMI Eingänge wo BluRay Player, Sat Receiver, Steam Link und Pi3 (Kodi und Hyperion) angeschlossen sind.
    Alle Quellen laufen dann über Hyperion auch der Pi mit Kodi.


    Ist für mich leider keine Option. Nutze den internen Tuner meines TVs und kriege das Signal dort über Scart raus und gehe direkt in den Grabber. Bin ich eigentlich auch ganz froh drüber, damit brauch ich nämlich keinen Splitter oder Converter was Geld spart und für nicht so viel Unordnung hinter dem Fernseher sorgt.

    Dann muss man aber immer daran denken auf den Grabber umzuschalten bevor man auf den TV schaltet. Ich kenne mich, das wird nix :D Und in Kodi habe ich die bunten Tasten bereits mit anderen Funktionen belegt.
    Ich bin gerade dabei alles neu einzurichten und werde es dann versuchen und Vollzug melden.
    Momentan habe ich aber noch Probleme damit, dass Hyperion generell nicht macht was es soll.

    Schade.
    Aber ich habe noch die beiden Sachen gefunden:
    https://github.com/Hwulex/hyperion-config-switch
    https://github.com/Schamper/hyperion-switcher


    Beim ersten wird ne Telnetverbindung zu dem AVR aufgebaut, der dort paar Infos raushaut wenn z.b. die Quelle geändert wurde. Mein AVR hat leider keinen offenen Telnet aber vll hilft ja wen anders.
    Das zweite wäre für mich schon interessanter. Da wird wie bei .bismarcks Lösung mit CEC gearbeitet. Habe schonmal getestet was mein AVR da so raushaut wenn man die Quellen umschaltet und das scheint schonmal legitim zu sein. Hat das schonmal jemand getestet oder will es testen? Würde es dann auch selber testen, aber dafür müsste ich Kodi erstmal neu aufsetzen usw. deswegen frag ich erstmal.


    Falls Du so einen I2C LCD Adapter wie bei deinem Link verwendest, brauchst Du keinen Transistor zum Schalten der LCD Beleuchtung. Der Transistor ist bereits auf dem ( u. vielen anderen ) Adapter(n) verbaut u. kann per I2C Befehl, die LED für die Hintergrundbeleuchtung ein- / ausschalten. Den Jumper verwendet man i.d.R. zum deaktivieren der Beleuchtung bzw. zum ändern der Helligkeit, indem man statt des Jumpers noch einen Widerstand ( Rv ) in Reihe für die LED schaltet.


    Ja ist richtig. Nutze die Abschaltung per Software auch in meinem Programm.
    Hier ging es allerdings darum, dass der ESP am USB vom Receiver hängt und somit auch keinen Strom mehr kriegt wenn dieser abgeschaltet wird. Da das im Programm nicht vorhersehbar ist, kann auch das Display zuvor nicht mittels backlight() deaktiviert werden, das Display bliebe halt einfach an. Jetzt versorge ich das Display aber auch einfach über den gleichen USB Port und damit hat das Display dann auch keinen Saft mehr und geht einfach mit aus.

    Guten Morgen.


    Ihr habt vollkommen recht, die Zeichnung ist falsch. Zu meiner Entschuldigung, es war spät als ich es gezeichnet habe :D Am I2C Adapter sind VCC und GND vertauscht. Aufgebaut habe ich es natürlich richtig, sonst würde es ja auch nicht funktionieren.



    ...du oben schreibst, dass du 5 Volt für den ESP nimmst, in der Zeichnung der ESP wieder an 3,3 Volt hängt ?
    Der ESP darf doch nur 3,3 Volt, oder ?


    Ja richtig, der ESP darf nur 3,3V, es handelt sich aber um einen NodeMCU. Dieser hat einen Spannungsregler verbaut damit man ihn auch direkt über 5V per MicroUSB oder den GPIO für V_in betreiben kann, an den man bis zu 20V anschließen kann.




    Die Module haben üblicherweise zwei Pins A+K für die Hintergrundbeleuchtung, da hast du Recht. Aber wenn du A+K kurzschließt, leuchtet nichts. Der Jumper muss also in der Strecke zwischen Vcc und Anode oder zwischen Kathode und Ground liegen. (Komplizierter wirds wohl kaum sein.)


    Evtl. gibt's auch die Möglichkeit, die Beleuchtung über einen entsprechenden Befehl ein-/auszuschalten. Manche I2C-Display-Platinen schalten die Beleuchtung über einen Transistor. Wäre dann eine Frage der Firmware, ob man die Beleuchtung auch softwareseitig schalten kann.


    Ja richtig, also der Jumper dient halt als Schalter und ist zw. Anode und VCC angeschlossen, habe ich gerade mal durchgemessen. Und Softwareseitig gibt es ebenfalls die Möglichkeit des Ein-/Ausschaltens.



    klar eben mal falsch stecken und umstecken wird immer DIE Lösung sein.


    Woher weißt du denn, dass ich es falsch gesteckt habe? Machst du das anhand des Bildes fest, auf dem ich versehentlich einen Fehler eingezeichnet habe, an einer Stelle, die nach dem Umstecken überhaupt nicht mehr relevant ist?


    Tut mir leid wenn ich durch den Fehlerhaften Plan und mangelnde Informationen Verwirrung gestiftet habe. Auf jeden Fall vielen Dank für Eure Antworten :) :thumbs1:

    Hier mal ein Bild zur Verdeutlichung. Leider gab es den I2C Adapter nicht in Fritzing deswegen mal wunderschön mit Paint :)


    Ja, warum hab ich ein extra Netzteil? Eigentlich weil das USB Kabel direkt in den ESP geht und ich dort nicht an 5V ran komme. Allerdings kam mir gerade die Idee, den ESP einfach über die GPIOs (Vin und GND) zu versorgen.
    Könnte also einfach eine MicroUSB Buchse hinzufügen und von dort sowohl den BD-LLC als auch den ESP mit 5V versorgen. Damit sollte sich das mit dem Transistor erledigt haben.


    Ansonsten hatte ich mir den Anschluss des Transistors so vorgestellt wie im Bild zu sehen ist (auch wenn jetzt wahrscheinlich nicht mehr relevant).


    [Blocked Image: http://abload.de/img/unbenannt0vu3z.png]


    Edit:
    Hab das eben mal schnell umgesteckt und funktioniert so. Also ich gehe jetzt vom USB des AVR in eine MicroUSB Buchse die auf dem Bradboard steckt und versorge von dort den BD-LLC und den I2C Adapter mit 5V und den ESP über Vin mit 5V. Das mit dem Transistor hat sich also eigentlich erledigt. Trotzdem würde mich interessieren ob das so funktioniert wie aufgemalt bzw. wie es richtig sein müsste.
    Vielen Dank für den Denkanstoß :-)

    Hallo,
    ich habe eine Frage bzgl. der Beschaltung eines Transistors als Schalter für die Hintergrundbeleuchtung eines Displays. Ich nutze allerdings kein RPi, sondern einen ESP8266 (NodeMCU). Das sollte für die gegebene Frage allerdings nicht relevant sein. Das ganze sollte sich 1:1 auf den Pi übertragen lassen.
    Ich verwende für die Ansteuerung einen I2C Adapter wie es hier beschrieben ist.
    Das I2C Board hat an der Seite zwei Pins auf denen ein Jumper steckt. Entfernt man diesen, geht die Hintergrundbeleuchtung aus.
    Ich würde die Hintergrundbeleuchtung nun gerne über einen GPIO Ein-/Ausschalten. Grund ist, dass der ESP via USB an meinem Verstärker angeschlossen ist und somit ausgeht, wenn der Verstärker aus geht. Das Display soll dann mit ausgehen (wird durch externes Netzteil versorgt).


    Ist denn mein genereller Gedanke, das mit einem Transistor zu lösen korrekt?


    Ich hätte jetzt einfach die beiden Pins für die Beleuchtung am I2C-Adapter an den Emitter und den Kollektor angeschlossen und einen GPIO an die Basis.
    Nun hat der Transistor ja auch einen verstärkenden Effekt. Muss ich dabei irgendwas beachten (ich vermute mal ja)?
    Was für einen Transistor muss ich benutzen? Habe ein Sortiment verschiedener NPN Transistoren hier.


    Danke schonmal für Eure Antworten!


    Finde ich das erwaehnte Image fuer den Pi3 noch irgendwo ?
    Danke, Wolfgang


    Das hat sich erstmal erledigt - Hyperion ermoeglicht das Umschalten jetzt schon von Hause aus -
    funktioniert sehr gut.


    Verstehe ich das richtig, Hyperion schaltet jetzt schon von Haus aus automatisch die Quelle um, wenn ich zwischen Kodi und TV hin und her schalte?
    Nutze derzeit noch ein sehr altes Image aus diesem Thread in dem das Script von .bismarck integriert ist und es lief bis jetzt alles super. Never touch a running System. Da ich jetzt gesehen hatte, dass OpenElec inzwischen in Version 8 da ist und ich immer noch bei Version 3 rumhänge wollte ich es nun aber doch mal wagen und das System von Grund auf neu aufsetzen. Auf die automatische Quellumschaltung will ich aber nicht verzichten.
    Kann ich nun also alles neu aufsetzen und habe die automatische Quellumschaltung auch ohne das Script von .bismarck?

    Hallo,
    hab den Prototypen soweit auch fertig. Alles noch auf Breadboard und der Code ist auch noch eher "alpha", aber die Grundsätzlichen sachen hab ich erstmal drin.
    Ich steuer das Display nun via I2C an. Auf dem ESP läuft dann der Webserver, dem ich die anzuzeigenden Daten via HTTP GET oder POST als JSON übergeben kann.
    Für die WLAN Konfiguration nutze ich diese Library: https://github.com/tzapu/WiFiManager
    Wenn der ESP sich nicht verbinden kann (kein WLAN konfiguriert oder das konfigurierte WLAN nicht in Reichweite), baut er einfach einen eigenen AP mit Webinterface auf, über welches man die WiFi-Settings vornehmen kann. Und das ganze mit gerade mal 2-3 Zeilen Code. Feine Sache!
    Im großen und ganzen war das alles einfacher als ich gedacht habe.

    Da ich nun erstmal das Kabellose Display bauen möchte, hab ich mich dazu entschlossen, erstmal den ESP8266 zu verwenden. Einerseits weil er kleiner ist und das Display damit wirklich mobil werden könnte. Andererseits weil ich meinen Pi nicht hinter dem TV vorholen wollte weil ich ihn ja noch als Mediacenter usw. benutze. Würde das ganze dann später ggf. nochmal auf dem Pi versuchen. Und den ESP8266 hab ich eh schon da, also kann ich direkt loslegen.
    Das ganze scheint einfacher zu sein als anfangs gedacht. Auf dem ESP8266 läuft ein Webserver an den ich Daten via URL-Parameter oder als JSON übergeben kann. Das hab ich nun erstmal in einfacher Form probiert und das funktioniert auch.
    Meine Frage bezieht sich nun auf dem Anschluss des Displays. Ich weiß, dass das hier kein ESP8266 Forum ist, aber ich bin mir sicher, der eine oder andere wird mir die Frage auch beantworten können.


    Ich hab mir ein I2C Interface für das Display und einen 4Kanal Levelshifter gekauft. Das dauert aber wohl noch, bis die da sind.
    Solange würde ich das Display gern konventionell mit 7 Leitungen, also 4Bit, anschließen.
    Allerdings hat der ESP8266 ja, wie der Pi auch, nur 3V3 I/O Logik und das HD44780 benötigt eigentlich 5V.
    Über die 5V Toleranz des ESP8266 liest man im Internet Gegensätzliches, letztendlich soll er aber wohl wahrscheinlich 5V tolerant sein. Gehen wir hier einfach mal davon aus, dass er es nicht ist.


    [Mutmaßung]
    Wenn ich das Display also konventionell als 4-bit an den ESP anschließe, sollte dem ESP nichts passieren (auch wenn er nicht 5V tolerant sein sollte), weil die 5V vom Display nicht zu dem ESP gelangen bzw. alle angeschlossenen GPIOs auf OUTPUT geschaltet sind!?
    Das einzige was passieren kann ist, dass das Display nicht funktioniert. Zerstört wird allerdings nichts.
    [/Mutmaßung]

    Ist die Aussage so richtig?
    Immerhin funktioniert das Display ja auch am Pi ohne ihn zu zerstören.
    Sollte das Display so nicht funktionieren, und das jetzt nur rein informativ, müsste ich zwischen alle 7 Leitungen (4Bit) die vom ESP zum Display führen, einen Levelshifter 3V3 -> 5V verbauen!?


    Was für Anschlüsse hat denn die Andriod Box? Falls die Box einen USB, DVI o. zugänglichen internen I2C hat, könnte man per Portexpander GPIO Ports bereitstellen, bzw. direkt ein LCD mit I2C daran betreiben.


    Typischerweise nur USB und HDMI. Allerdings hab ich die noch nicht. War erstmal nur so ein Hirngespinst, deswegen hab ich mir darüber noch gar keine Gedanken gemacht. Vll wird es auch eine GeekBox, die hätte ja wiederum GPIOs. Aber damit muss ich mich dann erstmal beschäftigen.
    Ich denke auch, das mit dem Kodi-Addon werde ich erstmal hinten anstellen. Als erstes werde ich versuchen, überhaupt mal externe Daten auf das Display geschoben zu kriegen. Werde das Projekt jetzt glaub ich erstmal unter dem Deckmantel, das HD44870 über Netzwerk zu füttern, versuchen.
    Ob ich das letztendlich unbedingt benötigen werde wird sich zeigen. Aber klingt für mich erstmal nach einer interessanten und spannenden Aufgabe.



    Warum sollte das Ambilight nicht gehen?
    Android TV Stick oder Whatever an HDMI Splitter / AVR dann zum HDMI to Chinch Converter -) Grabber vom Pi und dann zu den Leds!


    Oh stimmt, so geht das ja eigentlich, daran hab ich gar nicht gedacht :lol: . Ich nutze in meinem Setup weder HDMI Splitter, noch HDMI-Chinch Converter. Ich nutze nur Kodi selbst als Quelle und das Signal für TV, welches ich aber direkt aus dem TV über Scart geliefert kriege (zum Glück geht das, da ich einen integrierten Tuner habe würde ich sonst nicht an das Signal kommen). War billiger und andere Quellen hab ich normalerweise sowieso nicht angeschlossen.
    Aber falls ich dann auch außerhalb von Kodi Ambilight brauche, wäre das natürlich die Lösung.

    Hallo,


    ich möchte kurz eine Idee vorstellen, die mir heute kam und um etwas Feedback bitten.


    Momentanten Situation:
    Ich habe einen Raspi2 mit OpenELEC+Kodi. Daran betreibe ich auch mein Ambilight. Außerdem hängt dort noch ein HD44780 dran, welches mir den aktuellen Titel usw. anzeigt.


    Problem:
    Einige Addons fehlen mir einfach, z.B. Spotify, Netflix, Amazon Instant Video. Bzw die Versionen, die es ggf. gibt, funktionieren nicht richtig, sind umständlich, werden nicht mehr weiterentwickelt und funktionieren irgendwann gar nicht mehr.


    Lösung:
    Den Pi durch eine Android TVBox ersetzen und Kodi, sowie Spotify, Youtube etc. darauf als App nutzen.
    Habe mir nun die Frage gestellt, welche Nachteile das denn so mit sich bringt:


    1. Bedienung mit TV-Remote via HDMI-CEC?
    Soll wohl Kisten geben, die das auch unterstützen. Müsste man beim Kauf drauf achten.


    2. Die Boxen haben doch gar keine GPIOs, funktioniert Ambilight dann noch?
    Ich würde die Kodi App + Hyperion Addon nutzen.
    Ambilight würde weiter über den Pi laufen. Hoffe ich habe das richtig verstanden, dass die Signale für das Ambilight dann von dem Hyperion-Addon, über das Netzwerk, zum Hyperion-"Server" auf dem Pi geschickt werden.


    3. Die Boxen haben immer noch keine GPIOs, kriegt man dann das LCD-Display noch irgendwie zum laufen?
    Und das ist der springende Punkt...
    Das Display ist für mich eigentlich nur nice to have. Da ich aber momentan ohnehin auf der Suche nach einem Projekt für mein Studium bin und ich da irgendwie bock drauf hab, dachte ich mir, ich könnte mich ja mal damit beschäftigen.


    Die Idee:
    Wenn keine GPIOs vorhanden sind, dann sag ich halt einem anderen Gerät, welches GPIOs hat, dass es das für mich erledigen soll.
    Das Hd44780 würde also einfach am Raspi angeschlossen bleiben. Dieser würde es weiterhin mit Daten füttern, allerdings nicht mehr mit den Daten die er direkt von Kodi erhält, sondern mit Daten, die er von einer externen Quelle, in diesem Fall also der Andoid TV-Box, erhält. Es müsste also ein Plugin für Kodi geschrieben werden, was die anzuzeigenden Daten via Netzwerk, an den "Displayserver" schickt. Dann zeigt das Display zwar nur Daten von Kodi an, das reicht mir aber auch (zumindest erstmal).
    Der "Displayserver" müsste die Daten entgegennehmen und auf dem Display darstellen. Ich schreibe extra "Displayserver" und nicht explizit RaspberryPi, weil ich mir stattdessen auch gut einen ESP8266 mit integriertem WLAN vorstellen kann. Da in meinem Fall allerdings ohnehin der Pi für das Ambilight läuft, wäre das wohl am naheliegendsten.


    Was sagt ihr dazu?
    Ist das generell machbar? Wie schätzt ihr den Schwierigkeitsgrad ein?
    Hättet ihr eine bessere Idee, wie man das Display an einer AndroidBox zum laufen kriegt?


    Oder gibt es vielleicht sogar schon eine Lösung, die ähnliches leistet?


    Vielen Dank für Euer Feedback!

    Mir ist der Unterschied zwischen Netzteil und Ladegerät jetzt nicht unbedingt so klar. Aber liest man ja schon ab und zu, ist also vermutlich was dran :D
    Ja also wäre auch für die Entstörung offen, wenn es denn dieses mal funktioniert. Bisher habe ich diesen hier
    Der hat allerdings gar nicht gebracht. Hab mit mal sagen lassen, dass die Induktivität viel zu klein sei. Der von dir verlinkte scheint auch keine größere Induktivität zu haben.
    Hätte noch den im Angebot: http://www.pollin.de/shop/dt/O…FN612_3_06_250_V_3_A.html
    Ist der besser geeignet?


    EDIT:
    oder der, mit 2*10mH http://www.netzgeraet.de/absch…-1-5a-entstoerfilter.html

    Hallo,
    mein Ambilight ist schon ne Weile im Betrieb. Als Netzteil nutze ich dieses 5V/10A.
    Dummerweise stört das Netzteil mein TV-Signal (Artefaktbildung, Tonaussetzer und ekelhafte Piepgeräusche). Man muss dazu sagen, dass die Kombination Stromnetz <--> Kabelnetz(TV+Internet) in meiner Wohnung nicht sonderlich gut miteinander harmonieren. Irgendwas läuft da schief.
    Bevor ich das Netzteil hatte, hatte ich für alles ein extra Netzteil.
    Pi2 --> 5V/1A Handyladegerät + 5V/2,5A durch aktiven USB Hub
    Ambilight --> 5V/4A Steckernetzteil
    Da hat nichts das TV-Signal gestört. Allerdings war mir das viel zu viel Kabelsalat.


    Bin jetzt am überlegen, das Netzteil zu wechseln.
    Weiß jemand wie es sich mit solchen Netzteilen verhält?
    Link1 (Affiliate-Link)
    Link2 (Affiliate-Link)
    Es ist ja immer angegeben, dass die QC nur zum Einsatz kommt, wenn es das Gerät auch beherscht. Das ist auch gut so, brauch ja 5V und nicht 9V oder 12V. Ich würde jetzt an einen USB-Port den Pi2 anschließen und 2-3 Ports zur Einspeisung der LEDs benutzen. Wäre der Strom dann auf 1A beschränkt oder kann man tatsächlich mit, sagen wir mal 2A, pro Port rechnen?
    Hat schonmal jemand so ein Netzteil dafür benutzt?
    Hättet ihr alternativ noch Ideen, wie ich dem jetzigen Netzteil diese Macke austreiben kann? Hatt schonmal einen kleinen Netzfilter davor gebaut, der half allerdings nicht. War vermutlich zu klein dimensioniert. Was bräuchte man für einen Netzfilter?


    Grüße und vielen Dank für Eure Antworten

    hab ich versucht, hat auch nicht funktioniert. Er hat dann nicht mehr wegen rgb_matrix:: gemekert, sondern den Fehler beim linken geschmissen:

    Code
    Severity Code Description Project File Line Suppression State
    Error g++ exited with code 1, please see the Output Window - Build output for more details. MinimalExample C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Application Type\Linux\1.0\Linux.Common.targets 180


    Außerdem mekert er noch, dass die linuxspezifischen Header wie z.B. "unistd.h" nicht da sind.


    Hab jetzt einfach ein einfaches VS Projekt gemacht, dort alles wie gehabt angegeben damit IntelliSense funktioniert und dort geschrieben. Die Datei hab ich dann immer via SFTP auf den Pi kopiert und dort make ausgeführt. War weniger unkomfortabel als gedacht. Hab damit erstmal Snake programmiert, dafür ging das schon. Wenns allerdings etwas komplizierter wird, kommt man damit wohl schnell an seine Grenzen, weil man keine Breakepoints nutzen kann.


    Hatte auch nochmal verschiedene IDEs über Xming probiert. Die liefen teilweise echt sehr langsam und den ganzen Komfort wie VS mit IntelliSense haben die auch nicht geboten.


    Also wenn jemand noch ne bessere Lösung hat, immer her damit :D

    Hallo,
    ich habe eine LED-Matrix, welche ich mittels dieser Bibliothek am Pi betreiben will. Hab alles angeschlossen, Testprogramm wie beschrieben gestartet und alles funktioniert, soweit so gut.
    Nun will ich aber selbst eine Ausgabe programmieren. Da ich nich ständig die Tastatur und den Monitor umstecken will, fänd ich es am komfortabelsten, wenn ich einfach von meinem Windows Rechner aus programmieren könnte.
    Mein erster Versuch war mittels CodeBlocks und XServer auf dem Pi zu programmieren. Das lief allerdings nicht wirklich gut.
    Nun gibt es seit ca 2 Monaten von Microsoft eine Erweiterung für Visual Studio (link), die es erlauben soll, auf dem Windowsrechner für Linux entwickeln zu können. Das scheint auch zu funktionieren, ein einfaches HelloWorld krieg ich auf dem Pi schon hin.
    Ich muss nun aber auch die Includes und Libarys angeben, damit ich die LED-Matrix nutzen kann. Und da ist denk ich der springende Punkt. Ich habe schon viel herumprobiert, blieb aber immer erfolglos.


    Als Basis hab ich einfach mal das enthaltene minimale Beispiel genommen (minimal-example.cc).
    Hab in Visual Studio, in den Projekteinstellungen, die Pfade zu den zusätzlichen Include- und Libraryverzeichnissen angegeben und als Plattform ARM gewählt. Das führt schonmal dazu, dass IntelliSense alles absegnet (nur das usleep() musst ich noch auskommentieren, das gibts unter Windows nicht). Da das schon nicht funktioniert hatte, habe ich das Include- und das Lib-Verzeichnis auch noch auf dem Pi platziert und den Absoluten Pfad auch nochmal in VisualStudio angegeben (also /home/pi/rpi-rgb-led-matrix/include und /home/pi/rpi-rgb-led-matrix/lib).
    Ja, geht trotzdem nicht...
    Als Ausgabe erhalte ich folgendes:



    Meine Vermutung geht in Richtung Makefile. Da ich bisher aber noch nicht für Linux programmiert habe, verstehe ich da rein gar nichts. Normalerweise müsste die IDE doch das Makefile erzeugen oder? Nun scheint in dem Makefile aus dem Projekt (Makefile) noch das ein oder andere drin zu stehen, was die IDE nicht "weiß"!?
    Weiß nun nicht wirklich wie ich weiter vorgehen soll.



    Hatte auch schon Netbeans nach dieser Anleitung getestet.
    Dabei kommt folgendes bei raus:


    Hab das Makefile was mir Netbeans generiert durch das von GitHub ersetzt. Vermutlich muss ich wohl aus beiden eins machen, könnte das sein? Nur hab ich dann leider keine Ahnung wie man dabei vorgeht :-(
    Könnte mir jemand weiterhelfen? Vielleicht schonmal jemand ähnliche Probleme gehabt? Ob mit VisualStudio oder Netbeans oder Codeblocks oder oder ist mir eigentlich egal. Preferieren würde ich allerdings VisualStudio.


    wenn Du dieses offizielle Image benutzt, was kein Problem darstellt, funktioniert allerdings das autom. Umschalten des Ambilights nicht mehr. In einen meiner letzten Beiträge hier habe ich ein aktuelles Image im Angebot. :-)


    Hatte es gerade mal getestet und festgestellt dass mir kein Licht mehr aufgeht :D
    Kann ich bei deinem Image dann mein Backup, was ich aus Kodi raus gemacht hab (OpenELEC Einstellungen->System, ist ein .tar Archiv) wieder einspielen und bin dann von den Einstellungen her und den Addons wieder auf dem Stand auf dem ich aktuell bin?