Posts by driftmonster

    Freut mich dir geholfen zu haben[emoji6]
    Dass deine FB die 201 fur die VPN Verbindung nimmt ist klar, da das die erste Adresse ist, die nicht per DHCP vergeben werden kann und somit nicht belegt sein "sollte". Ich glaube aber, dass man die Adressen ändern kann, bei mir hab ich die VPN ab 220[emoji6]


    Ich vermute mal, das deine Idee sicher nicht so einfach umsetzbar ist, wie Du vielleicht denkst. Du müsstest Dir ein eigenes USB API Treibermodul für den ESP mit NodeMCU schreiben und dann gibt es ja auch noch einen Unterschied, ob ein USB Gerät ein Master o. Slave Device ist. Da wirst Du mit einem Printerserver, bestimmt schneller Erfolg haben.


    Ich weiß, dass das nicht von heute auf morgen fertig sein wird, im Vordergrund steht erstmal der Spaß am Basteln und Austesten. Allerdings möchte ich nicht unbedingt einen fertigen Printserver nehmen, da ich die kleinen ESPs dann überall an Kram anschliessen könnte und man diese zudem auch noch äußerst günstig erweitern kann.

    Hallo zusammen,


    ich hab mich mit Begeisterung zum Thema ESP8266 eingelesen und mir zudem auch gleich ein paar Module aus dem fernen Osten bestellt.
    Da diese leider noch einige Tage brauchen werden und ich zu meinem ersten Anwendungsfall noch keine passende Dokumentation gefunden habe, würde ich hier mal nachfragen wollen, ob schon jemand Erfahrung oder einen Ansatz für Wireless USB hat.


    Mein Vorhaben: Ich habe einen (relativ alten) USB Drucker, der wegen Lärm in einen anderen Raum soll. Jetzt sollte es bestimmt möglich sein, an dem Rechner (Linux/Windows) ein Software zu installieren, die ein USB Gerät vorgaukelt, wenn sich über WLAN der ESP verbunden hat. Dieses USB Gerät soll dann an dem Rechner wie gewohnt verwendet werden können.


    Ich habe HIER mal ein vergleichbares Produkt gefunden. Ideal wäre natürlich, wenn dann nicht nur Drucker, sondern auch alle anderen USB Geräte funktionieren würden.


    Bei der Programmierung bin ich relativ offen, hab mir auch schonmal nodeMCU angeschaut bzw. auch Programmieren in lua.

    BitteBitte ;)
    Zu den LEDs musst du dir selbst die Frage stellen, ob du diese einzeln oder aber alle auf einmal ansteuern können möchtest.
    Die günstigste Variante ist in diesem Fall die zweite Version, also alle auf einmal, da kannst die IKEA LED Leisten nehmen und diese per PWM ansteuern.


    Ich hatte genau die selbe Idee, den Patch usw. hatte ich auch entdeckt.
    Ich selbst habe keine Ahnung wie man den einbaut und den ganzen Spaß kompiliert.


    Darum habe ich es aufgegeben, die 10€ investiert und kann nun alle neuen Images nutzen ... also vergiss die Idee, meiner Meinung nach.



    Obwohl der Thread ja schon als erledigt markiert ist; ich betone nochmal, dass ich mir den gleichen (!) Stick besorgt hab, mit der selben ID (!). Der wird jetzt ohne Murren erkannt und es wird auch nicht mehr der STK1160 Treiber geladen, sondern laut dmesg auch der usbtvcore.


    Ich weiß bisher aber nicht, wieso mein alter Stick so rumzickt, werde ich zum Spaß vielleicht mal noch an nem frischen wheezy testen.

    Naja, du kannst z.B die verwendeten GPIO per Interrupt eine Variable setzen bzw. hochzählen lassen, solang der Button gedrückt ist.
    Du musst lediglich das Modul python-rpi.gpio installieren und dich evt. noch schlau machen, aus dem Stand weiß ich das jetzt nicht genau.


    Welche Fehlermeldung bekommst Du denn, wenn Du den UTV007 verwendest?
    Der Patch für FrameScaling ist so wie ich weis nur für den STK1160 und hat mit der Funktionalität des UTV007 nichts zu tun, damit kann man beim STK1160 niedrigere Auflösungen einstellen.
    Wenn der UTV007 bei Dir mit neuer Kernel nicht funktioniert ist irgend was anderes faul.


    Bekam immer "Frame too small" Meldungen am laufenden Band, praktisch kein verwertbares Bild dabei.


    Hab seit vorhin den geliehenen UTV007 am Start. Ausgabe von lsusb ist ebenfalls ID 1b71:3002. Allerdings hab ich jetzt absolut keine Probleme mehr, echt der Wahnsinn :s


    Werde mir jetzt im Endeffekt nochmal einen UTV007 für mich bestellen, dann scheint mein bisheriger wirklich einen Defekt zu haben.


    Damit ist der Thread eigentlich hinfällig und wird von mir als erledigt abgehakt. Sorry, falls ich wen zu sehr verwirrt hab ;)

    Verstehe ich nicht, mit neusten Kernel läuft der UTV007 problemlos ob 4.1 unstable oder nicht.
    Und woher weist Du das es ein STK1160 Treiber für alles ist, was hat der STK1160 mit dem UTV007 zu tun.


    Ich stelle mein fertiges Hyperion Image immer mit aktueller Kernel-Version in meinem Thread zur Verfügung, natürlich teste ich vorher ob es auch richtig funktioniert.


    Hab mich ja auch ein wenig schlau gemacht und gelesen, dass der STK1160 Treiber ab dem Kernel 3.7 für alle USB-Video Grabber zuständig ist, eben auch für den UTV007 Chip. (Link muss ich noch wieder suchen) Daher vielleicht die Verwirrung mit STK1160 und EasyCap.
    Eingabe von lsusb gibt mir die richtige ID für den UTV007; ID 1b71:3002, weshalb mich halt das Verhalten bezügl. Fehlermeldungen sehr verwundert. Daraufhin hab ich dann halt mal Google angeschmissen und ne Seite mit nem Patch gefunden (FrameScaling), den ich auf die Sources des STK1160 Treiber anwenden wollte. Danach halt alles kompilieren.


    Zugegebenermaßen habe ich noch nicht dein Image getestet, das würde ich zur Not noch zum Schluss machen wollen, da ich sonst unendlich viel Zeugs einrichten muss ;)


    Nichtsdestotrotz bekomme ich diese Woche noch von nem Kollegen leihweise den gleichen Grabber ausgeliehen. Den werde ich dann als Erstes ausprobieren und kann euch berichten, was sich tut ;)


    Kurz und knapp: Wenn du nicht selbst weißt, wie das geht, wird dir hier im Forum glaube ich keiner helfen.
    Grund: Der Fushicai funktioniert absolut ohne Probleme.


    10€ investieren, neuer Grabber, keine Probleme!


    Hast du das selbst mit dem Kernel getestet? Ich hab den UTV007, der lief ja auch bei dem alten Kernel ohne Probleme. Hatte vorher noch den Kernel 3.6.irgendwas, wo noch der Easycap Treiber anstatt des STK1160 an Board war.


    Warum der dann jetzt so rumzickt ist mir nicht ganz klar :s


    Zudem bin ich mir relativ sicher, dass es hier bestimmt wen Schlaues gibt, der weiß wie man sich einen Treiber kompilieren kann ;)