Posts by C-3po


    an PIN 9 hat das IC die Freilaufdioden für die Relaisspulen integriert.
    Die restlichen Eingänge werde ich gegen GND legen. Ausgänge kann ich offen lassen.


    Die 3,3kOhm werde ich auch noch vor die Eingänge des IC´s hängen.


    Deine Relaiskarte hat selbige Dioden schon drauf und desweiteren schaltest Du eh nur die Optokoplerstufe.


    Deswegen sagte ich, stört nicht weiter. Wenn ein Relais direkt geschaltet würde, auf jeden Fall notwendig.


    Die 3,3 kohm Widerstände hatte jar mal in einem anderen Fred vorgeschlagen (reine Schutzfunktion der Gpios)


    Ausgänge musst offen lassen.

    Doc,


    bring ihn jetzt nicht noch weiter durcheinander.
    Das Caos in deinem Fred reichte mir schon beim durchlesen.



    Hallo,


    der ULN2803 kann 8 Kanäle schalten, dann brauchst du keine 2 ICs.
    ...
    Warum die 5V an Pin 9 des ICs?


    Weil das so ok ist und auch in dem Fall nicht weiter stört.


    Aber ungenutzte Eingänge auf def. Pegel legen. zb GND

    Hi,



    Da sind gleich eine ganze Reihe von Widerständen drauf, aber was genau meinst wie gezeigt?


    Wenn ich dem kleinen Bild trauen kann, so habe ich das selbe Modul, dort sind 2 Widerstände drau die ich entfernt habe.


    Danach ist am i2c Bus alles ok.


    Bitte mal ein grösseres Bild machen von dem Modul, dann kann ich dir sagen welche Widerstände runter müssen.

    da wird der send befehl verwendet.


    auch von der konsole aus geht nix mehr.


    root@raspberrypi-ii:~# sudo /root/raspberry-remote/./send 10101 5 1
    sending systemCode[10101] unitCode[5] command[1]
    root@raspberrypi-ii:~# sudo /root/raspberry-remote/./send 10101 5 0
    sending systemCode[10101] unitCode[5] command[0]
    [hr]
    Kann es sein das die Impulsbreite verändert wird?
    [hr]


    pilight-reseive:


    per console:


    /root/raspberry-remote/./send 10101 5 0


    {
    "code": {
    "systemcode": 21,
    "unitcode": 16,
    "state": "off"
    },
    "origin": "receiver",
    "protocol": "mumbi",
    "uuid": "0000-00-00-9e-1b488a",
    "repeats": 6
    }


    keine Reaktion
    [hr]
    per FB


    {
    "code": {
    "systemcode": 21,
    "unitcode": 16,
    "state": "off"
    },
    "origin": "receiver",
    "protocol": "pollin",
    "uuid": "0000-00-00-9e-1b488a",
    "repeats": 1
    }


    schaltet
    [hr]
    über pilight


    /root/pilight/./pilight-send -p elro_he -s 21 -u 16 -f
    {
    "origin": "sender",
    "protocol": "elro_he",
    "code": {
    "systemcode": 21,
    "unitcode": 16,
    "state": "on"
    },
    "repeat": 1
    }


    schaltet

    Hi,


    mit einer älteren pilight Version (ca 2 mon. her) konnte ich parallel auch alle anderen Versionen der 433 Sender Steuerung nutzen. zb. http://www.forum-raspberrypi.d…mit-ios-android-version-2.


    Jetzt habe ich geupdatet und kann nur noch über pilight meine Steckdosen schalten (ausser PowerPi) das geht noch. Stoppe ich den pilight-Service kann ich auch wieder über netio arbeiten.
    Wenn der pilight-Service an ist wird zwar was gesendet (habe eine led parallel in der sendeleitung) aber es schaltet nix. Stoppe ich geht es wieder. Hat einer n Tip.


    /etc/pilight/hardware.json


    {
    "433gpio": {
    "sender": 0,
    "receiver": 2
    }


    Der Test an der Console endet schon mal nicht gut:


    Pilight mag irgendwie diese ' nicht und NetIO auch nicht.


    Wenn ich diesen Befehl eintrage ist er nach dem speichern verstümmelt. Alles nach dem ersten ' bzw incl. dem ' ist dann weg


    verwende ich in der Console " kommt der selbe Fehler.


    Code
    root@raspberrypi-ii:~/netio_server# python netio_client.py linux "pilight-send -p elro -s 19 -u 14 -f"
    ################# client >192.168.0.17< send >linux pilight-send -p elro -s 19 -u 14 -f<
    ['pilight-send', '-p']
    send data > linux pilight-send -p elro -s 19 -u 14 -f < to host 192.168.0.17 and port 44444
    ("Usage: pilight-send -p protocol [options]\n\nThe supported protocols are:\n\t cla ...


    Als Button im NetIO:



    bzw jetzt mit ' :



    aber ein stinknormales linux reboot wird natürlich ohne Kommentar ausgeführt (war n Test)

    Hi,


    kann mir einer verraten wie ich dieses Kommando absetzen kann:


    pilight-send -p elro -s 18 -u 14 -f <- Ein
    pilight-send -p elro -s 19 -u 14 -f <- Aus


    Das sind Steckdosen, die sich durch die Codierung nicht mit dem normalen Send schalten lassen.


    S.Star (Inter-Union)



    Desweiteren würde ich gern über NetIO auch Relaiskarten, die ich hinter einem mcp23s17 (I2C) hängen habe, auch schalten.


    so ging es bei mir nicht. Erst als ich in der Blacklist die beiden Module wieder hab Blacklisten lassen und dann über modules nachladen lassen war der Fehler weg.


    nach umstellung der modules datei. fehler blieb.

    Code
    i2cdetect -y 0
         0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
    00:          -- -- -- -- -- -- -- -- -- -- -- -- -- 
    10: -- -- 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f 
    20: 20 21 22 23 24 25 26 27 28 29 2a 2b 2c 2d 2e 2f 
    30: 30 31 32 33 34 35 36 37 38 39 3a 3b 3c 3d 3e 3f 
    40: 40 41 42 43 44 45 46 47 48 49 4a 4b 4c 4d 4e 4f 
    50: 50 51 52 53 54 55 56 57 58 59 5a 5b 5c 5d 5e 5f 
    60: 60 61 62 63 64 65 66 67 68 69 6a 6b 6c 6d 6e 6f 
    70: 70 71 72 73 74 75 76 77



    zusätzlich die Blacklist reaktiviert. Fehler ist weg. (aber noch ungetestet)

    Code
    i2cdetect -y 0
         0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
    00:          -- -- -- -- -- -- -- -- -- -- -- -- --
    10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    70: -- -- -- -- -- -- -- --