Posts by Willi/S

    Danke,


    für die Nachwelt

    die letzte beiden 0 habe nichts mit der umask zutun. Eigentümer Gruppe FALSCH

    sondern

    <dump> wird hier festgelegt ob die Partition gesichert wird

    <pass> Gibt an, ob und in welcher Reihenfolge die Partition beim Systemstart in die regelmäßigen Dateisystemprüfungen einbezogen wird.


    Gruß Willi und Danke

    Danke für den Tipp.


    Ich bin jetzt nochmal alles durchgegangen was fehlt:


    <File system>
    LABEL= Festplatte

    <mount point> /media/daten_1

    <type> ntfs

    <options> auto bei aufrufen mount -a

    nofail    bei nicht vorhanden sein ignorieren

    syns nach Schreibvorgang geflusht
    users     jeder kann einhängen
    rw read-write

    umask=000 0 0

    Zugriffsrechte



    Jo, hier hatte ich die 0 vergessen. Danke!

    Die Esten drei sind der Octal Werte der umask, wie bei chmod nur negiert 0=rwx 7=---


    Kannst du mir auch sagen was die beiden letzten Ziffern bedeuten,

    müssten dann Eigentümer und die Gruppe sein. D.h wenn ich da 1000 1000 ein gebe wäre der Eigentümer pi und die Gruppe auch pi?


    Gruß Willi und Danke

    Danke für die schnelle Antwort.


    Das war auch mein erster Gedanke, aber der hatte leider nicht funktioniert.

    Da wird nur die Festplatte erkannt die als erste steht, die zweite wird ignoriert.

    Wahrscheinlich erkennt er, dass zweimal auf dasselbe Verzeichnis gemountet wird.


    Ich habe es jetzt so hinbekommen.


    LABEL=Festplatte /media/daten_1 ntfs auto,nofail,sync,users,rw,umask=000 0


    Und das Label lässt sich vielleicht ändern als die UUID besonders bei NTFS Format.

    D.h. ich habe jetzt zwei USB-Festplatte mit derselben Verzeichnis Struktur und das Label bei beiden auf Festplatte gestellt. Jetzt kann man die Festplatte einfach austauschen.


    Gruß Willi und Danke

    Hallo Liebes Forum,


    Allen erst einmal schöne Feiertage und viel Zeit zum Basteln.


    Ich habe eine FTP Server auf einen PI aufgesetzt der Daten sammelt. An diesen habe ich eine USB-Festplatte angegossen, die ich fest im fstab über die UUID definiert.

    UUID=xxxxxxx /media/daten_1 ntfs auto,nofail,sync,users,rw,umask=000 0 0

    Soweit funktioniert alles super.


    Da dieses System nicht bei mir im Haus ist, sondern entfernt, wäre es gut wenn ich einfach die Festplatte auswechseln könnte. Somit könnte ich die Festplatte mitnehmen und die Daten abspeichern und danach wieder die Festplatte tauschen.


    Also habe ich die zwei Festplatte auf dasselbe Verzeichnis gemountet, hat leider nicht funktionier, auch nicht nach einen reboot.


    Wie könnte man das Realisieren?


    Kann man eine if Abfrage in fstab mache?

    Oder kann man die UUID der Festplatten einstellen das beide gleich sind.

    Oder gibt es noch andere Möglichkeiten.


    Vielen Dank im Voraus


    Willi

    Hallo Liebes Forum,


    ich habe ein Problem bei den Weiterleitungen mit einem VPN.


    Folgender auf Aufbau:

    Zu Hause Fritzbox und dahinter einen openvpn Server, Außenstation einen LTE Router und ein Pi mit vpn und noch weitere Raspberrys für Sensor, Kamera …


    Wenn ich jetzt von zu Hause aus mit einen Browser auf den vpnPi zugreife z.B 10.10.10.10 komme ich auf den Apache alles gut. Möchte ich aber auf einen anderen Raspberry der z.B. Sensordaten sammelt, komme ich mit einer Weiterleitung (html oder php) z.B.192.168.1.10 nicht weiter. Da die Weiterleitung nicht im Apache gemacht wird, sondern an meine Browser geschickt wird und der kann mit der 192.x.x.x nichts anfangen.


    Das Ganze habe ich jetzt so gelöst, dass ich ein Python Programm laufen habe, dass das Web überwacht und dem entsprechend auf den anderen Pi die Daten holt die benötigt werden. Das funktionier gut.


    Nur jetzt habe ich ein Problem, dass ich nicht hinbekommen. Ich habe an dem Router ein geschlossenes Gerät, was ich über Port 80 abfragen kann. Dieses hat eine grafische Benutzeroberfläche mit vielen Einstellmöglichkeiten. Diese mit Python holen und neu aufbauen ist nicht ganz trivial. Bei den LTE-Router hätte ich noch die Möglichkeit einen vpn auf zubauen, da ich aber noch eine Außenstation habe die über ein freies Wlan läuft, geht die Option leider nicht.


    Zurzeit mache ich es so, dass ich über Windows Remote in den Pi gehen und da den Browser aufrufen. Von da aus komme ich überall hin. Dies ist nur leider sehr umständlich und mit dem Handy klappt es gar nicht.


    Jetzt hoffe ich das einer vom Euch eine Idee hat, wie man diese Lösen könnte.



    Besten Dank im Voraus :danke_ATDE:




    Willi

    Dank fuer die schnellen Antworten,


    ja ich glaube das koennte es sein.
    Ich habe die Binaerdistributtion mit bdist_rpm gemacht, das ist zwar fuer Linux aber ob das fuer den PI passt?
    Nur wo bekommt man so ein bdist_xxx fuer den PI her. Google hatte keine Antwort


    Schoene gruesse Willi

    Hallo liebes Forum,


    ich habe ein Problem, wenn ich den PI nur den Binaercode (pyc) von Python uebergebe,
    dann kann er das Programm nicht ausfuehren. Auf meinem Linux Rechner geht das Problemlos.
    Weiss einer warum das so ist, oder mache ich einen Fehler.
    Der Hintergrund ist, dass ich nicht den Quellcode mit Kommentaren offen liegen haben moechte.


    Schoene gruesse Willi