Posts by raspimännche

    Welcher Fehler ist "der" ? :-/


    Hallo Meigrafd,


    Mit dem Fehler meine ich die letzten Zeilen in der Error.log vom Apache2 .
    Wo hinter dem Pfad zum Interpreter noch diese beiden Zeichen " ^M " kommen die ja auf einen Kovertierungsfehler hindeuten .
    Ich habe jetzt so viele Editoren ausprobiert, aber jedes mal werden die beiden Zeichen in der Error.log angegeben .


    Oder sollte ich vielleicht versuchen, das komplette Programm direkt am Raspberry Pi einzugeben, und nicht über einen Windows PC ?


    Gruß
    raspimännche



    Hallo meigrafd,


    Ich habe den Notepad++ Editor auf meinem Windowsrechner installiert, habe das Programm eingelesen und unter einem neuen Dateinamen abgespeichert . aber leider ist der Fehler immer noch vorhanden .


    Und mit dem Vi ist der VIM Editor gemeint, oder ?


    Gruß raspimännche


    Na da haben wir ja schon den Fehler - da arbeitet jemand unter Windows, gell? Und hat das Skript mit einem Windows-Editor geschrieben, und dann einfach rueberkopiert...


    Du hast dadurch ein Problem mit den Zeilenenden. Python selbst ist das egal, aber der Shell zum ausfuehren nicht. Du solltest so etwas wie duconv benutzen, oder besser noch einen Editor benutzen, der auch UNIX-Endungen speichern kann.


    Hallo __deets__ ,


    Vielen Dank für deinen Tip, aber ich habe versucht duconv zu installieren aber der hat das Paket nicht gefunden .
    Gibt es vielleicht noch ne lösung oder nen anderen Editor der das macht ?
    Ich verwende immer den Nano Editor .


    Sollte ich vielleicht mal den VIM Installieren ?


    Gruß
    raspimännche
    Automatisch zusammengefügt:[hr]


    Hallo Digiart,


    Da hab ich mich total verschrieben . die Letzten 4 Zeilen aus der Error log hab ich oben aufgeschrieben .
    Gruß raspimännche


    Was sagt denn das Apache-Log?


    Hallo Digiart,


    Das muss ich erst mal rausfinden, wo ich das finden kann .
    Bin absoluter Neuling auf dem Gebiet .



    Gruß raspimännche
    Automatisch zusammengefügt:[hr]


     
    Hallo Digiart,
    Ich habe das Script nochmal gestartet


    Die Meldung heisst : , und die letzten Zeilen in der Error.Log notiert .
    Ich hoffe das Du da was mit afangen kannst .



    /usr/bin/env: python^m: No such or file directory
    [Sun Oct 23 21:14:05 2016] [error] [client 192.xxx.xxx.xxx] Premature end of script headers: meinedatei.py
    [Sun Oct 23 21:14:06 2016] [error] [client 192.xxx.xxx.xxx] File does not exist: /var/www/favicon.ico
    [Sun Oct 23 21:14:06 2016] [error] [client 192.xxx.xxx.xxx] File does not exist: /var/www/favicon.ico
    [Sun Oct 23 21:14:06 2016] [error] [client 192.xxx.xxx.xxx] File does not exist: /var/www/favicon.ico



    Gruß
    raspimännche

    Hallo Ihr lieben,


    Ich habe ein kleines / großes Problem , und zwar habe ich an meinem Raspi 5 Dallas DS18B20 Sensoren hängen die die Temperaturen von meiner Heizung sprich Warmwasser, Kaltwasser, Heizung Vorlauf, Heizung Rücklauf und Aussentemperatur auslesen sollen .
    Dazu habe ich mit Hilfe ein Python Scrpt bekommen das die Temperaturen denn auch auslesen tut .
    In der Konsole funktioniert das Script wunderbar, nur sowie ich die Seite über einen Windowsrechner aufrufe bekomme ich den 500 Internal Server Error .
    Das komische ist aber ich habe ein Testscript zum Testen des Apache 2 Servers, und das funktioniert bei der abfrage von einem Windowsrechner einwandfrei .


    weil ich möchte nur , das die Temperaturdaten von jedem Rechner im Heimnetzwerk ausgelesen werden können .
    Ich habe jetzt schon alles mögliche ausprobiert aber so langsam weiss ich keinen Rat mehr .


    Ich bitte auch zu entschuldigen, falls ich dieses Thema im RaspberryPi Forum übersehen habe .


    Danke schon mal im voaus .


    Raspimännche

    Hallo ,


    Ich bin ganz neu hier im Raspberry Forum , und habe so einige kleine Problemchen , weil ich mich auch nicht so gut auskenne, muss ich Leute fragen, die Ahnung haben . Das kann man aber nur , wenn man sich in einem Forum anmeldet .


    Also, ich habe folgendes Problem,


    Ich habe momentan einen Raspi auf der Kellertreppe hängen, ohne Tastatur ohne Maus ohne Alles .
    An diesem Raspi habe ich über den GPIO einen Dallas DS 18S20 Temperatursensor angeschlossen .
    Wenn ich im Terminalfenster einige Befehle eingebe, bekomme ich auch Antwort , bzw bekomme auch die Temperatur von diesem 1 Sensor angezeigt .
    Ich möchte das ganze aber anders machen , und möchte diese Werte die , die Dallas Sensoren erbringen , (das werden definitiv noch mehr Dallas Sensoren werden .) Über einen Browser aufrufen .


    Nur weiss ich nicht so recht, wie ich das anstellen soll .
    Welche Software muss Installiert werden , was alles wie geändert werden muss ?



    Deshalb die Frage in das Forum .


    Vielen Dank schon im voraus .


    Mfg.


    raspimännche



    :danke_ATDE:
    Ich bin halt Neu , und brauche noch viel Hilfe .