Posts by IcedEarth

    Hey zusammen,


    ich habe mir nach dieser Anleitung eine Nextcloud auf meinem Pi3 (aktuell mit angeschlossener SSD) eingerichtet. Aktuell hängt der Pi3 via WLAN im Netz. Portfreigaben und DNS habe ich eingerichtet. Ich bin super zufrieden damit und alles funktioniert super. Den Login für das AdminKonto habe ich zusätzliches mittels 2FA abgesichert. Da es das erste mal ist, dass ich ein Gerät über das Internet verfügbar mache habe ich ein paar Fragen, die ich einfach mal ganz frech aufliste.

    Kurz was zur Infrastruktur:

    Fritzbox 7590. Daran eine Unify AP-AC-LR an den der Pi3 via WLAN angebunden ist.


    1) Gibt es die Möglichkeit den Pi3 mittels VLAN auf dem Unify von den anderen Geräten abzuschirmen UND gleichzeitig den Login für die fritzbox zu deaktivieren (also fritz.box aufzurufen und sich einzuloggen)? Würde das die Sicherheit erhöhen und Zugriffe von außerhalb auf andere Netzwerkgeräte effektiv verhindern?


    2) Wie sieht es mit der Zuverlässigkeit des Pi3 aus? Man liest ja immer wieder von beschädigten Dateisystemen.. Mal angenommen ich kann das Backup der SD Karte nicht zurückspielen. Was passiert mit den Daten auf der SSD? Kann ich die SSD einfach auf einer frischen SD mit frischer Nextcloud Installation einbinden und habe dann auch Zugriff auf die Daten?


    3) Bietet Nextcloud ein Plugin, dass es mir erlaubt einen Snapshot der aktuellen Daten zu machen und diesen dann auf eine andere physische Platte zu schreiben? Am besten automatisiert. Wenn nicht, gibt es eine solche Funktion vielleicht beim Pi selber mittels Script, dass auf eine angeschlossene Festplatte reagiert?


    4) Gibt es sowas wie Geofencing, um Aufrufe aus anderen Ländern eventuell gleich an der Fritzbox zu filtern?


    Ich würde mich über ein paar Anregung Eurerseits freuen.


    Viele Grüße!

    Habe das jetzt mal aufgesetzt und gleichzeitig noch die Pi Cam angeschlossen. War wirklich sehr einfach und hat sogar alles auf Anhieb funktioniert (! ;-) ).
    Die Darstellung der Werte ist auch sehr schön.

    Leider ist es super umständlich an die Graphen zu kommen. Gibt es eine Möglichkeit, wie ich die Graphen und die Motion Cam direkt auf der Startseite einbinden kann?


    Während ich da drüber nachgedacht hab, ist mir eingefallen, dass man doch eventuell die Werte in das Motion Bild schreiben könnte. Dazu habe ich abe rleider im Netz nichts gefunden... Das wäre nämlich die einfachste Möglichkeit.

    Hey zusammen,


    ich bin auf der suche nach einem einfachen (!) Tool, das ein paar Dinge erledigen soll. Leider gibt es zu dem Problem unendlich viele Tutorials und Snippets, dass ich da niemals einen Überblick erhalten kann.

    Ich suche ein Tool, dass mir folgendes bietet:
    - Temperatur Logging

    - Luftfeuchtigkeit Logging

    - Live Bild der Raspberry Camera darstellen

    - Möglichkeit für bspw. 2 Tage alle 10 min ein Bild aufzunehmen (optional)

    - Darstellung über einen Webserver nginx o.Ä.

    - Das alles möglichst als fertiges Tool, wo man im Prinzip nur noch die SensorIDs eingeben muss.


    Gibt es sowas irgendwo? Ich konnte leider nichts finden, dass mir das alles bietet.


    Vielleicht weiß einer von Euch da ein Projekt, dass er mir nennen könnte?


    Viele Grüße

    Danke für den Hinweis. PhP scheint openSSL zu beherrschen:

    Code
    1. pi@raspberrypi:~ $ php -i | grep -i openssl
    2. openssl
    3. OpenSSL support => enabled
    4. OpenSSL Library Version => OpenSSL 1.1.0f 25 May 2017
    5. OpenSSL Header Version => OpenSSL 1.1.0e 16 Feb 2017
    6. Openssl default config => /usr/lib/ssl/openssl.cnf
    7. openssl.cafile => no value => no value
    8. openssl.capath => no value => no value
    9. Native OpenSSL support => enabled
    10. pi@raspberrypi:~ $



    Gerade deinen Edit gesehen:

    Was vielleicht auch interessant ist, dass da lediglich Jessie aufgeführt wird und nicht stretch. Wobei es im Netz ja einiges zu Stretch und PiHole gibt...

    Ich pack mal testweise Jessie drauf und teste es nochmals.


    Und noch ein Edit:

    Code
    1. pi@raspberrypi:~ $ lscpu
    2. Architecture: armv6l

    Scheint doch was anderes zu sein, als der armv6 vom Pi ZeroohneW, oder hat der auch armv61?


    Und ein letzter Edit:

    Unter Jessie geht es ebenfalls nicht. Also ist entweder der Installer von FTL hinüber, oder der ZeroW wird noch nicht unterstützt.

    Jop:

    openssl is already the newest version (1.1.0f-3).


    Das Github Repo wird doch über https gezogen. Dann sollte das doch auch mit FTL gehen, oder?

    Wie gesagt gehen alle anderen Teilpakete problemlos durch.


    Edit:

    curl https://www.google.degibt mir zumindest den HTML Inhalt aus

    Problem gelöst: Anscheinend stimmte was mit den FTL Quellen nicht


    Hey,


    ich wollte gerade mal Pi-Hole auf meinem ZeroW installieren (aktuelles Stretch).

    Code
    1. sudo curl -sSL https://install.pi-hole.net | bash

    Während der Installation gibt es aber einen Fehler bei der Installation von FTL:

    Code
    1. ::: Downloading latest version of FTL...
    2. ::: Detected ARM-hf architecture (armv6 or lower)
    3. ::: Using ARM binary
    4. ::: Installing FTL... curl: (56) SSL read: error:00000000:lib(0):func(0):reason(0), errno 104
    5. failed (URL not found.)


    Wie bekomme ich diesen Fehler gelöst?

    Habe es auch mal auf einem frischen Image probiert und bekomme die selbe Fehlermeldung. Ich kann zwar das Admin Panel aufrufen, aber dort wird mir natürlich angezeigt, dass der FTL Dienst nicht läuft und dementsprechend gehen die Anzeigen auch nicht.


    Hatte das schon mal jemand?



    Hey,


    gute Arbeit. Das sieht echt super aus!

    Eine vermutlich sehr winzige Kleinigkeit: Das Logo bzw. der dunkelgraue Balken oben nimmt derzeit echt viel Platz weg. Vielleicht könnte man die Höhe etwas verringern?

    Der Style des Forums tendiert eh zu etwas größerer Darstellung, wodurch weniger Inhalt pro Bildschirmfläche angezeigt wird.


    Viele Grüße und weiter so!

    Das Prüfe ich nachher gleich mal.
    Kann dir gerade aus dem Kopf nicht sagen, welches ich verwendet habe. Da ich den Thread aber am 5. eröffnet habe, werde ich wohl zu 80% ein altes haben (ich weiß, dass ich es noch einmal neu geladen hatte - aber bin mir nicht sicher, ob es vor oder nach dem 7.0 war)


    Werde mich melden!

    Ja, das meinte er sicherlich. Schaffe ich dieses Wochenende aber wohl nicht mehr. Den Download kann ich vllt anschmeißen ;-)


    Ich verstehe trotzdem nicht, wie so ein Bug immer noch besteht. Ich mein der Zero W ist ja jetzt nicht brandneu und ich bin ja sicher nicht der erste der das Teil headless im WLAN aufsetzen will.


    Gruß

    Habe mit Paragon jetzt direkt in die wpa geschrieben. Ging auch nicht. Das liegt vielleicht daran, dass ich die Rechte hier nicht setzen kann. Ich geb es erstmal auf. Wollte eigentlich nicht so lange daran rumbasteln überhaupt in das OS zu kommen^^
    Wo bekomme ich denn die jessie Lite her?


    Danke dir trotzdem.


    PS: Hatte es auch mit dem code in der rc.local probiert...


    EDIT: Gefunden: https://downloads.raspberrypi.org/ (Keine Ahnung warum ich das vorhin nicht gesehen habe ;-)

    Das liegt daran, dass ich nur einen Widows PC hier habe. Auf dem hatte ich jetzt eigentlich geplant (wie auch schon bei meinem anderne 2er) einfach die SD Karte vorzubereiten und das WLAN vorzubereiten, um gar nicht erst Bildschirm/Tastatur anschließen zu müssen.


    Aber anscheinend ist das Image ja falsch. Kann man das irgenwie entpacken, bearbeiten und dann wieder zusammenpacken und flashen? Und das auch auf einem Windows PC)


    Ich habe jetzt noch eine Lösung probiert, wo einer meinte mit zwei network Einträgen würde das gehen - tut es aber nicht ;-(