Posts by Jabberwock

    Hallo,


    ich habe es jetzt mit LXDE versucht und bin soweit gekommen das dass
    LXterminal startet und den Befehl anscheinen ausführt. Man sieht es aufpoppen und das dort was geschrieben ist und dann verschwindet es gleicht wieder.
    Wenn ich
    @LXterminal -e sudo mc mache geht es!


    @LXterminal -e sudo /home/pi/ESD-Tester/MAIN3.pyw geht nicht!


    Wie kann ich herausfinden was er in dem Terminal schreib?
    Wird das irgendwo geloggt oder kann ich das loggen?


    Mfg
    Jabberwock

    also Du hattest recht. Per Doppelklick auf die .desktop startete das Programm auch nicht! Aber wohl eher weil ich jetzt so viel probiert hatte.
    Ich bin mir sicher das es schon ging.
    Jetzt geht es auf jeden Fall per Doppelklick aber immer noch nicht per Autostart!


    Kann noch was mit den rechten nicht stimmen?
    Owner ist Pi und es liegt im /home/pi/.config/autostart/



    [Desktop Entry]
    Name=ESD
    Comment=
    Path=/home/pi/ESD-Tester/
    Exec=sudo /home/pi/ESD-Tester/MAIN3.pyw
    #Exec=/home/pi/ESD-Tester/MAIN3.pyw
    #Terminal=true
    Type=Application



    habe gerade die Idee das es an dem desktop liegen könnte, oder?
    Wo wird denn der command ausgeführt? Wenn es nur ein terminal ohne Grafik ist dann geht das auch nicht, oder?
    Per SSH kann ich es ja auch nicht starten. Im LXTerminal geht es!
    Oder ist das quatsch?


    Mfg
    Jabberwock

    Hi,


    Ja ich hab es nach .config kopiert
    Ich habe die .desktop Datei ausführbar gemacht


    Und es funktioniert aber nur das Beispiel mit x11vnc aus dem Link.
    Das habe ich so übernommen und siehe da, es geht.


    Aber mein Python geht immer noch nicht...


    darf man mehrere .desktop Dateien haben? Oder müssen die Aufrufe alle in eine Datei?


    x11vnc.desktop angezeigt wird die Datei allerdings als "X11 VNC" Aber wenn ich sie umbenennen will wird der richtige Name x11vnc.desktop angezeigt! Denke das ist ok so, oder?


    [Desktop Entry]
    Name=X11 VNC
    Comment=
    Exec=x11vnc -forever -usepw -display :0
    Terminal=true
    Type=Application



    esd.desktop


    [Desktop Entry]
    Name=ESD-TEST
    Comment=ESD
    Type=Application
    Exec=sudo /home/pi/ESD-Tester/MAIN3.pyw
    Terminal=true

    Hallo,


    ich bekomme es einfach nicht hin. Ich habe mit Python eine Programmoberfläche erstellt und möchte das die beim Staten des PIs automatisch mitstartet.
    So dass der User den Desktop gar nicht, oder nur kurz, zusehen bekommt.


    Ich habe es mit LXDE und .Deskop versucht.


    Bei LXDE bekomme ich zb. Midori automatisch gestartet aber das Pythonprogramm nicht.
    Bei .Desktop tut sich gar nichts, wenn ich ein Doppelklick auf die .Desktop Datei mache startet das Tool so wie es soll!


    Ich vermute das Problem in den GPIOs weil dadurch wohl das Programm mit sudo gestartet werden muss.


    Bestimmt stelle ich mich nur zu blöd an...
    Könntet ihr mir mal bitte auf die Sprünge helfen?


    MfG
    Jabberwock

    Hallo,


    ich vermute es handelt sich einfach um einen Anfängerfehler...


    Ich habe es nun endlich geschafft Navit auf dem Raspberry zu kompilieren.
    wenn ich nun in dem navit-build Verzeichnis ./navit starte dann bekomme ich folgende Meldungen:


    Code
    pi@raspberrypi ~/navit-build/navit $ sudo ./navit
    Running from source directory
    error:navit:graphics_new:Failed to load graphics plugin gtk_drawing_area.
    error:navit:event_add_watch:Can't find event system method add_watch. Event system is not set.
    error:navit:event_remove_timeout:Can't find event system method remove_timeout. Event system is not set.
    error:navit:navit_init:Warning: No graphics subsystem available.
    error:navit:event_main_loop_run:Can't find event system method main_loop_run. Event system is not set.


    Dazu muss ich allerdings noch sagen das ich es zur Zeit per SSH mit x11 forwarding mache.
    Was an sich funktioniert, nur mit Navit nicht.


    in der navit.xml habe ich erst mal nichts verändert. Dann müsste es doch mit der DemoMap starten, oder?


    Als ich Navit einfach mit atp-get installiert hatte ging es. Allerdings ist es da immer beim berechnen einer Route abgestürzt. Deshalb wollte ich es mal kompilieren. Was an sich auch gut funktioniert hat nur starten klappt noch nicht ganz.


    Ich hoffe ihr könnt mir helfen.


    mfg
    Jabberwock