Posts by Pirat-Kapitan

    Moin Andreas,

    wenn ich Deine Suchbegriffe verwende, lande ich immer nur bei diesem Beitrag. Das ist irgendwie nicht richtig prickelnd.

    Du hast Tutorials erwähnt, ich habe bislang aber nur (bevor ich auf diesen Beitrag gestoßen bin) Hinweise auf CUPS gefunden, aber keinen mir richtig weiterhelfenden Beitrag, wie ich in CUPS meinen Netzwerkdrucker finden kann.


    Schöne Grüße
    Johannes

    "Da fällt mir gerade ein, dass man an einem laufenden System kein Update durchführt. Es sei denn man hat gute Gründe."
    Hi Patrick,
    wheezy hat wxgtk2.8-dev , ich brauche aber für mein Gartenbahn-Steuerungsprogramm besser die 3er Version, die nur unter jessie läuft, soweit ich weiß.
    Dazu kommt, dass der P3 nicht mehr unter wheezy läuft und ab und zu doch ein weiterer RasPi zur Steuerung angefordert wird.


    Schöne Grüße
    johannes

    Hallo HTH,
    Danke für deine Hinweise, da habe ich noch eine Weile dran zu knacken.
    hostapd und dnsmasq habe ich unter wheezy schon verwendet, das "systemd" mit dem "service" ist anscheinend eine neue jessie "Unart", in die ich mich einarbeiten muss.


    Ich habe inzwischen auch leider festgestellt, dass der im RasPi 3 eingebaute WLAN-Adapter nicht die für mich erforderliche Reichweite hat, also wieder ein externer WLAN-Adapter wie beim RasPi 2.


    Da ich meinen einzigen RasPi 3 jetzt bei meiner Gartenbahn fest eingebaut habe (im Client-Modus), kann ich den AP-Modus im Moment auch nicht weiter testen; das muss ich also auf später verschieben, wenn der nächste P3 da ist.


    Die AP-Funktionalität ist ein Goddie, Hauptaufgabe des RasPi ist die Gartenbahnsteuerung (fest installiert zu Hause und mobil für unterwegs). Wieweit ih da deinem Vorschlag folgen kann, alles runterzuschmeißen, muss ich noch austesten.


    Schöne Grüße
    johannes

    Hi,
    mit der ersten jessie-Version konnte ich ich nicht, wie unter wheezy, auf dem RasPi einen Accesspoint / Router einrichten. Da der RasPi 3 nur mit jessie läuft und ich den AP/Router fürs WLAN brauche, bräuchte ich bitte Unterstützung, wie ich auf dem RasPi 3 mit jessie das mache.


    Vielen Dank im Voraus !
    Johannes

    Hi,
    ich habe mir mal einen bestellt.
    - er paßt in die Pi2-Gehäuse
    - er hat WLAN auf der Platine
    - ich brauche sowieso einen weiteren (P2B oder besser wegen der Steckplätze).


    Bislang fahre ich WLAN immer über einen Adapter, wobei der RasPi zugleich auch AP ist und DHCP verwaltet. Wenn ich jetzt dafür kein externes Bauteil mehr brauche, habe ich sogar noch eine Kostenersparnis (und einen freien USB-Steckplatz).
    Gehäuse ist bei mir immer ein Kunststoffgehäuse, da stört mich eine interne Antenne nicht. Bei USB reicht mir USB 2.0, das Interface zu meiner Zentrale kann nicht mehr und wird auch hier nicht weiterentwickelt. bei 2 Zentralen parallel gehen hierfür auch 2 USB-Steckplätze drauf. Ein weiterer muss bei Bedarf für den tastaturanschluss verfügbar sein (ist also auch "weg"), der 4. ging beim P2 für den WLAN-Adapter drauf.
    Bislang wurde der WLAN-Adapter über USB vom RasPi versorgt, wenn der jetzt intern vom RasPi versorgt wird, sollte das in der Energiebilanz keinen Unterschied machen.


    Als Betriebssystem habe ich bislang (auch auf dem P2) Wheezy gefahren, der P3 benötigt vermutlich das aktuelle. Mal sehen, wie das mit meinem Steuerungsprogrammläuft.


    Schöne Grüße
    johannes

    Hi,
    ich verwende für einen RasPi mit Camera ein Powerpack, wie es auch zum Laden von Smartphones / Pads verwendet wird. Damit komme ich ohne Nachladen auf ca. 3 Stunden Betriebsdauer (RasPi incl. AP zur Bildübertragung per WLAN).
    Nachgeladen wird das Powerpack über den DCC-Gleisstrom (der natürlich auf 5V reduziert!).


    Schöne Grüße
    Johannes

    Hi,
    ich habe ein ähnliches Problem seit der neuen Betriebssystemversion vom 5. Mai (wheezy). Unter dieser Version läuft meine bisher funktionierende AP Installation nicht mehr.
    Dabei bekomme ich immer beim Hochfahren meines Raspi 2 die Fehlermeldung:
    [FAIL] Not running dhcpcd because /etc/network/interfaces ... failed !


    Zurück auf die Betriebssystemversion wheezy vom Feb. 2015 (#781) incl. update #781 (21. April 2015) läuft alles einwandfrei.


    Ich vermute, dass bei der Betriebssystem-Aktualisierung im Mai hier grundlegende Änderungen gemacht wurden, die ich noch nicht gefunden habe. Da mein System derzeit läuft, habe ich hier keine Priorität.
    Vielleicht liegt es bei Dir ja auch daran.


    Schöne Grüße
    Johannes

    Hi,
    ich habe freeRDP installiert, bekomme aber beim Starten aus der Konsole die Fehlermeldung
    xf_pre_connect: failed to open display
    Please check that the $DISPLAY enviroment variable is properly set


    hast Du da bitte einen Hinweis, wo ich was einstellen muss ?


    Schöne Grüße
    Johannes

    Hi,
    warum die SD-Karte formatieren?
    Ich nehme eine passsende, d.h mindestens 4 GB große SD Karte, ziehe darauf das raspian wheezy Image mit dem Win32DiskImager und der RasPi bootet.


    Das ganze NOOBS-Zeug ist meiner persönlichen Meinung nach Unsinn, ich will keine 1000 Betriebssysteme auf meinem RasPi sondern nur das eine, was ich brauche und was funktioniert.


    Im Rahmen der Erstkonfiguration des RasPi habe ich die menuegestützte Möglichkeit, die Imagepartition auf die gesamte SD-Kartenkapazität auszudehnen und dieses Formatierung ist immer in dem Format, das der RasPi braucht.


    Schöne Grüße
    Johannes

    Hi,
    iface lo inet loopback
    ist für die interne verbindung im RasPi, solltest Du bitte nicht verändern.


    iface wlan0 inet manual
    bedeutet, dass für den WLAN-Zugang die Zugangsdaten manuell eingegeben werden müssen. das ist normalerweise immer der fall, wenn noch keine WLAN-Verbindung aufgebaut wurde.


    Ich hänge Dir mal zum vergleich zwei dateiversionen meiner Installation an, die erste, wenn der rasPi als Client arbeitet, die zweite, wenn er als AP eingesetzt ist. Hier siehst Du auch die Einstellungen zu einer festen IP.


    interfaces als client:
    auto lo ** Einstellung füt die RasPi interne Verbindung
    iface lo inet loopback
    iface eth0 inet static ** Einstellung für den Kabel-netzwerkanschluss mit fester IP
    address 192.168.3.30
    netmask 255.255.255.0
    allow-hotplug wlan0 ** Einstellung für den WLAN-Zugang, wobei die IP vom externen Router zugeteilt wird
    iface wlan0 inet dhcp
    wpa-ssid "Netzwerkname"
    wpa-psk "Netzwerkschluessel"
    iface default inet dhcp


    interfaces als AP:
    auto lo
    iface lo inet loopback
    iface eth0 inet dhcp
    # WLAN mit statischer Konfiguration
    iface wlan0 inet static
    address 192.168.99.30
    netmask 255.255.255.0
    broadcast 192.168.99.255
    up /sbin/iptables –F
    up /sbin/iptables –X
    up /sbin/iptables -t nat –F
    up iptables -A FORWARD -o eth0 -i wlan0 -s 192.168.0.0/24 -m conntrack --ctstate NEW -j ACCEPT
    up iptables -A FORWARD -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT
    up iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    up sysctl -w net.ipv4.ip_forward=1
    up /etc/init.d/hostapd restart
    up /etc/init.d/dnsmasq restart


    Ich hoffe, es hat etwas zum Verständnis beigetragen
    Schöne Grüße
    johannes

    Hi,
    Laptop ohne eingeschobene SD-karte hochfahren,
    win32DiskImager starten und dort die Karte auswählen (Dein Standardlaufwerk für den SD-Karteneinschub kennst Du wohl noch?)
    Image neu kopieren (auf die SD-karte).

    Hi,
    was bringt mir dann das neue Modell A?
    - ich brauche einen aktiven USB-Hub, damit ich Tastatur, WLAN-Adapter und eine Gartenbahnzentrale anschließen kann.
    - Kosten für USB-Hub und WLAN-Stick sind höher als die Ersparnis Model A gegenüber Model B.


    Man muss nicht alle "Neuerungen" (andere sagen "Schwachsinn" dazu) mitmachen.


    Schöne Grüße
    Johannes

    Hi,
    ich habe ein Interface, das einen FTDI USB2COM Baustein enthält, sich aber mit einer falschen Hersteller / Produkt Kennung (vendor:product ID) meldet, die natürlich dem normalen FTDI-Treiber nicht bekannt ist.


    In einem englischsprachigen Forum habe ich einen Hinweis gefunden, dass ich in der Datei /etc/module diese Fake-ID bei Laden des Treibers dem Raspi bekannt geben kann. Leider weiß ich nicht mer, in welchem Forum. Der Befehl lautet:
    ftdi_sio vendor=0x1111 product=0x1234
    Damit aber auch andere User als der Root dann auf die /dev/ttyUSB0 Schnittstelle zugreifen können, ist nach diesem Forum noch ein user account in der "dialout group" anzulegen und eine "udev rule" wie
    ACTION=="add", ATTRS{idVendor}=="1111", ATTRS{idProduct}=="1234", MODE="0666"
    hinzuzufügen.


    meine Frage nun:
    wo bzw. wie greife ich auf diese dialout group Einträge zu und wo bzw. wie füge ich diese udev rule hinzu?


    Schöne Grüße
    johannes

    Hi
    127.0.0.1 ist m.E. die interne IP-Adresse des RasPi, die gehört in den Bereich
    iface lo inet loopback.
    Beobachtet doch mal beim Hochfahren, was der RasPi dazu an Meldungen ausstößt.


    Schöne Grüße
    Johannes

    Hi,
    ich habe meiner ersten erst im November bekommen, aber zum Rumspielen mit verschiedenen Distributionen bin ich noch nicht gekommen.
    Bei mir läuft darauf meine Eisenbahnsteuerung (bzw. der Serveranteil davon).


    Also mußt Du Dir zu einer sinnvollen Nutzung vielleichtz noch eine Modelleisenbahn anschaffen.:D


    Schöne Grüße
    Johannes

    Hi,
    wenn ich das richtig sehe, startet tightvnc immer die graphische Oberfläche startx. Hast Du mal einen anderen VNC-Server probiert (linux-vnc)?
    Wenn ich eine VNC-Verbindung im Terminalmodus brauche, verwende ich nicht tightvnc (geht natürlich auch, aber in startx wieder ein Terminalfenster öffnen ist nicht gerade ressourcenschonend).


    Schöne Grüße
    johannes

    Quote from klecks pid="2289" dateline="1353006582"


    EDIT 2 : muss mal schaun könnte mich nicht daran erinnern das raspi-config bei Raspbmc dabei ist..


    Hi klecks,
    genau das suche ich auch (raspi-config).
    In einer wheezy-Installation habe damit sehr schön u.a. meinen deutschen Zeichensatz einstellen können, was mir bei der Raspbmc-installation doch mächtig fehlt, wenn ich mit der Tastatur arbeite.


    Schöne Grüße
    johannes