Posts by Cryptomane_81

    Der Teufel liegt im Detail....

    Jetzt konnte ich mir selbst helfen.


    Meinem FORWARD hat eine 0 gefehlt :wallbash::blush:

    Code
    Falsch:
    -A FORWARD -o wwan -i eth0 -m conntrack --ctstate NEW -j ACCEPT
    Richtig:
    -A FORWARD -o wwan0 -i eth0 -m conntrack --ctstate NEW -j ACCEPT


    Somit geschlossen!


    Die Config ist (jetzt) alles im allen ganz nett, weil schlank. Für ähnliche Projekte bestimmt leicht anpassbar.

    Hi Chris,


    schau mal hier: Raspberry Pi als LTE Router

    Habe gerade ein ähnliches Projekt am Laufen. Vielleicht können wir uns ja gegenseitig unterstützen.


    Für meine Anforderungen sollte mein Pi4 auf jeden Fall reichen. Hatte das gleiche Setup vorher mit Pi3 laufen. Da hatte ich die Probleme wie jetzt nicht, dafür hatte ich Performance-Themen, wenn ich Videokonferenzen (WebEx, Zoom etc.) laufen hatte. Amazon Streaming lief einwandfrei. Wollte mit dem Pi4 einfach nur eine Fehlerquelle ausschließen und habe jetzt eine neue andere Fehlerquelle ;)


    Wie möchtest Du Deine Firewall umsetzten? Zu Fuß per iptables oder durch Pakete wie z.B. ufw?


    Grüße

    Hallo Kollegen,


    bei meinem Plan, mir einen eigenen LTE-Router für mein Heimnetz zu bauen, habe ich schon vieles ausprobiert und bin auch schon recht weit. Trotzdem scheitere ich gerade an Basics und finde den Denkfehler nicht :conf: Vermutlich irgendwo in den iptables oder im routing table. Aber eins nach dem anderen... ;)


    ... und an dieser Stelle schon VIELEN DANK!


    Stephan


    Mein Setup:

    Raspberry Pi 4 mit SIM7600X 4G HAT

    Heimnetz: 192.168.2.0/24

    internes Interface: eth0: 192.168.2.2

    externes Interface: wwan0

    DHCP und DNS (noch) über Fritzbox: 192.168.2.1

    uname -a: Linux raspberrypi 5.10.17-v7l+

    installierte Pakete: udhcpc, libqmi-utils, isc-dhcp-server, fail2ban, iptables-persistent



    Was ich bereits erreicht habe:

    aus dem internen Netz erreiche ich den Raspberry Pi per ssh ;)

    vom Raspberry Pi aus erreiche ich das Internet :bravo2:


    Woran ich gerade scheitere:

    alle Pakete in "FORWARD" werden gedropt

    Ping ins interne Netz geht auch nicht

    Code: ping 192.168.2.1
    PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
    ping: sendmsg: Operation not permitted



    Details zur Konfiguration:


    Code: /etc/dhcpcd.conf
    interface eth0
    static ip_address=192.168.2.2/24
    static domain_name_servers=8.8.8.8 8.8.4.4


    Code: sudo ip route
    default via 10.127.39.4 dev wwan0
    10.127.39.0/29 dev wwan0 proto kernel scope link src 10.127.39.3
    192.168.2.0/24 via 192.168.2.2 dev eth0
    192.168.2.0/24 dev eth0 proto dhcp scope link src 192.168.2.2 metric 202


    Code: /etc/sysctl.conf
    net.ipv4.ip_forward=1

    Vielen Dank für den Tipp und den Link auf Dein HowTo.


    Allerdings hat mir das ziemliches Kopfzerbrechen bereitet, denn ich habe mir damit permanent die gesamte Netzwerk-Konfig zerschossen, sodass ich ein paar mal meinen pi neu aufsetzen musste.


    Jetzt - nach weiteren google-sessions - bin ich etwas schlauer: ich bin im falschen Forum :(


    RaspBMC unterscheidet sich deutlich von Raspbian. Die /etc/network/interfaces ist leer und sollte es auch bleiben. Ob es überhaupt Wege gibt RaspBMC per Konsole zu konfigurieren, prüfe ich gerade noch. Angeblich liegt die Konfig hier: /home/pi/.xbmc/userdata/addon_data/script.raspbmc.settings/settings.xml


    Es bleibt spannend ;)

    Hallo Lunepi,
    Danke für die Reaktion.
    Der Pi hängt mit dem WLAN-Beinchen im Heimnetz und mit dem Ethernet-Port direkt am TV (ohne weiteren Switch o.ä.). Vom Pi aus lassen sich beide Netze per Ping erreichen.
    Leider kann ich vom TV aus keinen Ping absetzen. Die Netzwerk-Diagnose des Fernsehers sagt mir aber, dass das Internet nicht erreicht wird. Was wiederum bedeutet das entsprechende Anfrage nicht an mein Internet-GW (Default-GW des Heimnetzes) geroutet werden.


    Wer hat eine Idee?

    Hallo Forum,


    ich nutze meinen Raspberry primär als Mediaplayer (RaspBMC). Da ich aber ganz gerne bastle kam mir noch eine weitere Idee wie mir unser kleiner Freund weiterhelfen könnte. Für dieses Experiment benötige ich allerdings tiefere Kenntnisse vom Linux-Routing als ich derzeit habe. Daher zähle ich auch Euch ;)


    Ich schilde mal meinen eigentlich garnicht so komplexen Fall:
    Mein internetfähiger Fernseher hat große Sehnsucht nach www ;) Allerdings gönne ich ihm das moment nicht, weil ich hierzu ein Kabel durch meine halbe Wohnung ziehen müsste. Allerdings hängt an diesem Fernseher ja mein Raspberry und der hat dank USB-WLAN-Stick Zugriff auf das Internet. Der örtlich sehr nahe Respberry-Ethernet-Port ist folglich ungenutzt. Was spricht also dagegen den Raspberry als Router/Gateway zu verwenden? Mir scheint nichts; außer meinen beschränkten Raspbian-Kenntnissen.


    Über folgenden Befehl habe ich es bereits versucht:


    Code
    sudo route add -net 10.0.0.0 netmask 255.255.255.0 gw 10.0.0.1 dev eth0



    10-Netz = TV
    10.0.0.2 = manuell vergebene IP-Adresse des Fernsehers
    192-Netz = Heimnetz/WLAN
    192.168.2.1 = WLAN-Router mit Internet-Access


    Der Routing-Table sieht dann wie folgt aus:


    Code
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.2.1     0.0.0.0         UG    0      0        0 wlan0
    10.0.0.0        10.0.0.1        255.255.255.0   UG    0      0        0 eth0
    10.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0 eth0
    192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0


    Leider sieht mein Fernseher immer noch kein Licht am Ende des Tunnels.


    Was mache ich falsch? Was fehlt?


    Schon mal Dank für Eure Anregungen.


    Stephan