Posts by Timmi

    So sieht der komplette Log aus:


    E [21/Sep/2018:22:58:58 +0200] [Job 66] Unable to open raster stream - : Broken pipe

    E [21/Sep/2018:22:58:58 +0200] [Job 66] Job stopped due to filter errors; please consult the error_log file for details.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] The following messages were recorded from 22:58:56 to 22:58:58

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Adding start banner page "none".

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Adding end banner page "none".

    D [21/Sep/2018:22:58:58 +0200] [Job 66] File of type application/vnd.cups-pdf-banner queued by "pi".

    D [21/Sep/2018:22:58:58 +0200] [Job 66] hold_until=0

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Queued on "RICOH_SP_220Nw" by "pi".

    D [21/Sep/2018:22:58:58 +0200] [Job 66] time-at-processing=1537563536

    D [21/Sep/2018:22:58:58 +0200] [Job 66] 4 filters for job:

    D [21/Sep/2018:22:58:58 +0200] [Job 66] bannertopdf (application/vnd.cups-pdf-banner to application/pdf, cost 32)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] pdftopdf (application/pdf to application/vnd.cups-pdf, cost 66)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] gstoraster (application/vnd.cups-pdf to application/vnd.cups-raster, cost 99)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] rastertolilo2 (application/vnd.cups-raster to printer/RICOH_SP_220Nw, cost 0)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] job-sheets=none,none

    D [21/Sep/2018:22:58:58 +0200] [Job 66] argv[0]="RICOH_SP_220Nw"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] argv[1]="66"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] argv[2]="pi"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] argv[3]="Test Page"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] argv[4]="1"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] argv[5]="job-uuid=urn:uuid:2063e09a-4f44-367a-7bd6-42ccae9043b2 job-originating-host-name=localhost date-time-at-creation= date-time-at-processing= time-at-creation=1537563536 time-at-processing=1537563536"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] argv[6]="/var/spool/cups/d00066-001"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[0]="CUPS_CACHEDIR=/var/cache/cups"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[1]="CUPS_DATADIR=/usr/share/cups"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[2]="CUPS_DOCROOT=/usr/share/cups/doc-root"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[3]="CUPS_FONTPATH=/usr/share/cups/fonts"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[4]="CUPS_REQUESTROOT=/var/spool/cups"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[5]="CUPS_SERVERBIN=/usr/lib/cups"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[6]="CUPS_SERVERROOT=/etc/cups"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[7]="CUPS_STATEDIR=/var/run/cups"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[8]="HOME=/var/spool/cups/tmp"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[9]="PATH=/usr/lib/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[10]="SERVER_ADMIN=root@raspberrypi3b"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[11]="SOFTWARE=CUPS/2.2.1"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[12]="TMPDIR=/var/spool/cups/tmp"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[13]="USER=root"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[14]="CUPS_MAX_MESSAGE=2047"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[15]="CUPS_SERVER=/var/run/cups/cups.sock"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[16]="CUPS_ENCRYPTION=IfRequested"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[17]="IPP_PORT=631"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[18]="CHARSET=utf-8"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[19]="LANG=de.UTF-8"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[20]="PPD=/etc/cups/ppd/RICOH_SP_220Nw.ppd"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[21]="RIP_MAX_CACHE=128m"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[22]="CONTENT_TYPE=application/vnd.cups-pdf-banner"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[23]="DEVICE_URI=usb://RICOH/SP%20220Nw?serial=FIXC9985C8A"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[24]="PRINTER_INFO=RICOH SP 220Nw"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[25]="PRINTER_LOCATION="

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[26]="PRINTER=RICOH_SP_220Nw"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[27]="PRINTER_STATE_REASONS=none"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[28]="CUPS_FILETYPE=document"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[29]="FINAL_CONTENT_TYPE=application/vnd.cups-raster"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[30]="AUTH_I****"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Started filter /usr/lib/cups/filter/bannertopdf (PID 1067)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Started filter /usr/lib/cups/filter/pdftopdf (PID 1068)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Started filter /usr/lib/cups/filter/gstoraster (PID 1069)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Started filter /usr/lib/cups/filter/rastertolilo2 (PID 1070)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Started backend /usr/lib/cups/backend/usb (PID 1071)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] PID 1070 (/usr/lib/cups/filter/rastertolilo2) stopped with status 113 (Permission denied)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Hint: Try setting the LogLevel to "debug" to find out more.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] execv failed: Permission denied

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Loading USB quirks from \"/usr/share/cups/usb\".

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Loaded 132 quirks.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Printing on printer with URI: usb://RICOH/SP%20220Nw?serial=FIXC9985C8A

    D [21/Sep/2018:22:58:58 +0200] [Job 66] pdftopdf: Last filter determined by the PPD: rastertolilo2; FINAL_CONTENT_TYPE: application/vnd.cups-raster => pdftopdf will not log pages in page_log.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] OUTFORMAT=\"(null)\", so output format will be CUPS/PWG Raster

    D [21/Sep/2018:22:58:58 +0200] [Job 66] libusb_get_device_list=5

    D [21/Sep/2018:22:58:58 +0200] [Job 66] STATE: +connecting-to-device

    D [21/Sep/2018:22:58:58 +0200] [Job 66] STATE: -connecting-to-device

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Printer found with device ID: MFG:RICOH;CMD:GDI;MDL:SP 220Nw;FW:V1.03;VSTATUS:IDLE;CMT:1B2A6F0B;SN:FIXC9985C8A;CLASS:Printer;DES:RICOH SP 220Nw; Device URI: usb://RICOH/SP%20220Nw?serial=FIXC9985C8A

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Device protocol: 2

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Sende Daten zum Drucker.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Sent 0 bytes...

    D [21/Sep/2018:22:58:58 +0200] [Job 66] PDF template file doesn\'t have form. It\'s okay.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] PID 1067 (/usr/lib/cups/filter/bannertopdf) exited with no errors.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Color Manager: Calibration Mode/Off

    D [21/Sep/2018:22:58:58 +0200] [Job 66] PID 1068 (/usr/lib/cups/filter/pdftopdf) exited with no errors.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Calling FindDeviceById(cups-RICOH_SP_220Nw)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Found device /org/freedesktop/ColorManager/devices/cups_RICOH_SP_220Nw

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Calling org.freedesktop.ColorManager.Device.Get(ProfilingInhibitors)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Calling FindDeviceById(cups-RICOH_SP_220Nw)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Found device /org/freedesktop/ColorManager/devices/cups_RICOH_SP_220Nw

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Calling GetProfileForQualifiers(Gray.PlainRecycled.600dpi...)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Found profile /org/freedesktop/ColorManager/profiles/RICOH_SP_220Nw_Gray__

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Calling org.freedesktop.ColorManager.Profile.Get(Filename)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Use profile filename: \'\'

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Color Manager: ICC Profile:

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Ghostscript using Any-Part-of-Pixel method to fill paths.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Ghostscript command line: gs -dQUIET -dPARANOIDSAFER -dNOPAUSE -dBATCH -dNOINTERPOLATE -dNOMEDIAATTRS -sstdout=%stderr -sOutputFile=%stdout -sDEVICE=cups -sMediaType=PlainRecycled -r600x600 -dMediaPosition=2 -dDEVICEWIDTHPOINTS=595 -dDEVICEHEIGHTPOINTS=841 -dcupsBitsPerColor=8 -dcupsColorOrder=0 -dcupsColorSpace=3 -scupsPageSizeName=A4 -I/usr/share/cups/fonts -c \'<</.HWMargins[12.000000 12.000000 12.000000 12.000000] /Margins[0 0]>>setpagedevice\' -f -_

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[0]=\"CUPS_CACHEDIR=/var/cache/cups\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[1]=\"CUPS_DATADIR=/usr/share/cups\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[2]=\"CUPS_DOCROOT=/usr/share/cups/doc-root\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[3]=\"CUPS_FONTPATH=/usr/share/cups/fonts\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[4]=\"CUPS_REQUESTROOT=/var/spool/cups\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[5]=\"CUPS_SERVERBIN=/usr/lib/cups\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[6]=\"CUPS_SERVERROOT=/etc/cups\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[7]=\"CUPS_STATEDIR=/var/run/cups\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[8]=\"HOME=/var/spool/cups/tmp\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[9]=\"PATH=/usr/lib/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[10]=\"SERVER_ADMIN=root@raspberrypi3b\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[11]=\"SOFTWARE=CUPS/2.2.1\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[12]=\"TMPDIR=/var/spool/cups/tmp\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[13]=\"USER=root\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[14]=\"CUPS_MAX_MESSAGE=2047\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[15]=\"CUPS_SERVER=/var/run/cups/cups.sock\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[16]=\"CUPS_ENCRYPTION=IfRequested\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[17]=\"IPP_PORT=631\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[18]=\"CHARSET=utf-8\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[19]=\"LANG=de.UTF-8\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[20]=\"PPD=/etc/cups/ppd/RICOH_SP_220Nw.ppd\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[21]=\"RIP_MAX_CACHE=128m\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[22]=\"CONTENT_TYPE=application/vnd.cups-pdf-banner\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[23]=\"DEVICE_URI=usb://RICOH/SP%20220Nw?serial=FIXC9985C8A\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[24]=\"PRINTER_INFO=RICOH SP 220Nw\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[25]=\"PRINTER_LOCATION=\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[26]=\"PRINTER=RICOH_SP_220Nw\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[27]=\"PRINTER_STATE_REASONS=none\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[28]=\"CUPS_FILETYPE=document\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[29]=\"FINAL_CONTENT_TYPE=application/vnd.cups-raster\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] envp[30]=\"AUTH_INFO_REQUIRED=none\"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Read 64 bytes of back-channel data...

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Read 64 bytes of back-channel data...

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Read 64 bytes of back-channel data...

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Waiting for read thread to exit...

    D [21/Sep/2018:22:58:58 +0200] [Job 66] PID 1071 (/usr/lib/cups/backend/usb) exited with no errors.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Start rendering...

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Processing page 1...

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Error: /ioerror in --showpage--

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Operand stack:

    D [21/Sep/2018:22:58:58 +0200] [Job 66] (/var/spool/cups/tmp/gs_80Mx38) --nostringval-- 1 true

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Execution stack:

    D [21/Sep/2018:22:58:58 +0200] [Job 66] %interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 2003 1 3 %oparray_pop 2002 1 3 %oparray_pop 1986 1 3 %oparray_pop --nostringval-- --nostringval-- --nostringval-- 2 1 1 --nostringval-- %for_pos_int_continue --nostringval-- --nostringval-- 1874 2 9 %oparray_pop --nostringval-- --nostringval--

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Dictionary stack:

    D [21/Sep/2018:22:58:58 +0200] [Job 66] --dict:977/1684(ro)(G)-- --dict:1/20(G)-- --dict:83/200(L)-- --dict:83/200(L)-- --dict:135/256(ro)(G)-- --dict:291/300(ro)(G)-- --dict:32/32(L)-- --dict:6/9(L)-- --dict:27/40(L)--

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Current allocation mode is local

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Last OS error: Broken pipe

    D [21/Sep/2018:22:58:58 +0200] [Job 66] GPL Ghostscript 9.20: Unrecoverable error, exit code 1

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Rendering completed

    D [21/Sep/2018:22:58:58 +0200] [Job 66] PID 1069 (/usr/lib/cups/filter/gstoraster) stopped with status 1.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] Hint: Try setting the LogLevel to "debug" to find out more.

    D [21/Sep/2018:22:58:58 +0200] [Job 66] End of messages

    D [21/Sep/2018:22:58:58 +0200] [Job 66] printer-state=3(idle)

    D [21/Sep/2018:22:58:58 +0200] [Job 66] printer-state-message="Rendering completed"

    D [21/Sep/2018:22:58:58 +0200] [Job 66] printer-state-reasons=none

    Hallo zusammen,


    ich hoffe es kennt sich jemand ein wenig mit CUPS aus. Ich habe den Drucker "Ricoh SP220NW" am Raspberry hängen. Diesen habe ich über CUPS hinzugefügt und die entsprechende pdd.-Datei hinzugefügt. Allerdings habe ich das Problem das keine Datei gedruckt wird. Es kommt immer zu folgender Fehlermeldung (Fehlerausschnitt aus der Error.log):


    [21/Sep/2018:20:34:16 +0200] [Job 50] Start rendering...

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] Processing page 1...

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] Error: /ioerror in --showpage--

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] Operand stack:

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] (/var/spool/cups/tmp/gs_Bvld1a) --nostringval-- 1 true

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] Execution stack:

    D [21/Sep/2018:20:34:16 +0200] [Job 50] %interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 2003 1 3 %oparray_pop 2002 1 3 %oparray_pop 1986 1 3 %oparray_pop --nostringval-- --nostringval-- --nostringval-- 2 1 1 --nostringval-- %for_pos_int_continue --nostringval-- --nostringval-- 1874 2 9 %oparray_pop --nostringval-- --nostringval--

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] Dictionary stack:

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] --dict:977/1684(ro)(G)-- --dict:1/20(G)-- --dict:83/200(L)-- --dict:83/200(L)-- --dict:135/256(ro)(G)-- --dict:291/300(ro)(G)-- --dict:32/32(L)-- --dict:6/9(L)-- --dict:27/40(L)--

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] Current allocation mode is local

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] Last OS error: Broken pipe

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] GPL Ghostscript 9.20: Unrecoverable error, exit code 1

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] Rendering completed

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] PID 1903 (/usr/lib/cups/filter/gstoraster) stopped with status 1.

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] Hint: Try setting the LogLevel to "debug" to find out more.

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] End of messages

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] printer-state=3(idle)

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] printer-state-message="Rendering completed"

    D

    [21/Sep/2018:20:34:16 +0200] [Job 50] printer-state-reasons=none



    Kann mir da jemand weiterhelfen? Das übersteigt bei weitem meine Kenntnisse :helpnew:


    Gruß,

    Doch, ich verwende mehrere Webanwendungen Marke Eigenbau inklusive AJAX, auch an meinem iPad.


    Nein, nur mit PHP geht es nicht ohne Refresh der Seite. Dazu verwendet man nun mal AJAX oder WebSockets.


    Ok, dann habe ich es verkehrt recherchiert bzw. falsche Infos gelesen. Dann geht es in dieser Richtung weiter. :danke_ATDE:

    hyle Vielen Dank für deine Unterstützung. Ohne dich wäre ich bei weitem noch nicht so weit.


    Linus Danke für den Hinweis auf Ajax. Aber das funktioniert leider mit dem iPad nicht. Gibt es eine andere Möglichkeit? Ich hatte mal "onsubmit=(return false)" ausprobiert. Aber das hat leider nicht geklappt. Die Buttons auf meiner Seite aktualisieren sich ja auch nicht bei einem Refresh. Aber halt eben nach dem "Knopfdruck" lädt die ganze Seite neu. Das wäre mir ja im Prinzip egal, bis auf das iframe-Element wo ich die Webcam drin eingebunden habe. :helpnew:

    Ein letzte Frage hätte ich allerdings doch noch. Der Teil mit den Buttons löst einen Reload der Seite aus. Wie kann ich das verhindern?

    Ich habe auf Anhieb dazu nichts passendes gefunden, bzw. nur in Java.. Hat hier noch jemand einen Tipp für mich?

    Hallo hyle ,


    danke für deine Hilfe. Ich habe es jetzt soweit zum laufen gebracht:



    Allerdings habe ich noch das Phänomen das ich nur einmal einen Befehl ausführen kann und er danach die Buttons nicht mehr beachtet bzw. zur Zeit ist es so das ich, egal welchen Button ich betätige, immer nur den Vorwärtsbefehl ausführen.


    Muss ich da noch eine Schleife programmieren?


    //EDIT: Ich habe es herausgefunden. Ich hätte das 'Isset' nicht nutzen dürfen. Die Ausgänge sind ja'0' :wallbash:


    Gruß,

    hyle: Das hat leider keinen Erfolg gebracht. Ich habe die GPIOs jetzt beim starten als Ausgang definiert. Aber damit komme ich auch nicht weiter. Ist meine Abfrage der Buttons bzw. der Ansteuerung der GPIOs so korrekt?


    Ich warte natürlich nicht das mir jemand den Code schreibt, das ist nicht Sinn der Sache. Ich habe den Code heute neu aufgestellt und auch komplett Fehlerfrei (bis auf meine Frage in #34). Es ist deutlich weniger geworden.


    Allerdings habe ich noch Probleme mit echo, das gibt keinen Wert zurück wenn ich auf einen Button drücke. Heisst das der Wert vom Button wird nicht an den Shell_exec gesendet? Oder klappt das nicht weil er nicht ausgeführt werden kann?


    Anbei HTML und CSS.



    Vielleicht hat ja hier noch jemand einen Tipp für mich? :helpnew:

    Ich sitze auch nicht hier vor der Forumsseite und warte darauf das mir jemand antwortet. Ich arbeite jeden Tag 2-3 Stunden an der Software. Vielleicht mögen für den ein oder anderen diese Dinge elementar erscheinen, für mich ist alles an HTML und PHP neu. Und wenn ich dann eine Frage stelle, weil ich an der Stelle nicht weiter komme, vielleicht auch weil ich nicht weiss wie ich richtig danach suche, braucht mir nicht jeder Zweite irgendwelche Tutorials zu empfehlen. Ich lese mich auch durch diverse Foren, Anleitungen und Codes um mir daraus meinen Code anzupassen. Wenn jemand nur kommentiert um mit dem Finger auf irgendwelche Tutorials zu zeigen, möchte ich diejenigen doch bitten davon einfach abzusehen und weiter zu scrollen. Danke.


    An die hilfsbereiten Nutzer hier ein großes Danke für die bisherige Unterstützung.

    Btw.: Ich bin übrigens dabei das HTML-Gerüst von Grund auf neu aufzubauen..

    PHP-Datei

    CSS-Datei


    Die Befehle kommen aber noch nicht an den GPIOs an.. Vielleicht passt doch was mit den Rechten nicht.. Muss ich mir nochmal genauer ansehen.

    Geany meckert beim kompilieren zumindest nicht mehr und das Programm wirkt strukturierter (zumindest für mich) - Danke dafür.. :danke_ATDE:

    Ok, danke. Ich werde das dann testen und Rückmeldung geben.


    Allerdings hat sich meine Website jetzt total verschoben, also alles ist nicht mehr so Positioniert wie ich das vorher hatte.

    Weisst du woran das liegen kann?

    Nein, du hast Recht.. Ich hab noch ein paar kleine Fehlerchen korrigiert..


    So sieht es jetzt aus:


    Können keine. C++ verstehen und programmieren im kleinen Stil..



    Kann mir den Code denn für die beiden Buttons jemand mal korrigieren? Dann weiss ich wenigstens mal wie man das überhaupt angeht.

    Btw: Rechte für www-data sind übrigens vergeben..

    Ich hab mich mal mit C++ daran gewagt.. Aber davon wurde mir recht schnell abgeraten.. Daher bin ich auf PHP umgeschwenkt.. Weil ich da quasi "alles in einem" habe.. Sprich Aufbau der Website und Ansteuerung der GPIOs...