Posts by RobertP

    Hi,


    in jeder Desktopumgebung sind ja naturgemäß eine Reihe mehr oder weniger schöner Schriftarten verfügbar. Jetzt meine Frage: Wie kann ich die (zeichenweise) aus der entsprechenden Datei auslesen um sie im userspace auf einem GPIO-Display auszugeben? :s


    Mit einem 8Bit AVR habe ich das schon gemacht, aber wozu sollte ich die Schriftart in den Code hämmern, wenn sie im Filesystem ohnehin vorhanden sind?


    Ich danke für Ideen...

    Hallo,


    ich habe ein kleines Problemchen, das durch die Umstellung von Wheezy nach Jessie aufgetreten ist und bei dem ich nicht weiter weiß.


    Ich habe einen Pi2B im Auto am Radio für die USB-Wiedergabe angeschlossen und für die power-on und power-off-Events das DT-Overlay, wie auf der Bootpartition beschrieben, benutzt. Mit Wheezy hat das auch wunderbar funktioniert und ich habe das Verhalten sowohl auf dem Oszi als auch im power-management-Controller gesehen.


    Seit dem Upgrade auf Jessie und dem Upgrade vom MP3Player zum Navitgationssystem resultiert dasaktivierte DT-Overlay in einer kernel panic beim shutdown.


    Ich habe jetzt einen ekeligen Workaround, würde aber gern wieder auf das DT-Overlay gehen. Weiß dazu hier jemand was?


    Danke

    Es ist ein TFT mit brutalen 320x234 Pixel aus einem 2000er VW-Navi. Das wird mit RGB angesteuert und ich habe noch einen FBAS-RGB-Konverter dazwischen. Gleichzeitig ist an dem selben Konverter noch eine Rückfahrkamera angeschlossen. Da zeigt sich kein Balken an der Oberkante des Displays. Das Display selbst ist ein Sharp. Die genaue Bezeichnung habe ich aber gerade nicht im Kopf.
    Wenn das Display von der Navi-Hardware direkt angesteuert wird, dann ist natürlich kein Rand.

    Hi Leute,


    ich habe eine einfache Frage: Was sind die maximalwerte für den Overscan in der config.txt?


    Ich habe ein 5,4" RGB-TFT, das oben noch einen schwarzen Balken hat, der Overscan allerdings schon auf 130 (oder war es -130?) steht. Den würde ich gern los werden.Gibt es da einen Trick?


    Danke

    Vielen dank für die Hilfe. Mein Problem war offenbar nicht das Update sondern die portfreigabe in der Fritzbox. Jetzt geht alles, obwohl das zurückrollen nicht funktionierte. Ich bekomme dabei

    Code
    gzip: stdin: not in gzip format

    . Macht aber nichts, da das rpi-update nicht das Problem war.

    Hallo,


    ich habe ein Update auf meinem Apache-Pi mit SVN und einer Owncloud gemacht. Seitdem kann ich nichtmehr auf die Owncloud zugreifen und komme nichtmehr per SSH auf den PI.


    Ich habe folgendes gemacht:

    Code
    sudo apt-get update
    sudo apt-get upgrade
    sudo rpi-upgrade

    (Aus dem Gedächtnis)


    Gibt es eine Möglichkeit, das Update zurückzurollen und den Pi wieder auf seinen Zustand vor dem Update wiederherzustellen? Eine Linux-VM, mit der ich auf die SD-Karte zugreifen kann, ist da.

    Hallöchen,


    ich habe eine frisch geladenene Arch-SD-Karte nach Anleitung von archlinux.org erstellt. Kann ich, bevor ich die das erste Mal mit dem Pi benutze, mein Wlan vorkonfigurieren, damit ich den nicht ans Lan hängen muss. Die Kochrezepte im Netz sich scheinbar alle mit auf dem Pi laufenden Programmen gemacht.


    Ja? Nein? Vielleicht?


    Bitte ankreuzen und ehrlich sein. :D

    Jedenfalls kann man den von Dir geschilderten Effekt immer dann beobachten, wenn der Raspberry Pi über seine USB-Buchse einen USB-Hub mitversorgen mus, an dem (inkl. der USB-Ports am RPi) bereits zu viele Stromfresser hängen.

    Sowas ind er Art habe ich befürchtet. Der USB Hub ist nämlich nicht aktiv. Ich finde es aber sehr 'unprofessionell', wenn der PI2 die nach USB-Standard garantierten 500mA pro USB-Buchse nicht schafft.


    Wie geschrieben: Der Pi wird ja vom Labornetzgerät und nicht von irgendeinem USB-Netzteil versorgt. Die gesamte Stromaufnahme des Systems lag ja immer unter den 500mA, die ein USB-Port allein schaffen muss.


    Wo finde ich das Log für den Bootvorgang?

    Hallo,


    ich habe einen Pi2, der den Pi A+ in meinem CarPCLite ersetzen soll. Für die Aufrüstung zu einem vollwertigen Navi soll noch ein USB-GPS-Empfänger an den Pi. Dafür brauche ich aber einen USB-Hub, damit ich die Kombo auf dem Schreibtisch testen kann. Zum Testen und Programmieren brauche ich Tastatur, Maus, Wlan-Stick, USB-Speicherstick und GPS. OS ist Raspbian.


    Ich habe zwei verschiedene selfpowered 4-Port-Hubs ausprobiert. Beim Start, nach etwa 4s startet der Pi2 einfach neu. Der B+ läuft einfach durch und startet wie gewohnt. Die Stromaufnahme ist dabei maximal 450mA, die Spannung ist am Labornetzgerät auf 5,0V(@3A max) eingestellt und bleibt da auch.


    Ein Update / Upgrade ändert nichts.


    Was kann ich tun? Danke.

    Hallo,


    ist es möglich, die Bootreihenfolge einzelner Dienste zu ändern?


    Was ich erreichen möchte, ist nur die grundlegenden Dienste beim Booten zu starten und dann, wenn meine Applikation läuft, (Qt-App im X-Server) sollen die nicht so wichtigen Dienste nachgeladen werden.


    Beispiel: Wlan; Ich möchte nicht jedes mal 30s auf den DHCP-Offer warten, wenn am Ende gar kein Wlan verfügbar ist. Da sich der Pi im Auto befindet - wo es selten WLAN gibt.


    BS ist natürlich Raspbian. Das ganze läuft auf einem Pi A+.


    Danke.

    Hier ist die Lösung zum Problem.


    Hallo,


    ist es mölich zwei Soundkarten am B+ so zu betreiben, dass man ein Audiosignal so auf die vier Kanäle verteilen kann, wie man es von einem Autoradio mit vier Lautsprechern gewöhnt ist?


    Eine einfache USB-Stereo-Soundkarte habe ich am B+ laufen, aber kann man bspw. mehrere mit dem Alsamixer bearbeiten?


    Das balancing/fading soll per Software über eine Gui erledigt werden.


    Danke.

    Ich mach' mir eine Platine. Da brauche ich keine Module.


    Aber zu meiner Frage: Die ist inzwischen anderweitig gelöst. Ich schalte dem Pi die gesamte Versorgung weg (wenn er erfolgreich heruntergefahren ist). Damit muss ich keinen zweiten Schaltregler mehr nehmen, weil wenn das Auto abgestellt ist, der Pi ohnehin keine Versogung hat.


    Manche Lösungen entstehen bei der Formulierung des Problems. :D

    Hallo,


    Für mein Raspberry Pi CarPC Projekt entwerfe ich gerade die Schaltung, die den Pi ein und ausschaltet und die Eingabe an den Pi weiterleitet. Kern dieser Schaltung ist ein Atmega16, der eine Analogtastenmatrix einliest und die Werte per UART an den Pi senden soll. Der AVR lauscht auf den Schaltzustand des Radios und startet und beendet den Pi entsprechend. Um die Energieverschwendung minimieren zu können, soll es einen LM2576-5,0 Schaltregler für die 5V-Strecke und einen LM2574-3,3 für die 3,3V-Strecke geben. Den auf dem Pi verbauten Linearregler werde ich entfernen/deaktivieren.


    Nun zu meiner Frage: Ist es möglich, wenn der Pi bereits abgeschaltet ist, die 5V-Versorgung zu trennen und nur die 3,3V eingeschaltet zu lassen?


    Danke.