Posts by cornelius fillmore

    Guten Morgen, ich habe folgendes als upload.sh eingerichtet

    Bash
    #!/bin/bash
    
    sshpass -p 'Webcam12345678' sftp sftp@webcam.aartalsee.de@ssh.strato.de << !
       put /home/pi/www/webcam/bild.jpg
       bye
    !

    Dann kommt aber als Fehlermeldung

    Code
    pi@raspberrypi:~ $ sudo bash /home/pi/www/upload.sh
    sshpass: Failed to run command: No such file or directory

    mit sftp kann ich mich problemlos auf dem Strato-sftp mit Nutzer und Passwort einloggen


    Was kann ich tun um dies im einem script abzuarbeiten?

    Code
    sudo apt-get install libssh2-php

    Dann den Webserver einmal neustarten.

    Anbei das Ergebnis

    cornelius fillmore Kannst Du die Umstände mal bitte noch erläutern, wie es dazu kommt, dass PHP verwendet wird /werden soll und was das mit einem RPi zu tun hat?

    Ich lade halt ein Webcam-Foto alle 2 Minuten auf unseren Webspace und stelle es somit unterschiedlichen Nutzern zur Verfügung.
    Dies hatte ich halt mit einen php-script und dem RPI realisiert, da dieser sowieso 24/7 am Start ist
    Wenn es einfacher geht gerne doch

    Vielen Dank

    Ich habe

    PHP
    <?php
    $connection = ssh2_connect('ssh.strato.de', 22);
    ssh2_auth_password($connection, 'login@xxxx.de', 'yyyyyyy');
    
    ssh2_scp_send($connection, '/home/pi/www/webcam/bild.jpg', 'bild.jpg', 0644);
    ?>

    mal eingegeben und ausgeführt.

    Da kommt aber die Fehlermeldung:

    Code
    PHP Fatal error:  Uncaught Error: Call to undefined function ssh2_connect() in /home/pi/www/ipkamera3.php:2
    Stack trace:
    #0 {main}
      thrown in /home/pi/www/ipkamera3.php on line 2

    Was kann ich tun?

    Guten Morgen zusammen,


    nachdem STRATO seine FTP-Zugänge so langsam abschaltet haben wir ein Problem mit unserem Cam-upload

    Dies haben wir bisher mit diesem script alle 2 Minuten gemacht

    Dies funktioniert nur noch eingeschränkt.


    Da ich nicht der Experte bin, kann mir mal einer erklären wie ich das script ändern muss, damit dies wieder funktioniert?


    STRATO hat dies als Einstellungen angeben:

    Alle gängigen FTP-Programme unterstützen auch SFTP. Verwenden Sie dafür einfach folgende Angaben bei der Verbindung:

    Server: ssh.strato.de

    Port: 22

    Benutzername: gleicher Benutzername wir für FTP

    Passwort: gleiches Passwort wie für FTP






    Danke euch

    Hallo Forum,


    kann mir mal einer weiterhelfen.


    Ich habe jetzt die Cloud (Vers. 6.0.0a) erfolgreich installiert.


    Datenaustausch mit den Kalender funktioniert gut.


    Jetzt auf einmal meckert die cloud rum:
    "Ihr Web-Server ist noch nicht für eine Datei-Synchronisation konfiguriert, weil die WebDAV-Schnittstelle vermutlich defekt ist. Bitte überprüfen Sie die Instalationsanleitungen."


    Was muss ich denn jetzt machen?
    Die Meldung war doch eben noch nicht da


    Hab Temperatursensor über den Pi zum laufen bekommen (One Wire Sensor). Hab auch eine USB Wetterstation von pollin (WS-0101) mit wview über usb zum laufen bekommen. Ich würde jetzt gerne noch das PiFace als Schnittstelle nach außen verwenden. Also Relais schalten und vielleicht andere Werte zusätzlich auslesen (UV Index /Sonnenscheindauer über ... naja... vielelicht eine kleine Solarzelle oder so).
    Grüße
    Naischi


    FB_Addon_TelNo{ height:15px !important; white-space: nowrap !important; background-color: #0ff0ff;}
    Hallo Naischi,


    hast du an dem Projekt weitergemacht?


    Ich habe so etwas ähnlich vor und wollte mich mal mit dir darüber unterhalten.

    Hallo zusammen,


    ich habe das Watterot-Funbkmodul am laufen und wollte nun die Reichweite erhöhen in dem ich mit einem externen Netzteil die Spannung von 5V auf 12V erhöhe.


    Das funktioniert aber nicht.


    Was mach ich denn falsch?

    Ich habe nur versucht anhand von

    Quote


    [Tutorial] Raspberry Pi als Webserver - phpMyAdmin Installation


    den Pi neu aufzusetzen und die Funksteckdosen-Ansteuerung (wiringpi und remotecontrol) zu installieren und dann hat sich der o.g. Fehler eingestellt


    Noch was zu den Befehl:
    Während dem booten schreibt er

    Quote


    Starting OpenBSD Secure Shell Server: sshd


    dann die Fehlermeldung

    Quote


    Error opening ........

    Guten Morgen Forum,
    so jetzt habe ich meinen Pi neu aufgesetzt und das feb-image aufgespielt.


    Jetzt bekomme ich aber die Meldung : Error opening /dev/input/event* no such file or directery


    Wie bekomme ich das denn in den Griff?

    Gut was die Post angeht will ich mich bessern.


    Zu dem Image: Wie kann ich denn abfragen welches ich habe?
    Ich habe nur geschaut was er am Ende des booten schreibt.
    Aufgesetzt habe ich den Pi Ende Dezember.
    Ob dann das Image durch update und upgrade sich ändert weiß ich ja nicht.


    Daran schließt sich auch die nächste Frage an.
    Wenn ich ein neues Image downloade und auf die SD-Karte installiere, fange ich doch ganz jungfräulich an oder gibt es einen Weg das Februar_Image drauf zu machen und die Einstellungen zu behalten?

    [quote pid=9374 dateline=1364920964]
    Folgendes kommt dabei heraus:


    etc/rc02.d/S01remotecontrol
    [/quote]

    Code
    Bekommst du beim Starten des Systems die Anzeige "Starting Raspberry Remote Controle Daemon" zu sehen?


    Kann ich aktuell nicht sehen, da ich keine Monitor dran habe



    [hr]

    Quote from Der_Imperator pid=9383 dateline=1364926876


    Versuch mal #!/bin/sh ganz an den Anfang der Datei zu schreiben und nicht mitten drin.
    Ins blaue getippt, mein PI läuft im moment nicht.


    steht nun ganz oben.


    Verändern tut sich nix.


    Trotzdem Danke für die Antwort

    Frage:


    Wie bekomme ich denn das da unten weg?
    FB_Addon_TelNo{ height:15px !important; white-space: nowrap !important; background-color: #0ff0ff;}


    FB_Addon_TelNo{ height:15px !important; white-space: nowrap !important; background-color: #0ff0ff;}

    Hallo Forum,


    noch eine Frage, kennt jemand eine Möglichkeit eine Festplatte automatische einzubinden wenn der Pi bereits läuft.


    Sprich einen Art watchdog der prüft ob eine HDD nach dem einschalten vorhanden ist oder nicht.


    Die Idee hinter dem ganzen ist halt, dass ich eine Sicherungs-HDD nur zum reinen Backup starten will und danach wieder "schlafen" legen will.


    Dies aber möglichst ohne den Pi jedesmal zu booten


    FB_Addon_TelNo{ height:15px !important; white-space: nowrap !important; background-color: #0ff0ff;}

    Hallo Forum,


    ich benötige mal eure Hilfe.


    Ich bekommen folgendes script nicht automatisch gestartet



    egal was ich mache ich bekomme beim " sudo update.rc name_des_scripts defaults"
    das Ergebnis


    und es wird nicht mitgestartet.


    Kann mir da einer helfen.


    Danke



    FB_Addon_TelNo{ height:15px !important; white-space: nowrap !important; background-color: #0ff0ff;}