Posts by hajos118

    Hallo zusammen,


    hab' schon etliches gegoogelt, aber leider noch nichts gefunden.
    Hier mein Problem:
    Mit "raspistill -t xxxx -tl 1000 /var/xyz/%04dpic.jpg" erzeuge ich eine lange Reihe von jpg - Bilder, die auf einem ausreichend grossen Datenträger abgelegt werden. Dies klappt, wenn auch ab und zu mal ein Bild ausgelassen wird (Fehlermeldung wird entsprechend angezeigt).
    Diese Ausfälle sind leider nicht zu vermeiden, sind aber nicht weiter tragisch WENN
    avconv bei der anschließenden Umwandlung in ein AVI File nicht stolpern und aufhören würde. Fehlermeldung = Could not open file: ....


    Gibt es eine Möglichkeit, avconv einen Parameter mitzugeben, der diese Fehler unterdrückt und avconv dazu bringt mit dem nächsten File weiterzumachen?


    Danke für Eure Mühe schon mal im Voraus.
    Hajo

    @all:
    Hab mich dazu durchgerungen einen S-Mount (12*0.5mm) Objektivhalter und ein 16mm Objektiv zu kaufen und meine NOIR - Cam zu "zerlegen" und das alles zusammen zu verheiraten.
    Befestigung der Linsenhalterung auf der CAM-Platine über Draht, die Linsenhalterung mit einem Dremel etwas in Form gefräst, damit sie auch plan auf der Platine aufliegt.
    Alles zusammengezimmert und ein paar Aufnahmen gemacht, ebenso ein kurzes Video.
    Ergebnis:
    Brauchbare Bilder mit erstaunlicher Helligkeit. Video aus der Hand ist praktisch nicht ruhig zu bekommen - fehlende Masse und zu starke Vergrößerung. Scharfstellen war durch das recht lange Gewinde kein Problem. Für die ersten Versuche ein recht ermutigendes Ergebnis.
    Weiter geht's jetzt mit dem Projekt "Überwachung" - diesen thread möchte ich damit schließen - herzlichen Dank nochmal an alle!

    Mein Problem sagt eigentlich die Überschrift schon:
    Kennt jemand eine brauchbare Tele Linse für die Raspi - Cam?


    Ich möchte eine Eingangstür - Überwachung bauen, und mein Raspi + Cam ist ca. 15m entfernt (Garage).
    Anbindung per WLAN ist kein Problem. Software ebensowenig.
    Dummerweise erkennt man auf dem Bild so gut wie nix, weil der Blickwinkel der CAM einfach zu groß ist.
    Durch Bewegungsmelder vor der Haustür ist eine Beleuchtung schon automatisch bereitgestellt.
    Eine Montage des Raspi an der Tür ist wegen Stromversorgung, Gehäuse und befürchtetem Vandalismus leider so gut wie nicht praktikabel.

    Habe das selbe Problem.
    Am RPi B hab ich mal eine Bridge eingerichtet (ganz doof nach Anleitung aus'm Netz, ohne im Detail zu wissen was ich tu ;) ) und dann war das Problem beseitigt.
    Hängt wahrscheinlich damit zusammen, dass WLAN und LAN im gleichen Netzsegment (192.l168.178.xxx) liegen.

    Hallo nochmal,


    nachdem auch der letzte Tip leider erfolglos war, hab ich das aktuelle Raspbian Image neu aufgespielt und jetzt funktioniert die CAM wieder.
    Keine Ahnung, was bei der alten Installation schief gegangen ist.


    Danke nochmal für die Tips!


    Beste Grüße
    Hajo

    Hallo zusammen,


    habe ein Problem mit dem raspistiull (und raspivid) Aufrufen.
    Konkrete Fehlermeldung:


    pi@raspi:~$ raspistill -o test.jpg
    mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
    mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
    mmal: Failed to create camera component
    mmal: main: Failed to create camera component
    mmal: Camera is not detected. Please check carefully the camera module is installed correctly



    Wie kann ich Fehler beheben?
    Neuinstallation des Paketes könnte eine Lösung sein, aber wie mache ich das?


    Bin ein Neuling, also sorry, wenn es eine dumme Frage ist, aber ich komm nicht weiter....


    Asche auf mein Haupt!
    Hast natürlich Recht....


    ...Wenn der Pi läuft und ich schalte meinen AVR ein (ich meine auch manchmal beim ausschalten), fällt mit dem deutlich hörbaren Klacken des AVRs (irgendein Relais was anzieht?) manchmal das Display aus.


    Interessant wäre das Relais: Ist die Spule durch Leerlauf-Dioden geschützt?
    Wann schaltet das Relais normalerweise?
    An welchem Controller hängt das Relais (Glaskugel sagt AVR)?
    Wird die Kommunikation mit dem Display softwareseitig irgendwie überwacht?


    Vermutung:
    Display setzt sich durch Spannungsspitze/Spannungseinbruch der 5V versorgung des Display zurück und läuft im default - Mode weiter.
    Spannungsspitze kann durch Graphitring (zB. Netzfilter) in der Versorgung gefiltert werden, Spannungseinbruch durch Diode und Stützkondensator.
    Spannungsversorgung zu den einzelnen Controllern sternförmig vom Netzteil aus verlegen!

    Hallo ds,


    schönes Stück Arbeit, wollte es testen und erhalte

    Quote


    Arduino: 1.6.4 (Windows 7), Platine: "Arduino Uno"


    nokia5110_date_time.ino:2:26: fatal error: Adafruit_GFX.h: No such file or directory
    compilation terminated.
    Fehler beim Kompilieren.


    als meldung.
    Bin Anfänger und etwas hilflos:
    Wo bekomme ich die fehlenden Header Files?


    :danke_ATDE: für die Hilfe!


    PS.:
    Mit der eingebauten Lib-Verwaltung vom Arduino bekomme ich auch nur Fehlermeldungen...

    Bin recht neu im Raspberry - Basteln, kann ein wenig Programmieren und habe ein Problem:
    Hardware: C-Berry und IR-Cam Modul auf Raspi B+
    Software: ungelöst, aber mit Std. Raspbian laufen die zugehörigen Demoprogramme.


    Ziel: etwa sowas
    https://learn.adafruit.com/snappicam-raspberry-pi-camera


    wobei das ganze nicht wireless und Batteriebetrieben sein soll.
    Mir geht's darum die Camera vor Ort (Garagenüberwachung) ausrichten zu können und das Livebild in ein Netzwerk zu streamen (hohe Auflösung). Gleichzeitig sollte aber das Display (C-Berry) mitlaufen (niedrige Auflösung).


    Wer kann mir dabei unter die Arme greifen?
    Kann leider, beruflich bedingt, nur relativ selten am Problem arbeiten, bin aber für jede Hilfe dankbar.


    Hajo


    Habe mir die Lösung wie aus dem 1. Link zusammengestellt und diese funktioniert recht brauchbar.
    Im Firefox:
    http://[meine lokale IP]


    Genügen würde mir aber eine Vollbilddarstellung, am besten als stream mit VLC angezeigt.
    Was muss ich im VLC als Adresse eingeben?