Posts by Flipper92

    Für einen Schnelltest - ohne Reparatur - reicht ein < e2fsck -fnv /dev/sda2 > als user root.

    hmm.. also scheint also im Orginal schon ein Fehler zu sein.
    Wie gehe ich nun am besten vor?


    Hab nun mal versucht vom 250GB auf der 32GB an einem Kartenreader diesen -f parameter auszuführen.
    Versuch es nun anderstherum, aber ich glaub, da komm ich nicht weiter :-/

    so.. also ich hab nun ein paar Sachen probiert . z.B. per LiveLinux und mit zweiter SD Karte am Pi versucht zu erweitern.
    Mehrfach das Backup neu eingelesen usw..

    Ich schreib nun mal die 250GB zurück auf die SD (dauert dann aber bis morgen). Wie kann ich testen ob dort die EXT4 Metadaten in Ordnung sind?
    Oder kann man diese reparieren? fsck.ext4 /dev/sda2 und auch e2fsck hat nichts gebracht.


    PS: Schonmal danke für die Antworten :)

    Das dürfe auch am gemounteten FS möglich sein [root] < resize2fs -fp /dev/mmcblk0p2 >

    Code
    pi@raspberrypi:~ $ sudo resize2fs -fp /dev/mmcblk0p2
    resize2fs 1.44.5 (15-Dec-2018)
    Filesystem at /dev/mmcblk0p2 is mounted on /; on-line resizing required
    old_desc_blocks = 1, new_desc_blocks = 2
    Performing an on-line resize of /dev/mmcblk0p2 to 7725184 (4k) blocks.
    resize2fs: Das Argument ist ungültig While trying to add group #25



    Boote nochmal von Deiner 256er SD-Karte

    Kann ich erst morgen machen, da es knapp 9h dauert die SD wieder neu zu beschreiben.
    Wäre es möglich das über ein Live-Linuxsystem (am PC) zu machen? Wenn ja, mit welchem?

    Und wie schaut jetzt die Ausgabe von (root )< fdisk -l /dev/mmcblk0 > aus ?


    Für mich sieht es so aus, als wäre die Partition schon erweitert, aber das System hat davon nichts mitbekommen :-/

    Hallo zusammen,


    ich hab ein Projekt auf einer 265GB SD angelegt und habe dies nun abgeschlossen.
    Nach einem pishrink.sh ist von den 250GB Image nur noch 2,8GB übrig und ich möchte nun dieses auf eine 32GB Karte übertragen.
    Das hat auch gut funktioniert, ABER :(

    Ich hab nun das Problem, das ich nicht die Partition erweitern kann über

    sudo raspi-config -> Advanced Options -> Expand Filesystem

    Beim booten kommen ein paar Fehlermeldungen:


    Code
    [FAILED] Failed to start LS8: resize the root filesysten to fill partition.
    See 'systemctl status resize2fs_once.service' for details.
    [...]
    [FAILED] Failed to start The Apache HTTP Server.
    See 'systemctl status apache2.service' for details.


    Code
    pi@raspberrypi:~ $ df -h
    Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
    /dev/root       3,1G    1,5G     0  100% /
    devtmpfs        455M       0  455M    0% /dev
    tmpfs           488M       0  488M    0% /dev/shm
    tmpfs           488M     19M  469M    4% /run
    tmpfs           5,0M    4,0K  5,0M    1% /run/lock
    tmpfs           488M       0  488M    0% /sys/fs/cgroup
    /dev/mmcblk0p1  253M     54M  199M   22% /boot
    tmpfs            98M       0   98M    0% /run/user/1000


    Ich weiß leider nicht weiter, wo ich ansetzen soll.
    Ich hätte versucht nun die Partition zu erweitern und dann die Prozesse zu starten, aber dass klappt ja leider nicht so wie ich möchte.

    Ich hoffe mir hat hier jemand ein Tipp.

    Gruß Flipper

    Hallo zusammen,


    Ich bräuchte Mal einen Tipp, wie ich ein Raspberry Pi 4 mit Raspbian auf einer entfernten NAS (Synology DS1618+) sichern kann?

    Es handelt sich um den Desktop Ersatz für meine Mama. Die Daten sollen natürlich verschlüsselt werden.


    Pi sendet an die NAS - Idee mit VPN:

    Ich möchte nicht, das der Pi permanent in meinem Netz eingebunden ist. Bzw über meine Internetverbindung surft.


    NAS holt die Daten bei dem Pi:

    Leider hat der Pi keine feste IP Adresse.


    Ich fände es gut, wenn die Daten per quickconnect Übertragen werden. Doch leider fehlt mir hier die Linux Erfahrung und ich hab kein Synology Tool gefunden.


    Hat jemand eine Idee?


    Gruß Flipper


    Hallo Zusammen,


    ich frag mal hier, da ich dann kein neues Thema aufmachen muss.
    Ich hab überlegt aus Shadow.tech und einem Raspberry Pi Zero ein Konsolen Ersatz zu machen. Aktuell hab ich noch keinen Zero und bin mir nicht sicher ob er genug Power hat für mein vorhaben.

    Folgendes ist meine Idee:
    - Pi mit Shadow verbinden (vermutlich über Android als OS)
    - Pi mit TV verbinden
    - An den Pi 2 xBox One Controller (Bluetooth)

    Mein aktueller TV kann nur HD, aber in absehbarer Zeit wird dieser leider ganz kaputt gehen und dann wäre 4k das nächste Schritt.

    Wie hoch schaft es der Zero?

    Zum fehlerhaften Image fällt mir gerade noch was ein: Als ich meine Backups mit pishrink vor einer Weile verkleinerte, hat dieses Script bei manchen Backups diverse Fehler gefixt. Ich kann mich leider nicht mehr daran erinnern, was genau da repariert wurde.

    Sieh Dir evtl. mal diesen Thread an: Image verkleinern mit pishrink ...vielleicht bringt es ja was.

    Damit hat die Img wieder funktioniert. Dan konnte ich es einbinden und kam an die Datie ran.
    Danke für eure hilfe.

    Code
    user@pc ~/Downloads $ ./imagemount.sh ./RaspberryPiBackup-20180121-223312.img
    
     ./RaspberryPiBackup-20180121-223312.img1 8192 137215 129024 63M c W95 FAT32 (LBA)
    mount -o loop,ro,offset=4194304 ./RaspberryPiBackup-20180121-223312.img /mnt
    
     ./RaspberryPiBackup-20180121-223312.img2 137216 31116287 30979072 14.8G 83 Linux
    mount -o loop,ro,offset=70254592 ./RaspberryPiBackup-20180121-223312.img /mnt


    Dann weiter mit
    sudo mount -o loop,ro,offset=70254592 ./RaspberryPiBackup-20180121-223312.img /mnt

    das ergebnis ist dabei

    mount: cannot mount /dev/loop0 read-only


    hab ich irgendwas übersehen?

    Hallo zusammen,


    Irgendwie fehlt mir wieder das Keyword, mit dem ich die Lösung sofort finde.


    Ich hab auf dem Pi das Scrypt laufen, das eine img auf eine NAS schreibt im laufenden betrieb.
    Nun hab ich auf meinem Pi eine Datei gelöscht (nicht mehr im Papierkorb) die ich nochmal benötige. Ich weiß, das in der img die Datei noch vorhanden ist, aber ich möchte nicht das Backup wieder komplett einspielen.

    Gibt es eine Möglichkeit über Linux an die Dateien in der img ran zu kommen?

    Es handelt sich um eine *.conf Datei.


    Ich hoffe mir kann jemand helfen :)


    Gruß Flipper

    Hey Leute,


    Ich bin mal wieder am verzeifeln.


    Ich suche eine Möglichkeit Google Play Musik (All Inclusiv) auf dem Pi zum laufen zu bekommen.
    Versucht habe ich es schon mit
    - Musicbox (Mein Favoriet)
    - Volumia
    - Kodi


    Keins davon hat mich bis zu den Liedern gelassen.
    Am weitesten kamm ich bei MusicBox, da bekamm ich immerhin schon die Meldung das ich mich angemeldet habe (bekomm diese aber auch nicht mehr), aber keine Lieder ("Keine Tracks gefunden..").
    Hat von euch einer Google Music zum lafen bekommen und wenn ja wie?
    Ich komm niergends wirklich weiter. Hab nun gestern fast 10 mal neue Imig's aufgespielt.


    Danach würde ich gern mit FHEM den Server Steuern. Fhem leuft extra.
    Das sollte aber mit allen 3 Funktionieren. Aber hier war ich auch mit der MusicBox am weitesten.


    Hardware: Pi Modell B


    Ich hoffe mir kann jemand wieter helfen.
    Ich werde den Weg nehmen, der einer von euch hinbekommen hat. Sonnst muss ich ja von allen 3 versuchen den aktuellen Stand Posten.


    Gruß Flipper


    :danke_ATDE: :danke_ATDE: :danke_ATDE: :danke_ATDE:
    Es funktioniert!


    Vielen Dank!

    Sorry


    Achso zu erwähnen wäre noch das ich zuerst Lith installiert hatte und Pixel nachträglich für TeamViewer drauf gemacht hab.


    Eventuell sollte ich mal Pixel gleich von Anfang an installieren (hab bis jetzt noch nicht viel gemacht.


    Denn Rest schau ich mir morgen in aller Ruhe an.

    Code
    pi@raspberrypi:~ $ sudo ls -l /dev/serial?
    lrwxrwxrwx 1 root root 7 Feb 10 06:44 /dev/serial1 -> ttyAMA0
    pi@raspberrypi:~ $ dpkg -l | grep "pi-bluetooth"
    ii  pi-bluetooth                            0.1.2                             armhf        Raspberry Pi 3 bluetooth
    pi@raspberrypi:~ $



    0. Was willst Du eigentlich mit Bluetooth an den raspi hängen?
    5x Bluetooth Thermostate die mit THEM gesteuert werden sollen.


    1.1 RPi modell: RPi 3B
    1.2 Display: keins; bei bedarf HDMI TV
    1.3 Soundausgabe: keins
    1.4 Netzwerk: LAN; WLAN wollte nicht (Netze ggefunden aber keine Ferbindung)
    1.5 OS: raspbian jessie vom 11.01.2017 (SSH aktiviert mit Text Datei)
    1.6 soll der raspi in der Konsole oder mit grafischer Oberfläche laufen? Beides (siehe unten)
    1.7 hast Du weitere Software auf dem raspi installiert? was? FHEM; TeamViewer Host; Pixel
    1.8 hast weitere Hardware am raspi angeschlossen? Nichts


    2. Wie installierst Du
    2.1 wie wird das Image auf die SD-Karte geschrieben? Win32DiskImager
    2.1 vom PC oder MAC über ssh
    oder direkt am raspi mit usb-tastatur und fernseher am hdmi? (z.B. vom Windows PC mit putty) Anfangs Direkt am pie (mit Tastatur) seit SSH am Android mit JuiceSSH
    2.2 wie kopierst Du Dateien zwischen Deinem Rechner und dem raspi? nein



    Ich hoff das Hilft.

    Hallo Kle,


    da ich nicht ganz so fit bin in Linux weiß ich nicht was aus der Info entnommen werden kann.



    Paspberry-sys-mods ist installiert.
    Wie sollte ich nun weiter vorgehen?


    Gruß Flipper