Posts by brenner23

    Ich würde mal sagen Case Closed


    Code
    iptables -t nat -A PREROUTING -s 192.168.100.0/24 -i eth0 -p tcp -m tcp --dport 443 -j DNAT --to 192.168.100.1:443

    kann ich vergessen auch mit sachen wie

    Code
    DocumentRoot ...
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://192.168.100.1 [R=301,L]
    </IfModule>

    kann ich genauso vergessen weil immer die Zertifikatekontrolle dazwischen kommt...

    Selbst der Fritz!Box Gast Zugang hat keine Https-umleitung sondern nur alles was über port 80 geht wird auf die Vorschaltseite umlgeleitet...


    Case Closed



    Wenn noch jemand ne idee hat ....


    Bitte

    Das Meinte ich doch die ganze Zeit...

    es geht mir darum das ich diese auch umlenken kann ( Redirekct) wie man dies von Http zu https macht !


    ist das denn so schwer ????


    Ausserdem hab ich doch das gleiche beo den Hotspots... die geneigten endkunden die ihren Corme auf dem handy auf haben bekommen auch die fehlermeldung und denken der Hotspot geht nicht !


    weil keine vorschaltseite o.Ä. angezeigt wird oder umgelelenkt weil Https ....


    es geht mir nur um eine lösung zu Problem oder ein klares ... GEHT NICHT !

    HIer sind mal die Screenshots...

    Mein Anmeldebutton Mit Laufzeit bis... auf 192.168.100.1 ( auch Abbmelde seite)


    Browser A Crome:

    Zustand Abgemeldet (kein Internet nur Firewall umleitung zu https://192.168.100.1)


    Browser B Firfox:


    Zustand Abgemeldet (kein Internet nur Firewall umleitung zu https://192.168.100.1)

    Der Firefox gibt einen hinweis obben rechts das es eine Einlogseite gibt die man öffnen kann ! :-)

    Damit kann ich leben :-)






    Problem: war heute noch einkaufen und ich hatte mich einem Freien Hotspot mit mit meinem Smalrtphone eingeloggt,

    natürlich hatte ich eine Https seite aufmachen wollen und da gab es diese Zertifikatssch... auch... erst als ich mich auf die 1.1.1.1 von dem anbieter(router) durchgehangelt habe ohne https konnte ich wieder auf die webseite mit https://irgenteine seite... Ich nenne hier aber keine namen wer das ding hier betreibt und oder noch Daten sammelt um 30 minuten ins internet zu kommen :-)


    ich belese mich mal zum thema Zertifikate und URLs die nicht zum Zertifikat Passen ...


    lg

    Ich hatte verglichen....

    erst den Raspi der geht... ans kabel angeschlossen Eigenschaften IP 192.168.100.123 Gateway 192.168.100.1 DNS 8.8.8.8

    dann Orange Pi ans kabel.. Ip 192.168.100.123 Gateway 192.168.100.1 DNS 192.168.100.1


    Ich gehe davon aus das windows erst die DNS Anfage stellt und feststellt das DNS = Gate ist.

    Worauf ich dann im OrPi die 8.8.8.8 in 192.168.100.1 geändert habe in der dhcp-server conf


    lg

    Quote

    Das verstehe ich nicht? Was hat die Umleitung mit dem DNS-Server zu tun? Hast Du absichtlich die counter weggelassen?

    Counter ?

    Also geht um folgendes....


    Gateway ist er Pi / DNS /Firewall etc

    wenn ich http://www.irgenwas.de aufrufe und die Regel in der Firewall besagt alles was du auf port 80 haben willst wird an ip 192.68.100.1:80 geleitet,

    das geht auch...

    aber wenn ich https:// http://www.irgenwas.de aufrufe dann kommt der firefox mit der meldung Zertifikat bla... was ja auch normal ist da die IP von www.irgenwas.de auf den Pi aufläuft und mein sellber erstelltes Zertifikat geladen wird und nicht zu www.irgenwas.de passt sondern zu 192.168.100.1


    es geht mir um die umleitung.... :-)


    Quote

    brenner23 schrieb:



    "KEINE BRITDGE"


    Es heißt "Bridge" (= Brücke). War im anderen Thread auch schon falsch...


    Typos können mal passieren :-)

    Auf basis von den Befehl


    Code
    iptables -t nat -A PREROUTING -s 192.168.100.0/24 -i eth0 -p tcp -m tcp --dport 443 -j DNAT --to 192.168.100.1:443

    hatbe ich ein SSL Zertifikats Problem was immer dann auftritt wenn eine HTTPS seite aufgerufen wird,


    Dachte erst an

    Code
    iptables -t nat -A PREROUTING -s 192.168.100.0/24 -i eth0 -p tcp -m tcp --dport 443 -j DNAT --to 192.168.100.1:80


    Das geht irgentwie auch nicht...


    Hintergrund ist ich Hab mir einen WLAN0 >>> ETH0 Router gebaut "KEINE BRITDGE" mit einer "LoginSeite" damit man für xx Minuten /Stunden internet hat... also dies ist noch ausbaufähig...

    Also mein Problem ist es wenn man nicht eingeloggt ist, eine Https seite aufgerufen wird "Https://" "www.google.de" z.b dann ist die verbindung nicht sicher wegen Zertifikat....

    meine idee ist es das ganze dann auf meine HTTP seie (Port 80) umzuleiten damit man auf die Seite "Login" gelangt ....


    lg


    Hier mein alter Beitrag vom letztem problem ( Gelöst )


    Iptables

    Hat sich gerade erledig...

    Kann nicht funktionieren wenn ich 8.8.8.8 als DNS in die DHCP voreinstellung einsetze...

    Mit 192.168.100.1 geht es ...nun :-)


    Zur Erklärung. Am ETH0 hängt mein PC ( Ich könnte auch einen Switch dahintersetzen und oder auch einen AP ).

    IP wird zugewiesen via DHCP, und sollte ( so habe ich es mir vorgestellt auf dem "Orange Pi " jede anfrage erst auf die "Login" seite gelenkt wird...(ok SSL verbindungen bereiten mir noch kopfschmerzen weil der Browser mekkert wegen Zertifikat)




    lg

    OK

    ich mach mak die Kurzform ´:-)


    iptables -t nat -A PREROUTING -s 192.168.100.0/24 -i eth0 -p tcp -m tcp --dport 443 -j DNAT --to 192.168.100.1:443

    iptables -t nat -A PREROUTING -s 192.168.100.0/24 -i eth0 -p tcp -m tcp --dport 80 -j DNAT --to 192.168.100.1:80


    bei dem Rasperry Pi funktioniert es 100%tig


    beim Orange Pi Zero ("Bedingt bis") garnicht....


    (Ich meine die Umleitung die die Friewall macht auf den ports)


    Sind Bugs bekannt ?


    Wenn nicht ist auch nicht so wichtig.... :-)

    Hallo,

    hab de pi nun mit eine Papageienkabel( RT,SW,WS,GL) circa 3 Meter mal so an die Wand Getackert.... und das Geht so weit wie ich es am der Grapenschereiber sehen kann ... alle 5 Minten führe ich die abfrage aus und gebe sie an meine webseit mit der auswertung.... mal sehen ob ich den sensor weiter weg bekomme ( steht ein wenig in der Sonne) also in den momenten sind die Werte unbrauchbar (45 *C ) aber ich versuche noch weiter zu verlängern .-)


    zum Thema ausgang ... da denke ich dann über einen 1KOhm nach .-)


    Ansonsrten nehme ich pin +5 Volt


    lg

    Hallo,

    Ich hab mir mal aus Spaß, vlt. braucht man ma sowas in der Richtung einen "Router" Gebaut

    Raspberry Pi W-Lan zu Lan Router (keine Britge) ....


    Das geht alles 100 % mit Login seite und Cronjob für die freischaltung für xx Minute etc.

    Selbst die Umleitung geht wenn man http://bla.irgenwas eingibt Leitet die Firewall auch zur Loginseite um wenn keine Zeit abglaufen....


    Das gleiche habe ich nun auf den Orange Pi Zero H2 gemacht auf basis von Debian Neuestes Armbian ...


    Zu fuss auf 192.168.100.1 enter dann Login und schon "Stunde" Internet ! :-)


    ## Alle anfragen Port 80, 443 werden auf Routerseite Umgeleitet

    iptables -t nat -A PREROUTING -s 192.168.100.0/24 -i eth0 -p tcp -m tcp --dport 443 -j DNAT --to 192.168.100.1:443

    iptables -t nat -A PREROUTING -s 192.168.100.0/24 -i eth0 -p tcp -m tcp --dport 80 -j DNAT --to 192.168.100.1:80


    mir mach nur was sorgen... wenn man Ausgeloggt ist ( Zeit um ) dann solle jede anfrage nach dem Code umgeleitet werden...

    macht der Orange Pi aber irgentwie nicht....


    weis jemand von einem Bug ???


    lg

    Hallo

    ich will meinen Pi im Schuppen geschützt aufhängen und den / Die Sensoren da Plazieren wo sie messen Sollen !

    Frage: Wie lang dar das Kabel sein oder anders wie sollte ich den Querschnitt Dimiensionieren ( Kabel vom Semsor)

    oder kann ich da meni Cat5e kabel dafür benutzen als Sensorleiung ?


    lg

    So das läuft so aber ich hab da noch eine Kleinigkeit...


    Problem 1:

    Code
    rm /var/lib/mpd/playlists/current.m3u
    mpc clear
    mpc update
    mpc ls | mpc add
    mpc save current
    mpc play
    mpc stop

    Das geht soweit aber ich muss um alle Musikstücke zu laden mehmals dieses script ausführen... weil meine W-Lan stick etwas träge ist ( langsam ) Edimax Stadard stick


    Was kann ich wo einstellen das der länger sucht und dann erst beim letzen Musikstück aufhört zu suchen !


    Problem2: ( Weg 2 )



    bei

    Code
    mpc load current

    Kommt er mit einenm Timeout beim Laden der current.m3u

    Gibt es da auch eine Lösung ?


    lg

    Also ich hol mal aus !:--)

    Ich habe hier einen Pi aus einem voherigem Pi Mpd/Mpc Projekt in einem Gehäuse.... Hier mal ein paar Daten

    Hier ist es so das in der version funktioniert es alles wunderbar

    ########################################################


    und ja die dateien und pfade existieren ! :-)



    Nachtrag: Aktueller Pi Neu aufgesetzt !




    ...


    hier werden nur radiosener abgespielt



    Code

    Hallo,

    ich hab mir mal einen Raspberry Pi aufgesetzt neuestes Image...


    Dann hatte ich MPD MPC installiert


    in der Play.m3u die ich geladen habe sind Radiosender und mp3s vom der Nas und auch testweise habe ich noch stücke auf der SD karte gelassen

    apt install mpc mpd

    mpd.conf

    play.m3u

    mpc load Play

    mpc play

    ich stelle fest das ich nur Radiosender höhren kann aber mp3 files sie auf Nas oder SD gespeichert sind werden Ingnoriert...

    Dateinen sind vorhanden !


    hat jemand eine idee ?