Beiträge von sigi28

    Hallo, nein brauchst kein extra Kabel. Gigablue und Pi im Netzwerk natürlich.

    Poste erst mal Deine Hyperion Config bitte.


    Habe das jetzt schon ewig nicht mehr probiert über meinen Gigablue, weis jetzt auch nicht den aktuellen Stand von enigmalight, also ob daran weiter gebastelt wurde.


    Muss mal schauen ob das bei mir unter OpenHDF im Feed ist.

    Du musst Dich nicht unbedingt per root anmelden, braucht man eigentlich eher selten.

    Nimm mal den normalen Login.

    .

    pi

    raspberry

    .

    Mach doch einfach mal das Stock Raspbian drauf, kopiere die ssh Datei ins root Verzeichnis und probiere es aus ob es da funktioniert.

    Denke auch das es schon einige erfolgreich am Laufen haben, zumindest hat sich noch keiner beschwert.


    Mache demnächst mal wieder ein Image, den Pi3 B+ werde ich mir da aber nicht extra holen.

    Liegen schon zu viele Vorgängermodelle ungenutzt hier.

    Die SSH Datei dient nur dazu, beim ersten Start per SSH überhaupt Zugriff zu bekommen. Dieser ist von Haus aus in Raspbian deaktiviert.

    Danach bleibt SSH aber aktiviert. Die SSH Datei ist nur temporär und verschwindet nach dem ersten Start.

    Es wäre natürlich möglich, das mein Image mit dem neuen Pi Probleme macht, da auf dem Pi2 erstellt. Habe leider keinen Pi3 B+ zum testen hier.


    Lade Dir mal das Raspbian Image von deren Website runter und versuche es damit. Musst natürlich dann noch Hyperion installieren.

    Hallo,

    SSH ist in meinem Image auf alle Fälle aktiviert. Da brauchst Du keine ssh Datei einfügen.

    Die Zugangsdaten teste ich natürlich vorher, wie sollte ich sonst Hyperion installieren, den root Zugang einrichten und das Betriebssystem und Kernel updaten.

    Der Fehler muss wo anders liegen, vielleicht wirklich die falsche IP.

    Ich habe leider Deinen gelöschten Beitrag nicht gelesen, vielleicht hattest Du dort noch mehr geschrieben.

    Hey raspbastler, sei gegrüßt. Prinzipiell läuft das ganze ja auch ganz gut, nur das Aufblitzen bei dunklen Bilder ist schon nervig.


    Bei einer Neuinstallation wird ja (leider) immer die aktuelle Version von Hyperion installiert. Dann kann man mit der alten gespeicherten Config nichts mehr anfangen und muss ja leider alle Einstellungen neu vornehmen.

    Warum sollte man die alte config nicht mehr nehmen können, auch mit aktueller Hyperion Version geht das. Benutze selbst das neuste Hyperion und erstelle mir mit einer alten HyperCon Version die Config. Da es dort noch die Blacklevel Einstellungen gab. Komme damit besser zurecht.


    Du kannst doch Deine alte Config einfach über Hpercon zum Pi senden.

    Kann mir auch nicht vorstellen das es bei Dir an der neuen Hyperion Version liegt.

    Sieht einfach nur schlecht konfiguriert aus.

    Deswegen taste ich den ganzen Bildbereich ab und nicht nur den Rand. Da wird ein gewisser Durchschnitt vom Gesamtbild errechnet und das Ambilight ist schön ruhig. Einziger Nachteil. Die Farben sind dann nicht mehr genau abgegrenzt.

    Ich hätte lieber gleich APA102 LEDS bestellt, ist schon eine neuere Generation wo auch mehr LEDs/METER möglich sind.

    Das Netzteil richtet sich nach der Anzahl der LEDs des gesamten Stripes. Du musst also erst mal wissen wie viele es sind. 9,4m ist schon ne Hausnummer.

    An jeder Ecke auf jeden Fall einspeisen in Deinem Fall, wenn nicht sogar noch mehr.

    Das sollte mit drin stehen bei meinem Image, da ich das WLAN immer teste und auch auf DE einstelle.

    Ich habe das in der Anleitung nur weggelassen.


    Punkt 8 und 9 in Deinem Code tag muss meines Wissens nicht rein.

    Hat bei mir immer funktioniert.

    masel, Du kannst das natürlich mal versuchen, aber ich denke eher das Du noch einen anderen Fehler drin hast.

    Schaue mal in meinen Thread, unter Punkt 2.

    Ich habe im Image die WLAN Optionen so hinterlegt, das man nur seine Daten ergänzen bzw. einsetzten muss.


    In " . . . . . . "

    Da seine WLAN Daten eintragen.

    Also die SSID und den WLAN Schlüssel.

    Code
    1. network={
    2. 2. ssid="DEIN-WLAN-NAME"
    3. 3. psk="DEIN-WLAN-SCHLÜSSEL"
    4. 4.}

    Abspeichern und Pi ohne LAN Kabel neu starten.

    Verbindung über Putty oder HyperCon dann natürlich mit einer anderen IP Adresse.

    Der Framegrabber ist in Deiner Config drin, ja. Aber den sollst Du wie oben beschrieben auskommentieren mit den // davor.

    Oder in HyperCon gar nicht erst auswählen (Haken raus), dann taucht der in der Config erst gar nicht auf.


    Beide müssen komplett raus oder mit "//" davor auskommentieren.


    Was genau passiert denn? Farben werden angezeigt aber nur falsch oder wie?

    Vielleicht ist bei Dir die "colorOrder" : "gbr" Option nur falsch angelegt, wenn die Farben nicht stimmen.


    Wenn alles richtig angezeigt wird kannst Du den "grabber-v4l2" wieder aktivieren, damit es über den Grabber läuft.

    Wenn Du mit externen Grabber arbeitest, musst Du den auch in der Config aktivieren und den internen Framegrabber deaktivieren.


    Den V4L2 Grabber entweder manuell so eintragen oder direkt über HyperCon aktivieren.

    Die hier gesetzten Crop Werte von 5, solltest Du später noch anpassen, aber erstmal muss es überhaupt funktionieren.




    Den Framegrabber ebenfalls über HyperCon deaktivieren oder in Deiner jetzigen Config so auskommentieren.


    Code
    1. //"framegrabber" :
    2. // {
    3. // "width" : 64,
    4. // "height" : 64,
    5. // "frequency_Hz" : 10.0,
    6. // "priority" : 890
    7. // },


    Aber eigentlich müsstest Du erst mal beide Grabber deaktivieren, Hyperion so starten, dann sollten die LEDs nichts anzeigen und dann per Farbbefehlen testen ob alles funktioniert.

    Wenn das läuft, den V4L2 GRABBER aktivieren.