Posts by insidERR

    Super,

    :danke_ATDE: dir "daxb".


    Die Datei war nicht im angegebenen Ordner, dafür wo anders auf der Karte. Auch die Einträge für die erwähnte Tastenkombi waren nicht drin.

    Habe die Datei in das richtige Verzeichnis kopiert und die gewünschten Einträge aus einem älteren Image gezogen und siehe da.

    Nach einem Neustart funzt es auch auf dem RasPi 4 mit Buster.

    Hallo zusammen,

    ich habe heute einen neuen RasPi 4 (4GB) mit aktuellem OS aufgesetzt und da ist mir aufgefallen, dass die Tastenkombinationen {Win} + {R} / {E} nicht wie beim RasPi 3 (mit einem 3 Jahre altem OS) funktionieren.

    Auf dem RasPi 3 hat diese Tastenkombi noch ähnlich wie unter Windows entweder das "Ausführen" Menü geöffnet, oder den Dateimanager (PCMANFM) gestartet.


    Hat jemand ne Idee was umgestellt werden muss, damit es wieder so funzt?

    Momentan klappt die linke {Win} Taste nur das Startmenü auf. Die rechte ist ohne Funktion.


    Hintergrund: ich mache ein Masterimage für einige Benutzer, die den RasPi als ThinClient nutzen. Habe das Startmenü ausgeblendet damit die da kein Unfug treiben können.

    Zum konfigurieren muss ich aber in die Konsole und den Dateimanager aufrufen. Beim Image für den RasPi 3 drückte ich einfach nur die besagte Tastenkombi und schon war ich drin.


    :danke_ATDE:

    Habe den gleichen Post im Herstellerforum gepostet.

    Dort sind auch einige User, die vor dem selben Problem stehen.


    Habe dort die Info bekommen den "Legacy" Treiber zu verwenden. Der Treiber funzt. Rdesktop oder xfreerdp läuft dann flüssig wie auf dem Pi3. aber auch nur mit einem Bildschirm.

    Wenn man bei xfreerdp mit "/gdi:hw" startet, läuft es mit Windows Server 2016 noch akzeptabel. Mein Problem ist, dass ich es im aktuellen Fall mit dem Server 2008R2 nutzen will. Da läuft es zwar auch akzeptabel, nur wenn ich eine etwas ältere Access 2010 Datenbank starte, ist da anscheinend ein Button oder Steuerelement welches nicht dargestellt werden kann und xfreerdp wird mit einem Fehler beendet. Wenn ich xfreerdp dann ohne "/gdi:hw" starte, läuft es zäh, das zum Absturz führende Formular wird aber angezeigt.

    Sachen gibts... :(

    Hallo Leute,

    ich habe auf der Arbeit schon ca.20 von den RPi3 als Ersatz für HP ThinClient.

    Funktioniert wunderbar, kostet nur ein Bruchteil eines "echten" ThinClients von z.B. HP und ist zudem auch schneller in der Einrichtung.


    Jetzt habe ich einen RPi4 (4GB) geholt, weil immer mehr Arbeitsplätze zwei Monitore nutzen, was mit dem RPi3 nicht geht.

    Was mir jetzt sofort aufgefallen ist, dass der RPi4 selbst schneller als der RPI3 ist, bei der RemoteDesktop Aufgabe dem "alten" um Welten unterlegen ist. Sogar auf dem RPi2 lief es besser.

    Bei dem RPi3 gibt es überhaupt keinen Ruckler oder Zeilenaufbau während der RDP Sitzung. Das Bild ist wirklich sofort da, als würde ich nicht per RDP auf den Server zugreifen, sondern direkt davor sitzen und das sogar über WLAN oder gute Internetverbindung.


    Auf dem RPi4 muss ich wegen dem "/multimon" Feature "xfreerdp-x11" nutzen. Der Bildaufbau ist aber grauenhaft und im Vergleich zu dem was ich von dem RPi3 kenne nicht zumutbar. Als würde man es über eine langsame 1MBit Internetverbindung nutzen. Zeilen/Blockweise Bildaufbau.

    Auch das auf dem RPi3 genutzte Programm "rdesktop" (leider ohne /multimon) baut das Bild genauso langsam auf. Als wäre im System eine Bremse aktiv.

    Ich habe der GPU wie auf dem RPi3 ganze 512MB Speicher verpasst. Leider mit demselben Effekt.


    Meine Vermutung ist, dass das Betriebssystem(Buster) damit zu tun hat.


    Hat jemand ähnliche Erfahrungen oder Ideen an welcher Schraube man drehen kann um damit RDP auf dem RPi4 genauso flott läuft wie auf dem RPi3?


    :danke_ATDE:

    Hallo,

    ich nutze einen RPI als ThinClient um auf einem Windows Server 2008/2016 zu arbeiten.

    Dafür verwende ich den "RDesktop"


    Allerdings ist mir ein Problem aufgefallen.

    Wenn ich direkt unter Windows z.B. ein Ø-Symbol eingeben will, halte ich die "Alt" Taste und tippe auf dem Zahlenblock "0216" ein. Es werden so nicht die Zahlen getippt, sondern nachdem ich "Alt" losgelassen habe das Ø-Zeichen.


    Will ich das über den RPI und RDesktop machen, wird anscheinend die gehaltene "Alt" Taste zum Termina nicht übertragen. Auf dem Server werden z.B. im NOTEPAD die Zahlen "0216" getippt, anstatt dem Ø wenn ich "Alt" loslasse.


    Unter "Raspi-config" Menü "Localisation Options" -> "Change Keyboard Layout" ist "Generische PC-Tastatur mit 105 Tasten (Int)" -> "Deutsch" -> "Der Standard für die Tastenbelegung" -> "Keine Compose-Taste" und keine Tastenkombi für X-Server eingestellt.


    Fällt jemandem noch was ein, woran das liegen und an welcher (virtuellen) Schraube man noch drehen kann? :conf:


    :danke_ATDE:


    Nachtrag: wenn ich auf der Tastatur "Numlock" deaktivieren, funktioniert es. Bei gedrückter Alt-Taste 0216 eingeben und schon kommt Ø

    Wünschenswert wäre es, wenn es auch bei aktiviertem Numlock gehen würde.

    Paar Infos mehr wären schon hilfreich.

    Welchen Internetprovider hast du?

    Mein Unitymedia hat vor paar Monaten von (dynamischer) IPv4 auf DualStack Lite umgestellt und schon wars das mit dem VPN/VNC. Mein Router hat alle 5 Minuten die angebliche IPv4 beim http://www.ddnss.de aktualisiert. Trotzdem war es nicht mehr möglich nen Tunnel einzurichten.


    Ansonsten läuft bei mir hinter der ConnectBox (blödes Ding) ein ASUS Router, an dem ein RasPi hängt und bei Bedarf die IPv4 bei http://www.ddnss.de aktualisiert. Leite VPN, VNC, FTP und HTTP Ports in der ConnectBox auf den Router weiter. Der verteilt es wiederrum an die entsprechenden Stellen weiter.


    Greife über UltraVNC von überall auf meinen RasPi zuhause und arbeite dort weiter.

    Hallo dreamshader und rpi444,

    nochmal Danke für eure Vorschläge :)


    Der letzte Post von dreamshader kommt der Sache schon ganz nah.

    Das Logo taucht kurz auf. Zwar etwas später und nur für ne kürzere Zeitspanne, als wenn man es mit der /init.d/ macht, aber ist besser als nix.


    Bleibe jetzt erstmal dabei...

    Habe(und auch ihr) schon zu viel Zeit in ein "nice to have" Feature investiert.


    Das wofür der RasPi eingesetzt wird, tut er ganz gut. Starten, auf Netzwerk warten (WLAN), (bei Bedarf)VPN zum Firmennetzwerk aufbaun, RDesktop starten. Wenn RDesktop nicht mehr läuft fährt der RasPi runter. Ein sehr preiswerter ThinClient.

    Leider keine Änderung :(

    Hallo rpi444, danke für deine Mühe.

    Vor:

    und nach: (das Script: asplashscreen wird ordnungsgemäß ausgeführt. Das Bild wird im Vollbildmodus geöffnet)

    Ausgabe von: show asplashscreen

    Hi rpi444

    ich habe nun in die Zeile mit Required-Start: $all ergänzt.

    Beim Neustart keine Änderung. Script wird nicht ausgeführt.

    Hier das Ergebniss von systemctl status asplashscreen


    Code
    pi@DPRpiX:~ $ systemctl status asplashscreen
    ● asplashscreen.service - LSB: Show custom splashscreen
       Loaded: loaded (/etc/init.d/asplashscreen; generated; vendor preset: enabled)
       Active: inactive (dead)
         Docs: man:systemd-sysv-generator(8)

    Welche Abhängigkeiten hat asplashscreen bzw. welche Ressourcen braucht asplashscreen?


    Wie sind die Ausgaben von:

    Code
    cat /etc/init.d/asplashscreen | grep -i required
    systemctl is-active asplashscreen
    systemctl is-enabled asplashscreen

    ?

    Hallo rpi444, hier die gewünschten Ausgaben

    Code
    pi@DPRpiX:~ $ cat /etc/init.d/asplashscreen | grep -i required
    # Required-Start:
    # Required-Stop:
    pi@DPRpiX:~ $ systemctl is-active asplashscreen
    inactive
    pi@DPRpiX:~ $ systemctl is-enabled asplashscreen
    asplashscreen.service is not a native service, redirecting to systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install is-enabled asplashscreen
    enabled

    Hi dreamshader,

    ich hatte mich strickt nach der Anleitung gehalten.

    "asplashscreen" beinhaltet den Code, den der Verfasser erstellt hat.


    Wenn ich die Datei manuell oder mit systemctl restart asplashscreen ausführe, wird das gewünschte Bild im Vollbildmodus angezeigt. Genauso wie es beim Booten sein soll.


    Angemerkt: damit die Anleitung auch funzt, musste ich bei dem anderen RasPi3 noch die bootcode.bin tauschen. Nur im aktuellen Fall klappt es nicht mit dem RasPi3+ und aktuellem DEBIAN

    Hallo dreamshader, danke für deine Antwort

    Ich bekomme das hier raus:


    pi@DPRpiX:~ $ apt-cache pkgnames|grep sysvinit

    sysvinit-utils

    live-config-sysvinit

    git-daemon-sysvinit

    sysvinit-core



    Ich habe die Prozedur (Splashscreen tauschen) schon auf zwei anderen RPI3 gemacht. Allerdings mit nem NOOBS Image vom letzten Jahr.

    Hallo rpi444,

    danke für deine Antwort.

    Gibt es die service unit für asplashscreen? Wie sind die Ausgaben von:

    Code
    systemctl status asplashscreen
        systemctl cat asplashscreen
        systemd-analyze blame | grep -i asplashscreen

    ?

    Hier die Ergebnisse:


    pi@DPRpiX:~ $ systemctl status asplashscreen

    ● asplashscreen.service - LSB: Show custom splashscreen

    Loaded: loaded (/etc/init.d/asplashscreen; generated; vendor preset: enabled)

    Active: inactive (dead)

    Docs: man:systemd-sysv-generator(8)

    pi@DPRpiX:~ $ systemctl cat asplashscreen

    # /run/systemd/generator.late/asplashscreen.service

    # Automatically generated by systemd-sysv-generator


    [Unit]

    Documentation=man:systemd-sysv-generator(8)

    SourcePath=/etc/init.d/asplashscreen

    Description=LSB: Show custom splashscreen


    [Service]

    Type=forking

    Restart=no

    TimeoutSec=5min

    IgnoreSIGPIPE=no

    KillMode=process

    GuessMainPID=no

    RemainAfterExit=yes

    SuccessExitStatus=5 6

    ExecStart=/etc/init.d/asplashscreen start

    ExecStop=/etc/init.d/asplashscreen stop

    pi@DPRpiX:~ $ systemd-analyze blame | grep -i asplashscreen

    pi@DPRpiX:~ $

    Hallo,

    ich habe heute auf einem neuen RPI3+ Strech installiert und wollte den Bootscreen durch eigenes Logo ersetzen.

    Anleitung:

    http://www.raspberry-projects.…ian/custom-boot-up-screen

    und https://raspberrypi.stackexcha…ssages-all-text-in-jessie

    Die Himbeeren, das Regenbogenquadrat und die Boottexte sind nicht mehr zu sehen. Aber auch kein Bootlogo, welches beim älteren PRI3 mit NOOBS vom letzten Jahr angezeigt wird.

    Der RPI bootet mit nem schwarzen Bildschirm direkt in den Desktop.


    Nur was ist mit dem Startscript (/etc/init.d/asplashscreen) ? Wenn ich es manuel starte, wird das Bild geöffnet angezeigt.

    Irgendwie wird es generell nicht gestartet. Ich lasse dort auch zu Testzwecken nen Ordner auf dem Desktop anlegen. Nach dem Booten ist der Desktop leer. Beim manuellen starten, wird der Ordner erstellt und auch das Logo angezeigt. Script und Bild müssten also i.O. sein.


    Habe den eindruck, dass alle Scripte unter /etc/init.d/ ignoriert weden.

    Wurde bei Strech was verändert? :conf: