Posts by JenselBensel


    Hi Jens,


    so 100% kann ich dir da nicht helfen aber vielleicht hilft dir das etwas weiter?


    gruß
    co8


    Ja soweit bin ich auch schon gewesen. Aber trotzdem danke. :)
    Automatisch zusammengefügt:[hr]


    Danke erstmal für diesen Kalender. Der ist leider zu groß für mein kleines 7" Display von Pollin. ^^
    Ich möchte zwar direkt auf die Daten des Owncloud Kalender zugreifen. Aber nicht alle Daten eines Monats darstellen.
    Ich habe da schon ein paar CalDAV Lösungsansätze gesehen. Im Owncloud Forum findet man auch eine extra App dazu.
    Nur bekommt man da nicht einzelne, bevorstehende Termine angezeigt.
    Falls ich eine korrekte Lösung finde. Werde ich sie natürlich hier posten. :)
    Vielen Dank erstmal. (y)

    Hi Leutz,


    ich suche eine Möglichkeit meinen Owncloud Kalender in meinen Webfronted anzeigen zu lassen.
    Einmal als kleines Widget in dem nur die nächsten anstehenden Termine aufgelistet werden,
    und einmal als Seite wo drüber ich alle Termine einsehen kann.


    Kann mir jemand weiterhelfen?


    Vielen Dank.


    Gruß Jens

    Hey,


    wollte mal kurz das Problem hier aufgreifen.
    Heute hatte ich die gleiche Fehlermeldung wie im Eröffnungsthread beschrieben.
    Stutzig wurde ich bei der Aussage:


    "meinem schönen neuen Buch "Hannahs 25 neue Server" und dem Forum..."


    In diesem Buch (Seite 36) steht beschrieben, wie man auf dem RasPi eine feste IP-Adresse einträgt.
    Laut Beschreibung geht das Ganze über '/boot/cmdline.txt'. Dort trägt man die feste IP-Adresse ein.


    Nachdem ich genau diesen Weg gegangen war, konnte ich zwar noch auf den RasPi zugreifen. Aber der RasPi konnte keine Verbindung ins Internet herstellen.
    Erschwerend für eine erfolgreiche Fehlersuche kam hinzu, dass es in letzter Zeit öfter Probleme gab mit diesem RasPi auf das Internet zuzugreifen.
    Komischerweise wurden alle Pings(außer ins Internet), sowie die richtige IP-Adresse angezeigt.


    Kurzum, wer das gleiche Problem und dieses Buch zur Hand liegen hat, sollte seine Einträge in der "/boot/cmdline.txt" mal überprüfen.


    GLÜCK AUF!!! :)

    So, jetzt habe ich ein Problem. Es ist zwar nicht zum Thema Ambilight. Aber zum Thema LED Strips, Steuerung, Raspi und Arduino.


    Leider habe ich mit Arduino und Raspi zusammen noch keine Erfahrungen sammeln können.
    Mein Problem liegt im Moment darin dass ich einmal die normalen RGB LED Strips mit PI-BLASTER steuern möchte, und die WS281x über die NEOPIXEL Library.
    Leider braucht man für beide Varianten einen PWM GPIO PIN. Bekanntlich lassen sich ja beide PWM GPIOs nicht getrennt von einander ansprechen.
    Wäre ein Arduino Nano in Verbindung mit dem Raspi zur gleichzeitigen Steuerung beider LED Varianten möglich? Wenn ja, wie?

    Ich glaube das Raspberry kann die nicht direkt ansteuern, der Arduino schon. Die WS2812b sind günstiger als z.B. WS2801 und kommen mit 60 LED/m daher.


    Wenn ich falsch liege biete korrigieren, habe mich da bisher nur reingelesen :)


    Über die Neopixel Library kannst Du die WS281x direkt ansteuern. Nur kannst Du sie nicht direkt mit Strom versorgen. Mit einem weiteren ausreichend starken Netzteil gibt es keine Probleme.
    Automatisch zusammengefügt:[hr]

    Ich verwende auch einen Arduino dazwischen dann flackert und blitzt nichts - auch nicht bei Nutzung des RPI2 LAN-Anschlusses.


    Also bei mir flackert und blitzt auch nichts. Außer ich will das so. Getestet habe ich es schon mit dem B+, 150 LEDs an 5V 2A und einer Gleichrichterdiode.
    [emoji106]


    Aso, ich glaub -,16 Cent habe ich für eine Diode bezahlt. Was auch unnötig war, da ich noch 5 Nutzbare Dioden hier liegen hatte.

    Hi Freaks,


    seitdem ich heute mein heimisches Netzwerk verkleinert habe und meinen Test-Raspberry neu starten musste. Bleibt dieser jetzt immer in der Bootsequenz bei:


    Quote

    [ ok ] Starting system message bus: dbus.
    Using hardware: PWM


    hängen.


    Einzig den Apache2 Service hatte ich zuvor neu gestartet. Der mir nur einen kleinen Fehler raus haut. Ich soll doch die Loopback Ip anstatt eines Domain Name benutzen.
    Seitdem komm ich via Putty und Remote Desktop nicht mehr auf den Raspi.


    Lustigerweise funktionieren alle zuvor gestarteten Tools, Programme & Service perfekt.
    Selbst ein PHP Skript welches sonst nur bei öffnen im Browser funktioniere, funktioniert.


    Kann mir jemand sagen ob und wie ich in die Bootsequenz eingreifen kann, oder ob es eine Möglichkeit gibt die Bootsequenz mit den nötigsten Funktionen zu starten, dass man dieses Problem beheben kann?


    Nachtrag: HTTP Zugriff funktioniert soweit...^^


    ok, mir war die Schreibweise mit den Doppelpunkten nicht bekannt, darum die "korrigierte" Syntax. (abgesehen davon wäre es mit switch statt den ganzen elseif auch schöner ;))


    Aber nochmal zum Problem, Zeilenumbruch oder Leerzeichen könntest du mit trim() beseitigen:


    $td = trim($tdarr[1]);


    Ich kannte es mit dem Doppelpunkt so auch nicht und es kurz vor dem Post hier ausprobiert.
    Mittlerweile habe ich alle Varianten ausprobier(glaube ich). ^^


    Ja cool danke. Das werde ich jetzt direkt mal testen.


    Vielleicht bekomme ich dann wenigstens irgendwas zu sehen außer "ERROR". :)
    [hr]
    Mittlerweile bekomme ich überhaupt keine Ausgabe mehr. Noch nicht mal mit var_dump...:-(
    [hr]
    Boah verdammt...ich hab es!!!


    Es lag wirklich am Leerzeichen und durch trim wurde es entfernt.


    Vielen Dank BennY für Deinen Tipp. Trim war mir zwar als Befehl bekannt. Nur kannte ich seine Funktion noch nicht.


    BOMBE...Ich freu mich wie Bolle!!! :D


    Laut dem hier


    http://php.net/manual/de/control-structures.elseif.php


    ist else if nur mit geschwungener Klammer erlaubt, bzw. überhaupt nicht erlaubt.


    ^^

    Das habe ich. Einmal mit print_r() und einmal mit echo. Darüber konnte ich ja auch erst die Arrays bestimmen.
    Die anderen Variablen geben vorher genau die gewollten Werte aus.
    Ich habe auch schon Variablen umgeschrieben und als reinen Text versucht auszuwerten.
    Nichts.
    Spätestens hier hätte etwas ausgewertet werden müssen.

    Hey RasPi Junks,


    ich versuche gerade meine BabyCam DCS-825L in mein Webfront zu integrieren.
    Dazu benutze ich ein PHP zum auslesen der Datei notify.cgi.
    Soweit funktioniert auch alles, bis auf das ändern der Schriftfarbe von der Temperaturausgabe.
    Es gibt 3 Zustände:


    cold //Farbe:blau
    normal //Farbe:grün
    hot //Farbe:rot


    Mein Script sieht wie folgt aus:



    Bis jetzt bekommen ich immer ERROR angezeigt.
    Ich habe auch schon verschiedene andere Varianten ausprobiert.
    Doch immer wieder wird ein Fehler generiert.
    Andere ähnliche Abfragen habe ich auch hinbekommen.
    Bei dieser finde ich einfach den Fehler nicht. Wer kann mir da helfen?


    Vielen Dank

    Vielen Dank für eure Antworten.


    Ich habe es jetzt so gelöst:



    Code
    <head>
    <script type="text/javascript">
    $(document).ready(function() {
    $("#refresh").load("status_gpio.php");
    var refreshId = setInterval(function() {
    $("#refresh").load('status_gpio.php?' + 1*new Date());
    }, 1000);
    });
    </script>
    </head>


    und:


    Code
    <div id="refresh" style="text-align:center;"></div>


    Meine status_gpio.php (provisorisch):



    Ich denke so wurde es mir hier auch geraten.


    Abgesehen, dass das hier wirklich die falsch Sektion ist, schreibe ein php-Script, welches bei Aufruf den GPIO abfragt. Erstelle dann eine HTML-Seite, in der Du entweder per Java mit Ajax diese Script in dem von Dir gewünschten intervall aufrufst. Eine andere Möglichkeit ist, das php-script gleich in die Seite einzubinden und mit einem meta-tag zu refreshen:


    Code
    <meta http-equiv="refresh" content="3">


    Beispiel ist für alle 3 Sekunden. Alle Varianten erzeugen eine Menge Traffic


    Vielen Dank erstmal.


    Ich werde beim nächsten Mal drauf achten in die richtigen Sektion zu posten.


    Also die Meta-Tag Variante funktioniert. Leider ist diese Lösung nicht das gelbe vom Ei.
    Wäre es nicht besser wenn ich die GPIO Abfrage und den Intervall als Javascript in meine PHP/HTML schreibe?


    Bin ich mit

    Code
    body onload

    und

    Code
    window.set.Timeout

    auf dem richtigen Weg?

    Die Kategorie ist GPIO, ganz klarer Fall. Gerade wenn man die Unterkategorie "Web-Programmierung" nicht auf den ersten Blick sieht. :stumm:


    Ja nee is kla dass es sich um einen dynamischen Inhalt handelt. Soweit bin ich auch schon gewesen (siehe Ansatz 1 Subtext).


    Also ich finde da nicht konkretes zum Thema. Es kann aber daran liegen dass ich mich hier schon richtig müde gelesen habe.


    Link zum Thread würde mir schon reichen. :thumbs1:
    [hr]
    Asö, bevor ich es vergesse. Wenn möglich würde ich gerne auf JS oder andere Skriptsprachen verzichten wollen.

    Hey ihr RasPi Junks...


    ...in Sachen PHP & RasPi bin ich noch totaler Neuling. Seit 6 Wochen bin ich stolzer Besitzer zweier RasPis (B & B+). Jetzt habe ich meinen B+ ins Kinderzimmer an einen LED Strip und zwei PIR Modulen verbaut. Das Ganze habe ich mit dem einfachen PIRI Skript von E.F. Engelhardt und PI-Blaster kombiniert. Soweit läuft alles super. Bis auf ein kleines Problem beim Starten von PIRI Service über Daemon. Bei jedem Neustart schalten sich der LED Stripe an. Obwohl im Skript eindeutig aus steht.


    Naja, jetzt zu meinem eigentlichen Problem. Ich würde mir gerne auf meinen gebastelten PHP Webfrontend den Status vom PIR Modul anzeigen lassen. Also quasi sobald das PIR Modul eine Bewegung erkennt, soll mir im Webfrontend diese direkt angezeigt werden.
    Informationen zum Auslesen von GPIOs habe ich schon gefunden. Nur fehlt mir jetzt noch die permanente Aktualisierung, bzw. die regelmäßige Abfrage des Status.
    Hier hätte ich zwei Lösungsansätze.


    ANSATZ 1:
    Ich würde versuchen mit Daemon, einem Service Skript und einem Loop den GPIO Status direkt in meine PHP Seite zu schreiben.
    Wobei ich denke dass dann immer noch nicht die Seite aktualisiert ist.


    ANSATZ 2:
    Wäre über eine Funktion in der PHP Seite die auch regelmäßig über einen weiteren Befehl aktualisiert wird.
    Doch mit dem Thema Funktionen tue ich mich noch ein bisschen schwer.


    Kann mir jemand da weiterhelfen?


    Gruss