Posts by Outlaw

    Also ich konnte vor einiger Zeit dieses Problem mit einer 512GB Festplatte nachvollziehen und wie gesagt, mit dem Raspi Imager lief das Image nicht, Win32DiskImager begann erst mal gar nicht mit dem Schreiben und Belana Etcher hat es dann - nur mit dem Warnhinweis - trotzdem gebacken bekommen.


    Allerdings ist der Raspi Imager inzwischen 3 Versionen weiter und sollte heute auch kein Problem mehr damit haben.

    Katzenreh

    Ja, programmieren ist nicht das Gelbe vom Ei aber der Bekannte macht das seit Jahren und hat wohl viele Formen schneller "gecoded", als wir wohl in irgend einem Programm gezeichnet.

    Aber das ist auch nicht der Punkt, sondern war nur ein Beispiel.


    Wie geschrieben, ich nutze Fusion 360 und das ist nicht nur für 3D Drucker geeignet, sondern viele Fräser nutzen das auch als 3D Konstruktion.

    Gesliced (3D in GCode übersetzen) wird dann halt mit was anderem wie z.B. Cura (3d Druck) gemacht.


    Fipsi

    Frag Deinen Bekannten doch mal, was er für Formate verarbeiten kann.

    Mir sind hauptsächlich STL und DXF und Co. bekannt.

    Ich kenne jemanden, der seine Fräse direkt per GCode programmiert, ist aber für Deinen Fall wohl eher Horror ....


    Ansonsten höre ich immer wieder vom Autodesk Programm Fusion 360, welches für private Zwecke kostenlos ist, wenn man sich dort registriert.

    Ich konstruiere einfache 3D Teile für meinen 3D Drucker aber was man damit letztendlich dann steuert, dürfte egal sein.


    Also bei mir sieht es so aus: Teil konstruieren => in Slicer (GCode Generator) importieren => an Drucker senden


    Laut meinem Bekannten arbeiten CNC Fräsen ebenfalls mit GCode, womit der Unterschied nich allzugroß ausfallen dürfte.


    Womit Deine Fräse allerdings gesteuert wird, weiß ich nicht.

    Die Software muss halt das verstehen, was Deine Fräse steuern kann.

    Zum konstruieren hat sich eben u.A. Fusion 360 als gut erwiesen oder andere kostenlose Tools wie FreeCad oder so.

    Ich bin zum Schluss halt bei Fusion 360 hängen geblieben, da ich dort am schnellsten zu Ergebnissen gekommen bin.

    NAS für Laien ist irgendwo auch ein wenig widersprüchlich.


    Generell gehe ich bei richtigen NAS(en) eher auf Synology & Co., die schon für kleines Geld (ca. 160€ ohne Platten) zu haben sind.

    Aber auch das ist nicht unbedingt was für Laien aber wenigstens für das ausgelegt, für was es eben sein soll, eben NAS.


    Aber man kann sich bei beiden Welten Wissen aneignen, um an ein (halbwegs vernünftiges) NAS zu kommen.


    Mehrere Platten/SSDs an einem Pi sollten aber kein Problem sein.

    Der Tausch in eine SSD war eine gute Entscheidung, gerade bei diesen Größen.


    Ich hatte allerdings auch mal das Problem mit einer größeren HDD an nem Pi4 mit dem hauseigenen Imager.

    Auch der Win32DiskImager hat gestreikt.

    Mit dem Belana Etcher gabs zwar auch eine Warnmeldung, hat dann aber problemlos funktioniert.

    Also ich muss sagen, dass Win 11 Pro Prev bei mir recht gut arbeitet.

    Ok, mit einem PC nicht zu vergleichen aber trotzdem kann man damit arbeiten.

    Da es aber keinen wirklichen Grafiktreiber gibt, sind speziell Videosachen nicht gerade flott aber für normale Sachen reicht es.

    Ich beobachte die Sache gespannt und jetzt in dem Moment gerade läuft das Update auf die Version 22000.100.


    Ja, SSD sollte man haben, sonst wird es sehr träge und ich habe eine Anleitung geschrieben, die keine Registration bei heise.de benötigt.


    Da ich aber nicht auf (m)ein Forum verlinken möchte (ist hier sicherlich nicht gern gesehen), habe ich eine Anleitung hier verlinkt,

    nach der ich damals den ersten Test gemacht habe:


    How to Install Windows 11 on a Raspberry Pi 4 | Tom's Hardware (tomshardware.com)

    Der Hinweis aufs originale Netzteil macht auch deshalb Sinn, da man dieses sehr günstig bekommt.

    Ein USB-C-Adapter ist kein Problem, wenn das verwendete Netzteil sonst ausreichend ist, habe ich am Anfang auch so gemacht.

    Mittlerweile habe ich aber genügend originale Netzteile mit USB-C-Anschluss, so dass ich diese <1€ Adapter nicht mehr brauche.

    Wenn DU wirklich "Speed" haben willst, nimmst Du eine SSD.

    Da reicht eine günstige, da der Pi die eh nicht komplett ausreizen kann aber so 200 bis 300 MByte/s sollten schon drin sein (laut Foundation).

    Ich habe an meinem 400er eine ältere 120er Kingston und die macht so um die 160 bis 200 MByte/s und das ist allemal besser als die schnellste SD am lahmen SDF Port der PIs.

    Der Pi2 kann nicht direkt von der Platte booten, Du müsstest also weiterhin von der SD Karte booten und dann auf die Platte wechseln.


    Mit dem Pi2 macht das aber auch keinen Spaß, da wäre ein Pi4 mit 4GB deutlich besser.


    PiHole und Nextcloud zusammen auf Port 80 wird nicht funktionieren, daher am besten den PiHole auf einen anderen Port konfigurieren.


    Beim Rest muss ich leider passen.


    Wobei noch zu erwähnen wäre, dass Ubuntu Server 64Bit auf einem Pi4 mit Nextcloud (nicht NextcloudPi) recht geschmeidig läuft.

    Zudem kannst Du dann auch noch Collabora Online installieren um Office Dokumente direkt zu bearbeiten (geht eigentlich in recht annehmbarer Geschwindigkeit, wenn auch keine Rakete).


    Nextcloud kannste ja auf einem fertigen System nachinstallieren:


    Code
    sudo wget https://download.nextcloud.com/server/installer/setup-nextcloud.php
    sudo chown www-data:www-data setup-nextcloud.php
    sudo chmod 0755 setup-nextcloud.php

    Dann per Browser mit der Webseite


    http://ubuntu/setup-nextcloud.php


    die Installation starten (Pfad anpassen, je nach System).


    NextcloudPi lässt sich momentan unter Ubuntu Server 64Bit nicht installieren, daher das "normale" Nextcloud.


    Du kannst natürlich auch das normale Raspberry Pi Os nutzen aber bei der 32Bit Version sind die Prozesse auf 3GB begrenzt.

    Und die 64Bit Version ist noch Beta und wäre mir zu "wackelig".

    Habe vor Kurzem auch mal mit RetroPie "rumgespielt".


    Dabei ist mir aufgefallen, das mame-libreto ziemlicher Käse ist und sogar viele Arcade Games damit gar nicht laufen.

    Habe dann das mame-libreto durch das experimentelle Paket "mame" (bei mir Paket #25) installiert, welches bedeutend besser läuft.


    Vielleicht hilft das ....

    Der Apache blockiert trotzdem den Port, auch wenn DynDNS aus ist.


    Schalte doch zum Erneuern des Zertis den Apachen kurz aus.


    Ich habe bei mir bei einem Pi die automatische Verlängerung aktiviert.

    Soweit ich die Routine von LetsEncrypt verstanden habe, macht die das selbstständig (wenn richtig konfiguriert) und aktiviert diesen danach wieder.

    Da der Apache mit dem neuen Zertifikat eh neu gestartet/aktualisiert werden muss, passt das.


    Nachtrag:
    Ach so, bei Rechteproblemen kann es auch sein, dass Du "sudo" davor vergessen hast, wenn Du nicht als Root arbeitest.