Posts by eiermann1


    Wo hast Du denn Deine .cgi-Datei liegen?
    Dein ScriptAlias zeigt auf /usr/lib/cgi-bin/


    ja da liegt es und ausführbar. Es wird ja im Browser runtergeladen ansatt ausgeführt.
    [hr]

    ja da liegt es und ausführbar. Es wird ja im Browser runtergeladen ansatt ausgeführt.


    jetzt hab ich einen anderen Browser genommen, der frägt mich jetzt was er damit tun soll?
    downloaden oder ausführen, ja eigentlich ausführen aber doch auf dem Pi und nicht unter dem Windowsrechner.
    eiermann1


    Auch wenn Brückentag ist gibt es viele die erst gegen Abend hier reinsehen, also nicht so ungeduldig.


    Schau doch man in /etc/apache2/sites-available/default welches Verzeichnis als Script-Alias gesetzt ist.


    Hallo orb
    auf meinem Image gibt es kein Verzeichniss unter apache2 das sites-available heisst,nur mods-available
    da drin ist eine Datei: php5_cgi mit diesemInhalt:
    # This file replaces old system MIME types and sets them only in the
    # Apache webserver


    # application/x-httpd-php phtml pht php
    # application/x-httpd-php3 php3
    # application/x-httpd-php4 php4
    # application/x-httpd-php5 php
    <FilesMatch ".+\.ph(p[345]?|t|tml)$">
    SetHandler application/x-httpd-php
    </FilesMatch>
    # application/x-httpd-php-source phps
    <FilesMatch ".+\.phps$">
    SetHandler application/x-httpd-php-source
    # Deny access to raw php sources by default
    # To re-enable it's recommended to enable access to the files
    # only in specific virtual host or directory
    Order Deny,Allow
    Deny from all
    </FilesMatch>
    # Deny access to files without filename (e.g. '.php')
    <FilesMatch "^\.ph(p[345]?|t|tml|ps)$">
    Order Deny,Allow
    Deny from all
    </FilesMatch>


    # To enable PHP CGI site-wide, just uncomment following lines, however
    # as a security measure, it's recommended to enable PHP just in the
    # specific virtual servers or just specific directories


    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AddHandler cgi-script .cgi
    AllowOverride All
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>
    Action application/x-httpd-php /cgi-bin/php5


    DEn Pi hab ich schon neu gestartet.Es wird das cgi script nur immer downgeloaded obwohl obiges enabled ist.
    Eiermann1


    Hallo kungel
    ja perfekt. Jetzt läufts.
    Danke nochmal.
    Klasse Forum !!:)


    Ja, ich meinte mit dem Geheimnis geschweifte Klammer, dass ich es zuerst immer mit ( oder [ probiert habe und es nie ging. Dann nahm ich die { und es ging irgendwie. Dann konnte ich testen und dann war der -Wert der Richtige.
    Jetzt hab ich das nächste Problem. Jetzt frag ich den Wert ab (if [ $(echo "if (${var2} > $1) 1 else 0" | bc) -eq 1 ]) dann kann ich abfragen was ich will nie treffend. Ich meine die Variable $1 hat z.B. 500 und die var2 ist 485,63 (Gleitkomma, deshalb mit bc).
    Wenn aber die Variable mitgegeben wurde geht die Abfrage, nur nicht wenn mit echo{1:-500} gesetzt wurde. Hab auch schon echo${1:-500.00} probiert.
    Da liegt der Teufel wieder im Detail.:idea:
    eiermann1


    Das liegt nicht an den Devices, das dürfte eher daran liegen, daß sich Dein 'Lesekopf' nicht mit dem Hub verträgt.
    Ich würde einfach mal einen anderen (aktiven?) Hub versuchen.


    Es ist ein aktiver HUB, aber ich werde einen anderen versuchen.
    Danke


    Wieso kannst Du was nicht realisieren?
    Was willst Du denn genau machen?
    Du hast scheinbar zwei serielle Schnittstellen für den USB-Bus. Die tauchen als /dev/ttyUSB0 und /dev/ttyUSB1 auf. Das tun sie, egal ob ein Hub dazwischen steckt oder nicht, egal wo sie stecken.
    Dein WLan wird als wlan0 oder ähnlich (je nach Treiber) erkannt und bekommt keinen Eintrag in /dev


    das Problem ist, wenn ich den 2. Lesekopf am HUB anschließe wird dieser nicht erkannt bzw. es gibt kein ttyUSB1 mehr. Wlan geht.


    Hallo Kungel
    so geht es auch mit einer Systemvariablen:
    echo ${1:-500}


    das Geheimnis sind die geschweiften Klammern.
    Hier wird die Systemvariable $1, wenn nicht schon belegt mit 500 ersetzt.
    Ich dachte eigentlich es müsste echo ${1:+500} heißen , aber egal es geht.
    Danke nochmal

    Hallo zusammen
    möchte cgi scripte auf dem Pi ausführen. Das script wird leider nur downgeloaded anstatt ausgeführt.
    Finde auf dem Pi nicht das richtige Apache -Verzeichniss oder was auch immer.
    Hoffe jemand kann helfen.
    eiermann1


    /dev/ttyUSBn sind normalerweise USB-Seriell-Wandler, keine USB-Ports.
    Die USB-Schnittstelle hat kein Device in /dev, die findest Du in /sys/bus/usb, die einzelnen Geräte in /sys/bus/usb/devices
    Das File in /dev für die Devices legt der Treiber an.


    Hallo orb
    Ok Seriall-Wandler.
    Heist das ,dass ich dies mit einem 4 fach USB Hub am untern USb Anschluss nicht realisieren kann.
    Sprich:
    ein Port(oder was auch immer) für das Device ttyUSB0(serial Lesekopf)
    ein Port (am HUB) für das Device ttyUSB1(2.serialLesekopf)
    und ein Port wieder am HUb für meinen WLan Stick
    eiermann1


    Hallo eiermann1,


    woher hast du denn die Bezeichnungen USB0 und USB1? Zeigt dir die ein bestimmter Befehl an?


    Gruß Georg


    Hallo ja
    mit diesem:
    [font="monospace"]udevadm info --query=all --name=/dev/ttyUSB0[/font]
    und
    [font="monospace"]udevadm info --query=all --name=/dev/ttyUSB1
    mit Hub gibt es keine weiteren USB Ports.
    Möchte von den USB0 und USB1 Daten einlesen. Wenn ich versuche die Daten über den HUB zu lesen, weiß ich nicht welche Ports ich angeben muss. Weiter möchte ich meinen Wlan Stick an den USB Port anschliessen.
    eiermann1
    [/font]


    Hallo ErzGabriel
    hab leider selbiges Problem. Hast du eine Lösung gefunden?
    eiermann1

    Hallo zusammen
    der Pi hat ja zwei USB Ports. USB0 und USB1.
    Wenn ich nun einen 4xUSB-Hub anschließe(an USB0), gibt es welche Ports mit welcher Bezeichnung?
    Wie kann ich die Ports dann einlesen?


    PS es gibt dann keine Ports mit USB2,3 usw.. !!!
    eiermann1

    aber ups, im Beispiel heißen die Variablen # und 1


    ja, ich weiß


    $0 ist der Programmaufruf
    $1, $2, ... sind die Parameter 1, 2 usw.
    $# zeigt die Anzahl der Parameter an.


    Hallo zusammen
    ja kungel hat es richtig geschrieben.
    Ich starte ein script mit "./script.sh 300" und übergebe dem Script 300 in der systemvariablen $1.
    Jetzt möchte ich im script einen Fehler abfangen, wenn die Eingabe der Variablen vergessen wurde.
    Hab in div. Bash Büchern dann diesen Befehl gefunden:
    $1:=xyz --> bedeutet wenn var1 nicht gesetzt ist nehm xyz.
    Bekomms aber nicht hin.
    eiermann1

    hallo zusammen
    möchte die Systemvariable $1 in einem bash script testen.
    Wenn ich:
    $1:=200
    im script einstelle kommt immer eine Fehlermeldung.
    Hab schon allerhand Varianten probiert, immer eine Fehlermeldung.
    Ich dachte obiger Befel setzt für die Variable $1 auf 200 wenn nichts anderes angegeben wurde.
    Hab leider nichts erklärendes gefunden.
    eiermann1


    warum denn überhaupt zwei nahezu identische Scripte.


    Starte doch ein script, das einfach nur das Ergebnis des ersten jobs in eine andere Datei sichert.
    Kein großer Aufwand und job1 und job2 kommen sich nicht in die Quere.


    Hallo
    wäre natürlich auch machbar. Aber dann müsste ich den ersten Job umprogrammieren und dies bereitet mir mehr Schwierigkeiten, als den fast gleichen Job nur einmal am Tag aufzurufen.


    Jetzt geht es übrigens. In der Syslog war kein Eintrag oder Fehlermeldung sichtbar.
    Hab den cronjob komplett neu geschrieben und jetzt gehts. Keine Ahnung was da los war.
    :rolleyes:
    Danke nochmal.


    Hallo
    mit sudo crontab -e erstellt.(unter /home/pi)
    Der erste Eintrag läuft ja und von Hand laufen beide.
    Syslog schau ich mir an.
    Danke

    hallo zusammen
    in meiner crontab stehen folgende Aufrufe drin.
    */10 * * * * /home/pi/job1.sh
    59 23 * * * /home/pi/job2.sh


    also alle 10 Minuten ausführen und um 23:59 jeden Tag.
    Die jobs unterscheiden sich nur im abspeichern der Daten in einer anderen Datei.
    Alle 10 Minuten wird der job1 ausgeführt.
    Der um 23:59 aber überhaupt nicht.
    Ausführbar sind beide Dateien.(755)
    Hat jemand eine Idee??
    eiermann1