Posts by wagnbeu0

    Kurzes Update:

    Nach dem setzen von Netzwerkparametern mittels


    Code
    ethtool --offload eth0 rx off tx off


    läuft der Pi3+ nun sehr stabil, keine Netzwerkhänger mehr.

    ISCSI habe ich nicht mehr probiert, da ich wegen der Probleme auf NFS umgestellt habe, und noch keine Zeit hatte, ISCSI wieder zu testen.



    Vielleicht hilft das dem einen oder anderem.

    Kurzes Update:

    Nach dem setzen von Netzwerkparametern mittels


    Code
    ethtool --offload eth0 rx off tx off


    läuft der Pi3+ nun sehr stabil, keine Netzwerkhänger mehr. Vielleicht hilft das dem einen oder anderem.

    Das ist ein bekanntes Problem wird hoffentlich bald gefixed. Vielleicht erledigen sich dann auch deine anderen Probleme

    Das wäre super, denn aktuell bin ich echt am überlegen, den Pi in die Tonne zu treten. Pi1 - Pi3 waren stabil, Pi3+ ist schneller, dafür läuft vieles, was mit Netzwerk zu tun hat, nicht mehr stabil ...

    Hallo,
    Ich habe einen Pi1,2 und Pi3 mit einer externen USB-Festplatte seit mehreren Jahre laufen. Ich habe einen mit der OSMC-Distribution und einen zweiten mit Raspian verwendet. Alles hat einwandfrei geklappt.
    Aus Gründen der Datensicherheit habe ich eine QNAP NAS gekauft und wollte den USB-Datenträger durch einen ISCSI-Datenträger auf meinem QNAP ersetzen. Leider war meine ISCSI-Anbindung nicht erfolgreich, weil ich eine Menge Timeouts bekommen habe.
    Sie können meine Geschichte hier finden:
    OSMc und ISCSI
    Jetzt habe ich alle Daten von der ISCSI-Platte zu meinem QNAP umgezogen, der über NFS gemounted wird. Fast alles funktioniert, aber:
    Ich habe einen raspbibackup cronjob, der meine Daten über rsync und dd auf meiner externen USB Festplatte speichert. Das hat einige Jahre geklappt. Da ich NFS verwende, funktioniert es nun nicht mehr. Sowohl der DD- als auch der rsync-Job erzeugen hohe IO-Werte auf der NFS-Netzwerkfreigabe. Dies führt dazu, dass der Pi hängt.
    Weiß jemand, warum die Netzwerkschnittstelle von Pi3 + mit Kernel 4.14 so instabil ist? Da der QNAP über Gigabit verbunden ist, sollte die Netzwerkgeschwindigkeit ausreichen.
    Da ISCSI mehr oder weniger das gleiche Problem hat, scheint es mir, dass der Kernel 4.14, der auf dem pi3 + benötigt wird, (installiert über raspi-update) jedoch ein Problem mit high IO auf der Netzwerkkarte hat.
    Ich benutze nextcloud auf meinem pi. Wenn ich Hunderte kleiner Dateien hochlade (das Datenverzeichnis ist auf der NFS-Freigabe gespeichert), funktioniert es einwandfrei. Wenn ich einige riesige Dateien (ISO-Dateien mit 2 oder mehr GB) hinzufügen, habe ich das gleiche Verhalten - das System hängt.
    Wer kann mir helfen, wie man die Netzwerkverbindung auf dem pi3 stabil hält?
    Meine Konfiguration:
    Raspian 9
    Pi3 +
    Kernel 4.14
    QNAP 2BAy mit der neuesten Firmware, die über GB-LAN verbunden ist.

    Hallo, ich habe einen Pi3 im Einsatz. Jetzt habe ich mir eine Synology NAS gekauft, und eine ISCSI Freigabe erstellt. Ich kann sie auf dem Pi3 auch mounten, weil ich hier die Verzeichnisse vom Webserver ablegen will.


    Sobald viel Last erzeugt wird, kommen jedoch Timeout Fehlermeldungen im dmesg, und irgendwann wird das Volume auf RO gemountet. Der Fehler ist auch reproduzierbar, wenn per rsync Daten lokal auf die Synology kopiert werden.


    Da ich von einem Hardwarefehler ausgegangen bin, habe ich einen Pi 3+ gekauft. Der Fehler bleibt jedoch der gleiche.

    Interessanterweise habe ich auf dem alten Pi ein Debian9 installiert. Hier kann ich problemlos mit ISCSI arbeiten.


    OSCM hat den Kernel 4.14, Debian 4.9, die Open-ISCSI tools sind auf dem OSMC in Version 2.0.873 installiert, auf Debian 2.0.874.


    Hat jemand das gleiche verhalten beobachten können? Ich habe die Konfigeinstellungen verglichen, die Settings unter /etc/iscsi sind identisch.

    Hallo, ich würde das auch gerne mit meinem Pi machen. Das Problem, vor dem ich genauso stehe wie du, ist, dass die interfaces Datei leer ist, da OSMC ja einen Networkmanager verwendet: connman


    Hast du das mittlerweile hinbekommen, dass die Bridge bei dir läuft?

    Hallo, ich setze meinen kleinen Raspy Model A als Server unter Debian 7 ein.
    Dabei ist mir folgendes aufgefallen:
    Sobald keine USB Tastatur dran hängt, bleibt er beim DHCP Client stehen. Tagelang, also er macht da nicht weiter.


    Wenn ich eine Tastatur anstöpsel, dann bootet er 1A. Da er nur zwei USB-anschlüsse hat, und ich da zwei Drucker dranhänge, geht das so natürlich nicht.


    was muss ich wo einstellen, damit er ohne Tastatur sauber bootet? Da er eh ohne Monitor läuft, und nur per SSH administriert wird, ist mir die Tastatur erst mal egal.


    vielen Dank für eure Hilfe.