Posts by PatrickS


    aber beim Start gibt es trotzdem ein Warning, weil wohl ein dhcppcd client versucht zu starten und einen Fehler in der interfaces hat.Versteh grad noch nicht, wo dort der Fehler sein soll...
    Brauch ich das überhaupt? DHCP macht doch eigentlich der Server von der FritzBox, der die IP verwaltet und verteilt?
    Hat jemand eine Idee?


    Es gibt ab Raspbian Wheezy vom 2015-05-05 zwei Möglichkeiten eine IPv4-Konfiguration vorzunehmen. Die alte Vorgehensweise über die Datei “/etc/network/interfaces“ und die neue Vorgehensweise über die Datei “/etc/dhcpcd.conf“. Wenn man beides macht, kommt es zu Fehlern.


    Normalerweise sollte kein Fehler kommen, wenn man die Datei “/etc/network/interfaces“ unverändert gelassen hat.


    Du kannst dir ja mal den Status vom DHCP-Client anzeigen lassen:


    Code
    sudo service dhcpcd status



    Und ggf. abschalten. Empfehle ich Dir aber nicht.


    Code
    sudo update-rc.d -f dhcpcd remove


    Stattdessen stelle den Original-Zustand der Datei “/etc/network/interfaces“ wieder her:



    Was würdet ihr mir empfehlen auf meinem EeePC zu installieren?


    Auch wenn Du den Thread schon als erledigt markiert hast, würde ich Dir zu Xubuntu raten, weil der Desktop dort besser mit kleinen Auflösungen klarkommt.


    Bei EeePCs gibt es Modelle, die haben nur 600 Pixel Höhe bei der Auflösung. Das kann bei vielen Fenstern knapp werden. Vor allem bei Einstellungsdialogen, wo der Speichern- und Abbrechen-Button nicht mehr sichtbar ist.


    Viel Erfolg.


    Ich habe meinen Raspberry Pi mit der neusten Software ausgestattet und habe dann versucht ihn mit einem Fritzbox WLAN mit WPA2 zu verbinden. Der WLAN Stick funktioniert mit dem Pi, da ich ihn schon an einem anderen RPI ausgetestet habe. Als das nicht klappte versuchte ich es manuell, das ging auch nicht .. : =(
    aus aller verzweiflung holte ich mir dann das Programm Wicd welches meine Probleme ebenfalls nicht löste: das Programm zeige verbindungen an, versuchte dann auch eine Verbindung mit dem WLAN herzustellen, brach den Vorgang dann aber immer erfolglos ab.


    Ohne die fehlenden Angaben kann man Dir wenig helfen. Vielleicht fügst Du sie anonymisiert noch mal ein.


    Ganz spontan tippe ich aber auf eine instabile Stromversorgung. Versuche mal ein anderes Netzteil.


    Ansonsten würde vielleicht ein update & upgrade helfen.
    Automatisch zusammengefügt:[hr]


    Hallo,
    ich hatte mit dem Wlan immer Probleme, bis ich eine statische IP zugewiesen habe.


    Ja, das hat oft folgenden Grund:


    Je nach Stick braucht der Raspi relativ lange, bis er sich mit dem WLAN verbunden hat. Wenn es geklappt hat, dann bezieht er die IP-Konfiguration per DHCP. Der gesamte Prozess kann mehrere Minuten dauern. Wenn man den Raspi headless betreibt und nach einem Neustart per SSH drauf will, dann bekommt man Gicht, weil es nicht funktioniert und man nicht weiß, woran es liegt. 2 oder 3 Minuten können lange dauern. Je nach Temperament bekommt man schnell Lust das Ding an die Wand zu klatschen.

    Die hier vorgestellten Netzteile haben alle den Nachteil, dass das Kabel nicht austauschbar ist.


    Ich verwende nach Möglichkeit kurze Kabel mit abgewickeltem Micro-USB-Stecker. Das spart Platz.


    Ich nehme gerne Netzteile, die 3 oder mehr Ampere haben. Die haben meist 2 bis 4 USB-Ports. Da kann man dann auch mal 2 Raspis dran betreiben.


    Ich habe meinen Pi mal einem Port-Scanner ausgesetzt um zu sehen, welche Ports effektiv "offen" sind.
    Bei mir sind es, wie erwartet, nur Port 80 und 443 auf dem Pi.


    Was kann ein Angreifer nun effektiv anrichten, wenn nur diese beiden Ports offen sind?


    Das hängt davon ab, was dahinter hängt.


    Als Angreifer würde mich interessieren, welcher Webserver antwortet und welchen Konfigurationsstand er hat. Ist zum Beispiel Directory-Browsing möglich? Dann kann ich die Verzeichnisstruktur einsehen und nach Scripts suchen, die sich für einen Angriff eignen.
    Zweitens, wie werden die Daten gebildet. Reine HTML-Dateien oder dynamische Ausgaben. Eventuell eine Datenbank dahinter.
    Kann ich irgendwo benutzerdefinierte Eingaben machen? Werden diese Eingaben geprüft. Vielleicht kann ich eine Datei hochladen, die mir eine Shell öffnet.


    Der Betrieb eines Webservers bietet so viel Fallstricke.


    Hat es mal jemand von euch geschafft, eine hostapd so zu kompilieren, dass die dann auch noch läuft, ohne sich über den fehlenden Standard-Treiber (rtl871xdrv/nl8ß211) zu beschweren? Ich habs mit den hostapd-Versionen 1.0., 2.0 und 2.4 ausprobiert und im 05.05.2015 nicht zum Laufen gebracht. Würde mich mal interessieren, ob jemand die gleiche Erfahrung gemacht hat.


    Ich würde momentan und in diesem Fall (Raspberry Pi als Gateway) den dhcpcd deaktivieren und die Konfiguration nach der alten Methode vornehmen.


    Man muss dann halt aufpassen, dass man sich mit einem Upgrade nicht das System zerschießt.


    Bei einem reinen Client-Betrieb würde ich den dhcpcd empfehlen. Als Server, sofern er nicht als Gateway dient, auch.


    Alles was sich weiß ist, dass die Deutsche Telekom am 10.7 damit angefangen hat, alle Telefonverbindungen zu VoIP umzuwandeln.
    Das alles soll bis 2018 geregelt sein wenn ich mich nicht verlesen habe.


    Weiß da zufällig jemand mehr?


    Es geht darum Kombi-Anschlüsse, also Analog+DSL und ISDN+DSL auf VDSL mit VoIP umzustellen. Die betreffenden Anschlüsse werden bis 2018 gekündigt. In einem zweiten Schritt werden auch alle ISDN-Anschlüsse gekündigt. Reine Analog-Anschlüsse werden davon nicht betroffen sein.


    Ob das jetzt was mit den Störungen zu tun hat mag ich bezweifeln.


    Servus,
    Jedoch möchte ich gerne meinen 24/7 Raspberry Pi so einstellen, dass er eine Art Port Mapping bzw. Relaying macht - sodass sich die IPV4-Webcams als IPV6-Geräte ansprechen lassen.
    Gibt es dafür kostenlose Tools bzw. Scripts, die ich mir auf dem Raspberry installieren kann?


    Was Du brauchst ist ein Tunneling von IPv4 in IPv6, was DS Lite eigentlich ist.


    Eine andere Möglichkeit wäre NAT64. Allerdings kenne ich dazu keine Software. Da wirst Du was frickeln müssen.


    Beim SSH Login uber einen WIN-PC mit putty komme ich nicht über die Eingabe des Usernames hinaus.
    Nach der Eingabe des Usernamens passiert in den meisten Fällen nach dem ENTER nix mehr!?
    Auch ein Ping auf die IP ist merkwürdig, mal sind schnelle Pings dabei, mal bekomme ich eine Zeitüberschreitung.


    Und was passiert, wenn Du den mal an einen Bildschirm hängst. Ist da das selbe Problem?


    Das mit dem Bildschirm habe ich schon versucht, siehe Post 2 von mir.
    Da er nicht hochfährt, gibt es auch kein Bild. Oder fährt er doch hoch? Es ist komisch Bild bekomme ich aufjedenfall keins. Wenn ich das Lan Kabel stecke, steht die Verbindung innerhalb 5 Sekunden. So schnell fährt er normalerweise nicht hoch.


    Die Darstellung auf dem Bildschirm hat mit dem Hochfahren nichts zu tun. Das kann einfach nur eine falsche Einstellung.


    Es wäre halt interessant, wo es beim Booten hängt, wenn es überhaupt hängt. Wenn Du keine Anzeige auf dem Bildschirm bekommst, dann kannst Du per SSH auch das Kommando "dmesg" ausführen und schauen, ob da irgendwelche Warnings oder Fails sind.


    Zum Thema WLAN: Vorausgesetzt, alles ist richtig konfiguriert, dann kann es ein paar Minuten dauern, bis eine Verbindung übers WLAN möglich ist. Das geht nicht so schnell, wie bei der Kabelverbindung.
    Das zweite, was man wissen sollte. Wenn man LAN und WLAN parallel betreibt, dann kommt es durchaus mal zu seltsamen Effekten. Normalerweise sollte die LAN-Verbindung bevorrechtigt sein. Aber, wer weiß das schon.

    Aja. Ich habs geahnt.


    Ich gehe davon aus, dass Du Deine Netzwerk-Konfiguration in der Datei /etc/network/interfaces machen willst. Wenn ja, dann musst Du den dhcpcd abschalten.


    Code
    sudo update-rc.d dhcpcd disable


    Ich muss mich gerade noch mal korrigieren. Das wäre besser.


    Code
    sudo update-rc.d -f dhcpcd remove


    Danach sollte man einen Reboot machen, um zu sehen, ob der DHCPCD außer Betrieb bleibt.

    Da kommt:

    Code
    [ ok ] dhcpcd is running.


    Aja. Ich habs geahnt.


    Ich gehe davon aus, dass Du Deine Netzwerk-Konfiguration in der Datei /etc/network/interfaces machen willst. Wenn ja, dann musst Du den dhcpcd abschalten.


    Code
    sudo update-rc.d dhcpcd disable


    Ein eventuelles Problem mit der Stromversorgung ist dann aber noch nicht gelöst. Das solltest Du prüfen.


    Das Problem ist allerdings, dass er mir einfach nicht mehr hochfahren mag.
    Stecke ich das Netzwerkkabel wieder ein, fährt er wie gewohnt hoch.


    Fahr ihn mal mit Bildschirm hoch und sag uns dann, an welcher Stelle er hängen bleibt.


    Was sagt ifconfig?