Posts by PatrickS


    Was ich brauche, ist eine »Verlängerung« meines Netzes in das Wohnzimmer (und auf den Balkon), nicht ein weiteres Netz, auf das man explizit wechseln muss.


    Wenn Du in Deiner Wohnung x WLANs (gleicher Name und Passwort) betreibst, dann wechseln Deine Clients automatisch in das WLAN mit dem besten Empfang.

    Bei allen Anleitungen die ich gefunden habe (bisschen älter) soll man in der smb.conf das # in der Zeile
    # security = user entfernen.


    Dieser Parameter ist inzwischen optional und er ist standardmäßig gesetzt, auch wenn er nicht explizit aufgeführt ist. Selbstverständlich ist es Dir überlassen diese Zeile in die Datei einzufügen.


    Besorge Dir eine aktuelle Anleitung. Es gibt haufenweise davon.


    Ich mag keine Empfehlung geben, weil ich nicht weiß welche Distribution Du verwendest.


    Am 14.4. habe ich versucht meinen neuen Raspi 3 zu starten. Nach Abschluß des Bootvorgangs funktionierte Debian ohne das eingebaute Wlan0. Bei den Versuchen zu konfigurieren mit einem festen Internetanschluß blieb der Prozessor dann stehen. Angeschlossen hatte ich zu der Zeit nur meinen USB-Dongle für die Tasten und Maus.


    Einige USB-Geräte, die Ihre Stromversorgung aus dem USB ziehen, ziehen heftige Stromspitzen, die die üblichen Netzteile, die eigentlich nur Ladegeräte sind, nicht mit einer stabilen Spannung liefern können. Das dabei auftretende Fehlerbild ist recht unterschiedlich. Meistens bleibt der Pi in Betrieb, manchmal nicht.


    Ich habe hier einige WLAN-Adapter rumliegen, die mit dem Pi nicht stabil funktionieren. Hauptsächlich Billigteile, unabhängig vom Hersteller. Ähnlich wird es mit Deinem USB-Dongle sein. Da hilft nur ausprobieren.

    Also, normalerweise meide ich Hilfe bei solchen Problemen, wie der Teufel das Weihwasser.


    Aber nun gut...mache ich mal eine Ausnahmen, weil Dir so gar niemand helfen kann.



    Was kann da (beim Update?) passiert sein ?? Hat jemand ne Idee?


    Was beim Update passiert ist kann Dir vermutlich niemand sagen, weil nur Du Einblick auf Dein System hast. Von daher ist ein definierter Lösungsansatz schwierig.


    Gehen wir mal davon aus, dass das Update keinen Bug mitgebracht hat und jetzt einfach nur irgendwo in der Konfiguration was verbogen ist, auch wenn Du nichts geändert hast.


    Poste doch mal Deine /etc/exports Datei.


    Zweitens wäre interessant, was

    Code
    sudo service nfs-kernel-server status
    sudo rpcinfo -p


    auf dem Server (Paketname beachten) sagt.


    Auf der anderen Seite gibt es ja noch die Clients:


    Code
    showmount -e {IP-Adresse-NFS-Server}


    Damit könntest Du mal anfangen. Dann sieht man weiter. Wenn Du weiter Hilfe möchtest, dann bitte hier die Kommandoausgaben hier posten.


    EDIT:


    Ich habe noch ein wenig nachgedacht. Das Mounting auf Client-Seite wäre auch noch zu betrachten. Insbesondere bei instabilen Netzwerk-Verbindungen stellen sich NFS-Exports zickig an.


    Ich habe folgendes Problem: Wenn ich den Raspberry starte, muss ich den Wlan Stick abstecken, anstecken, warten, abstecken, anstecken und dann funktioniert das Wlan erst. Ich hätte es gerne so, dass das Wlan sofort funktioniert. Das hat auch alles mal eine Zeit lang funktioniert, nur weiss ich nicht mehr genau was ich gemacht habe, dass ich den Stick erst paar mal an und abstecken muss bis er eine Verbindung hat.


    Kürzeres Micro-USB-Kabel verwenden.
    Netzteil tauschen.


    Stichwort: Namensauflösung, DNS-Server, /etc/resolv.conf


    Vermutlich fehlerhafte IP-Konfiguration.


    Für einen Test mit Starmoney brauche ich allerdings windows 10 auf dem Raspberry . Nachdem ich der Installation gefolgt bin und als Ergebnis nur einen Bildschirm mit Farbverlauf erhalten habe, ging es an die Fehlersuche.


    Dabei kam heraus, dass sich windows10 IoT NUR mit einem Rechner installieren lässt, der ebenfalls Windows 10 als OS hat.


    Windows 10 IoT <> Windows 10


    Das heißt, Du wirst Dein Starmoney nicht auf Windows 10 IoT installiert bekommen.

    Ich habe Jessie neu aufgesetzt und über die GUI die IP Adresse eingerichtet.



    Weiß jemand wo diese Datei liegt, da es denke ich noch einen anderen Weg gibt über das neue Jessie, die IP Adresse einzustellen.


    Die GUI schreibt die IP-Konfiguration in die Datei /etc/dhcpcd.conf rein:


    Anzeigen:

    Code
    cat /etc/dhcpcd.conf


    Verdrillte Kabel helfen nur bei gestrahlter Störung. Aber nicht bei leitungsgebundener Störungen.


    Verdrillte Kabel helfen eigentlich nur dann, wenn in das Kabel gleiche Signale mit gegensätzlicher Polarität eingespeist werden. Nur dann würden sich eingestrahlte Störungen gegenseitig aufheben. Nur, das scheint mir hier nicht der Fall zu sein.


    Ich befürchte, dass ein verdrilltes Kabel hier nicht hilft.


    Ich bin mir auch nicht sicher, ob ein geschirmtes Kabel hilft. Das würde voraussetzen, dass ein ordentlicher Potentialausgleich vorgenommen wird.


    abgeschaltet, oder wie auch immer, es geht am Anfang einfach nicht!


    Es ist trotzdem falsch. Natürlich kann man sich von Anfang an verbinden.




    Das ändert nur, dass man sich auch als "root" per SSH verbinden kann. Und ob man das so machen sollte ist eine andere Frage.
    Automatisch zusammengefügt:[hr]

    Nachdem ich meine SD Karte Platt gemacht habe(hatte irgend eine alte version von wheezy drauf), hab ich mir die aktuelle Jessie Version(2016-02-26) drauf gespielt, kann mich aber nicht nicht mehr mit via SSH(Putty Release 0.67) verbinden.


    Ohne qualifizierte Fehlermeldung kann Dir niemand wirklich helfen.


    Leider spuckt mir der Debugmodus ein "nl80211 driver initialization failed" aus.


    Das bedeutet letztlich, dass der Fritz-Stick mit dem Netlink-Treiber nicht klarkommt.


    Also ich nehme für solche Dinge ausschließlich billige WLAN-Adapter mit Ralink-Chipsatz. Das funktioniert sofort. Man muss sich nicht quälen.

    Es gibt zwei Dinge, die mir nicht gefallen:


    1. IPv6 ist aktiv. Das heißt, IPv6-Verbindungen werden eventuell nicht richtig behandelt.


    2. Du hast ein tun0-Interface. Vermutlich hast Du Dir was verbogen.


    ip r wäre noch interessant.


    An Deiner Stelle würde ich es mit einem frischen Image noch mal versuchen.