Posts by PatrickS


    Scheint so als ob ich meinen Pi erreichen könnte der pi auch im Internet ist aber keine Verbindung zwischen beiden Teilen hergestellt werden kann.
    Vorschläge ::s


    Ok muss mich etwas korrigieren der Pc lässt sich nicht vom pi aus anpingen er wird aber trotzdem als verbunden angezeigt.


    Das Routing fehlt.


    Du hast was vergessen einzutragen. Siehe unten im Tutorial.


    an dem Adapter (abgesehen von Monitormodus) ist eigentlich nichts ungewöhnliches, gibt es auch viele davon auf dem Markt.


    Vielleicht magst Du schreiben, was genau Du machen möchtest. Vielleicht lässt sich eine qualifizierte Empfehlung geben.




    Ich habe schon mehrere Listen durchstöbert, bis jetzt aber nichts gefunden.


    Stichwort "wlan adapter dual band"


    Auswahl ohne Ende. Herausfinden, welcher Chipsatz verbaut ist und prüfen, ob der Monitor Mode unterstützt wird. Ralink- oder Atheros-Chipsätze von der Tendenz her. Finger weg von Realtek (RTL).


    Wenn Du sicher gehen willst, dann schaust Du nach, was Alfa Networks hat. Die unterstützen in der Regel den Monitor Mode (nicht alle). Allerdings sind die Dinger sehr klapprig gebaut und brauchen oft eine Mini-USB-Verlängerung, die sehr anfällig ist.


    Jede Zeile, außer mit { und }, muss mit einem ";" beendet werden. Bei einer Zeile fehlt es. :P

    Wenn ich das richtig verstehe, geht es in diesem Thread auch um Raspbian-Jessie und dort kann man u. a. auch lesen:


    Ok, es ist da.


    Code
    systemd-networkd.service - Network Service
     Loaded: loaded (/lib/systemd/system/systemd-networkd.service; disabled)
    Active: inactive (dead)
    Docs: man:systemd-networkd.service(8)


    Es sehe aber keinen Grund es zu aktivieren. Das macht es nur komplizierter.


    BTW: In jessie sollte man auch mit systemd-network, das Netzwerk konfigurieren können.


    Du solltest das nicht empfehlen, weil das auf Raspbian Jessie nicht existiert. Das verwirrt nur.
    Automatisch zusammengefügt:[hr]


    Ich habe in der interfaces-Datei die Einträge auf manuell gesetzt, wie auf http://www.elektronik-kompendium.de gelesen, habe in der Datei dhcpcd.conf alles auskommentiert


    Lass die Datei /etc/dhcpcd.conf wie sie ist und füge unten einfach diese Zeilen an.


    Code
    interface eth0
    static ip_address=192.168.1.2/24
    static routers=192.168.1.1
    static domain_name_servers=192.168.1.1


    Die IP-Adressen wählst Du nach Deinen Adressen in Deinem Netzwerk aus.




    Wie geht es weiter?


    Wo liegt jetzt noch mal das Problem?


    Wenn ich den Pi in der Firma am wlan anmelde, erhalte ich mit iwconfig bei der Bit Rate einen Wert von 150 Mb/s.


    Wenn ich den Pi dann zu Hause an den Archer C7 hänge, bekomme ich nur noch 72,2 Mb/s mit iwconfig angezeigt.


    Räumliche Distanz.


    Exemplarstreuung.


    Unterschiedliche Firmware-Version.


    Unterschiedliche Hardware-Version.


    Fehlkonfiguration.

    Stell mal auf


    Code
    bridge_stp yes


    Ansonsten kann ich Dir noch den Tipp geben, nirgendwo im Netzwerk die Bridge als Gateway einzutragen, sondern den entsprechenden Router. Ich meine, der Netzzugangsrouter sollte das Standard-Gateway sein.

    Code
    Feb 17 18:39:02 pi-bridge kernel: [390226.455736] br0: received packet on eth0 with own address as source address
    Feb 17 18:39:03 pi-bridge kernel: [390227.456871] br0: received packet on eth0 with own address as source address
    Feb 17 18:39:04 pi-bridge kernel: [390228.458595] br0: received packet on eth0 with own address as source address
    Feb 17 18:39:05 pi-bridge kernel: [390229.460444] net_ratelimit: 3 callbacks suppressed
    Feb 17 18:39:05 pi-bridge kernel: [390229.460472] br0: received packet on eth0 with own address as source address


    Kann mir hierbei jemand nen Tipp geben, wie ich das Problem lösen kann??


    Das bedeutet so viel wie, dass die Brücke die eigenen Pakete empfängt. Du hast da irgendwo eine Schleife drin. Kann ein Konfigurationsfehler sein.


    Die Parameter meiner fstab sehen so aus:


    Code
    //192.168.178.32/nas  /media/nas  cifs  user=myUser,password=myPw,_netdev,auto,rw,soft  0  0


    Wenn Du Raspbian Jessie verwendest, dann versuche es mit folgenden zusätzlichen Mount-Optionen:


    Code
    x-systemd.automount,x-systemd.requires=network-online.target


    Die Mount-Option "auto" muss auf "noauto" stehen.


    hat jemand eine Idee


    Mach mal folgendes:


    Trag folgendes in Deine /etc/fstab ein (Server):


    Code
    UUID=3f21afb1-15d1-43f9-9e0f-664afd587a6b    /media/usb    ext4    auto,sync,users,rw    0    0


    Beachte bitte: Die Trennung der Parameter erfolgt typischerweise mit "TAB". Bei funktionieren aber auch 4 Leerzeichen.


    DEINE UUID bekommst Du mit:


    Code
    sudo blkid


    Der Mount-Point sollte existieren.


    Anschließend:


    Code
    sudo mount -a


    Mit „df -h“ und „lsblk“ kannst Du prüfen ob und wo (Mount-Point) der USB-Stick eingehängt wurde.


    Das sollte auch nach einen Reboot funktionieren.


    Wenn das geklappt hat, dann gehen wir einen Schritt weiter.