Posts by Meisengeier

    Hallo werte Forummitglieder, hallo rpi444,


    ich danke euch allen vielmals für eure Unterstützung.

    Nur nochmal kurz: Die Kamera ist direkt mit dem eth0-Anschluss verbunden und der Raspi soll über Wlan erreichbar sein.

    Aber wie ich vorhin schon schrieb, habe ich die "feste" Wlan-IP inzwischen wieder aus der Datei "/etc/systemd/network/mylanif.network" entfernt und es ist wieder "nur" noch die eth0-IP drin. Damit kann ich zwar nun (immer noch) nicht die 3.Stelle nach 169.254. fest einstellen, aber mit der Version von rpi444 funktioniert mein Eingangs-Anliegen auch. Aus meiner Sicht ist damit meine Anfrage beantwortet. Ich möchte mich noch gern bei rpi444 hier im Forum bedanken und wäre diesbezüglich für einen abschließenden Hinweis, wo und in welcher Form man das machen kann, dankbar.


    Meisengeier

    Hallo rpi444,


    kann es sein, dass wir anfangen, aneinander vorbeizureden, den Faden zu verlieren? Siehe dazu Beitrag 18 und 17. Die 192.168.178.11 ist die eth0-IP und die 100 ist die Wlan-IP, welche ich zusätzlich in dieselbe Datei (2 Zeilen) eintragen sollte und auch getan habe.


    Meisengeier

    Hallo rpi444,


    hier die Datei: sudo nano /etc/systemd/network/mylanif.network

    Inhalt:

    [Match]

    Name=eth0

    #Host=

    [Network]

    DHCP=no

    LinkLocalAddressing=no

    Address=192.168.11.13/24

    Broadcast=192.168.11.255

    [Address]

    Address=192.168.178.100/24

    Broadcast=192.168.178.255

    ConfigureWithoutCarrier=true


    Meisengeier

    Hallo rpi444,


    also schnell bist du, dafür möchte ich dir wirklich einmal danken!

    Da bin ich noch nichtmal fertig, deinen letzten Tip abzuarbeiten, da ist schon dein nächster Tip "da".


    Zur SD-Karte: Da hast du recht. Wenn man einen 2. Raspi hat, ist das eine echte Option.


    "Warum schreibst Du "Wlan IP 192.168.178.100"? Das sollte doch die 2. feste/statische IP-Adresse von eth0-Interface des PI sein. Poste mal die Ausgaben von:"

    Vergiss das wieder mit der festen Wlan-IP, nehme ich wieder raus und gut, ist nicht wirklich wichtig.

    Ich wollte eingangs eigentlich auch nur wissen, ob man bei der Direkt-IP 169.254.xxx.xxx die 3.Stelle fest einstellen kann. Bitte sei mir nicht böse, aber für das, was du mir hier vorschlägst, habe ich nicht annähernd die Kenntnisse, kann dir gar nicht folgen.

    Ich "sehe" also beim besten Willen nicht, warum das Wlan nicht mehr funktioniert, wenn der eth0-Anschluss belegt wird. (Vielleicht weil 2 feste IPs in der Datei sind?)


    Hier noch die Ausgaben:

    pi@raspberrypi:~ $ ip a

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

    valid_lft forever preferred_lft forever

    inet6 ::1/128 scope host

    valid_lft forever preferred_lft forever

    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000

    link/ether dc:a6:32:4d:ed:ca brd ff:ff:ff:ff:ff:ff

    inet 192.168.11.13/24 brd 192.168.11.255 scope global eth0

    valid_lft forever preferred_lft forever

    inet 192.168.178.100/24 brd 192.168.178.255 scope global eth0

    valid_lft forever preferred_lft forever

    3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether dc:a6:32:4d:ed:cb brd ff:ff:ff:ff:ff:ff

    inet 192.168.178.100/24 brd 192.168.178.255 scope global dynamic noprefixroute wlan0

    valid_lft 863910sec preferred_lft 755910sec

    inet6 fe80::9bd6:5c85:c9a3:1f45/64 scope link

    valid_lft forever preferred_lft forever


    pi@raspberrypi:~ $ route -n

    Kernel-IP-Routentabelle

    Ziel Router Genmask Flags Metric Ref Use Iface

    0.0.0.0 192.168.178.1 0.0.0.0 UG 303 0 0 wlan0

    192.168.11.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

    192.168.178.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

    192.168.178.0 0.0.0.0 255.255.255.0 U 303 0 0 wlan0

    Hallo rpi444,


    "Die SD-Karte musst Du nicht neu bespielen, denn wenn es nicht behoben werden kann, kannst Du die in der *.network-Datei zusätzlich eingefügten Zeilen, kommentieren."


    Also nach meinen bisherigen Erfahrungen, kann man auf keine Datei zugreifen, wenn der Raspi nicht mehr erreichbar ist...

    Aber davon abgesehen, war ich eben auch nicht untätig und ich habe folgendes festgestellt:

    Habe per eth0-Direktverbindung zwischen Raspi-PC mit der IP 192.168.11.13 wieder eine Verbindung ! Diese Festeinstellung von eth0 klappt also.

    Habe dann gesehen (ip -a), dass die Wlan IP 192.168.178.100 nun auch "da" ist und darüber auch eine Verbindung aufbauen können! Auch gut!

    Aber:

    Verbinde ich nun die Kamera wieder per eth0-Anschluss mit dem Raspi, bricht die Wlan-Verbindung SOFORT ab, ziehe ich die Kamera ab, ist sie wieder "da" und das sogar ohne Neustart des Raspis! Jetzt ist die Frage: "Woran liegt das"?


    Meisengeier

    Hallo rpi444,


    danke, und ja, natürlich musste es heißen: 192.168.178.xx


    Habe die beiden Zeilen eingefügt und nach dem Ausführen von:

    Code
    sudo systemctl restart systemd-networkd


    bekomme ich nun, auch nach Neustart, keine Verbindung mehr zum Raspi. In putty und danach noch in der Fritzbox habe ich eingetragen: 192.168.178.100. Aber auch 105 brachte nichts. Kann ich versuchen, per eth0 =

    Code
    192.168.11.13

    eine Verbindung zu bekommen oder muss ich jetzt die SD-Karte neu bespielen oder kennst du eine andere Möglichkeit zum Verbindungsaufbau?


    Meisengeier

    Hallo rpi444,


    danke für die Codes.

    (Konnte leider heute erst heute weitermachen, da der Raspi nicht bei mir in der Wohnung steht)


    Was ich vollkommen vergessen habe zu erwähnen: Der eth0-Anschluss muss vor dem Anschluss der Kamera noch "normal" per DHCP funktionieren, also Netzwerkkabel zwischen Fritzbox und Raspi, weil im Raspi erst noch der Wlan-Schlüssel eingetragen werden muss.

    Da wir hier gerade bei einer "festen" eth0-IP sind, kann man den Raspi zusätzlich noch auf eine "feste" Wlan-IP im DHCP-Bereich, z.B. 192.178.168.100, einstellen?


    Aber hier erst mal die Ergebnisse der Codes:


    ip a

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

    valid_lft forever preferred_lft forever

    inet6 ::1/128 scope host

    valid_lft forever preferred_lft forever

    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000

    link/ether dc:a6:32:4d:ed:ca brd ff:ff:ff:ff:ff:ff

    inet 192.168.11.13/24 brd 192.168.11.255 scope global eth0

    valid_lft forever preferred_lft forever

    3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether dc:a6:32:4d:ed:cb brd ff:ff:ff:ff:ff:ff

    inet 192.168.178.23/24 brd 192.168.178.255 scope global dynamic noprefixroute wlan0

    valid_lft 863925sec preferred_lft 755925sec

    inet6 fe80::9bd6:5c85:c9a3:1f45/64 scope link

    valid_lft forever preferred_lft forever


    route -n

    Kernel-IP-Routentabelle

    Ziel Router Genmask Flags Metric Ref Use Iface

    0.0.0.0 192.168.178.1 0.0.0.0 UG 0 0 0 wlan0

    192.168.11.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

    192.168.178.0 0.0.0.0 255.255.255.0 U 303 0 0 wlan0


    systemctl is-enabled systemd-networkd

    enabled


    systemctl is-active systemd-networkd

    active


    Ich hoffe, ich habe soweit alles richtig gemacht, aussehen tuts so. Bitte um Entschuldigung, weiß leider nicht mehr, wie/wo die Spoiler-Funktion funktioniert.


    Meisengeier

    Ich danke Euch für eure Antworten,


    Was ich nicht verstehe: Die vom Raspi selbst erzeugte IP 169.254.xxx.xxx, welche ja auch nach einem Neustart noch "da" ist, muss doch irgendwo gespeichert sein. Man kommt an diesen "Speicher" aber nicht ran, richtig?


    rpi444, du schriebst:

    "Du musst dem eth0-Interface eine feste IP-Adresse (die nicht aus dem Subnetz des wlan ist) zuweisen und keine LL-IP-Adresse für das eth0-Interface zulassen. Das geht z. B. mit systemd-networkd."


    Ich verstehe (wieder) nicht wirklich, was du meinst, habe nur die Datei /etc/systemd/networkd.conf gefunden und da steht nur "DHCP" drin. Frage deshalb: Hättest du hier eventeull ein konkretes Beispiel für die "systemd-networkd" ? Ich hatte bereits vor dieser Anfrage Versuche "gefahren", die Eth0 fest einzustellen, z.B. in der dhcpcd.conf o.ä. Haben alle nicht funktioniert bzw. ich bin an den Raspi gar nicht mehr "rangekommen"!


    Meisengeier

    Hallo,


    vielen Dank für eure weiteren Antworten.

    Wie ich vorhin schon schrieb: Die 4.Stelle ist unkritisch und natürlich stelle ich jede Kamera auf eine andere IP ein, sodass keine doppelt vorkommt. Mir geht es nur darum, ob, wo und wie man für ALLE (meine) Raspis die 3.Stelle nach 169.254. gleich einstellen kann, z.B. auf: 169.254.100.xxx, ohne an Änderung der dhcpcd.conf. Das sei vielleicht noch erwähnt: Die Raspberrys selbst arbeiten vollkommen autark, in keinem gemeinsamen Netzwerk.


    Meisengeier

    Hallo rpi444,


    vielen Dank für deine Antwort, welche ich aber ehrlich gesagt, nicht 100%ig verstehe.

    Deshalb möchte ich noch hinzufügen, weil ich denke, dass du die technischen Möglichkeiten mit Sicherheit besser kennst als ich und die Kommunikation so einfacher sein wird, dass am Eth0-Anschluss meines bzw. meiner Raspis (je) eine Netzwerkkamera (direkt) angeschlossen ist, also NICHT über DHCP, wohl aber soll die Wlan-Verbindung weiterhin ganz normal über DHCP "laufen". Das funktioniert ja soweit auch alles, nur muss ich momentan wegen der unterschiedlichen Direkt-Adressen der Raspis z.B. die Kamera 1 auch den Raspi 1 einstellen/betreiben und kann Kamera 1 nicht einfach an Raspi 2 "stecken". Ließen sich nun alle Raspis auf die gleiche Direkt-IP einstellen, könnten die Kameras ebenfalls auf diese 1 Adresse eingestellt werden und ließen sich somit problemlos tauschen.


    Meisengeier

    Hallo werte Forengemeinschaft,


    zuerst wünsche ich allen ein gesundes, erfolgreiches Jahr 2021.


    Ich habe wieder einmal ein Anliegen und möchte euch hiermit um eure Mitheilfe bitten:

    Wenn man einen Raspberry, in meinem Fall einen Pi4B, direkt per Netzwerkkabel mit einem Computer verbindet, lauten ja die ersten beiden Stellen der IP- Adresse (so kenne ich es jedenfalls) in der Regel immer gleich, nämlich: 169.254., aber (leider) schon die 3. Stelle nicht mehr. Diese ist dann z.B. 85 oder 105 oder 223, usw.

    (Nur, um es erwähnt zu haben, die 4. Stelle ist für mich unkritisch).

    Mich würde jetzt interessieren, wie oder wo eigentlich diese 169.254.xxx.xxx-IP erzeugt wird, wo sie im Raspberry abgelegt wird UND, was das Wichtigste ist: Kann man diese IP-Adresse auch nachträglich ändern, fest (für den Eth0-Anschluss) einstellen? Wichtig dabei ist jedoch, dass der Aufbau einer Wlan-Verbindung zwischen dem Raspi und dem Router (z.B. ) weiterhin möglich ist, also normal funktioniert.


    Vielen Dank vorab.


    Meisengeier

    Hallo Bernd666,


    dein Tipp war genau der richtige, vielen Dank!

    -lohldht- funktionierte (zumindest bei mir) schon seit 04/2018 NICHT mehr, dafür kam dann AdafruitDHT. Aus reiner Verzweiflung habe ich mir gedacht, ich habe schon soviel Zeit "verplempert", installiere -lohldht- doch einfach noch mal und siehe da: FUNKTIONIERT jetzt mit meinem Raspi Pi 4 = 1A, kann sogar die alten Scripte wieder verwenden! Unglaublich, aber wahr.

    Damit ist mein Problem im Prinzip "vom Tisch" und ich könnte das Thema eigentlich "als erledigt beenden". Aber ich werde noch ein bißchen warten, denn vielleicht hat ja doch noch jemand eine Lösung für mein Eingangsanliegen, zum Auslesen der Werte bei Verwendung von Circuit-Python.


    Ansonsten bedanke ich mich hiermit bei allen, die mir geholfen haben.


    Meisengeier

    Hallo Dennis,


    danke. Es ist aus meiner Sicht schon ein Krampf mit den ewigen Änderungen, man kommt gar nicht hinterher mit aktualisieren, wie ich ja jetzt wieder "erleben" darf. Eigentlich banale Dinge, wie einen Temp-Sensor auslesen, funktionieren dann nicht mehr. Und so geht das schon seit Jahren. Na ja, ist eben so.

    Ich kann inzwischen das Python-Script aus dem bash-Script aufrufen, kann aber immer noch nicht die Werte daraus extrahieren.


    Meisengeier

    Hallo Dennis89,


    nochmals danke.

    "Das es mit dem Pi4 zusammenhängt kann ich mir nicht vorstellen..."


    Doch, genauso ist es aber leider jetzt bei mir. Auf meinem Pi 4B ist auch Adafruit installiert, ging noch bis vor kurzem einwandfrei, aber NACH dem letzten Update, Upgrade war Schluss!!! Darum ja jetzt die Umstellung auf dieses "Circuit Python" mit den geschilderten Problemen!


    Aber wenn du auch aktuell Adafruit installiert hast, dann wäre, sofern du einen Pi4B (mit Buster) hast meine Bitte: Mach doch mal ein Update/Upgrade und berichte, ob bei dir dann das Adafruit noch "läuft", sprich noch Werte ausgegeben werden. Würde mich echt interessieren.


    Meisengeier

    Hallo Denis89,


    vielen Dank, dass du mir helfen möchtest. Bitte nimm es mir nicht übel, aber jemand, der sich AKTUELL auch mit dem DHT22 o.ä. in Verbindung mit einem Raspi 4B (Buster) beschäftigt bzw. vorher Adafruit benutzt hat, wird mein Problem auch haben oder besser schon gehabt haben und weiß sofort was ich suche.


    Meisengeier

    Hallo Dennis89, blackjack,


    erst einmal danke für eure Antworten.

    Habe "chmod" ausgeführt, keine Änderung!


    Bitte lasst mal die Schleife außen vor. Es geht einzig nur darum, den Temp. Wert (python3) über das "alte" Adafruit-Shell-Script ausgelesen zu bekommen.

    Oder, wie ich schon schrieb, vielleicht hat jemand auch eine ganz andere Lösung zum Auslesen des DHT22 Sensors. Hauptsache wäre nur, es läßt sich per -bash- aufrufen.


    Meisengeier

    Werte Forengemeinschaft,


    noch bis vor kurzem habe ich einen DHT22 mit dem nachstehenden Script ausgelesen bekommen:


    #!/bin/bash

    i=0

    while [ $i -le 1 ]; do

    i=$[$i+1]

    WERTE=$(/home/pi/Adafruit_Python_DHT/examples/AdafruitDHT.py 22 12 | grep Humidity)

    # Temp=20.4* Humidity=37.4%

    [[ ! -z "$WERTE" ]] && break

    sleep 2

    done

    if [ "$WERTE" = "" ]; then

    echo "Keine Werte! Temperaturfühler angeschlossen?"

    exit

    fi

    if [[ ! -z "$WERTE" ]]; then

    Temp=$(echo $WERTE | awk {'print $1'})

    Hum=$(echo $WERTE | awk {'print $2'})

    echo "Temperatur $Temp Celsius"

    echo "Luftfeuche/ $Hum"

    fi


    Doch nach einem Update/Upgrade meines Raspberry Pi4B (Buster) funktioniert es NICHT mehr, scheinbar ist das Adafruit veraltet ,sodass ich durch Suche hier im Forum nun das Circuit Python installiert habe.

    Durch die Eingabe von "python3 dht_simpletest.py" auf der Konsole werden auch die Werte für Temperatur u. Luftfeuchtigkeit ausgegeben:

    Temp: 22.4 *C Humidity: 40.3%


    Allsdann habe ich im obigen Script, in der Zeile "WERTE=$(/home/pi/AdafruitDHT.py....Humidity)" durch die Eingabe "WERTE=$(pyhton3 dht_simple...)" ersetzt.

    Leider funktioniert das NICHT, das Script bleibt nun schon in der "WERTE"-Zeile hängen, sprich, es gibt keine Werte.


    Meine Frage und Bitte ist: "Kann mir hierzu jemand helfen das obige "alte" Script entsprechend anzupassen oder hat vielleicht jemand von euch ein anderes geeignetes (Shell) Script zum Auslesen des DHT22? Ich brauche eigentlich nur die Temperatur in Celsius für meine Anwendung.

    Vielen Dank vorab


    Meisengeier

    Hallo Tell,


    ich habe dein Script gerade eben ausprobiert: PERFEKT !!! Das macht zu 100% genau das, was ich gesucht habe! Vielen, vielen Dank!

    Im Spoiler mal noch meine Auswertung: Wenn der SM-Speicher leer ist = alles OK. Wenn nicht leer = Speicher mit "CMGD" löschen, wobei das per -cat- zu tun, vielleicht auch noch ersetzt werden sollte. (mal sehen, ob ichs nun nach deinem Muster hinkriege?)

    Ich war schon lange nicht mehr hier im Forum. Ich traue mich hier garnicht auf die Symbole zu klicken. Wo ist denn bitte jetzt die "Bedanken- bzw. Punkte- Funktion für dein Super Script? Und wo kann ich das Thema als erledigt kennzeichnen?


    Meisengeier


    :danke_ATDE: