Posts by raspberry314

    Ich habe leider keine weitere Hardware zum Testen. Hatte mir diese Funksteckdosen extra für das Projekt zugelegt.


    pilight-receive ist soweit klar. Aber ich denke, ich kann per Terminal auch alles steuern, ohne die config.json anzupassen...? Bei mir kommen per pilight-receive so viele Werte, da weiß ich gar nicht, was ich eintragen sollte. Das hier entspricht einem Tastendruck... Obwohl es laut Verpackung eine mumbi Steckdose ist, steht hinten etwas von elro drauf. Nun habe ich null Ahnung, wie ich aus all diesen Werten eine config Datei schustern soll, wenn ich per Terminal nicht einmal testen kann, welche system- und unitcodes in Frage kommen. Oder sehe ich hier etwas grundlegend falsch?


    Gleiches Problem. Beim Aufrufen des Befehls tut sich nichts. Meine Ideen wären, dass entweder pilight noch nicht für den Pi2 ausgelegt ist, oder die GPIO anders belegt sind.


    Ich überlege schon, ob ich die Funksteckdosen zurücksende und es mal mit solchen probiere, bei denen man den Code selbst einstellen und so direkt an pilight übergeben kann, anstatt sie erst auslesen zu müssen. Vielleicht ist meine Funkhardware (Steckdosen und Fernbedienung) auch einfach Müll..?

    Quote

    bis ich dann den anderen pilight Daemon stoppte ... und schon funktionierte es wieder


    Ich bin ja ein absoluter Anfänger auf dem Gebiet pi und generell Linux. Habe es dementsprechend nicht von der Pieke aus gelernt, sondern durch trial and error. Da ich mit apache angefangen habe und man den Server auch oft neustarten mussten, bevor Änderungen sichtbar waren, ist das Neustarten von Services immer mein allererster Anlaufpunkt ^^


    Quote

    Sie dazu mal auf der pilight Webseite nach. Dort ist ein Hinweis wie man die Netzwerkdefinition vornehmen soll um diesen Fehler nicht zu bekommen.


    Danke! Habe ich getan, funktioniert allerdings nicht. Ich habe jetzt auf dem original System noch einmal pilight 6 komplett entfernt (sudo apt-get remove 'pilight*', sudo apt-get purge 'pilight*'), danach wurden per dpkg -l 'pilight*' auch absolut keine Pakaete mehr gefunden.


    Jetzt Neuinstallation von pilight-5.0


    serivce pilight start / restart hängt sich auf. Neustart des Pi. Nun bleibt sogar der Pi bei ..... Starting : pilight stehen.


    Es passiert einfach gar nichts, ich komme nicht einmal mehr in Raspbian rein -.- Sehr merkwürdig.
    [hr]
    Ich teste nun einfach mal ein anderes System... Satt raspbian wird auf eine SD mal snappy ubuntu geladen, dann damit gestartet. Geht wahrscheinlich schneller, als dieses Boot-Problem manuell zu fixen ^^

    Das funktioniert soweit. Jetzt ist auch wieder pilight-learn enthalten. Wenn ich das starte, werde ich jedoch auf die nicht vorhandene Settings-Datei hingewiesen
    (null): the settings file /etc/pilight/settings.json does not exist
    Danach hängt der Prozess und lässt sich auch mit Strg C nicht beenden.


    Gleiches beim Ausführen von pilight-send -p elro_800_switch -s 24 -u 11 -t
    pilight-send: the settings file /etc/pilight/settings.json does not exists
    pilight-send: ERROR: cannnot read settings file: (null)


    Die Settings-Datei existiert. Ich habe den Inhalt testweise durch
    {
    }
    ersetzt, auch ohne Erfolg.


    ----------------------------------


    Da ich jetzt erst pilight 6 drauf hatte und mehrmals installiert und deinstalliert wurde, starte ich noch einmal auf einem 'frischen' System.


    Drauf sind nur openssh, xrdp und eben die neusten Updates.


    pilight-5.0 heruntergeladen, entpackt, versucht zu kompilieren. cmake fehlt, also cmake installiert. dialog fehlt, dialog installiert.


    ./setup.sh
    --> sicherheitshalber mal alle Protokolle und Optionen angewählt, Save and Install. Während der Installation sind keine für mich erkennbarer Probleme (Error o.Ä.) aufgetaucht.


    sudo dpkg-query -l 'pilight*'
    dpkg-query: no packages found matching pilight*


    service pilight start
    [....] Starting : pilightpilight-daemon requires root priveliges in order to run
    failed!


    sudo pilight-daemon
    (das Terminal fängt an zu hängen) Lässt sich auch per STRG C nicht stoppen. Keine Fehlermeldung.


    Werde mal neu starten und sehen, ob sich etwas tut. Ganz schön frickelig die Angelegenheit ^^
    [hr]
    service pilight start
    [....] pilight is running.


    pilight-receive
    [ Mar 01 08:53:04:53664] pilight-receive: ERROR: no pilight ssdp connections found


    pilight-learn
    erneutes Aufhängen.


    Ich habe das Terminal dann immer nach ein paar Minuten beendet. Werde jetzt mal warten, wie lange es dauert, bis irgend etwas passiert...
    [hr]
    Nach über 30 Minuten hängt das Terminal immer noch. Ich nehme an, da tut sich nichts mehr.

    Kann man noch irgendwie auf die 5.0 downgraden?


    Ich habe auf die Schnelle gerade keinen Vergleich gefunden, ob der Pi 2 anders belegte GPIO hat als der Pi 1. Wenn andere User mit exakt der gleichen Hardware-Konstellation ein ähnliches Problem haben, schließe ich vorerst doch mal einen Hardwarefehler meines Sender aus.

    Also wenn ich also su
    pilight-send -p elro_800_switch -s 24 -u 11 -t bzw. -f
    eingebe, passiert weiterhin nichts.


    Der Pi läuft nun mit einer SD, auf der nur pilight installiert ist. Weiterhin kein Error, nur halt auch keine andere Aktion. An anderen Programmen oder Konfigurationen kann es also auch nicht liegen...

    Ich habe mir die Hardware noch mal genauer angesehen. Laut Verkäufer habe ich ja die mumbi FS300 gekauft...


    Auf den Funksteckdosen selbst ist die Produktbezeichnung FA500S angegeben, von Elro. Fernbedienung ebenfalls Elro, FA500R.


    Ist es normal, dass ich so einen langen Input über pilight-receive bekomme? Da werden ja zig verschiedene Protokolle gesendet... Ich kann mir nicht erklären, welche Befehle ich jetzt aussenden soll. Es klappt auch mit dem von Towerle genannten Befehl (-s und -u entsprechend abgeändert) nicht.


    Kann man testen, ob einfach mein Sender defekt ist? Mit angelöteter Antenne und der Funksteckdose direkt neben dem Pi kann man ja zumindest ausschließen, dass das Signal gestört wird. Entweder stimmt softwareseitig etwas nicht, oder der Sender ist einfach nicht funktionsfähig. Oder gibt es noch andere Faktoren?


    Ich werde mal parallel eine neue SD zum Testen einrichten und wirklich nur pilight darauf installieren. Vielleicht klappt das ja.

    Da muss tatsächlich etwas bei der Installation falsch gelaufen sein...


    Ich werde noch einmal alles entfernen und neu installieren.



    [hr]
    Jetzt sieht es so aus.


    [hr]
    pilight-reeive gibt folgendes aus (1x kurz aus und 1x kurz an gedrückt)


    [/quote]
    [hr]


    sudo pilight-send -p elro_800_switch -i 2770946 -s 24 -u 11 -t bzw. -f machen nichts. Ich gehe gerade testweise alle Protokolle durch (ab elro, die archtech sind gar nicht gelistet)
    sudo pilight-send -p ehome -i 4 -s 24 -u 11 -f gleiches Ergebnis. Kann man irgendwie noch testen, ob nicht doch einfach der Sender defekt ist? Bzw. gibt es noch andere mögliche Fehlerquellen? Ich bin mir auch nicht ganz sicher, wie ich anhand dieser Angaben die config.jason erstellen soll... Oder brauche ich die nicht, wenn ich die Eingaben von Hand per bash ausführe?

    Vielen Dank für Euren Input!


    Ich habe jetzt mal eine 17cm Antenne (Draht) angelötet. Ich schließe mal neu an und sehe, was passiert. Wie genau ich verdrahtet habe reiche ich gleich noch nach.
    [hr]
    [Blocked Image: http://i.imgur.com/LaHgcIy.jpg]


    GPIO 1 an +
    (jeweils an VCC Sender und VCC Empfänger)


    GPIO 6 an -
    (jeweils GND Sender und GND Empfänger)


    GPIO 11 an ATAD Sender


    GPIO 12 an DATA Empfänger


    Ich denke immer noch, dass das vielleicht an der Software liegt. Warum erhalte ich "bash pilight-learn: command not found", wenn das doch Bestandteil von pilight sein sollte? Es funktioniert auch mit Antenna nicht.

    pilight-learn
    bash: pilight-learn: command not found


    pilight-debug


    Ich habe versucht, die entsprechenden raw-Codes per sudo pilight-send -p -raw -c "raw code" abzuschicken, kein Erfolg.


    Das Logfile unter /var/log/pilight.log scheint nur den Webserver zu überwachen. Seitdem ich den Tab mit dem Webserver geschlossen habe, wird das Log zumindest nicht aktualisiert, obwohl ich andere Befehle per Terminal durchgeführt habe.

    Hallo,


    ich habe auf meinem Raspberry Pi 2 gerade Pilight eingerichtet.
    Ich benutze die Mumbi m-FS300 Funksteckdosen (Affiliate-Link) zusammen mit diesen (Affiliate-Link)433 Empfänger / Transmitter.


    Alles ist folgendermaßen verkabelt
    [Blocked Image: http://i.imgur.com/0u3ojnN.jpg]


    Falls man es nicht genau erkennt: es sind die PINs 1, 6, 11 und 12 an das Steckboard angeschlossen.


    Raspbian und Pilight laufen jeweils in der aktuellen Stable Version.


    Per pilight-receive empfange ich mittlerweile auch ein entsprechendes Eingangssignal.
    Wenn ich dieses nun per sudo pilight-send -p -mumbi -s 23 -u 10 -t senden möchte, passiert gar nichts. Kein Error, aber eben auch kein an die Steckdose gesendetes Signal (bzw. es tut sich nichts). -f geht ebenfalls nicht.


    Die Test-Funksteckdose habe ich nun an verschiedenen Orten (auch direkt neben dem Pi) aufgestellt. An der Verbindung scheint es demnach nicht zu liegen.


    Wie kann ich testen, ob beispielsweise der Sender defekt ist, ob ich evtl. doch falsch verkabelt habe oder ob überhaupt ein Signal gesendet wird?


    Dies ist mein erster Versuch, hardwaretechnisch am Pi etwas zu verändern und mir gehen gerade die Lösungsansätze aus.


    Danke im Voraus für Eure Hilfe :) LG

    Hallo,


    ich benötige schnell einen Raspberry Pi 2. Könnt Ihr einen Shop empfehlen, wo dieser aktuell auf Lager ist? Ich hatte im raspishop bestellt (Lieferbar ab 13.02.) und wurde nun auf den 03.03. vertröstet. Da das Gerät dringend benötigt wird, würde ich notfalls lieber woanders bestellen, wenn möglich.


    Bin um jeden Tipp dankbar.


    LG

    Vielen Dank für die Infos.


    Dann werde ich mich bei meinem Projekt wohl erst einmal darauf beschränken, Funksteckdosen zu kontrollieren.


    Alles andere scheint zu kompliziert für mich als Noob. Cron-Job als Begriff sagt mir was, da hört es dann aber schon auf. Und zumindest für Funksteckdosen gibt es ja genügend vorgefertigte Lösung, bei deren Realisierung ich vielleicht für spätere Projekte etwas dazulernen kann.

    Hallo,


    vorneweg muss ich sagen, dass ich keinerlei Ahnung von Programmierung oder Basteln mit Hardware habe. Allerdings habe ich ein paar Ideen, die ich gerne mit dem Raspberry Pi umsetzen würde. Könnt Ihr mir sagen, ob das für einen blutigen Anfänger überhaupt machbar ist (z.B. durch bereits umgesetzte Projekte, die man nur noch kombiniert oder anderweitig vorhandene Bausteine)?


    1. Funksteckdosen
    Steckdosen über Google Kalender (oder in Verbindung mit Llama auf dem Androiden) schalten.
    Status (an/aus) anzeigen lassen.


    2. Lichtschalter
    Schalter an/aus.
    Status anzeigen lassen.


    3. Haustür öffnen
    Per Smartphone oder NFC. Alternativ soll man trotzdem einen Schlüssel benutzen können.
    Tür soll immer verschlossen sein, außer jemand geht gerade durch die Tür.
    Muss natürlich sicher sein, nicht, dass sich jemand ein meine Wohnung "hacken" kann :D
    Muss so installiert werden können, dass es ohne Schäden an der Tür wieder entfernt werden kann (Mietwohnung).
    Logfile, wer wann kommt und geht.


    4. Waschmaschine / Geschirrspüler
    Kann man ohne großen Aufwand erfassen, wann die Geräte fertig sind und sich jeweils per Push benachrichtigen lassen, wenn z.B. der Spülvorgang durch ist?


    5. Kühlschrank
    Temperatur messen und ggf. regeln (Drehregler vorhanden)


    6. Webinterface
    Alle gesammelten Informationen sollen über ein Webinterface abrufbar sein.
    Schalten der Geräte soll ebenfalls über Webinterface möglich sein (und somit mit allen Geräten, die sich im Netzwerk befinden)


    6.1 Statistiken
    Wann wurden Geräte geschaltet und wie lange waren sie an?
    Wie oft pro Woche läuft der Geschirrspüler, die Waschmaschine etc.?
    Wann hat sich die Kühlschranktemperatur geändert?


    7. Autobackup
    System soll sich vollständig täglich in der Cloud sichern, sodass im Fall eines Crashes immer ein aktuelles Backup vorhanden ist.


    Sind das realistische Anforderungen, die sich ohne Profikenntnisse realisieren lassen?
    Welche Hardware brauche ich?


    Danke & LG