Posts by FrankC

    Guten Morgen,


    du hast total recht. Mir fiel es die nacht wie Schuppen aus den Haaren.


    Vor dem Update habe ich versucht nach dem Beitrag unter https://forum.iobroker.net/topic/4024/pioneer-avr-skript meinen Receiver im IObroker einzubinden. Dazu habe ich:


    Code
    sudo apt-get install git-all
    cd /opt/iobroker/node_modules
    npm install https://github.com/stormboy/node-pioneer-avr.git
    npm install https://github.com/EbSe/node-pioneer-avr

    ausgeführt.


    Leider hat das nicht funktioniert. Das ganze wurde mit Fehlermeldung quittiert:


    npm WARN bl@0.7.0 requires a peer of stream-browserify@* but none is installed. You must install peer dependencies yourself.


    npm ERR! code EPERM

    npm ERR! syscall spawn

    npm ERR! errno EPERM

    npm ERR! Error: spawn EPERM

    npm ERR! at ChildProcess.spawn (internal/child_process.js:366:11)

    npm ERR! at spawn (child_process.js:538:9)

    npm ERR! at execFile (child_process.js:221:15)

    npm ERR! at tryCatcher (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/util.js:16:23)

    npm ERR! at ret (eval at makeNodePromisifiedEval (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promisify.js:184:12), <anonymous>:16:23)

    npm ERR! at promiseRetry (/usr/local/lib/node_modules/npm/node_modules/pacote/lib/util/git.js:192:14)

    npm ERR! at /usr/local/lib/node_modules/npm/node_modules/promise-retry/index.js:29:24

    npm ERR! { Error: spawn EPERM

    npm ERR! at ChildProcess.spawn (internal/child_process.js:366:11)

    npm ERR! at spawn (child_process.js:538:9)

    npm ERR! at execFile (child_process.js:221:15)

    npm ERR! at tryCatcher (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/util.js:16:23)

    npm ERR! at ret (eval at makeNodePromisifiedEval (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promisify.js:184:12), <anonymous>:16:23)

    npm ERR! at promiseRetry (/usr/local/lib/node_modules/npm/node_modules/pacote/lib/util/git.js:192:14)

    npm ERR! at /usr/local/lib/node_modules/npm/node_modules/promise-retry/index.js:29:24

    npm ERR! cause:

    npm ERR! { Error: spawn EPERM

    npm ERR! at ChildProcess.spawn (internal/child_process.js:366:11)

    npm ERR! at spawn (child_process.js:538:9)

    npm ERR! at execFile (child_process.js:221:15)

    npm ERR! at tryCatcher (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/util.js:16:23)

    npm ERR! at ret (eval at makeNodePromisifiedEval (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promisify.js:184:12), <anonymous>:16:23)

    npm ERR! at promiseRetry (/usr/local/lib/node_modules/npm/node_modules/pacote/lib/util/git.js:192:14)

    npm ERR! at /usr/local/lib/node_modules/npm/node_modules/promise-retry/index.js:29:24 errno: 'EPERM', code: 'EPERM', syscall: 'spawn' },

    npm ERR! stack:

    npm ERR! 'Error: spawn EPERM\n at ChildProcess.spawn (internal/child_process.js:366:11)\n at spawn (child_process.js:538:9)\n at execFile (child_process.js:221:15)\n at tryCatcher (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/util.js:16:23)\n at ret (eval at makeNodePromisifiedEval (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promisify.js:184:12), <anonymous>:16:23)\n at promiseRetry (/usr/local/lib/node_modules/npm/node_modules/pacote/lib/util/git.js:192:14)\n at /usr/local/lib/node_modules/npm/node_modules/promise-retry/index.js:29:24',

    npm ERR! errno: 'EPERM',

    npm ERR! code: 'EPERM',

    npm ERR! syscall: 'spawn',

    npm ERR! parent: 'iobroker' }

    npm ERR!

    npm ERR! The operation was rejected by your operating system.

    npm ERR! It is likely you do not have the permissions to access this file as the current user

    npm ERR!

    npm ERR! If you believe this might be a permissions issue, please double-check the

    npm ERR! permissions of the file and its containing directories, or try running

    npm ERR! the command again as root/Administrator.


    npm ERR! A complete log of this run can be found in:

    npm ERR! /home/pi/.npm/_logs/2019-11-02T08_05_32_599Z-debug.log


    Sorry, das hatte ich total verdrängt.... :conf:


    Achso, und aufgrund der


    npm ERR! permissions of the file and its containing directories, or try running

    npm ERR! the command again as root/Administrator


    habe ich batürlich den Befehl nochmal mit sudo ausgeführt.... :wallbash:

    ich habe gerade gesehen das ein Ordner /boot.bak vom 01.11.19 existiert.


    jetzt muss ich den bloß noch irgendwie zurückumbennen. Wenn ich versuche /boot umzubennen kommt die, Meldung dass der Ordner busy ist.


    hast du da eine Idee?

    nein, da kommt genau:


    pi@raspberrypi:~ $ systemctl

    System has not been booted with systemd as init system (PID 1). Can't operate.

    Failed to connect to bus: Host is down


    :(

    pi@raspberrypi:~ $ systemctl status iobroker

    System has not been booted with systemd as init system (PID 1). Can't operate.

    Failed to connect to bus: Host is down

    Ok, dann versuche ich noch Infos zur Software und zu dem problem zu ergänzen:


    PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"

    NAME="Raspbian GNU/Linux"

    VERSION_ID="10"

    VERSION="10 (buster)"

    VERSION_CODENAME=buster

    ID=raspbian

    ID_LIKE=debian

    HOME_URL="http://www.raspbian.org/"

    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"

    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"


    Raspberry Pi reference 2019-07-10


    wie gesagt, lief bis heute Morgen der raspi problemlos. Erst nach dem ich


    Sudo apt-get update

    sudo apt-get upgrade

    sudo apt install rpi-eeprom rpi-eeprom-images


    ausgeführt und einen neustart durchgefüht habe, begannen die Probleme. Der iobroker startet nicht mehr. Und ein manueller Start wirft die og. Fehlermeldung aus.


    Mir fehlt irgendwie jeglicher Ansatz, wonach ich suchen soll :(


    Wenn noch weitere Infos benötigt werden, jederzeit...


    Danke für eure Hilfe

    Hallo zusammen,


    ich habe eine mittelschweres Problem. Habe heute meinen raspi4 geupdatet. Seitdem habe ich ein Problem mit Systemd.


    Auf dem raspi läuft iobroker. Und immer wenn ich den starten will kommt:


    System has not been booted with systemd as init system (PID 1). Can't operate.

    Failed to connect to bus: Host is down


    Was könnte das Problem sein und wie könnte man das beheben?


    Bin für jede Hilfe dankbar.


    Gruß Frank

    Hallo zusammen,


    ich bin jetzt stolzer Besitzer eines Pi2 und versuche mich langsam in die Linux-Welt reinzudenken. Allerdings ist das für einen Windowssianer tastsächlich nicht leicht. Darum entschuldigt, wenn hier schon das eine oder andere Problem gelöst wurde.


    Ziel der ersten Bemühungen ist es einen Sealife-Server (mit Raspbian) mit externer HDD zum Laufen zu bekommen.


    Eigentlich habe ich mehrere Sorgen:


    1. mounten einer externen Festplatte beim Start.
    Dazu habe ich folgendes in der fstab eingestragen:


    /dev/sda1 /home/pi2/sealife-daten-usb/ auto defaults 0 0


    Allerdings ignorierte der raspi beim Starten das mounten.
    Wenn ich sudo mount -a ausführe, funktioniert es.


    Wenn die Frage kommt, warum ich unter home/pi2 mounte und nicht unter /media/hdd/... jeglicher versuch dahinzumounten, endete damit das nur root zugriff auf die Festplatte bekam. Und bei der Installation von Sealife quitierte selbige dass dann mit einer Fehlermeldung wegen mangelender Rechte. Noch so ein Mysterium.


    2. Crontab wird nicht ausgeführt
    Damit der Server beim Start automatisch startet, habe ich mittels Crontab -e folgendes eingetragen:


    @reboot /home/pi2/seafile-server-4.0.6/seafile.sh start
    @reboot /home/pi2/seafile-server-4.0.6/seahub.sh start


    Leider funktioniert das nicht. Der Server wird nicht gestartet :(


    Übrigens weil punkt1 ja nicht funzt, habe ich mal spaßeshalber in der Crontab


    @reboot sudo mount -a


    eingetragen. Und siehe da, dass mounten klappt. Aber der Server startet immer noch nicht :(


    3. Wenn der Server einmal läuft, dann läuft er, zumindest bis zum nächsten Tag. Dann muss ich ihn manuell wieder starten. Kann es sein das der raspi über nacht rebootet? Kann ich das irgendwo nachvollziehen?


    So das wärs erstmal mit meinen Problemchen. Hoffe mit einigermaßen verständlich ausgedrückt zuhaben.


    (Und nicht geschlagen zu werden wegen Doppelpost)


    Gruß Frank