Posts by Itzolino

    Bin jetzt einen Schritt weiter.
    Habe diese Schaltung integriert, um mein Display im Standby zu deaktivieren:


    Quelle: http://lcdproc.sourceforge.net…ml#hd44780-ftdi-backlight


    Jetzt macht er leider aber genau das Gegenteil. Im Stanby geht das Display an und im Betrieb aus. Wie könnte ich das umstellen?

    Hallo!


    Ich würde gerne mein Raspbmc mit XBMC 13.2 zur neuen Raspbmc mit Kodi 14.0 updaten. Leider gelingt mir das nicht.


    Wenn ich dieser Anleitung folge startet der Pi nicht mehr und zeigt nur an "Downloading kernel binaries". Kommt dor aber nicht vorran.


    How to force an update if your PI won't update

    Code
    sudo -s
    cd /scripts/upd_sys
    rm *.sh
    wget http://svn.stmlabs.com/svn/raspbmc/release/update-system/getfile.sh
    wget http://svn.stmlabs.com/svn/raspbmc/release/update-system/cdn_env_prep.sh
    reboot


    Oder muss man grundsätzlich komplett neu installieren? Meine ganzen Einstellungen sind mir eigentlich zu wertvoll..


    danke!


    Schöne Grüße
    itzolino

    Habe das PowerPI Problem noch nicht lösen können und jetzt erst einmal mit dem Display weiter gemacht.
    Läuft soweit super, nur leider geht es nicht in den standby (bzw. Display Beleuchtung aus) wenn raspbmc in den Bildschirmschoner geht, obwohl ich ihm das gesagt habe.


    Nutze raspbmc 13.2 und für das Display lcdproc 2.51.


    In den Einstellungen ist eingestellt, dass das Display in den standby geht, sobald xbmc in den Bildschirmschoner wechselt. Leider macht er einfach nichts

    Hallo, ich würde gerne meine ELRO Steckdosen steuern. Diese sind vom Modell AB600S. Leider haben diese keine DIP Schalter, sondern zwei Drehregler von 1-16 und A-P.
    Wie kann ich den Befehlscode ableiten? Ich finde einfach keine Lösung.... danke!

    Also ich bin gestern angefangen mit meinem Projekt.
    Die Infrarot Verbindung steht schon einmal :) Raspbmc lief ja schon länger.


    Jetzt komme ich allerdings nicht weiter mit meinem 433 Mhz Sender.
    Das Problem ist bisher erst einmal auf Software Ebene. Ich schaffe es nicht PowerPi zu installieren.


    Gehe nach der Anleitung des Entwicklers vor: http://raspberrypiguide.de/how…spberry-pi-haussteuerung/


    Schritt 1 (Webserver) und Schritt 2 (Wiring Pi) habe ich erfolgreich durchgeführt.


    Jetzt komme ich an dieser Stelle nicht weiter. Ich denke es liegt daran, dass die Anleitung für Raspbian ist und nicht für Raspbmc.


    So soll man eigentlich PowerPi instlalieren:

    Code
    pi@raspberrypi ~ $ wget http://raspberrypiguide.de/stuff/powerpi-0.1.tar.gz
    pi@raspberrypi ~ $ tar xfz powerpi-0.1.tar.gz
    pi@raspberrypi ~ $ cd powerpi-0.1
    pi@raspberrypi ~/powerpi-0.1 $ sudo make clean
    pi@raspberrypi ~/powerpi-0.1 $ sudo make
    pi@raspberrypi ~/powerpi-0.1 $ sudo make install
    pi@raspberrypi ~/powerpi-0.1 $ sudo /etc/init.d/powerpi start


    Bei mir scheitert es allerdings am Punkt install:
    Meine ssh Verbindung meldet:

    Code
    pi@raspbmc:~/powerpi-0.1$ sudo make
    chmod -R 755 *
    g++ ./src/powerpi.cpp ./src/structs.cpp ./src/xmlreader.cpp ./src/tools.cpp ./src/picontrol.cpp -lwiringPi -lpthread -o ./bin/powerpi
    make: g++: Command not found
    make: *** [bin/powerpi] Error 127


    Wenn ich diesen Fehler ignoriere und versuche weiter zu machen kommt folgende Meldung:

    Code
    pi@raspbmc:~/powerpi-0.1$ sudo make install
    cp ./src/settings /etc/default/powerpi
    cp ./bin/powerpi /bin/powerpi
    cp: cannot stat `./bin/powerpi': No such file or directory
    make: *** [install] Error 1


    Warum scheint ihr diese Befehle nicht zu kennen? Welche Pakete könnten Raspbmc fehlen?


    Danke für jede Hilfe!


    EDIT: Das Problem konnte ich selbst lösen ;) weiter gehts...

    jetzt hat er es gerade zum erten mal geschafft!!!


    Ich habe allerdings vorher den Mountpoint verändert, um auszuschließen, das irgendwelche Dienste die Platte wachhalten. Jetzt habe ich den ursprünglichen Mountpoint wieder eingestellt. Daumen drücken! :angel:


    Edit: Frag mich nicht waurm, aber es scheint geklappt zu haben! Habe den wert jetzt wieder auf 180 gestellt ;) Wird besser sein für die Platte!


    Ich danke dir vielmals!!!!:bravo2::bravo2::bravo2::bravo2::thumbs1::thumbs1::):)

    okay, gerne! Danke für die Hilfe



    meine fstab:


    Code
    proc            /proc           proc    defaults          0       0
    /dev/mmcblk0p1  /boot           vfat    defaults          0       2
    /dev/mmcblk0p2  /               ext4    defaults,noatime  0       1
    # a swapfile is not a swap partition, so no using swapon|off from here on, use $
    
    
    UUID=075dd1ae-a440-4dab-82b2-1bfe01ee3c7e /media/Filme/ auto defaults 0

    Hallo zusammen,


    ich habe eine 4TB externe 3,5 Zoll (eigene Stromversorgung) Festplatte von Intenso. Sie ist ext4 formatiert und funktioniert soweit zuverlässig. Auf ihr sind nur Filme. Angeschlossen an meinen Raspberry Pi mit Wheezy und als Samba Server freigegeben.


    Leider fährt sie nicht automatisch in den Stanbdy. Die hdparm Befehle:


    Code
    sudo hdparm -y /dev/sda


    und auch

    Code
    sudo hdparm -Y /dev/sda


    funktionieren sofort und die Platte geht in den Standby. Leider funktioniert der Befehel nur manuell.


    Code
    sudo hdparm -s12 /dev/sda


    sollte die festplatte nach einer Minute in den Standby bringen. Leider passiert nichts.


    Auch die Datei /etc/hdparm.conf habe ich schon folgendermaßen geändert:

    Code
    /dev/disk/by-uuid/075dd1ae-a440-4dab-82b2-1bfe01ee3c7e {
        spindown_time = 12
    }


    die UUID stimmt.


    hdparm scheint zu laufen, da es mit einer anderen USB Festplatte funktioniert.
    Auch der manuelle Befehl

    Code
    sudo hdparm -y /dev/sda

    funktioniert ja.


    Habe sonst keiner software den Auftrag gegeben auf die Platte zuzugreifen. Zumindest nicht bewusst... hd-idle hat ebenfalls keine Hilfe gebracht


    Wäre sehr froh über Hilfe. :)


    Liebste Grüße!

    So, ich habe (ernsthaft!) bis jetzt am PC gesessen und bin ein Stück weiter gekommen. Habe das automatic downsizer Script durchgeführt und meine Karte passt jetzt wieder auf die sd. Leider habe ich jetzt noch eine Fehlermeldung beim booten und einen bootloop.


    Hab als Foto mal "Screenshots" gemacht. Irgendwie scheint was mit der Partition noch nicht zu stimmen... Kann mich aber jetzt auch nicht mehr konzentrieren und muss dringend schlafen. :D Hoffentlich ist das jetzt nur noch ein Klacks...


    Fotos:
    http://1drv.ms/1EkLcC2

    ich schaffs einfach nicht. Egal ob mit PiParted und allen Anleitungen.
    Irgendwo bricht immer was ab. Ich werde wahnsinnig. Warum kann nicht einfach mal was einfach laufen? Man muss doch irgendwie ne img Datei bearbeiten können =(=(=(

    Sorry, hab deshalb windows als virtuelle Maschine in windows installiert, weil ich dachte, dass ich von dort aus dann eine virtuelle Festplatte als sd Karte nutzen kann.


    Danke für eure Hilfe soweit. Bitte habt etwas Geduld [WINKING FACE]


    Installiere gerade stattdessen eine Linux Distribution in der virtuellen Maschine

    hmm.. also ich hab mir jetzt die Sachen durchgelesen. Aber letztlich brauche ich immer wieder eine SD Karte mit dem Image drauf, um dieses dann zu verkleinern.


    Habe mir jetzt mal Windows als virtuelle Maschine installiert um da vielleicht eine 17 GB virtuelle SD Karte zu erstellen, darauf dann mein backup wiederherstellen und dieses dann per Partitionsassistenen verkleinern.


    Bisher funktioniert das noch nicht, da ich noch nicht geschafft habe eine SD Karte zu emulieren

    Hallo zusammen! :)


    Ich habe ein Problem mit meinem Raspberry Pi inklusive Raspbian.
    Meine SD Karte ist leider defekt (16GB). Gott sei dank habe ich regelmäßig Backups mit WInDisk32Imager gemacht. Diese defekte Karte habe ich nun eingeschickt und das Geld erstattet bekommen. Davon habe ich mir eine andere 16GB Karte gekauft.


    Leider scheinen die Sektoren unterschiedlich zu sein, sodass ich das Image nicht auf die neue Karte kopieren kann. Gibt es eine Möglichkeit die .img-Datei nachträglich zu verkleinern? Die Lösungsvorschläge, dass man mit gparted die Partitionierung verkleinert kommt bei mir ja leider nicht mehr in Frage, da ich die alte Karte nicht mehr habe.


    Schöne Grüße und herzlichen Dank für die Hilfe! :thumbs1: