Posts by MoonKid

    Mit diesem Gehäuse Alu-Gehäuse für knapp 15,-€ habe ich gute Erfahrungen gemacht. Das Gehäuse sitzt wie angegossen, 2x Sets Thermalpads und zwei Lüfter sind dabei.
    WLAN funktioniert dabei recht gut, ca. 9-13 MB/sek

    Ich kann diese Erfahrung bestätigen.


    Ich habe mir jetzt das von dir genannte Gehäuse ohne Lüfter gekauft. Die Temperatur ist im Vergleich zum vorherigen Gehäuse 20°C niedriger (von +50 auf +30); da läuft nur eine XRDP Session mit XFCE. Erstaunlich.


    Auch die WLAN Antenne ist weniger gedämpft, als mit dem vorherigen Gehäuse. Die Dämpfung ist noch da, aber ich kann an dem ein oder anderen problematischen Ort, doch wieder eine Verbindung aufbauen. Habe mir trotzdem eine externe WLAN-Antenne besorgt, mit der es natürlich um ein Vielfaches besser läuft.


    Zum neuen Gehäuse und die Pads: Auch bei mir waren zwei Sets Thermalpads (je 3 Stück) dabei. Ich war unsicher, ob ich beide Sets gleichzeitig nutzen sollte, oder nicht. Anleitung gibt es ja nicht. Ich habe nur eines genutzt, habe augenscheinlich scheinbar Kontakt mit dem Gehäuse und vermute, dass das zweite Set nur als Ersatz für einen erneuten Umbau, dient.

    Vorab hatte ich mich auf YouTube über das Gehäuse informiert und bin etwas reingefallen. Es gibt scheinbar mehrere Revisionen davon. In einem Video ist zu sehen, dass auf der unteren Gehäuseplatte auch eine Erhebung, auf der Position der CPU-Rückseite, für ein Thermalpad ist. Aber ein Pad wurde nicht mitgeliefert. Also hatte ich vorsorglich gleich noch zusätzliche Pads (10x10cm) besorgt.

    Pustekuchen! Meine Revision hat keine solche Erhebung auf der Rückseite.


    Braucht noch jemand ein frisches Thermalpad 10x10m (2,5mm Dicke)? ;)

    Abgesehen davon ist Debian11 für Raspi anscheinend noch in einer Testphase.

    Hi Bernd, nur nebenbei: Debian 11 ist offiziell für Pi verfügbar: Raspberry Pi Debian images (raspi.debian.net)

    Du meinst vermutlich, das Raspberry Pi OS (ehm. Raspian?) noch nicht auf den Debian 11 Unterbau umgestiegen ist.


    Meine Frage mit der Temperaturschwelle war etwas wabbelig gestellt, sorry.

    OK, die Schwelle liegt laut offizieller Pi Foundation Docu bei 85°C. Es gibt keine Garantie dass das so bleibt und daher möchte ich in meinen Skripten (die auch in 10 Jahren noch funktionieren sollen) die Schwelle des gerade laufenden Pi's abfrage können. Das war mein Hintergedanke. Hartkodierte Zahlen sind auf die Dauer keine gute Idee, wenn man Code wartbar halten möchte.

    Danke für eure Hinweise.


    /sys/class/thermal/thermal_zone0/temp liefert nur den aktuellen Wert, aber nicht die eingestellte Schwelle.


    vcgencmd existiert nicht unter Debian 11 - ist vermutlich raspian spezifisch?


    Aber ich denke das reicht so erstmal. Ich werde wohl bei Gelegenheit auf ein Gehäuse mit Board-Kontakt wechseln (evtl. FLIRC).

    Aber eigentlich hab ich ja ein Alu-Gehäuse - nur ohne Kontakt. Gibt es da keine Bastelei, mit der man einen Kontakt herstelle könnte?

    Ich betreibe einen Pi4 mit Debian 11 und XFCE headless und greife per SSH und XRDP drauf zu.

    Auf dem Board ist kein Lüfter und kein Kühlkörper. Das Board steckt in einem löcherigen Alugehäuse ohne wärmeableitenden Kontakt zum Board.

    Die Temperatur steht im "Leerlauf" bei knapp 60°C und geht bei "Last" zwischen 70°C und 80°C. Das Teil läuft nicht 24/7 aber immer einen ganzen Arbeitstag. Im Sommer ist die Umgebungstemperatur katastrophal, deswegen möchte ich vorsorgen.


    Ich weiß nicht, ob ein Lüfter evtl. etwas übertrieben ist für mein use-case. Aber wenn, würde ich mich für so einen Argon Lüfter mit Kühlkörper und PWD Steuerung interessieren. Der geht dann nur an, wenn es heiß wird und löst somit mein Geräuschproblem, da der Pi über den Tag eigentlich relativ unauffällig für seine Umgebung sein soll. 8):evil: Hat jemand damit Erfahrung?


    Nur Kühlkörper machen angeblich nicht so viel Sinn, weil ihre Wärmespeicher-Kapazität auch begrenzt ist und a.G. der geringen Größe keine echte Konvektion entsteht. Verstehe aber zu wenig von der Physik dahinter, um das zu durchdringen. Meinungen? Mir würde dieses 4er-Set vorschweben.


    In Kombination mit den Kühlkörpern macht es evtl. Sinn, einen Kontakt zwischen meinem Alu-Gehäuse und dem Kühlkörpern herzustellen? Nur weiß ich nicht wie. Ich bin kein Bastler und wüsste nicht wie ich das anstellen sollte. Auch konnte ich kein passendes Produkt finden.


    Angeblich sollen Kühlkörper aus Kupfer leitfähiger sein. Nur in Shops finde ich keine. Alles ein Märchen? Wo würde ich welche herbekommen?


    Alternativ könnte ich auch das Gehäuse gegen eines mit Kühlkörperkontakt tauschen.

    Ich lese mich gerade in das Temperatur-Thema zum Pi4 ein.


    Habe ich das richtig verstanden, dass der Pi4 seine CPU (und evtl. auch andere Komponenten) drosselt, wenn er zu warm wird?

    Die Regel lautet scheinbar: Kühlung vor Leistung.


    Daraus würde folgen, dass ich schon der Performance wegen, mich um eine Kühlung kümmern sollte?


    EDIT: Lässt sich der Temperatur-Grenzwert, bei dem eine "bewusste" Performancereduzierung (Heruntertakten?) geschieht, in einem laufenden System auslesen?

    Das ist der wpa_supplicant. In der /etc/wpa_supplicant/wpa_supplicant.conf werden die Netzwerkeinstellungen eingetragen.

    Ich weiß. Das habe ich nach einer Anleitung (https://www.elektronik-kompend…/raspberry-pi/2205191.htm) aber auch getan. Kein Effekt. Nach einem reboot ist mein eduroam-Eintrag in der wpa_supplicant.conf sogar verschwunden. Er scheint immer entfernt zu werden bzw. wird meine Datei-Version mit einer früheren überschrieben.


    EDIT:

    Also ich habe jetzt raspi-config genutzt um eine neue WLAN-Verbindung "eduroam" ohne key hinzuzufügen. Der Eintrag erscheint dann auch in der wpa_supplicant.conf Datei und bleibt auch nach einem reboot erhalten. Dann hab ich den Eintrag entsprechend erweitert.


    Then I did a test

    Code
    sudo killall wpa_supplicant 
    sudo wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

    The result is irritating. There are success messages. But the connection does not keep stable. It looks like that it always reconnects


    Magst du auch noch eine Frage formulieren? Für eduroam muss ein Zertifikat installiert werden. Zumindest ist das an meiner Uni so.

    Das Zertifikat ist nicht das Problem. Ich bekomme ja nicht mal die Gelegenheit eine Verbindung zu versuchen, weil der Eintrag "eduroam" im Kontextmenu des LXDE-Netzwerk-Icons im Systray disabled ist.


    Welches Paket steckt hinter dem Netzwerk-Icon?


    Ist es evtl. LXDE spezifisch?


    Gibt es evtl. irgendwelche Zusatzpakete, die ich installieren muss, damit mir das Netzwerk-Icon erlaubt, mich auch zu solchen Netzwerken zu verbinden?

    Ich habe Raspberry Pi OS auf einem Pi 4.


    Mein Problem ist, dass ich im desktop environment (LXDE?) im Systray einige der WLAN's in der Umgebung ausgegraut (disabled) sind.

    Es handelt sich um das "eduroam" WLAN, dass an den meisten europäischen Uni's eigentlich bekannt sein sollte. Ich kenne nicht die genauen technischen Begriffe, aber da wird wohl ein RADIUS Server dahinter sein. Evlt. ist EAP auch noch eine relevante Abkürzung.


    Ich identifiziere mich in dem WLAN mit einem Nutzernamen und einem Passwort.


    Mein WLAN-Lands ist konfiguriert. Andere 5G Nezte in der Umgebung sind sicht- und anwählbar.


    Diese Konfig-Hilfe hat bei mir scheinbar keinen Effekt. Der dort beschriebene Test geht nicht, weil wpa_supplicant schon eine Instanz laufen hat.

    Raspberry Pi: Mit dem eduroam-WLAN verbinden (elektronik-kompendium.de)

    Ich erfahre gerade, dass der Pi4 auch als WLAN HotSpot fungieren könnte.


    Aber kann er auch beides gleichzeitig? Kann er ein WLAN als HotSpot zur Verfügung stellen und sich gleichzeitig in ein weiteres WLAN als Client einloggen?

    Ja, ich denke gerade darüber nach, ob ich mich mit dem Hostnamen.local zufrieden gebe. Das geht.

    Aber wer weiß, ob das überall auch funktioniert. Der Pi wird wandern und an vielen Geräten hängen. Vielleicht ist das einfacher, als jetzt noch an einem DHCP rumzubasteln.


    Bisher hab ich LL per nachinstallierten network-manager eingeschaltet.

    Kann man das auch mit respbianOS Boardmitteln aktivieren?


    Das Netzwerksymol im LXDE/LXQT (?) panel ist nur sehr rudimentär und bot mir das nicht an.


    Allerdings scheint der netwerk-manager zu interferieren mit anderen Komponenten. Deswegen wäre es mir lieber, dass ich nur mit den Boardmitteln arbeite und hier keine Extrawürste anfange, was spätere Fehlersuche auch problematischer macht.

    Dickes Danke für die geduldige Erklärung.

    Ich denke dann fällt LL als Option raus, weil ich auf dem Windows Rechner nichts ändern kann.


    Ich schaue mir deinen DHCP Link an.

    Ich hatte versucht das im initialen Posting zu erklären, aber war wohl nicht erfolgreich. ;)


    Am Win-Rechner kann ich nichts konfigurieren. Ich kann dort bspw. keine feste IP einstellen. Er muss sich die IP selbst nehmen (per LL) oder geben lassen (per DHCP).


    Ich vermute, dass wenn ich auf dem Pi LL deaktiviere, dort eine feste IP vergebe; dass dann der Win Rechner gar nicht mehr weiß, was er machen soll, wenn ich da das LAN Kabel reinstecke.


    So wie ich dich verstehe, kann ich es nicht so machen, dass sich einer von 2 LL-Partner eine feste IP nutzt und der zweite (Win Rechner) sich eine aus dem selben subnet automatisch nimmt?


    In dem Fall, komme ich wohl nicht um einen DHCP Server auf dem Pi herum. Oder wie schätzt du das ein?