Posts by BarnyFeuerstein

    Wenn's welche mit Solid State Relais sind, ist es kontaktlos, also voll Elektronisch die können aber auch nur 2A 250VAC schalten, (ca.480Watt) Schalten aber bei High Pegel.
    Wehrs eine Nummer Großer Bracht Mein Solid State Relais kann 25A bis 380VAC Ist bei dem Pegel Variabel und kann mit 3 bis 32 VDC Angesteuert werden zieht aber bei 3,3V ca. 7mA am GPIO. Sie müssen bei höheren Schaltströmen einen entsprechenden Kühlkörper haben.

    Ist eigentlich alles machbar erfordert bei einer automatischen Steuerung gute Programmierkenntnisse.
    Mein Tipp fang langsam an mit Pilight. das zeigt die Temperaturen, die Relais zustände und was einem noch so alles einfällt
    über ein Webinterface.
    Man kann die Relais selbst über das Handy Schalten.
    Die Protocols von Pilight.
    Pilight Handbuch


    Bevor ich einen neuen Thread aufmache frage ich einfach mal hier nach.


    Was ist an dieser Schaltung nicht richtig? Ich habe es so mit dem Pi verbunden und die Relais schalten auch.


    Beitrag 97
    1. Der zusätzliche Schaltkreis ist eigentlich überflüssig.
    2. Die GPIOs werden über 1. Widerstand, 1. Optokoppler -Diode, und einer LED, in Reihe von der 5V VCC gespeist, wobei die Spannung am In-Anschluss auf ca. 2,9V fällt was ausreicht für die GPIOs, sie schalten bei Low den Stromkreis.
    3. Bei JD-VCC zu VCC reicht ein Jumper die Leitung kann entfallen.
    4. Wenn zusätzlich mit einer Externen Stromversorgung gearbeitet wird (5V) die an JD-VCC, und GND an die 6er leiste Anschließen.
    5. Dabei die 5V vom Raspbi an die VCC der 6er leiste GND Weglassen, so hat man ein Galvanische Trennung zwischen den 2 Spannungsquellen und den GPIOs.

    Zitat: //EDIT: Was scheinbar immer wieder gerne vergessen wird: es geht nicht darum, dass man recht hat sondern darum einem Fragesteller eine Antwort/Anleitung zu geben, mit der er auf der sicheren Seite ist. Es ist schliesslich nicht meine/Deine Hardware, die im Zweifelsfall abraucht, sondern die eines anderen Teilnehmers.
    Da bin ich mal genau deiner Meinung gut geschrieben. Nach dem Grundsatz versuche ich immer zu helfen und das so genau wie möglich.

    @ dreamshader Gemessen heißt das es selbst gemessen ist am lebenden Objekt.
    Strom und Spannungsangaben mache ich nur wen ich sie überprüft habe, und nicht aus Dubiösen Internetseiten.
    Zitat: http://www.forum-raspberrypi.d…mit-raspberrypi-verbinden Beitrag 9.


    Edit: Zusammenfassung
    Da hier im Forum viel falsches aus den Netz verbreitend wird hab ich mal am GPIO Selbst nachgemessen. (Nicht alles was im Netz steht muss auch richtig sein!)
    Nach dem Start LED Glimmt leicht GPIO 0.04mA (GPIO Strom)
    GPIO Low =Angeschaltet 2 mA (GPIO Strom)
    GPIO High =Aus 0 mA (GPIO Strom)
    An 5V Gemessen 0 Relais An 0 mA
    An 5V Gemessen 1 Relais An 72 mA
    An 5V Gemessen 2 Relais An 137 mA


    Nochmal der Schaltplan >Hier< (Der hat Leiter auch einen Fehler mit der Anschluss Belegung zu meinem 2-Kanal Relais,
    VCC und GND der 4 Pins sind vertauscht.) Wer noch mehr Findet immer her damit, ich editiere nur noch diesen Beitrag wenn notwendig.
    Meine Interpretation des Schaltplans:
    Zitat: Vom Beitrag 45
    So habe den Schaltplan des Relais-Boards gefunden die Optokoppler sind nur dazu da um bei gezogenen Jumper
    die äußere 5V (VCC/2) Spannungsversorgung Galvanisch mit der des Raspbis zu trennen.
    Also ist der Optokoppler nur bei 2 Spannungsquellen notwendig.
    Bei 2 Spannungsquellen nur die Masse der Externen anschließen dabei den Jumper entfernen.
    Und nur die in-Anschlüsse und 5V vom Raspbi nehmen ohne GND der Optokoppler macht es Möglich.
    Die 5V vom Raspbi geht in reihe zu einem Widerstand, der Optokoppler Diode, und der LED.
    Was die Spannung am Relais-in-Anschluss auf ca. 2,9V Reduziert. (unbelastet)
    Automatisch zusammengefügt:
    [hr]
    @ flyppo sorry wen du den Schaltplan noch nicht sehen Konntest! Habe es angenommen Beitrag 47 zu 48.


    Soviel zum Thema "Relais Boards made in China" und zuverlässiges Informationsmaterial dazu ;)
    Fazit: Trau keinem Relais-Board, das Du nicht selbst vermessen hast ... (und damit wären wir wieder bei Beitrag #21 )


    cu,
    -ds-


    Nun ist aber gut die 2mA habe ich selber gemessen, und wer Augen im Kopf hat sieht auf den Relais Boards
    die Bauelemente und teilweise die Leiterbannen.
    Automatisch zusammengefügt:[hr]
    Schaltplan ist immer noch da wo er war in der 47.

    So habe den Schaltplan des Relais-Boards gefunden die Optokoppler sind nur dazu da um bei gezogenen Jumper
    die äußere 5V (VCC/2) Spannungsversorgung Galvanisch mit der des Raspbis zu trennen.
    Also ist der Optokoppler nur bei 2 Spannungsquellen notwendig.
    Bei 2 Spannungsquellen nur die Masse der Externen anschließen dabei den Jumper entfernen.
    Und nur die in-Anschlüsse und 5V vom Raspbi nehmen ohne GND der Optokoppler macht es Möglich.
    Die 5V vom Raspbi geht in reihe zu einem Widerstand, der Optokoppler Diode, und der LED.
    Was die Spannung am Relais-in-Anschluss auf Ca. 2,9V Reduziert.

    Der Optokoppler ist (klaube ich) nur um bei relaisspulen möglichen Sehr hohen Spannungsspitzen von den raspbie Eingängen fern zu Halten.
    Ein Schaltplan der Karte währe sehr hilfreich um es besser zu versehen.

    Zitat: 5V 4-Kanal-Relaiskarte-Schnittstelle und jeden Kanal braucht 15-20mA


    Nicht alles was bei den Produktbeschreibungen von Amazon seht muss auch stimmen!


    Die Relais Ziehen pro Kanal ca. 70mA an der 5V Versorgungsspannung, habe ich nachgemessen.
    An den GPIO nur 2 mA
    [font="Calibri"]Am Dateneingang des Relais ist eine Spannung von 2,91 V[/font]
    [font="Calibri"]die wen der GPIO [/font][font="Calibri"]auf Low geht den Kontakt Schaltet.[/font]
    Das heißt selbst die 2mA kommen nicht vom GPIO, sie gehen zu ihm, nach GND.
    Somit ist ein 4 Kanal Relais ohne Zusatz Verwendbar. (ca. 280mA an 5V)

    Bazingoo
    So wie in deinen ersten Beitrag hab ich es auch angeschlossen. Es ist mit Optokoppler und Transistor-Schaltung schon ausgestattet. Es wirt bei low also bei 0V am GPIO geschaltet. Am GPIO ist nur ein geringer Strom, da die Transistoren den Strom über die 5V durch das Relais zur GND nehmen.
    Das mit der zweiten Stromversorgung würd ich nur machen wen das Relais weit Entfernt ist und am Aufstellungsort schon 5V vorhanden ist. Von 3,3v Betriebsspannung bei 5V Relaisspulen kann ich nur abraten die kontakte vertragen 10A 250VAC und brachen schon den richtigen anpressdruck.


    Edit: Da hier im Forum viel falsch verbreitend wird hab ich mal am GPIO nachgemessen. (Nicht alles was im Netz steht muss auch richtig sein!)
    Nach dem Start LED Glimmt leicht GPIO 0.04mA
    GPIO Low =Angeschaltet 2 mA
    GPIO High =Aus 0 mA
    An 5V Gemessen 0 Relais An 0 mA
    An 5V Gemessen 1 Relais An 72 mA
    An 5V Gemessen 2 Relais An 137 mA