Posts by schousda

    Hallo,


    ich möchte eine Storchencam bauen und das Bild ins Netz streamen und auf einer Webseite einbinden.

    Zur Verteilung hätte ich mir vorgestellt, einen Mistserverauf einem vServer im Netz zu installieren.


    Mit einer Raspi-Cam geht das leider nicht, da das Storchen-Nest gut 135m weg ist.

    Deshalb möchte ich einen Camcorder mit ordentlich Zoom (30x?) einsetzen und das Bild via Raspberry ins Netz streamen.

    Leider bin ich auf diesem Gebiet nicht sehr informiert.

    Welchen (relativ günstigen- grobes Budget bis 100 €) Camcorder würdet ihr mir dafür empfehlen?

    Er sollte über den Pi ansteuerbar sein und das Bild per USB direkt übertragen können.

    Es darf gerne ein älteres Model sein, sollte aber schon HD-Auflösung bieten.


    Zusatzfrage:

    Wie viel Bandbreite wird so ein Stream benötigen?


    Danke.

    Hallo,


    ich habe hier einen Pi Zero und auch einen Pi Zero W und mit beiden habe ich das Problem, dass USB-Geräte nicht erkannt werden.

    Was ich schon versucht habe:

    • passiver USB-Hub
    • aktiver USB-Hub (integrierter Hub meines Dell Monitors)
    • OTG-Kabel
    • verschiedene Netzteile bis 2A
    • per Config-Eintrag die Übertragungsgeschwindigkeit reduziert

    Könnt ihr mir hier Hinweise zur Lösung geben?

    Gibt es Empfehlungen für OTG-Kabel oder USB-Hubs mit Micro-USB Stecker?


    Danke.

    Danke, der Hinweis mit der zusätlichen Liste hat mir geholfen und ich habe jetzt eine funkitonierende Lösung.


    Hallo,


    ich suche mit Tweepy Tweets mit einem bestimmten Suchbegriff und lasse mir dann das Ergebnis anzeigen.

    Das klappt soweit bereits.

    Jetzt möchte ich die Tweets aber gerne nach Zeitpunkt der Veröffentlichung auf-/absteigend sortieren. Der Wert müsste in der Variable "created_at" stehen.

    Die Sortierung habe ich leider bisher trotz intensiver Suche nicht hinbekommen.

    Könnt ihr mir dabei bitte helfen?


    Hier mal mein Code:


    Danke.

    Dann werde ich mir für die Spannungsübertragung mal was überlegen. Evtl. lege ich einfach doch noch ein zusätzliches Kabel (ca. 4m) mit einem größeren Querschnitt.


    Das Sensorkabel werde ich dann mal durch ein Cat 5e Kabel ersetzen und immer ein Adernpaar bündeln.
    Das wäre dann geschirmt und der Querschnitt wäre auch größer.


    Wegen Blitzeinschlag mache ich mir wenig Gedanken. Es kann zwar immer mal was passieren, aber die letzten Jahrzehnte gab es hier keine Probleme.
    Der Sensor sitzt unter einem tiefergelegenem Dachvorsprung.
    Der Antennenmast selbst ist geerdet und er Raspberry sitzt isoliert in einem Kunststoffgehäuse.


    1. Warum nutzt du für Power nur 2 der dünnen Netzwerkadern wenn du doch 4 über hast?
    (2x2 würden den Widerstand schon mal halbieren)


    Ich verwende dazu einen fertigen Adapter, ähnlich diesem hier:
    http://www.ebay.de/itm/Etherne…60fa4c:g:~nUAAOSw8-tWUCed
    Jetzt habe ich extra nochmal nachgemessen. Auch mein Adapter nutzt für die Spannungsübertragung jeweils 2 Adern.


    2. warum nutzt du für einen Sensor der wenig Strom braucht ein Telefonkabel?
    (das mehr an Kupfer würde der Stromlieferung zum PI zu gute kommen, der1w Sensor darf seine Stromdiät am Netzwerkkabel ausüben)


    Ich konnte mehrfach lesen, dass ein Telefonkabel selbst über längere Strecken völlig ausreichend ist.
    Welches Kabel wäre denn besser geeignet?



    Welcher 1w Sensor? einer der nur 1mA benötigt wenn er aktiv ist oder braucht der etliche 10mA?


    Es handelt sich um eine fertige Platine mit eine DHT22 Sensor samt Beschaltung. Es werden also nur +. - und Data benötigt.

    Hallo,


    folgende Situation:
    Ich möchte meinen RPi außen am Antennenmast befestigen. Dazu führe ich Strom und Netzwerk über ein Netzwerkkabel nach außen. Über einen Adapter werden dabei 4 Adern für das Netzwerk verwendet und auf 2 weiteren Adern erhält der RPi die Spannung. Zusätzlich soll über ein knapp 10 m langes Telefonkabel ein 1-Wire-Sensor angeschlossen werden.


    Jetzt ist es so, dass alles wunderbar funktioniert hat, solange ich im Büro getestet habe.
    Nach der Montage auf dem Dach bricht mir das Netzwerk ständig weg (vermutlich, sobald das System mehr ausgelastet ist) und auch der Sensor liefert keine Daten mehr.
    Kann es sein, dass durch die parallel verlegten Satellitenkabel und das Kabel der WLAN-Antenne, das ebenfalls nach außen führt, die Signalübertragung in beiden Fällen gestört wird?
    Das Sensorkabel bei den Tests war nur 20 cm lang aber soweit ich lesen konnte, sollten die 10m eigentlich kein Problem sein.


    Danke.

    Das Script wird mit sudo gestartet.
    Die ganzen Textausgaben brauche ich eigentlich gar nicht, habe sie aber eingebaut, um auf der Konsole sehen zu können, in welchem Schritt ich gerade bin und was da passiert.
    Aber das mit dem auskommentieren werde ich mal versuchen. Guter Hinweis.


    Edit:
    Ich bekomme für beide Meßwerte jeweils ein "None".


    Edit 2:
    Ich habe eben noch mal ein Upgrade & Update laufen lassen. Jetzt bekomme ich auch in meinem Script wieder Meßwerte.
    Verstehen tue ich es aber nicht.


    Edit 3:
    OK, das hat nur bis zum Reboot gehalten. =(
    Automatisch zusammengefügt:[hr]
    Jetzt habe ich auch eine Fehlermeldung erhalten:


    Code
    1. Traceback (most recent call last):
    2.  File "cam_v3.py3", line 435, in <module>
    3.    humidity, temperature = Adafruit_DHT.read_retry(sensor, pin)
    4.  File "/usr/local/lib/python3.4/dist-packages/Adafruit_DHT-1.1.1-py3.4-linux-armv6l.egg/Adafruit_DHT/common.py", line 90, in read_retry
    5.    humidity, temperature = read(sensor, pin, platform)
    6.  File "/usr/local/lib/python3.4/dist-packages/Adafruit_DHT-1.1.1-py3.4-linux-armv6l.egg/Adafruit_DHT/common.py", line 76, in read
    7.    platform = get_platform()
    8.  File "/usr/local/lib/python3.4/dist-packages/Adafruit_DHT-1.1.1-py3.4-linux-armv6l.egg/Adafruit_DHT/common.py", line 59, in get_platform
    9.    raise RuntimeError('Unknown platform.')
    10. RuntimeError: Unknown platform.


    Automatisch zusammengefügt:[hr]
    Hier habe ich einen Hinweis zur Meldung gefunden:
    https://github.com/adafruit/Adafruit_Python_DHT/issues/61


    Sieht so aus, als ob nach einer Aktualisierung von Adafruit_DHT das Script jetzt wieder läuft.

    Sorry, musste noch die ganzen Zugangsdaten usw. entfernen, die ich fest im Script mit einprogrammiert habe.


    Schlagt mich bitte nicht wegen des Codes. Das ist mein erstes Projekt, das ich mir mehr oder weniger aus vielen kleinen Beispielscripts zusammengeflickt habe.
    Automatisch zusammengefügt:[hr]


    Hallo schousda,


    [quote='schousda','http://test.forum-raspberrypi.de/forum/index.php?thread/&postID=281246#post281246']
    Hast Du genau wie gemacht?




    Über die Konsolenbefehle:


    sudo apt-get update
    sudo apt-get dist-upgrade

    Files

    • cam.txt

      (20.71 kB, downloaded 66 times, last: )


    Allerdings habe ich eine andere Frage: hast Du den 1W Bus aktiviert?


    Mit dem Beispielscript läuft es wie gesagt ja.


    Was mich noch am meisten stutzig macht: Bis vor ca. 6 Monaten hat mein Script funktioniert. Danach hatte ich das Projekt eingemottet und jetzt wieder reaktiviert. Und jetzt plötzlich läuft es nicht mehr sauber.
    Kann da ein Update schuld sein? Ich habe nämlich als erste Aktion nach der Pause erstmal ein Update / Upgrade laufen lassen.

    Hallo zusammen,


    folgendes Problem:


    Ich habe einen DHT22 Sensor angeschlossen und ihn in einem Script angesprochen.
    Mit folgendem Testscript werden mir Werte angezeigt:

    Code
    1. import Adafruit_DHT
    2. sensor = 22
    3. pin = 4 # sensor pin GPIO
    4. humidity, temperature = Adafruit_DHT.read_retry(sensor, pin)
    5. print (temperature)
    6. print (humidity)


    In meinem eigentlichen Programm habe ich das Script leicht angepasst ebenfalls eingefügt. Import und Variablen habe ich wie im obigen Beispiel ebenfalls gesetzt. Allerdings wird hier der Sensor nicht gefunden, bzw. kann nicht ausgelesen werden. Das Programm läuft immer in den except Teil.



    Das restliche Programm läuft ohne jegliche Fehlermeldung durch.
    Gibt es Möglichkeiten, herauszufinden, warum dies passiert?
    Danke.


    Schau mal nach der Extension "folder gallery" oder so ähnlich. Die nimmt sich Fotos aus einem vordefinierten Ordner und bildet sie dann auf der Webseite ab. Bin grad in Tobago, ich schau mal wie die genau heißt wenn ich morgen wieder in Berlin bin.


    Das Plugin heißt genau so. Ich habe es installiert und es funktioniert soweit auch alles. Jetzt muss ich nur noch für die Funktion erstellen, mit der alte Dateien regelmäßig gelöscht werden. Aber auch da wird sich bestimmt ein Weg finden.
    Danke.

    Hallo,
    im Prinzip möchte ich ein Projekt umsetzen, das es in weiten Teilen schon x-fach gibt.
    Mit dem Raspberry soll ein Bild gemacht werden und dann ins Internet geladen werden.
    Dies erledige ich aktuell per FTP.
    Jetzt kommt der Teil, zu dem ich aktuell keine Lösung habe.
    Gerne würde ich das Bild in eine Gallerie einer Wordpress-Seite hochladen. Dabei soll das Bild automatisch einer bestimmten Gallerie (es soll mehrere geben) zugeordnet werden und es sollen z. B. nur die letzten 50 Bilder abrufbar sein. Dabei soll natürlich auch gleich jeweils ein Thumbnail usw. erzeugt werden.
    Ich habe bereits von XMLRPC gelesen, allerdings da nur den einfachen Upload eines Bildes in die Bibliothek gefunden. Eine Zuordnung zu einer Galerie scheint über diesen Weg nicht möglich zu sein.


    Welches Wordpress-Plugin wäre dazu geeignet und wie erledige ich den Upload mit Python?


    Danke.

    Ups, da habe ich wohl was verwechselt.
    Verkabelt hatte ich aber richtig, da der Sensor an Pi auf kurze Distanz funktioniert hat. Erst also ich dann mal testweise eine längere Leitung dazwischengeklemmt habe, konnte ich die Werte nicht mehr auslesen.
    Es geht also um 1-wire über die genannte Strecke.

    Hallo,


    ich möchte einen DHT22 Sensor am Raspberry Pi betreiben. Allerdings benötige ich rund 20 m Kabellänge.
    Gibt es da Verstärker für den I2C Bus?
    Wo bekomme ich da günstig ein Komplettmodul?
    Danke.

    Hallo,


    ich hatte heute folgende Idee:
    Man könnte mit dem Raspberry regelmäßig automatisch den Kontostand abrufen und dann verschiedene Alarme daraus erzeugen, z. B. wenn der Kontostand unter 0 € fällt.
    Gibt es eine Banking-Software, die auf dem Pi läuft, und die man dann auch mit Python abfragen könnte?
    Würdet ihr diese Abfrage aus Sicherheitsgründen lieber gar nicht machen?
    Danke.

    Das mit dem RTC finde ich eigentlich am "schönsten", da es ebenfalls sehr klein ist. Ich habe mir jetzt mal zum testen ein ähnliches Modul bestellt. Wie genau ich das anschließen und ansprechen muss, werde ich hoffentlich noch herausfinden.