Posts by Kurti

    Moin,
    nein Du nervst nicht.
    Ich bin selbst Programmierer für Industrie-Maschinen.
    Daher weiß ich, wie sch.....ade es ist, wenn man einen Fehler nicht nachvollziehen kann.
    Die meisten Fehler sind sowieso zwischen Bildschirm und Rückenlehne.


    Also zum besseren Nachvollziehen:
    Ich habe mir ein rasbian-Image herunter geladen und installiert.
    Als Bildschirm nutze ich den LS-8T von Pollin.
    Diesen habe ich nach Pollin-Anleitung installiert und er funktioniert.
    Danach habe ich newtron nach Deiner Anleitung installiert.
    mpd habe ich nachinstalliert, das hatte ich übersehen.
    Seither läuft newtron einwandfrei, wenn die GUI gestartet ist, auch die Bedienung über den Touchscreen ist gegeben.
    Lediglich die Bildschirmauflösung wird nicht automatisch eingestellt.
    Zur Zeit verwende ich die letzte von Dir veröffentlichte Version.


    Wenn ich newtron über die Konsole starte, ohne das die GUI gestartet ist,
    wird der Bildschirm kurz schwarz, dann erscheint die Fehlermeldung.
    Konsoleneingaben:
    cd newtron-v2
    sudo python newtron-radio.py


    Statusmeldungen Auszug:
    FBDev/Surface: Allocated 640x480 16 bit LTU8 buffer (index 0) at offset 0 and pitch 2048
    .
    .
    Display area size: 640 x 480
    SDL DirectFB_SetVideoMode: 640x480@8, flags: 0x10010000
    .
    .
    .


    von fbcon habe ich nichts gefunden.
    Wenn Du genauer schreibst, was wichtig ist, ergänze ich die ausgegebenen Meldungen gerne.


    Gruss
    Kurti

    Moin,
    Zitat: Sorry für die späte Antwort, ich komme momentan zu nix...


    Danke, dass Du Dir überhaupt die Zeit nimmst zu antworten.


    Ich habe die Änderung durchgeführt.
    Es ergibt sich keine Änderung, newtron bleibt beim Start in der GUI gleich gross (klein).
    Wenn ich in die Konsole boote und newtron versuche zu starte, erscheint wieder die Fehlermeldung ( siehe oben )


    Gruss
    Kurti

    Hallo,
    LCDE-Desktop ist richtig.
    Wenn ich den RasPi so umstelle, das er in die Konsole bootet
    und nach dem Anmelden newtron starte:
    cd newtron-v2
    sudo python-radio.py
    wird versucht newtron in einer Auflösung von 640 x 480 zu starten.
    das scheitert jedoch an
    Zeile 990: screen.blit(splash_buf,(0,0))
    pygame.error: Blit combination not supported


    wenn ich dann mit startx die GUI starte, und newtron starte
    wird newtron ausgeführt ( 320 x 240 )


    Gruss
    Kurti

    Moin,
    ich bin schneller als erwartet dazu gekommen:


    Auflösung des Displays: 1024 x 768 Pixel
    eingestellt in boot/config.txt: 1024 x 768
    alle overscan auskommentiert
    Anzeige auf dem Display beim Einschalten: 1056 x 794, 70 Hz !!
    Anzeige durch newtron nach Programmstart: 320 x 240


    Interessant finde ich die Anzeige auf dem Display beim Einschalten.


    Gruss
    Kurti

    Hallo,
    ich habe rasbian so konfiguriert, dass immer die GUI gestartet wird.
    Ausserdem bediene ich den RasPi über die angeschlossene Peripherie.
    ( Tastatur mit Touchpad, Maus, Touchscreen )
    Mit putty habe ich noch nicht gearbeitet, ist aber geplant.


    Da ich die Auflösung von Hand eingestellt habe, werden diese Werte auch angezeigt.
    Deine neue Version werde ich mal im Original testen.
    Die Anzeige werde ich dann posten.


    Gruss
    Kurti

    Hallo,
    es muss ( soll ) Dir nichts leid tun.
    Das Display ist über HDMI angeschlossen.


    Als Neuling muss ich auf
    'Was ist an der Konsole zu lesen, wenn die Auflösung nicht erkannt wird?'
    leider sagen: ich weiß nicht, was Du meinst.


    Wenn ich mich etwas weiter eingearbeitet habe, werde ich das mit den Playlisten selbst umsetzen.


    Gruss
    Kurti

    Hallo Veloci,
    herzlichen Dank für das Programm und vorallem für die leicht nachvollziehbare Anleitung.
    Selbst ich als absoluter Neuling habe das newtron funktionsfähig bekommen.
    Als Display verwende ich den 8 Zoll Touchscreen LS-8T von Pollin.
    Die Auflösung wird allerdings nicht automatisch erkannt.
    Ich habe es daher von Hand eingestellt.


    Damit die Playlisten immer kopiert werden habe ich Dein Programm noch 'vergewaltigt'.
    ( Abfrage Playlistordner leer auf ungleich geändert )
    Ein Button 'Playlisten kopieren' im Menü 'Playlisten anzeigen' wäre toll.
    Etwas nach /home/User/... zu kopieren ist halt einfacher als nach ... äh ... wo war das Playlistverzeichnis ?


    Gruss und Dank
    Kurti

    Moin Moin,
    auf der Startseite gibt es ganz unten rechts die Möglichkeit
    'Alle Foren als gelesen markieren'.


    Ich fände es sinvoll, wenn es diese Möglichkeit auch auf der Seite 'Neue Beiträge' gäbe.
    Dann könnte der Aufrufer dieser Seite, wenn er unten angelangt ist, die Markierung durchführen.
    Beim nächsten Aufruf wären nur aktualisierte Threads zu sehen.


    Gruss
    Kurti

    Moin,
    hier ein funktionierender Link zum Video:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Gruss
    Kurti

    Moin,
    ich kenn die DS1307 nur vom Arduino.
    Auch bei mir laufen die sehr ungenau. Der Fehler wird um so größer, je öfter man die Uhrzeit abfragt.


    Die DS3231 laufen wesentlich genauer.
    Das liegt ( zum Teil ) daran, dass sie temperaturkompensiert sind.
    Beim Arduino sind sie 1 zu 1 austauschbar mit den DS1307.


    Preislich sind kaum noch Unterschiede, daher besser DS3231 verwenden.


    Gruss
    Kurti

    Tach,
    wie wäre es mit den Suchbegriffen
    'front audio connector'
    in Google
    dazu noch so schöne Worte wie 'Slotblech' oder 'Kabel' oder 'Cinch' oder 'Adapter'


    Wenn Du dann noch auf 'Bilder' klickst solltest Du sehen, ob etwas brauchbares zu finden ist.


    Gruss
    Kurti

    Hallo,
    ich würde trotzdem mal das Handbuch lesen.
    Ich denke, Du hast nicht zwei Soundkarten / Soundchips auf Deinem Board.


    Also müsten die Anschlüsse des Frontaudio auch hinten verfügbar sein.
    Wenn Dein Motherboard mehrkanal-Audio unterstützt, hast Du diverse farbige Buchsen hinten.
    Am besten .... testen.


    Gruss
    Kurti

    Moin,
    schaue mal auf der Motherboard-Blende nach, da, wo die anderen Anschlüsse auch alle sind.
    Dort sollten auch Audio-Anschlüsse sein.
    Es kann sein, dass diese abgeschaltet werden, wenn an der Front etwas angeschlossen ist.


    Am einfachsten wäre, das Handbuch zum Motherboard zu lesen.


    Gruss
    Kurti

    Hallo,
    ich habe schon einige CNC-Umbauten dieses Kreuztisches gesehen.
    Es gibt / gab sogar fertige Umbausätze.
    Mit den Suchbegriffen
    'proxxon mf70 cnc conversion kit'
    bzw.
    'proxxon mf70 cnc anbausatz'
    kannst Du Dir bei Google Anregungen holen.


    Gruss
    Kurti

    Moin,
    kauf Dir zwei digitale Messschieber für je ca. 10 Euro.
    Diese baust Du dann an den Kreuztisch.
    Vorteile:
    - kein Raspberry nötig, das Geld hast Du gespart
    - kein Monitor/Display nötig, die Messschieber haben Anzeigen
    - direkte Messung des zurückgelegten Weges.


    Es gibt auch spezielle Anbaumessschieber.
    Du bist nicht der Erste, der so etwas macht, Google ist Dein Freund.


    Gruss
    Kurti