Posts by hth

    Danke für deine bisherige Unterstützung.
    Bei meinen Versuchen bekomme ich nun keine VPN Verbindung (Notebook und IPhone) mehr zustande.
    Ich werde meinen RPI mit einem Image (Stand vor VPN Server Installation) neu aufsetzen und nochmal von vorne beginnen.


    Hast du eine Empfehlung für meine installierte Rasbian Version: PRETTY_NAME="Raspbian GNU/Linux 7 (wheezy)"
    NAME="Raspbian GNU/Linux"
    VERSION_ID="7"
    VERSION="7 (wheezy)
    Würdest du mich dann bei Fragen(die sicherlich auftreten) unterstützen.
    Ich bin totaler Anfänger was Linux-System betrifft, möchte das aber gerne lernen.


    Man kann das Script auch mit einem normalen Browser runterladen. Das füge ich noch oben ein.


    Warum Du aber mit wget Probleme hast würde mich ja schon interessieren :s :s :s


    mich auch.
    Ende der Woche besucht mich ein Freund, der sich mit dem RPI bestens auskennt.
    Der kann sich das System mal genau anschauen, vielleicht gibt es dann Aufklärung.

    Vielen Dank für Deine Unterstützung.
    Automatisch zusammengefügt:[hr]
    Ich habe es mit dem Zusatz "no-check-certificate" noch mal versucht,
    es hat wie von Dir vorhergesagt dann auch funktioniert.
    Beim absetzen des Befehl bash raspiNetInfo.sh -e kam folgender Hinweis:
    RNI020I: 'sudo apt-get update; sudo apt-get install dnsutils' wird die noch notwendigen Netzwerktools installieren sofern eine funktionierende
    Netzwerkverbindung per Kabel existiert
    dnsutils habe ich dann noch installiert, dann erhielt ich auch ein Ergebnis mit "bash raspiNetInfo.sh -e"
    Nochmals vielen Dank für die Unterstüzung!

    Der Befehl: sudo iptables --list-rules
    ergibt folgendes Ergebnis:


    -P INPUT ACCEPT
    -P FORWARD ACCEPT
    -P OUTPUT ACCEPT


    Der Befehl: sudo iptables --list-rules -t nat
    ergibt folgendes Ergebnis:


    -P PREROUTING ACCEPT
    -P INPUT ACCEPT
    -P OUTPUT ACCEPT
    -P POSTROUTING ACCEPT


    WLAN Verbindung via IPhone Connect:
    Drahtlos-LAN-Adapter WiFi:


    Verbindungsspezifisches DNS-Suffix:
    Beschreibung. . . . . . . . . . . : Intel(R) Dual Band Wireless-AC 7260
    Physische Adresse . . . . . . . . : A0-A8-CD-12-38-60
    DHCP aktiviert. . . . . . . . . . : Ja
    Autokonfiguration aktiviert . . . : Ja
    IPv4-Adresse . . . . . . . . . . : 172.20.10.2(Bevorzugt)
    Subnetzmaske . . . . . . . . . . : 255.255.255.240
    Lease erhalten. . . . . . . . . . : Samstag, 13. August 2016 23:55:31
    Lease läuft ab. . . . . . . . . . : Sonntag, 14. August 2016 23:41:11
    Standardgateway . . . . . . . . . : 172.20.10.1
    DHCP-Server . . . . . . . . . . . : 172.20.10.1
    DNS-Server . . . . . . . . . . . : 172.20.10.1
    NetBIOS über TCP/IP . . . . . . . : Aktiviert

    Mich würde mal interessieren welches OS Du benutzt. Was sagt den die Ausgabe von

    Code
    uname -a

    ?



    Linux raspberrypi 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux


    Habe ich fast vergessen, Danke für die Erklärungen :thumbs1:
    Automatisch zusammengefügt:[hr]



    D.h. also folgende Befehle eingeben:

    Code
    sudo apt-get update
    sudo apt-get install ca-certificates
    sudo update-ca-certificates


    nach absetzen des Befehl sudo apt-get install ca-certificates
    erschien folgende Meldung:
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    ca-certificates ist schon die neueste Version.
    Das folgende Paket wurde automatisch installiert und wird nicht mehr benötigt:
    libopts25
    Verwenden Sie »apt-get autoremove«, um es zu entfernen.


    Das Paket libopts25 habe ich erfolgreich entfernt.


    nach absetzen des Befehl sudo update-ca-certificates
    erschien diese Meldung:


    Updating certificates in /etc/ssl/certs... 0 added, 0 removed; done.


    Running hooks in /etc/ca-certificates/update.d....done.


    Leider ist mir nicht klar ob die certifikate nun aktuell sind.


    Nun habe ich den Befehl wget -O raspiNetInfo.sh http://www.linux-tips-and-tricks.de/raspiNetInfo.sh
    nochmal ausgeführt und erhalte dies Meldung:
    --2015-06-05 15:21:33-- http://www.linux-tips-and-tricks.de/raspiNetInfo.sh
    Auflösen des Hostnamen »http://www.linux-tips-and-tricks.de (http://www.linux-tips-and-tricks.de)«... 78.46.156.195
    Verbindungsaufbau zu http://www.linux-tips-and-tricks.de (http://www.linux-tips-and-tricks.de)|78.46.156.195|:80... verbunden.
    HTTP-Anforderung gesendet, warte auf Antwort... 301 Moved Permanently
    Platz: https://www.linux-tips-and-tricks.de/raspiNetInfo.sh[folge]
    --2015-06-05 15:21:33-- https://www.linux-tips-and-tricks.de/raspiNetInfo.sh
    Verbindungsaufbau zu http://www.linux-tips-and-tricks.de (http://www.linux-tips-and-tricks.de)|78.46.156.195|:443... verbunden.
    FEHLER: Dem Zertifikat von »http://www.linux-tips-and-tricks.de« wird nicht vertraut.
    Das ausgestellte Zertifikat ist noch nicht aktiviert.


    War ich nun zu voreilig?


    1. man nutzt kein sudo für sowas
    2. installiere/update mal ca-certificates


    Ich bin leider blutiger Anfänger was RPI und Linux betrifft, bin aber gewillt das zu lernen.
    zu 1. was benutzt man dann anstelle von sudo?
    zu 2. dank der ausführlichen Befehle von framp werde ich das versuchen.

    Danke für Eure Unterstützung!


    Hier der Inhalt meiner openvpn.conf:
    dev tun


    proto udp


    port 1194


    ca /etc/openvpn/easy-rsa/keys/ca.crt


    cert /etc/openvpn/easy-rsa/keys/server.crt


    key /etc/openvpn/easy-rsa/keys/server.key


    dh /etc/openvpn/easy-rsa/keys/dh1024.pem


    user nobody


    group nogroup


    server 10.8.0.0 255.255.255.0


    persist-key
    persist-tun


    status /var/log/openvpn-status.log


    verb 3


    client-to-client


    push "route 192.168.10.0 255.255.255.0"


    push "redirect-gateway def1 bypass-dhcp"


    #set the dns servers


    push "dhcp-option DNS 8.8.8.8"


    push "dhcp-option DNS 8.8.4.4"


    log-append /var/log/openvpn


    comp-lzo


    duplicate-cn


    keepalive 10 120


    Ich hatte berichtet, das ich von meinem IPhone via OpenVPN Connect auf mein NAS im Home-LAN zugreifen kann, dies funktioniert leider nicht mehr.
    Die App OpenVPN Connect stellt zwar die Verbindung zum RPI VPN-Server her, leider kann ich aber nicht mehr auf die Devices in meinem Home-LAN zugreifen.
    Da habe ich wahrscheinlich bei meinem rum testen was verbogen.

    folgende Meldung erhalte ich, wenn ich den Befehl wget -O raspiNetInfo.sh http://www.linux-tips-and-tricks.de/raspiNetInfo.sh
    in der Konsole auf meinem RPI starte:



    pi@raspberrypi ~ $ sudo wget -O raspiNetInfo.sh http://www.linux-tips-and-tricks.de/raspiNetInfo.sh


    --2015-06-04 18:55:30-- http://www.linux-tips-and-tricks.de/raspiNetInfo.sh


    Auflösen des Hostnamen »http://www.linux-tips-and-tricks.de (www.linux-tips-and-tricks.de)«... 78.46.156.195


    Verbindungsaufbau zu www.linux-tips-and-tricks.de (www.linux-tips-and-tricks.de)|78.46.156.195|:80... verbunden.


    HTTP-Anforderung gesendet, warte auf Antwort... 301 Moved Permanently


    Platz: https://www.linux-tips-and-tricks.de/raspiNetInfo.sh[folge]


    --2015-06-04 18:55:30-- https://www.linux-tips-and-tricks.de/raspiNetInfo.sh


    Verbindungsaufbau zu www.linux-tips-and-tricks.de (www.linux-tips-and-tricks.de)|78.46.156.195|:443... verbunden.


    FEHLER: Dem Zertifikat von »http://www.linux-tips-and-tricks.de« wird nicht vertraut.


    [font="Source Sans Pro"]Das ausgestellte Zertifikat ist noch nicht aktiviert.[/font]


    [font="Times New Roman"]Was mache ich falsch ?[/font]
    [font="Source Sans Pro"]
    [/font]

    Ich habe hier im Forum viel gelesen, aber kein Lösungsansatz gefunden.


    benötige Unterstützung bei der Konfiguration VPN Zugriff via Raspberry auf mein HOME LAN


    Leider funktioniert der Zugriff von aussen auf mein HOME LAN an meinem Notebook nicht.
    Folgendes habe ich durchgeführt, das meiste wohl erfolgreich.


    [font="Calibri"]Lokales LAN 192.168.10.0 255.255.255.0[/font]


    [font="Calibri"]NAS 192.168.10.2[/font]


    [font="Calibri"]Gateway (Fritzbox 7490) 192.168.10.1[/font]


    [font="Calibri"]Notebook (Win10) 192.168.10.200[/font]


    [font="Calibri"]Raspberry PI2 192.168.10.217[/font]
    [font="Open Sans"]OpenVPN Server auf PI installiert.[/font]
    [font="Open Sans"]Anleitung:[/font] [font="Open Sans"]https://jankarres.de/2013/05/r…-vpn-server-installieren/[/font]


    [font="Open Sans"]Notebook: OpenVPN GUI installiert und Client konfiguriert.[/font]


    [font="Open Sans"]Fritzbox 7490: [/font]
    [font="Open Sans"]Portfreigabe UDP Port 1194 auf 192.168.10.217[/font]
    [font="Open Sans"]Statische Ipv4 Route [/font]
    [font="Open Sans"]Netzwerk 10.8.0.0 Subnetmaske 255.255.255.0 Gateway 192.168.10.1[/font]
    [font="Open Sans"] [/font]
    [font="Open Sans"]Notebook:[/font]
    [font="Open Sans"]Vom lokalen LAN getrennt[/font]
    [font="Open Sans"]über Iphone Hotspot verbunden. Erfolgreich[/font]
    [font="Open Sans"]OpenVPN zum Raspberry VPN-Server hergestellt Erfolgreich[/font]
    [font="Open Sans"]RDP Verbindung zum Raspberry hergestellt Erfolgreich[/font]
    [font="Open Sans"]Zugriff auf Raspberry via Putty erfolgreich[/font]
    [font="Open Sans"]Ping auf Raspberry 10.8.0.6 erfolgreich[/font]
    [font="Open Sans"]Problem:[/font]
    [font="Open Sans"]Zugriff auf NAS-Freigaben (beiVPN-Verbindung) nicht möglich[/font]
    [font="Open Sans"]Ping ins lokale LAN nicht möglich.[/font]
    [font="Open Sans"] [/font]
    [font="Open Sans"] [/font]
    [font="Open Sans"]Raspberry;[/font]
    [font="Open Sans"]NAS-Freigaben gemountet erfolgreich[/font]


    [font="Open Sans"]Iphone 6:[/font]
    [font="Open Sans"]OpenVPN unter iOS installiert[/font]
    [font="Open Sans"]Verbindung zum lokalen über VPN erfolgreich[/font]
    [font="Open Sans"]Zugriff auf NAS-Freigaben möglich.[/font]


    [font="Open Sans"]Über Unterstützung würde ich mich freuen.[/font]