Posts by mattesflower

    ja, denn es wird noch immer der "alte" Treiber benutzt:

    Code
    rtl8192cu              86016  0
    rtl_usb                20480  1 rtl8192cu
    rtl8192c_common        65536  1 rtl8192cu
    rtlwifi               114688  3 rtl_usb,rtl8192c_common,rtl8192cu
    mac80211              737280  3 rtl_usb,rtlwifi,rtl8192cu

    Du solltest jetzt diesen Treiber

    Code
    rtl8192cu

    blacklisten und den Treiber "8192cu" mit der /etc/modules laden und testen.

    wie Blackliste ich diesen Treiber?

    Z. B. mit:

    Code
    sudo mv /etc/modprobe.d/blacklist-8192cu.conf /etc/modprobe.d/blacklist-8192cu.conf.txt

    und danach rebooten.

    gerade gemacht hier direkt die Ausgabe von lsmod:

    Das heißt jetzt müsste ich dann also die Treiber wieder ändern richtig?

    Mit den Befehlen die da standen oder brauche ich da andere bevor ich mich jetzt ganz verlaufe?

    Die Frage ist, ob der PI den 8192cu überhaupt verwendet hat, denn der ist noch immer beblacklistet.

    Hast Du sofort nach dem Befehl, mit lsmod nachgeschaut, ob der 8192cu verwendet wird?

    leider nein, das heißt noch mal testen wenn ich ihn aus dem Sicherungskasten raus hole, wie hole ich denn den Treiber von der Blacklist runter bzw. was muss ich abändern??

    Wenn Du diese Befehle:

    Code
    sudo modprobe -rv rtl8192cu
    sudo modprobe -v 8192cu

    aus #27 meinst, dann ist dazu zu sagen, dass die Änderungen die mit diesen Befehlen gemacht werden, nicht persistent sind (d. h. nach einem reboot ist alles weg). Diese Befehle kannst Du (z. Zt.) nur dann verwenden, wenn Du zusätzlich zum Zugang per WLAN zu deinem PI, auch Bildschirm+Tastatur und/oder (evtl. auch nur temporärer) ssh-Zugang per Kabelverbindung zu deinem PI hast. Mit einer "perfekten" WLAN-Konfiguration, kann man auch bei _nur_ WLAN-Verbindung, den Treiber entladen und (oder einen gleichwertigen Treiber) wieder laden:

    Code
    sudo modprobe -r rtl8192cu && sudo modprobe rtl8192cu

    Beim entladen wird die WLAN-Verbindung unterbrochen, beim laden wird sich nicht wieder hergestellt. D. h. Du musst was anderes (z. B. cronjob oder timer-unit oder gleichwertig), konfiguriert haben, um die WLAN-Verbindung wieder herzustellen. Aber soweit bist Du mit deinem Pi noch nicht.

    Servus,

    ja das ist das was mich gerade Wundert, da der Pi seit dieser änderung nicht mehr neu gestartet hatte, deswegen verwundert mich das er wieder den alten Treiber nutzt und nicht den 8192cu...

    OK, d. h. lt. der Ausgabe von lsmod wird z. Zt. der Treiber rtl8192cu benutzt:

    Code
    rtl8192cu              86016  0
    rtl_usb                20480  1 rtl8192cu
    rtl8192c_common        65536  1 rtl8192cu
    rtlwifi               114688  3 rtl_usb,rtl8192c_common,rtl8192cu
    mac80211              737280  3 rtl_usb,rtlwifi,rtl8192cu

    Wenn Du mal als Test auch den Treiber 8192cu benutzen willst, dann kannst Du den Treiber rtl8192cu temporär blacklisten, die jetzige Blacklist-Datei "blacklist-8192cu.conf" des Treibers 8192cu richtig umbenennen (damit sie unwirksam ist) und evtl. den Treiber 8192cu via "/etc/modules"-Datei laden.

    Moin,

    Das heißt also das durch die Befehle vom Beitrag #27 sich nix verändert hat obwohl er jetzt einen anderen Treiber nutzen sollte, richtig?? Ist nur eine Frage zur Verständnis, sonst blicke ich nicht mehr durch.

    ich verstehe dich noch immer nicht. Was willst Du mit "den gleichen Treiber" (Mehrzahl?) sagen? Du kannst nicht zwei Treiber gleichzeitig benutzen. Entweder den einen oder den anderen.

    Und eine conf-Datei meinen benutzen zu können, wenn es gleichzeitig auch eine blacklist für den Treiber gibt ... ? ... ob das funktioniert? ... kann man mit lsmod sehen, aber Du wolltest ja diese Ausgabe noch nicht posten.

    Klar gebe ich dir die Info, du versuchst mir ja auch zu helfen, ich habe nur nicht Verstanden welche Info dir gerade fehlt.

    Hier die Ausgabe zu lsmod:

    Ich denke Du hast es noch immer nicht verstanden.

    Schreibe genau welchen Treiber Du meinst und mit welcher Datei (Eintrag dort) Du das power-management für diesen Treiber deaktiviert hast.

    Ja ich denke wir reden gerade dran vorbei, immernoch so wie es in der Anleitung stand Variante zwei, auch mit den gleichen Treiber:

    Nur kurz bemerkt... Bei meinem schon älteren Küchenradio RPi 1B / Jessie verwende ich einen Edimax-WLAN-Stick. Dort existiert die Datei /etc/modprobe.d/8192cu.conf, die ich damals selber erstellte um den Schlafmodus abzuschalten.

    Code
    $ cat /etc/modprobe.d/8192cu.conf
    options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

    Eine Datei blacklist-8192cu.conf gibt es da nicht.

    Code
    $ ls -la /etc/modprobe.d
    insgesamt 20
    drwxr-xr-x  2 root root 4096 Jan 21  2017 .
    drwxr-xr-x 89 root root 4096 Mär 24  2017 ..
    -rw-r--r--  1 root root   46 Mai 27  2016 8192cu.conf
    -rw-r--r--  1 root root  390 Apr  2  2016 fbdev-blacklist.conf
    -rw-r--r--  1 root root   65 Mai 10  2016 ipv6.conf
    -rw-r--r--  1 root root    0 Jan 21  2017 raspi-blacklist.conf

    ABER bei aktuellem Buster (auf einem RPi 3b) ist diese Datei ootb dabei.

    Code
    $ ls -la /etc/modprobe.d
    insgesamt 16
    drwxr-xr-x   2 root root 4096 Nov 18 09:52 .
    drwxr-xr-x 111 root root 4096 Nov 14 18:03 ..
    -rw-r--r--   1 root root   17 Nov  5  2019 blacklist-8192cu.conf
    -rw-r--r--   1 root root   19 Mär  2  2017 blacklist-rtl8xxxu.conf
    -rw-r--r--   1 root root    0 Aug 20 12:39 raspi-blacklist.conf

    Vielleicht hilft das ja irgendwie weiter.

    Servus,

    ja ich danke dir also läuft jetzt so wie du es mir beschrieben hattest auf dem anderen Treiber. Jetzt heißt es warten ob er wieder aussetzt oder diesmal durch läuft, werde mich melden sobald es Neuigkeiten gibt, aber erstmal Dankeschön das du dir Zeit genommen hast für mein Problem.

    Ja, ... er kann den Stick dann auch nicht mehr nutzen, weil der Treiber nicht mehr geladen ist.

    Hab den Pi dann mal aus dem Sicherungskasten ausgebaut dafür^^

    Hier noch der Code:

    Dass der Treiber schon auf deinem PI ist, hast Du doch mit:

    Code
    modinfo 8192cu | grep -i 'v0bdap8178'

    schon gesehen bzw. festgestellt.

    Ich habe doch geschrieben, durch blacklisten des ungewollten Treiber und durch laden (evtl. mit /etc/modules) des andren Treiber. Zum testen kann Du auch manuell entladen und laden. Z. B.:

    Code
    sudo modprobe -rv rtl8192cu
    sudo modprobe -v 8192cu
    lsmod | grep -i 8192cu
    ip a
    iwconfig

    Guten Morgen,

    frage was passiert wenn ich den ersten Befehl eingebe, vergisst der Pi dann das er den Stick nutzen soll?

    Das war nur zur Info und hat keine Auswirkungen. Du musst blacklisten, konfigurieren/optimieren, laden und danach testen.

    Mit:

    Code
    lsmod

    kannst Du auch sehen, welche Treiber z. Zt. benutzt wird.

    Habe gerade versucht die Treiber zu installieren, das System sagt sind die Aktuellen drauf, wie kann ich dem USB Wlan Stick denn nun die neuen Treiber zuweisen?

    Da ist ein kleiner Fipptehler passiert. So passt es:

    Code
    ls -la /etc/modprobe.d

    Hatte ich mir zwar gedacht, aber auch eiskalt 1:1 übernommen :P

    Hier noch die Ausgabe dazu:

    Code
    pi@raspberrypi:~ $ ls -la /etc/modprobe.d
    insgesamt 24
    drwxr-xr-x   2 root root 4096 Okt 27 17:06 .
    drwxr-xr-x 114 root root 4096 Nov 17 20:09 ..
    -rw-r--r--   1 pi   pi    129 Apr 16  2018 8188eu.conf
    -rw-r--r--   1 root root   46 Okt 19 05:43 8192cu.conf
    -rw-r--r--   1 root root   17 Nov  5  2019 blacklist-8192cu.conf
    -rw-r--r--   1 root root   19 Mär  2  2017 blacklist-rtl8xxxu.conf
    -rw-r--r--   1 root root    0 Aug 20 12:39 raspi-blacklist.conf

    Wie sind auf deinem PI, die Ausgaben von:

    Code
    lsusb
    lsmod | grep -i cfg80211
    ls -la /etc/mosprobe.d
    modinfo rtl8192cu | grep -i parm

    ?

    Servus,

    hier die Ausgaben:

    Auch noch mal beobachten, was da zwischen Wlan-Router und Raspi passiert. Mal zur Beobachtung in die Nähe des Routers bringen, feste IP verpassen und ggf. Logdateien des Routers analysieren.

    Kann leider noch keinen Sicherungskasten verlegen von daher muss er leider bleiben wo er ist^^. Router sagt leider gar nichts zumindest nix gefunden warum er die Wlan Verbindung verliert.

    Hast Du einen Link dazu? Vielleicht legt der Stick sich ja schlafen. :conf:

    Was ist die Ausgabe von

    Code
    dmesg

    ? Taucht der Stick dann auf und wenn ja unter welchem Namen? Hier kommt es auf den Treiber an, ggf ist das ein rtl8192cu.

    Ggf. müsstest Du mal neu starten, aber das vielleicht später, falls Du nichts finden solltest.

    Japp, war auf jedenfall die Treiber die mir angezeigt wurden, der Power_Mode wurde auch schon auf off gestellt,

    hie noch die Einträge bei dmesg: