Posts by Rasperli2000


    in
    <code>
    ~/.bashrc
    $HOME/.bashrc
    </code>

    Das dachte ich anfangs auch. Nur log ich mich NIE (das hätte ich erwähnen sollen) davor ein. Dafür nehm ich immer SSH remote.

    Ich wüsste nicht mal mehr das Passwort ;) *zugeb* - Ist 30 stellen lang und in einer Textdatei für den Notfall. Aber da man am PI eh kein USB Keyboard im laufenden Betrieb anschliessen kann, hab ich mir das total abgewöhnt.

    Letztendlich waren die Leute vom Kernelteam zu gut. Bildschirmschoner koste was es wolle. Leider :(

    Hallo.


    Ich bin ein bisschen am verzweifeln. Ich möchte das mein PI, der immer im Consolen Modus ohne X läuft, nicht mehr in den Blankmode umschaltet.


    /etc/kbd/config


    Code
    POWERDOWN_TIME=0
    BLANK_TIME=0
    BLANK_DPMS=off


    Und in der

    /etc/rc.local

    gibt es auch schon ein

    Code
    sh -c 'setterm -blank 0 -powersave off -powerdown 0 < /dev/console > /dev/console 2>&1'

    was ich auf einer Codeschnipsselseite fand.


    Ich hab noch mehr probiert, aber es bleibt eine 600 in der /sys/module/kernel/parameters/consoleblank


    Ich fand noch diesen Hinweis.

    'The only permanent solution is to add "consoleblank=0" to the kernel command-line.'

    Weiss jemand zufällig wo man das einträgt?

    Meine Vermutung war erstmal die /boot/config.txt. Doch auch da blieb der Wert auf 600 und es schaltet weiter auf Schwarz.


    Vielleicht hat noch jemand Ideen.


    PS:


    Ich hab nebenbei eine

    chvt 7
    tail -f /var/log/syslog >> /dev/tty7 &

    in meiner rc.local.

    Deshalb soll der Bildschirm nicht ständig ausgehen.


    jessie


    Oh, toll wie du alle anderen Ratschläge nieder machst. Wir, versuchen nicht Symtome zu bekämpfen, sondern die Ursache herauszufinden, was der deutlich sinnvollerere Weg ist. Und warum symlnken wenn man einfach umbennen kann :denker:

    Ganz einfach. Doppelt hält besser ;)
    Falls SSH mal wegen eines fehlendes Netzwerkes nicht starten mag, könnte es erneut versucht werden zu starten.


    Und ich schrieb ja auch, dass ich den kleinen Fehler vielleicht dabei verschmerze.

    Sowas in der Art, was es aber leider nicht gibt, wäre da sicher besser.
    update-rc.d --always-load SSH --before-start NETWORK

    Mit update-rc.d steh ich aber sowieso auf Kriegsfuss. Ich will eigentlich alles verstehen. Gerade die Startverwaltung. In dem Fall war es gut noch zu wissen wie es arbeitet und doch noch nach den alten Methoden funktioniert.
    Leider versuchen irgendwelche Debianer die immer mehr zu verkomplizieren. Und das völlig unnötig - was zu einem Fork geführt hat.


    Google mal etwas. Du wirst leider das Phänomen finden, dass oft eine Frage gestellt wird, die so auseinander gerissen wird, dass es zu keiner eigentlichen Lösung kommt.

    Das beste ist immer, "Google mal danach" als Antwort ;-). Lustigerweise findet man dann immer den Beitrag immer wieder.

    Und dann so unnötige Diskussionen wie diese ;)


    Niemand kann man es aber recht machen ;) Besonders diesen Spitzohren. ( R.I.P. seufz )


    Zumal ich die Ursache selber bekämpfen wollte, nur aber eben ins System leichter rein mochte.


    Du weisst das jessie für den Pi noch "testing" ist?

    Da ist die Informationspoliitik für den PI zu schlecht. Das lese ich zum ersten mal heute. Und ich Wette, dass wird auch noch ein Jahr so bleiben.

    Auf jedenfalls kam mir wie testing bei der Installation auch vor mit den tausenden Nachfragen vor.
    Nun läuft dieses aber auch wieder perfekt.... Und vor allem stabiler als zuvor noch mit dem weezy.

    Und was siehtst du wenn du einen Monitor + Tastatur am Pi hast, wo hängt er?

    Das habe ich nie gefragt ;) Zur Lösung musste ich erst mal rein kommen. Das hab ich nun so hinbekommen.


    Lösung:

    Code
    # von einem fremden System
    mkdir --parents /media/tmppi
    mount /dev/sda2 /media/temppi
    cd /media/tmppi
    ln -s etc/rc2.d/S03ssh etc/rc2.d/S02ssh


    Die alten Link-Methoden scheinen doch noch weiter zu gehen :)

    Wer hier aber noch eine bessere und saubere Lösung kennt, bitte gerne nennen :)

    Diese jedenfalls war selbst ohne aktives System von hinten herum möglich.

    Ich werde gleich mal auf allen anderen PIs auch nochmal den Befehl so ausführen.

    Code
    ln -s /etc/rc2.d/S03ssh /etc/rc2.d/S02ssh

    Mir ist zwar bewusst, dass es SSH quasi zwei mal starten und vielleicht zu einer unbedeutenen Fehlermeldung kommen könnte/würde. Aber lieber einmal zu viel als das ich wieder die Karte ohne sauberes Unmount rausnehmen muss.


    Die Ursache habe ich auch gefunden, wenn es nur im Hintergrund darum ging. Der WiFi Stick lief nicht mehr. Da nicht mehr vorhanden. Der wurde bei der Installation noch benutzt. Nun bleibt scheinbar alles stehen, wenn nicht alle Netzwerke aktiv sind. Ob das ein "Testing"-Bug ist - ist aber zu bezweifeln. Dir Ursache dürfte aber mehr an der Zwangsumstellung beim Debian-Projekt zu suchen sein.



    Und warum sollte man ssh vor dem Netzwerk starten, das macht keinen Sinn?


    ssh ohne Netzwerk??? Könntest du zwar so starten aber was hilft's?
    ...


    Oh und WIE das Sinn macht(e) bzw. geholfen hat :)

    Gerade in meinem Fall war gerade der Start von Networking das Problem. Es ging zwar online, aber nicht komplett. Also blieb hier das System hängen.

    Ich hatte also ein aktives Netzwerk, während das andere immer noch auf den Adapter scheinbar wartete.

    Durch meinen o.g. symbolischen neuen Link musste ich zum Glück doch nicht das Backup zurückspielen.

    Danach konnte ich mich via SSH einloggen, was selbst direkt an der Hardwareconsole nicht ging und das Problem fix auffinden und lösen.


    Das ist nebenbei nicht das erstemal das ich dieses Problem hatte. Auf PIs "Pappa" (ohje kann man "Pappa" schreiben - sind doch Hermaphroditen) - besser ... der Schnecke (http://de.wikipedia.org/wiki/NSLU2) gab es auch eine Einstellungen - in einem ziemlich chaotischen Dienstmanager - SSH gleich als erstes zu starten.
    Auch das Gerät brauchte von Natur aus sehr lange um zu starten. So konnte man aber schon darauf arbeiten, während noch die externen Datenträger usw. fertig geladen wurden.

    Ohne HDMI/VGA, Keyboard Support oder Steckkarte war das auch bitter nötig!



    Ja, so sind sie, die Jungen Leute, bekommen alles in den A****...

    Ich bin mir sicher du verstöst gegen die Forensregeln ! Oder ist das hier "GTA"?


    ...Raspbian ist nicht Debian. ...

    Code
    deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi

    Es benutzt aber die gleichen Bezeichnungen. Offizell habe ich da auch noch keine Stellungsnahme gelesen, noch eine Warnung es nicht umzustellen. Es läuft auf jedenfall (nach der Upgrade hürde) besser als zuvor. Sorry das ich extra sehr kleingedruckt ein paar Bugs kommentiert habe. Kommt nie wieder vor, wenn man dafür hier gleich ge-"sternt" wird.



    Hallo Rasperli2000,

    eine andere Frage:
    Warum setzt Du ein Betriebssystem ein, dass den Status "Testing" trägt - und wunderst Dich dann, dass Sachen nicht funktionieren, die unter einer "stabilen" Version noch gelaufen sind?

    Ich dachte der PI ist hauptsächlich auch ein Bastel-Gerät. Mut neues auszuprobieren. Und selbst mein durch mein verantwortungsvolles Backup bin ich keinerlei wirkliches Risiko eingegangen.

    Soll sich jetzt jemand eine SD-Karte besorgen, ein ebenfalls unfertiges Betriebssystem installieren, ....

    Die Frage könnte alle beantworten, die schon mit jessie auch auf den PC zu tun gehabt haben. Im nachhinein ist es beim alten zum Glück geblieben :)


    Ich wollte nur wissen, wie man SSH zuerst starten kann. Und habe dazu viel Background gegeben. Um den Hintergrund zu verstehen. Ich war deutlich ausführlicher und damit man den Überblick über das eigentliche Problem behält, hab extra die eigentliche Frage grösserer gestellt.

    Etwas was mich an Foren oft etwas stört sind Gegenfragen - die am eigentlichen Problem vorbeigehen oft nur fragen warum und nie zu einer Lösung führen. Aber das passierte auch hier ausführlich leider wieder. Die eigentliche Lösung fand ich selbst. Aber ich teile Sie, falls jemand mal auch so ein Problem in irgendeiner weise hat. Extra auch hier wieder vergrössert, dass es gleich ins Auge fällt.


    Versuch mal als Test, vor dem Backup zurückspielen, ...

    Danke für den vielleicht auch helfenden Hinweis. Leider schon zu spät. System läuft wieder.

    Hallo.

    Gerade gibt es wieder ein tolles Problem.

    Von weezy auf jessie gewechselt und nun hängt ein job beim start in einer Endlosschleife.

    Netzwerk geht bereits doch SSH wurde noch nicht gestartet. Ich komme ohne Hardware Tastatur nicht heran :( - Auch selbst da komme ich noch nicht heran. - Deshalb werde ich wohl mein Backup zurückspielen und das Dist-Upgrade erneut durchführen müssen.


    Deshalb jetzt diese Frage...


    Wie bekomme ich den SSH-Dienst immer als erstes gestartet?


    Noch bevor der Netzwerkdienst startet?

    SSH ist bei mir sehr sicher eingestellt, selbst ohne Firewall dürfte es hier keine Probleme also geben. Jemand eine Idee?

    Undzwar so das selbst ein nächstes Systemupgrade die Reihenfolge nicht wieder ändert.

    Kann man vielleicht auf einfache Weise einen zweien SSH-Prestart-Dienst einfach erstellen?

    Welches auch eine Umstellung auf das neue Dienst-Start-System "überlebt". Bin mit dem leider noch gar nicht vertraut.


    PS: Kritik an die PI-Paketbetreuer. Das Upgrade von weezy auf jessie ist eine kleine Katastrophe. Soviele conf-Dateien die ich geändert haben soll. Das war hier ein System wo ich gerade mal eine verändert habe. Drei mal musste ich auch den Upgrade Vorgang erneut starten. Mit -f was ich sehr ungern tat. Und das wie gesagt auf einen System das gerade mal eine conf-Einstellung verändert hat. Für nur einen Zweck. Ohne spielerein, wie auf den anderen.

    Hallo.


    Kurz: Ich suche einen Hostfähigen bzw. Soft-AP-Fähigen USB-WLAN Stick der 5 GHz unterstützt.


    Neben meinem normalen WLAN möchte ich nun ein zweites Funknetzwerk für Gäste aufbauen.

    Um mich rechtlich ganz abzusichern, soll diese nur über ein VPN auf einem PI laufen.

    Da viel zu viel auf bei uns auf dem 2.4 Ghz Band los ist, soll dieser eher auf dem 5 GHz arbeiten.

    Kennt jemand hier Ideale Hardware?

    Wäre vielleicht der AVM FRITZ!WLAN USB Stick N 2,4 GHz und 5 GHz dafür geeignet?

    http://www.ebay.de/itm//251784113624

    Und wenn ja, braucht man zwei Sticks für 2.4 und 5 GHz oder könnte der in beiden Bändern gleichzeitig arbeiten?

    Muss ich mir bei diesen FritzStick wegen einer CD-Emulation sorgen machen?