Posts by kle

    Nachdem ich den "schlechten" Zero an das Display des guten gesteckt habe und den "guten" zero an das andere Display habe ich beide laufen und ssh geht auch bei beiden.

    Hallo Martin,

    Ich denke es liegt am Display

    Deine Schlußfolgerungen ist Spekulation.


    Es könnte am Image auf der SD-Karte liegen, es könnte auch an Deiner Treiber-Installation liegen, bei allen Displays wäre Deine /boot/config.txt interessant. Poste die Ausgaben

    von egrep -v "^#|^$" /boot/config.txt von beiden Zeros.

    (Info: Damit werden Kommentar- und Leer-Zeilen unterdrückt.)


    Meine Frage:

    das gute Display und das schlechte Display, welche Displays sind das?

    Bitte poste Links auf die Displays!

    Deine Tests mit (1) "schlechten" Zero an das Display des guten.. und (2) "guten" zero and das andere Display klären nicht,

    • ob der Zero "schlecht" ist oder
    • das Display oder nur
    • das Image auf der SD-Karte oder
    • (seltener) die SD-Karte selbst.

    Schönen Gruß, kle

    Hallo Martin,

    SSH

    Beim SSH ist es egal ob sie über das WLAN oder den USB Port geht, bei beiden geht es nicht. Ich habe einen Ubuntu 18.04 Laptop und bis jetzt an dieser Stelle noch nie Probleme gehabt. Ach ja, mit einem zweiten zero gab es die gleichen Probleme.

    Leider bin ich bei Dir nie sicher, was Du meinst, Du schreibst immer in Prosa anstatt Dateiinhalte, Consol-Ein-/Aus-gaben in Codeblöcken zu posten. Damit nimmst Du mir die Möglichkeit etwas anders zu bewerten als Du es tust.


    Wenn Dein Problem mit ssh nur die Geschwindigkeit im Zusammenhang mit dem Peppy Player auf einem RPi Zero [W] ist, dann vermute ich mal, daß Du Performance-Probleme hast.


    Der Peppy Player frisst CPU-Leistung und braucht Speicher.

    Ich will Dich nicht abwerben, aber NewTron-Radio ist deutlich Resourcen schonender und

    deshalb für RPi Zero [W] geeigneter. Ich betreibe NewTron-Radio auf dem RPi Zero W ohne Display nur mit der RasPiRadio-App.


    Hier mal Info zur Leistungsfähigkeit der Pi-s:

    RPi Zero und RPI Zero W haben Single Core CPUs

    RPi 2B, RPi 3B, RPi 3b+, RPi 3A+ und RPi 4B haben Quad Core CPUs.


    RPi 2B, RPi 3B, RPi 3b+ haben zwar LAN-Buchsen, die sind aber in der Geschwindigkeit begrenzt, weil sie sich den Kanal mit den USB-Ports teilen.


    Nur der RPi 4B hat Gigabit-LAN.


    Speicherausbau ist auch ein Thema,

    512 MB: RPi Zero, RPi Zero W, RPi 3A+

    1024 MB: RPi 2B, RPi 3B, RPI 3B+

    1024 MB oder 2048 MB oder 4096 MB: RPi 4B

    weiteres auf der Wiki-Seite.


    Datei peppy.log ist leer

    nicht, wenn

    Code: ~/Peppy/config.txt
    1. ...
    2. [logging]
    3. file.logging = True
    4. log.filename = /home/pi/Peppy/peppy.log
    5. console.logging = False
    6. ...

    Wann man consol.logging weiß ich nicht sicher. Vielleicht, wenn Tracebacks unter dem Betrieb auftreten.

    Schönen Gruß, kle

    Hallo,

    in config.txt kannst Du Ausgaben in ein Log-File (default ~/Peppy/peppy.log) aktivieren. Ob Du die Tracebacks mit sudo journalctl sehen kannst, weiß ich nicht. Aber, ob Peppy Player läuft, siehst Du mit ps -ef | grep "peppy.py" | grep -v "grep", wenn Peppy läuft, siehst Du eine Zeile

    Schönen Gruß, kle


    Edit: Zugriffsrechte von pygame auf Konsole im nicht-GUI-Betrieb sind ein bekanntes Problem.

    pygame.error: Unable to open a console terminal

    daran kannst Du nichts ändern. veloci hat das NewTron-Radio (auch pygame im Konsol-Betrieb) als systemd service unit gestartet.

    Hallo,

    sei nicht beleidigt über Kritik, Du machst halt, wie alle zu Beginn Anfängerfehler.

    habe mir auf meinen RPi mit 5'' Touchdisplay die aktuelle Cranach installiert (Image).

    Du mußt genaue Informationen liefern, damit wir Dir helfen können.
    (1) Welches Display hast Du poste einen Link.

    Leider bekomme ich mit meinem USB DAC keinen Sound ausgegeben. Ansonsten läuft der Player.

    (2) Hast Du den 3.5mm-Klinkenstecker probiert? Der sollte gehen (schaue auch Punkt 6).

    (3) USB DAC sagt nur Dir was, bitte poste einen Link.

    Ich habe auch all die Anmerkungen hier gelesen und auch ausprobiert. Durch Anpassen der .asoundrc bekomme ich mit der im player.txt angegebenen Kommandozeile für vlc und mplayer auch eine Ausgabe. Nur Peppy gibt keinen Ton von sich?

    Du erzählst "Prosa", das verstehst nur Du.

    (4) Zeige in Codeblöcken (das ist das -Symbol im schwarzen Balken) den Inhalt von ~/.asoundrc und ~/Peppy/player.txt.

    (5) Verstehe ich richtig: VLC und Mplayer spielen Audiodateien für Dich hörbar ab, aber bei Peppy hörst Du nichts?

    (6) Hast Du den Lautstärkeregler (Slider) nach rechts gezogen?

    Danach habe ich versucht Peppy von der Kommandozeile (ssh Terminal) zu starten um mit Ausgaben dem Problem auf die Spur zu kommen. Das Programm wird mit


    pygame.error: Unable to open a console terminal


    beendet

    Wieder der gleiche Fehler: Du berichtest in Deinen Worten.

    (7) Hilfreich wäre Deine Eingabe in die Console/putty-Fenster und die Ausgabe, beides im Codeblock.

    (8) So startest Du als Benutzer pi Peppy in der Konsole cd /home/pi/Peppy; openvt -s -- python3 peppy.py. Peppy darf nur einmal laufen, entweder über Autostart in /etc/rc.local oder von Hand gestartet, wie gerade beschrieben.

    Schönen Gruß, kle


    Edit: Du kennst die ausfühliche Beschreibung vom Peppy Player z.B. Expert Installation. Auf der rechten Seite ist die Spalte Contents, Mit deren Hilfe kannst Du Dich zu Hardware, Software (GUI) und Installation durchhangeln. und

    Hallo,

    Wlan-Unterbrechungen können auch durch ungeeignete Spannungsquellen verursacht werden.

    mit Internet über WLAN braucht der Raspi mehr Strom. Die rote PWR LED soll ununterbrochen leuchten.

    das Netzteil sollte (besonders beim RPi 3B+ und RPi 4B) das original Raspberry Pi Netzeil sein und unter Belastung 5.1V liefern.

    Unterbrechungen im 5GHz-Band können durch Flugverkehr veranlaßt werden (Radar).

    Schönen Gruß, kle

    Hallo,

    ist Dein Raspi über WLAN im Internet?

    Bin Umgezogen und vorher hatte ich Internet über die Telekom

    und jetzt Unitymedia.

    WLAN ist eine Funkverbindung. Was kann eine Rolle spielen:

    • dichter belegtes WLAN (mehr SSIDs)
    • anderer Router
    • großere Entfernung zum Router
    • Wände oder Metall zwischen Router und Raspi

    Schönen Gruß, kle

    Python Script ausführe funktioniert die Steuerung einwandfrei! Hohe Freuqenz, stabiler Rhytmus - so wie ich es mir wünsche.

    Mit dem Python-Skript steuerst Du den Schrittmotor direkt über die GPIO-Pins. Über Web liegt einiges dazwischen.


    (Vorschlag) Wenn Du über HTML/PHP etc. den Schrittmotor steuern willst, solltest Du eine andere Schnittstelle (zwischen Bediener-Oberfläche und Motorsteuerung) definieren (z.B. 250 Schritte nach links).

    Die Motorsteuerung (z.B. auch ein Python-Skript) könnte dann z.B. den Motor langsam hochlaufen lassen, damit (wegen Masseträgheit) keine Schritte verloren gehen. Um dem Anschlag kümmert sich die Motorsteuerung.

    Schönen Gruß, kle

    Hallo Andre,

    Dieser Beitrag ist schon älter, aber klingt genau, wie mein aktuelles Problem..

    Sich in ein bestehendes Thema einzuklinken, ist ein weit verbreiteter "Anfängerfehler".


    Du solltest ein eigenes "Thema" anlegen.

    • Damit ist gewährleistet, daß alle Antworten auf das Thema sich auf ein einziges (nämlich Dein) Problem beziehen.
    • Außerdem gibt es fast immer Unterschiede: neue Raspberry Pi Modelle, neues Raspbian-Betrebssystem, zusätzliche Hardware, ...

    Ein weiterere Anfängerfehler: ein Leser Deines Themas steht nicht hinter Dir, er kennt Deinen Aufbau nicht. Deshalb solltest Du Dein Problem so beschreiben, daß sich der Leser ein Bild machen kann.

    Lies bitte mal Wie Frage ich nach Hilfe? damit Du eine Vorstellung bekommst, was ein Leser wissen muß, um Dir zu helfen.

    ------------

    Model: RPi 3B (oder RPi 3B+)

    Internet: mit LAN-Kabel an Fritzbox

    Programm: ioBroker


    Problem: kein Zugriff über ssh/putty oder Filezilla

    -------------

    Du weißt, daß Du (seit Raspbian vom 25.11.2016) ssh aktivieren mußt (dazu reicht es, eine leere Datei ssh oder ssh.txt z.B. unter Windows auf die SD-Karte zu schreiben). Siehe auch

    Setting up a Raspberry Pi headless.


    Du hast kontrolliert, daß der Raspi in der Fritzbox erkannt wird?

    Schönen Gruß, kle

    nimm die Cranach Edition, die ist auf Raspbian Buster aufgesetzt, und folge dem Edit2 im Beitrag #383.


    Das Disk-Image holbein-waveshare.3.5.zip ist auf Raspbian Stretch aufgesetzt. Deshalb mußt Du anders vorgehen.

    • das Overlay aus dem Waveshare-Installations-Skript LCD-Show (mit git clone https://github.com/waveshare/LCD-show.git) holen (Achtung: nicht installieren)*1 und Treiber an die richtige Stelle mit richtigen Namen kopieren.
      *1 die Installation ist für die grafische Oberfläche
    • in der Konfigurations-Datei /boot/config.txt den Namen des Overlays ändern.

    Es ist also umständlicher und daqnach hast Du den vor-vorigen Stand vom Peppy Player.

    Schönen Gruß, kle

    meine 3 fragen wären nun

    Deine Fragen kann ich nicht beantworten.

    Zu dem Disk-Image für das 3.5" Waveshare-Display kann ich Dir Tipps geben.

    Leider gibt es nicht nur ein 3.5" Touchscreen-Display von Waveshare.

    Vielleicht passt das Installierte Overlay nicht zu Deinem Display.

    • zeige die Ausgabe von egrep -v "^#|^$" /boot/config.txt im Codeblock (das ist das -Symbol im schwarzen Balken)
    • zeige ein Foto der Rückseite Deines Displays

    Schönen Gruß, kle


    Edit:

    hätte ich mal vorher überlegt da man das Display scheinbar nicht richtig befestigen kann

    dann hast Du das falsche Gehäuse, such mal 3.5" touch screen acryl case und wähle eines das zu Deinem Raspi und zu Deinem Display passt


    Edit2: foolhardy

    Das Disk-Image cranach-waveshare.3.5.zip der Cranach Edition ist für 3.5" waveshare LCD(B), Du brauchst ...v2 Dazu gibt es eine Lösung:

    Hole Dir vom Newtron-Radio, Beitrag #1778 von veloci das shell-Skript für Raspbian-Buster waveshare-spi-console-setup.sh, das installiert Dir interaktiv das richtige waveshare-Display.

    fred0815 ich habe den Beitrag aktualisiert

    ich benutze die Lautstärkeregelung der grafischen Oberfläche, die gilt für alle Programme, und lasse die von Peppy Player unverändert (100%).

    • Im Radio-Fenster gibt es einen Slider, damit regelst Du die Lautstärke.
    • Die Peppy/current.txt ist eine interne Datei vom Peppy Player, da merkt 'er' sich beim shutdown die aktuelle Einstellung. Dort solltest Du nicht ändern, außer Du weißt, was Du tust.
    • Damit, daß bestimmte Radiostationen mit impertinent lautem Pegel senden, mußt Du leben.

    Edit: zur Zeit ist die Lautstärke der grafischen Umgebung mit VNC nicht boot-überdauernd, nach reboot ( Himbeere => Shutdown => Neustarten) sehe ich 100%.

    Auch wird mit reboot die Peppy/current.txt nicht gespeichert, Peppy Player speichert sie (vermutlich) nur mit dem -Button


    Edit2: Hintergrund: der Peppy Player ist nicht als Programm auf einem Computer, sondern als einzige Anwendung in einem Gerät gedacht. Deshalb löst der -Button auch einen Shutdown aus. Das kann man in config.txt ändern mit poweroff = False.

    fred0815 das hat was mit dem Pfad zu tun, Du mußt im richtigen Verzeichnis sein.

    Edit: 'er' findet sonst die Konfigurationsdateien nicht.

    cd ~/Peppy

    python3 ./peppy.py &

    Schönen Gruß, kle

    fred0815 der Autostart vom Peppy Player funktioniert

    1. Peppy Player in Desktop/GUI integrieren, da nur den Spoiler so geht's in 8. Peppy Player ins Desktop Menue integrieren durchführen. Das Ergebnis sieht dann so aus:
      Info: NewTron-Radio war schon installiert


    2. eine Desktop-Datei erzeugen lassen: mit der rechten Maustaste auf Peppy Player klicken und Add to desktop, die sieht so aus

      und enthält:

      Code: ~pi/Desktop/peppy-player.desktop
      1. [Desktop Entry]
      2. Type=Link
      3. Name=Peppy Player
      4. Icon=peppy-player
      5. URL=/usr/share/applications/peppy-player.desktop
    3. Wir brauchen nur die letzte Zeile für die kommandos:
      mkdir ~/.config/autostart
      cp /usr/share/applications/peppy-player.desktop ~/.config/autostart
      Damit ist der Autostart eingerichtet.

    Schönen Gruß, kle

    Hi,

    ohne die Datei util/config.py zu ändern kann man Peppy auch auf der grafischen Oberfläche starten. Dann mußt Du die Enviroment-Variable SDL_VIDEODRIVER vor dem Aufruf von Peppy auf x11 setzen .

    --------------------

    You can launch Peppy on desktop/GUI without changes in util/config.py. But then you have to set environment variable SDL_VIDEODRIVER

    ----------

    Beispiel/Example:

    Start Peppy Player on Desktop/GUI with

    cd /home/pi/Peppy; SDL_VIDEODRIVER=x11 python3 ./peppy.py &

    -----------

    Der Vorteil der Codeänderung ist, daß dann automatisch erkannt wird ob Peppy auf einer grafischen Oberfläche läuft oder auf einer Konsole/CLI. Und zwar je nachdem ob die Environment Variable DISPLAY existiert.

    ---------

    Advantage of code modifikation is the automatic detetion of Desktop/GUI or Console/CLI environment with the existance of DISPLAY


    Edit

    One code for both environments. You must not remember to set SDL_VIDEODRIVER


    Regards, kle