Posts by synth

    Moin Bernd,

    hab ich bereits zum Laufen bekommen ... muss morgen nochmal schauen wie genau,

    versuche gerade den Part "Webradio" wieder zum Laufen zu bekommen.

    Aber genug für heute. :)

    Okay, ich habe jetzt mal alle Ursprungseinstellungen wieder rein gesetzt und das mit der main.c hat geholfen.

    Hammer allerdings noch, ich habe bei Lautstärke 30 (wie im Tutorial drin steht) nix, was ich höre (entspricht Lautstärke 3), maximale Lautstärke bei mir 15.


    Nachdem ich mir zwischendurch mein Design zerkloppt habe fange ich da jetzt wieder an ... aber dem "ordentlichen" Radio ist jetzt nichts mehr im Weg. :) Ach ja und rausfinden, wie ich den Mikrofon-Eingang direkt auf den Ausgang meiner USB-Soundkarte "umrouten" kann ... das fehlt leider auch noch. :(

    Okay,

    der sdaPin dürfte inkorrekt sein, habe ihn jetzt laut dieser Belegung auf BCM2 im Code geändert, und ich bekomme eine sinnvolle Veränderung.

    Allerdings funktionierts noch immer nicht ...

    Code
    pi@rpi3-radio:~/RdSpi $ i2cdetect -y 1
    0 1 2 3 4 5 6 7 8 9 a b c d e f
    00: 03 04 05 06 07 08 09 0a 0b 0c 0d 0e 0f
    10: 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f
    20: 20 21 22 23 24 25 26 27 28 29 2a 2b 2c 2d 2e 2f
    30: 30 31 32 33 34 35 36 37 38 39 3a 3b 3c 3d 3e 3f
    40: 40 41 42 43 44 45 46 47 48 49 4a 4b 4c 4d 4e 4f
    50: 50 51 52 53 54 55 56 57 58 59 5a 5b 5c 5d 5e 5f
    60: 60 61 62 63 64 65 66 67 68 69 6a 6b 6c 6d 6e 6f
    70: 70 71 72 73 74 75 76 77

    das sollte so schonmal nicht aussehen, wenn ich im Test jetzt den Reset durchführe erhalte ich folgendes:

    Interessant finde ich, dass da jetzt steht, dass es sich um einen Si4702 handelt ... muss ich das irgendwo intragen?
    Das Tuning steht dort jetzt auch, kann dieses aber icht wie im Tutorial beschrieben verändern.

    Hallo liebes Forum,

    ich bin seit einiger Zeit dran ein Radio zu bauen, als Basis nutze ich CarPi, aber so weit bin ich noch nicht.


    Ich habe mir schon vor einiger Zeit ein Radio-Modul besorgt und hatte es mit wenig Zeit schonmal ausprobiert und bin nicht sehr weit gekommen. Jetzt habe ich mich erneut hin gesetzt und probiert und bekomme das Teil nicht zum Laufen ...


    Als Anleitung habe ich diese hier verwendet

    Bis zum "Test" läuft alles, wie im Tutorial beschrieben.

    Wenn ich mit dem Test los lege fangen die Probleme an.


    Wenn ich jetzt den Reset ausführe war es das. Fehlermeldung:

    Code
    Unable to read Si4703!
    Communication error

    wenn ich erneut "i2cdetect -y 1" ausführe wird mir die Adress-Matrix komplett mit Strichen angezeigt.


    Verwenden tue ich einen rPI3 mit Raspbian Jessie.


    Hat jmd. eine Idee, was da falsch läuft?

    Danke, LG Ralf

    Hallo Outlaw,

    leider nicht und mit einem anderen Treiber hab ich es auch nicht zum Laufen bekommen. :(


    Habs nochmal auf nem ATOM probiert, da läuft der Treiber (selbstverständlich), auf dem Pi leider nicht, wobei sich die Fehlermeldungen geändert haben ...

    bin jetzt an dem Punkt, dass ich die Meldung bekomme:

    Code
    # PDF-BANNER
    Template defaul-testpage.pdf
    Show printer-name printerinfo printer

    bzw. alternativ:

    Code
    Die PDF-Daten werden für einen direkten Druck nicht unterstützt:1000

    ... habe dann versucht etwas zu drucken, nur Seitenweise Steuerzeichen ... vllt. finde ich ja noch was
    ich bleibe auf jeden Fall dran. :)

    Hallo Ihr Lieben,

    ich habe einen brother-Drucker (MFC-9142cdn), für welchen bei brother auch Linux-Treiber bereitgestellt werden.

    Jetzt habe ich mir die "cups wrapper"-Datei gezogen, welche er aber nicht installiert, weil ja für 386er-Struktur und nicht für arm.


    http://support.brother.com/g/b…n_eu&os=128&flang=English


    So weit so gut.

    Nun habe ich mir diese angeschaut und auch eine ppd-Datei gefunden und extrahiert. Wenn ich jetzt über localhost:631 gehe, kann ich den Drucker installieren und alles scheint fein, allerdings kommen nur Seiten raus, auf denen steht:


    ERROR : Brother LDP filter is not installed.

    Restarting cups (via systemctl): c


    mehr steht leider nicht auf den Seiten ... wie bekomme ich die Kiste endgültig zum Laufen?

    Drucker ist im Netzwerk, also nicht via USB angebunden.


    THNX, LG Ralf aka synth

    Hallo STF,

    der Drucker ist ein Brother, ich bin mit der Kiste äusserst zufrieden. Es gibt diverse Möglichkeiten ins Netzwerk und auf Server zu scannen. FTP reicht hier vollkommen. Alles Weitere bedeutet unnötig Aufwand. Aber das ist ja nicht das "Problem".


    Auf dem Pi laufen verschiedene Dinge ... pi-hole, eine Download-Software (Online-Video-Recorder) [verschlingt wohl am meisten], + halt der FTP, dank pi-hole ein Webserver ...


    Samba ist toll, aber wenn ich eine "einfache" Lösung habe, dass ich Samba nicht installieren muss, dann ziehe ich diese Lösung vor wie hier via SSH, bzw. SFTP.


    ;)


    LG Ralf

    Huhu RTFM,

    der Drucker, bzw. Scanner bietet u.a. (indiskutabel) FTP an, ich denke er erstellt das File im internen Speicher und schiebt es dann rüber.


    Bernd ... ja alles tolle Tools, nur leider für die Tonne ... das einzige wirklich gute Tool war der sshfs-Manager, der ja leider nicht mehr funktioniert. :(


    DirectNET Drive scannt den gesamten Speicher vom rPI, was nervig ist und


    swich .. na ja ...

    ich bin aber noch aufstfp netdrive gestoßen ... das ist echt gut!

    https://www.medienpaedagogik-p…ndows-explorer-einbinden/

    http://www.sftpnetdrive.com/


    LG Ralf aka synth

    Also, Grundnutzen:

    rPI als kleiner Server auf dem mein Multi-Drucker gescanntes oder per Fax eingegangenes abspeichert.

    Zugriff mit Windows-Rechnern auf diesen Server möglichst als Laufwerk. FTP-Client hat sich im täglichen

    Umgang nicht bewährt.

    Ursprünglich hatte ich - wie im verlinkten Beitrag versucht - mit dem sshfs-Manager den Zugriff für die

    Windows-Rechner realisiert (hier brauchte ich keine neuen Rechte oder dgl. setzen, habe nur bei den jeweiligen

    Rechnern definiert in welche Pfade sie dürfen). Der Drucker hat Zugriff via FTP. Somit hatte ich nur einen Zugriff

    für den Drucker eingerichtet.


    Jetzt beim erneuten einrichten erhalte ich zwar via FTP-Client Zugriff auf den eingerichteten Account,

    aber der FTP-Client vom Drucker bekommt keine Schreibrechte und Windows über die bordeigenen Möglichkeiten

    erhält auch nur Leserechte. Da ich zwischendurch auch mal Daten vom Win-PC rasch auf den rPI2 drauf schieben

    möchte um von einem anderen Computer darauf zugreifen zu können (ohne dass beide Computer laufen), ist

    das mit den Schreibrechten natürlich notwendig. ;)


    THNX, LG Ralf aka synth

    Hallo Ihr Lieben,

    nachdem der Zugriff via SSH mit dem SSHFS-Manager leider scheitert und ich eh einen FTP-Zugang für meinen Drucker benötige versuche ich jetzt den einfachen Weg via FTP zu gehen. Win ermöglicht mir ja auch hier sogar einen Systemintegrierten Zugriff, was mir letztenendes reicht.


    Da der rPI2 in einem eigenen Netzwerk hängt reicht mir ein einfacher Zugang über den Benutzer PI.


    Ich habe das Ganze jetzt mehrfach durchgespielt nach verschiedenen Anleitungen ... u.a.:

    http://praxistipps.chip.de/ras…einrichten-so-gehts_29526

    https://tutorials-raspberrypi.…lation-teil-5-ftp-server/


    Ich habe mittlerweile zwar Zugriff mit Windows, erhalte aber keinen Schreibzugriff.

    Sind die Tutorials korrekt oder ist da ein Fehler drin?


    Allgemein muss ich sagen, dass ich mit solchen Tutorials immer auf Kriegsfuß stehe.

    Hab schon einiges bzgl. Samba und FTP durch ... und fahre damit immer an die Wand.


    THNX, LG Ralf aka synth

    UPDATE 2.1.2018 - sorry wg. Doppelpost, aber sonst bekommts keiner mit.

    Hallo Ihr Lieben,

    so ich habe jetzt endlich mal mein Notebook raus gekramt und auch das meines Vater mir "einverleibt" und selbes Problem. Somit definitiv nicht sshfs das Problem, sondern wirklich der rPI2.

    Ich habe Spaßeshalber die alte microSD mal rein geschoben und siehe da, ich komme wieder drauf.

    Auf der alten ist ein mittlerweile ziemlich verbogenes Wheezy LITE drauf, auf der neuen selbstverständlich ein aktuelles Stretch LITE.


    Gibt es irgendeine Möglichkeit nachzuvollziehen, was bzgl. SSH geändert wurde? Ich habe zwar eine andere Software gefunden, welche das macht, was der sshfs-Manager macht, allerdings ist diese saulangsam, scheint auch einmal komplett den rPI2 zu spiegeln, versucht nämlich erstmal im Laufe der Zeit auf alle Ordner einmal zuzugreifen. Schön ist somit anders.


    Danke, LG Ralf aka synth


    PS: Wünsche allen ein frohes und gesundes neues Jahr!

    dbv ... autsch ... ja hast recht ... ich bin schon blind.


    RTFM ... ich hatte bei einem test-rPI2 wo ich mein neues System drauf aufgesetzt habe versucht das Laufwerk zu mounten. Da war wohl ein Fehler in den Zugangsdaten und danach kam nur noch die Meldung. Also werde ich mal die Software runter schmeissen und neu insallieren. In er Hoffnung, dass da irgendwelche Fehleinträge irgendwo sind.



    EDIT:

    und nein, es wurde auch nix verändert am System. :)
    Ich komme auch auf meinen anderen PI drauf ohne Probleme.


    Allerdings muss es irgendwie dennoch mit dem System zusammenhängen auf dem Pi, weil ich jetzt den Pi gewechselt habe, und die Speicherkarte getauscht habe ... also Ursprungskonfiguration:


    PI1 mit Produktiv-System

    PI2 mit Test-System


    Auf PI2 mit Test-System konnte ich nicht mehr zugreifen, auf PI1 mit Produktiv-System aber schon,

    jetzt habe ich das Test-System in PI1 und es bleibt dabei, komme nicht rauf.

    Und ... eine komplette Deinstallation von sshfs hat nichts gebracht, habe auch die REG gereinigt und sämtliche Files die zu finden waren entfernt. :(

    Werde morgen endilch mal mein Notebook auspacken und mit dem nochmal schauen, ob es läuft.


    THNX für den Anfang, LG Ralf aka synth

    Hallo Ihr Lieben,

    nachdem ich meinen rPI2 komplett neu aufgesetzt habe, gibt es ein Problem.


    Ich greife mit meinem Windows-Rechner mit dem SSHFS-Manager (0.0.1.5) normalerweise auf meinen kompletten rPI2 zu.

    Jetzt funktioniert das aber nicht (mehr).


    Egal, was ich mache, ich erhalte die Fehlermeldung:

    "rPI2 could not connect:

    An estabilshed connection was aborted by the software in your host machine." :@;(


    Gibt es irgendeine Möglichkeit, irgendein Log, wo ich im rPI2 die Fehlermeldung nochmal habe und raus bekomme, was genau da passiert ist, dass er mir den Zugriff verweigert? Per SSH mit putty oder SFTP habe ich Zugriff. :daumendreh2:


    Gefunden habe ich den SSHFS-Manager damals dank diesen Beitrags: https://linuxundich.de/gnu-lin…sftp-transparent-windows/

    Bis heute hatte ich weder auf W7, WXP oder W10 keinerlei Probleme.


    Auf dem rPI2 habe ich die aktuelle raspberrian-Version, alles auf dem aktuellen Stand von vorgestern.


    Danke Euch und schonmal einen guten Rutsch in das neue Jahr,

    LG Ralf

    Das Problem liegt sozusagen im Ordner /media/pi/, also auf der SD-Karte und nicht auf den gemounteten.

    Auf SDA5 und SDB2 schreibe ich aktiv daten und lösche sie auch, ich kann aber nicht in /media/pi/ schreiben ...


    Interessant ist allerdings folgendes ... ich habe sozusagen als "Backup" in /media/pi/ eine .inf-datei liegen.

    Diese konnte ich soeben löschen, danach konnte ich auch wieder meine Datei via touch erstellen ... Zufall?

    keine Ahnung, jetzt funktionierts aber komischer Weise "alles" wieder. *amkopfkratz*

    Hallo Ihr Lieben,

    ich bin gerade vor ein paar Tagen aus dem Ausland wieder zurück gekommen und hatte unterwegs schon ein paar Probleme mit meinem zu Hause laufenden Pi, weil das Dateisystem auf einem Datenträger nicht mehr ganz sauber war.

    Nachdem ich dieses Problem behoben habe und den Datenträger, der jetzt leider nicht mehr als SDA1, sondern SDA5 im System eingehangen ist, wieder in meine Scripte eingeplfegt habe, gibt es ein kleines Problem.


    Laut raspberrian ist der Speicher /media/pi/ "voll".

    Ich möchte an dieser Stelle eine leere Text-Datei erstellen mit dem Befehl touch und bekomme die Rückmeldung, dass: "DATEINAME" kann icht berührt werden: Auf dem Gerät ist kein Speicherplatz mehr verfügbar


    Wenn ich jetzt schaue, wie viel Patz noch verfügbar ist mit DF -m /media/pi/ liefert er mir zurück, dass 7298 MByte also insgesamt 49% noch verfügbar sind.

    Getestst mit Aktivuser- mit dem das System läuft, mit user Pi und als root.


    Ich habe gerade keine Idee, bin aber wie ich zugeben muss auch jedes Mal wieder wenn ich 5 Monate weg war ziemlich eingerostet, habe vor Ort weder Zeit noch möglichkeiten mich mit Linux zu beschäftigen. :(


    Danke schonmal, LG Ralf aka synth

    Hallo Ihr Lieben,
    ich habe mir CarPi geschnappt, weil das ganze Paket schon das beinhaltet, was ich benötige ... aber an ein paar Punkten komme ich nicht weiter und hoffe auf Eure Hilfe ...
    zur Anwendung ... es ist bei mir ein "Küchenradio" mit etwas mehr Funktionen ...
    aktuell verwende ich:
    - FM-Radio
    - Musik (auch für Webradios)
    - Wetter
    - Favoriten (z.B. für die Webradio-Streams zum direkt auswählen, aber auch um bestimmte Alben direkt auswählen zu können).


    Jetzt möchte ich so etwas wie einen Timer oder die Alarm Clock (welche es als Add-On gibt) in die Oberfläche einbinden, weiss aber nicht, was ich für die Alarm Clock aufrufen muss hinter dem Button.
    Ich habe auch ein nettes Evernote-Plugin gefunden, was aber anscheinend leider nicht funktioniert. :(
    Kennt hier jmd. etwas vergleichbares? Muss auch nicht unbedingt via Web synchronisiert werden, geht mir nur darum "persönliche" Kochbücher auf den Screen zu bringen. ;)


    THNX 4 Help,
    LG Ralf aka synth