Posts by synth

    Ok, Daten werden zusätzlich gesichert, bis auf Kontakte und Termine sind hier aber nur relativ selten Änderungen.
    Wenn der Server stirbt sind diese aber auf den Geräten noch vorhanden, also nicht wirklich schlimm.


    Die meisten Daten in der Cloud speichere sind nur intern, hin und wieder mal ein File extern, aber meist
    nur kleine Office-Files oder Text-Files.

    Hallo Ihr Lieben,
    ich habe einen rPI2 mit einer Speicherkarte, auf der Raspbian drauf installiert ist.
    Angeschlossen ist ein 128 GB USB-Stick als externer Speicher und eine 3TB Festplatte,
    welche ebenfalls per USB angeschlossen ist und über den rPI2 ein und ausgeschaltet
    wird. Ausserdem ist noch ein LCD 20x4 angeschlossen, welches mir einige Informationen
    ausgibt.


    Aktuell hängt das ganze relativ lose aneinander. Ich möchte jetzt alles in ein HTPC-Gehäuse
    einbauen ... hierbei soll anstatt dem 128GB-USB-Stick durch eine SSD ausgetauscht werden
    und diese wenn möglich über einen SATA-Port (wie z.B. diesem hier) angeschlossen werden.


    Grundgedanke, ich möchte so viele USB-Ports wie möglich "frei" lassen, um diese in dem neuen
    Gehäuse extern nutzen zu können, um im Fall z.B. Maus&Tastatur anschließen zu können,
    oder eine externe HDD, oder ein Laufwerk oder oder oder. Auch ganz bestimmte "Steuerufnktionen"
    möchte ich mit verschiedenen USB-Sticks verknüpfen, weshalb ich ein paar mehr Ports benötige,
    aber keinen HUB nutzen möchte.


    Die Festplatten, also auch die SSD sollen in den Einschüben wechselbar sein, wie zum Beispiel
    mit diesem hier und mit diesem.


    Da die 3TB-HDD weiterhin geschaltet sein soll, wird sie weiterhin am USB hängen, denke mir,
    dass das das sinnvollste ist.


    Grund für die Wechselrahmen und das Gehäuse,
    a) es soll "schön" aussehen
    b) ich möchte HDD, wie auch SSD rasch raus nehmen und insbesondere die HDD einfach austauschen können.
    c) ich möchte das Gehäuse mit allem drum und dran auch mal einfach transportieren können, um es wo anders
    zum Einsatz zu bringen.


    Ach ja, die Kiste zieht von einem online-Video-Recorder die aufgenommenen Videos auf den USB-Stick (später SSD)
    und wenn dieses Medium voll ist auf die 3TB-HDD.

    Hallo Ihr Lieben,
    ich möchte (aus diversen Gründen) einen OwnCloud-Server bei mir im heimischen Netzwerk einrichten.
    Da der rPI ja Netzwerkseitig ziemlich schwach auf der Brust ist, liegt der Gedanke nahe auf eine andere
    Basis auszuweichen, ich dachte z.B. an einen BananaPI ...


    da ich bestimmt nicht der erste mit einer Überlegung dieser Art bin wollte ich mal fragen, wie Ihr das sehr,
    gibt es noch etwas was besser als ein BananaPI passen könnte oder ob ich irgendwo einen Denkfehler
    habe!?


    Wofür möchte ich die OwnCloud verwenden:
    - Kontakt-Synchro
    - Termin-Synchro
    - File-Synchro
    - Mehrere User


    Als Speicher sollen zwei USB-Sticks genutzt werden, einer für das BS (wenns beim BananaPI geht) und ein zweiter für die Daten dann.


    Hauptsächlich wird zu Hause im eigenen Netzwerk synchronisiert, was die File-Synchro betrifft ... Kontakte und Termine auch von ausserhalb.


    Danke Euch, für Eure Meinungen, Ideen ... Sichtweisen ...
    LG Ralf aka synth

    sorry, korrektur
    "su pi -c screen ...." kommt davon, wenn man aus dem Kopf schreibt ... sudo braucht ich ja in der rc.local nicht. :)


    dennoch bleibt die Frage, wie ich automatisch mit der Konsole am pi den Screen wieder attache ... hab jetzt wie ein blöder gesucht ... aber keine Idee ...

    Ok, so weit so gut ... läuft ... nur ein Problem hab ich noch ...
    ich starte weiterhin meinen Screen und das Script in der start.sh ...

    Code
    sudo su pi -c screen -dmS loader /home/pi/downloader.sh


    in der .bashrc vom user pi mache ich beim Starten ausserdem ein "screen -r", damit die Konsole zum Screen attached ist.


    Wenn ich mich jetzt einlogge via SSH kann ich den Screen von der Konsole detachen und zu meiner SSH-Session attachen ...
    wie bekomme ich ihn aber (nach dem detach via SSH) wieder automatisch attached an die Konsole?


    Hintergrund, am Pi hängt zwar kein Monitor und nix, aber im Fall aller Fälle soll jemand bei mir zu Hause wenigstens einen Monitor
    ran hängen können, um zu schauen was los ist.


    Crontab (dache ich so, einfach alle 15 Minuten, wie oben mit sudo su pi ....) funzt nicht, ein kleines Script, welches ich automatisch über .bashrc anstatt dem "screen -r" ausführe, welches im Hintergrund läuft und nach SSH-Logout das "screen -r" ausführt funktioniert auch nicht, weil das Script nicht auf der Konsole (sondern halt im Hintergrund) ausgeführt wird.

    Okay, ... dann schau ich mir das nachher nochmal in ner ruhigen Minute an ...
    die sudos sind zwar überflüssig ... sind aber noch aus der Zeit des manuellen Testens drin ... manchmal muss ich die sh auch manuell ausführen ... da ist es dann sinnvoll. ;)


    das mit dem rs.local ... ich wusste ich hab was vergessen ... erklärt das natürlich eindeutig.


    screen -list ... wie beschrieben, schaue nach sessions ... da ich keine gefunden habe, kann ich auch nicht attachen ;)


    Muss erstmal weiter packen ... melde mich bevor ich abhaue nochmal oder von unterwegs. :)


    Danke Dir meigrafd!

    Das hängt in der /etc/rc.local (sorry, wollte ich noch schreiben, habs vergessen)
    Dort wird einfach nur /home/pi/start.sh ausgeführt, was auch geschieht.


    Wenn ich mich per SSH anmelde suche ich über "screen -list" nach den existierenden Sessions


    die downloader.sh startet nur ein pythonscript mit python2 /home/pi/HiScri/dl.py

    Ich habe Screen bisher gar nicht gestartet ...


    Wenn ich es von Hand so aufrufe funktioniert es, wenn ich es automatisch in meiner "start.sh" aufrufe funktioniert es nicht. :(


    ich glaube da die Kiste jetzt zuverlässig läuft sollte ich aber auch nicht mehr fummeln ... werde also nix mehr machen ... nur noch heute und morgen Sachen packen + aufräumen + Kleinkram und ich bin weg ... die Baustelle nehme ich mir für das nächste Mal vor, sollte ich
    den rPI dann überhaupt noch als Downloader nutzen.

    Hallo Ihr Lieben,
    ich bin bald wieder für längere Zeit weg, mein rPI2 läuft so weit, eine kleine Verbessung würde ich aber gerne noch machen ...


    kurz was er macht ...
    beim starten des rPI2 werden von einer sh verschiedene py-Scripte gestartet, welche externe Tasten überwachen, ein LCD ansteuern, die Funktion einer externen HDD steuern (un-/ mounten, ein- / ausschalten, etc.) und zum Schluss wird ein Script gestartet, welches dauerhaft auf der Konsole angezeigt wird (ein Download-Script).


    Ich habe die Möglichkeit mit per SSH einzuloggen, um Änderungen/Korrekturen durchzuführen, oder aber herrunter geladene Dateien zu löschen, etc..


    Jetzt habe ich "screen" für mich entdeckt" ...


    Besteht die Möglichkeit den Startprozess so umzubauen, dass vor dem Download-Script ein "screen" eröffnet wird und das Download-Script in diesem geöffnet wird?


    Wenn ich per SSH auf den rPI2 drauf gehe könnte ich dann nämlich diesen "screen" reconnecten, um in die Bildschirmmeldungen des Download-Scripts rein zu schauen.


    Leider blieb meine Suche ergebnislos ... wichtig ist auch, dass das Download-Script nicht einfach erneut ausgeführt wird, wenn ich einen neuen "screen" auf mache (warum auch immer).


    THNX, LG Ralf aka synth

    So, WatchDog läuft ...
    hat die Lasteinstellungen für die CPU nicht übernommen ... warum auch immer, keine Ahnung.
    Hab die Config nochmal neu gemacht und jetzt läuft er ... ist aber schon komisch ... den WatchDog auf dem Test-Pi eingerichtet (lief komplett), Karte in den Betriebs-Pi rein ...
    *amkopfkratz*


    Jetzt nur noch eine Sache und ich kann für ein paar Monate wieder verschwinden. :)
    THNX, LG Ralf aka synth

    Okay, also erstmal uname -a
    der rPI2 auf dem es funktioniert:
    Linux MYPI2 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv71 GNU/Linux


    der rPI2 auf dem es NICHT funktioniert:
    Linux MYPI2 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv71 GNU/Linux


    die config.txt ist identisch ...
    ... auch in raspi-config die Einstellungen sind identisch ...
    Einziger unterschied, der eine rPI2 werkelt aktiv, der zweite wird nur zum testen betrieben, die eigentlichen Aufgaben sind ihm also verwehrt (weil ich ihn nicht dazu kommen lasse sie auszuführen, bzw. die Hardware auch nicht angeschlossen ist ...


    Ich habe ein 1:1 Image auf zwei Speicherkarten, aber auch wenn ich die Speicherkarte vom einen zum anderen umstecke ... funktioniert der Watchdog, oder halt nicht.


    Als Hardware versteht sich hier folgendes:
    Nutzung der GPIO-Pins mit zwei selber gelöteten Platinen (eine zum Schalten von Relais, eine zum Steuern von Taster-Eingaben und einem LCD), USB-Stick zum zwischenspeichern und eine externe 3TB-HDD, welche über die Relais eingeschaltet und abgeschaltet wird).

    Hallo Ihr Lieben,
    ich bereite wieder eine längere Abwesenheit vor.


    Jetzt wollte ich auf meinem rPI2 schon den Watchdog aktivieren, bin aber immer gescheitert.
    Benutzte Anleitung: http://kd8twg.net/2015/10/30/r…chdog-on-raspbian-jessie/


    Nächster Test war, dass ich die Speicherkarte in meinen zweiten rPI2 gesteckt habe, hier konnte ich
    den Watchdog ohne Probleme starten.
    Getestet habe ich
    a) über eine manuell angelegte Datei und
    b) über den CPU-Load, welchen ich künstlich hoch gejagt habe, Abbruchwert war hier ein Load von 5 für 1 Min.
    Es läuft ein raspbian jessie auf dem rPI2.


    Beides hat den rPI2 erfolgreich neu gestartet.
    Stecke ich diese microSD jetzt wieder in den "ersten" rPI2 kann ich den Load hoch jagen, wie ich will (Abbruchwert
    ebenfalls im Moment auf 5 für 1Min gesetzt, LOAD-Wert aktuell auf 16 für 1 Min)



    Auch die Dateiüberwachung spricht nicht an.
    Wenn ich versuche den Dienst von Hand zu starten, dann wandert der Cursor nach dem "Enter" in die nächste
    Zeile, mehr nicht, keine neue Eingabeaufforderung, nix ...


    Ist der "erste" rPI2 fehlerhaft? Ich weiss nicht mehr, was ich noch wo suchen soll/ausprobieren soll.


    Danke, LG Ralf aka synth


    PS witziges Profilbild, weisses L BG und Blitz, könnte glatt ich sein, aber dann müsste ich mich rasieren :)


    Danke ... müsste ich auch im Moment *g*
    allerdings ist es noch die alte Cam mit dem alten BG und ich glaub sogar dem alten Speedlite ... nur das Objektiv ist bis heute geblieben. :)

    Okay, nach vielem hin und her ... es hat sich herrausgestellt, dass bei einem der Datenpins (gilt für sämtliche Kontakte) eine notwendige Verbindung von der Vorder- zur Rückseite der Platine fehlt ...
    Verbindung hergestellt, läuft.


    Danke allen für die Hilfe.



    EDIT: Hier auch noch ein Bildchen, natürlich noch im Testmodus ... alles dahinter funktioniert bereits tadellos ... habe allerdings viel für die Bedienung und Anzeige nochmal ändern/anpassen müssen, ein paar Hintergrundprozesse ... so schauts im Teststadium aus (und zwar nicht ganz so hängend, aber deutlich nach Bastelprojekt aussehend noch bis in den Oktober hinein) ... dann kommt ein vernünftiges Gehäuse und noch eine Menüführung für ein paar Funktionen dazu.



    Aktuell hier zu sehen:
    Aktuelle Zeit + Datum,
    Speicherauslastund eines angesteckten USB-Sticks, sowie einer angeschlossenen (nicht laufendenden) 3TB HDD.
    CPU-Temperatur + Taktfrequenz
    Betriebsmodus (download von Files aus dem Internet auf den USB-Stick) ... das Omega bedeutet, dass jmd. per SSH eingelogt ist.


    über den schwarzen Taster kann man sich noch den freien Speicherplatz auf dem USB-Stick, wie auch den belegten anzeigen lassen.
    Ebenso den freien und belegten Speicherplatz der HDD (wird auch mit aktuellen Daten angezeigt, wenn die HDD abgeschaltet ist).


    Über den roten Taster kann die externe HDD manuell ein-, selbstverständlich dann auch wieder ausgeschaltet, der rPI neu gestartet und komplett herrunter gefahren werden.
    Das Display zeigt immer die IST-Werte an, wird aber nur aktualisiert, wenn die Werte sich auch wirklich geändert haben.


    Warum das Ganze?
    Nutze einen Online-Videorecorder und bin immer zwischendurch für längere Zeit (jetzt dann mal wieder ab Ende Mai bis Anfang Oktober) nicht zu Hause.

    Nee, kontrolliert ... aber was neues ... hab eben nochmal auch die Katanazeichen in Ruhe durchgetaktet ...
    0b11110000 bis 0b11111111 also die letzte Spalte ist ebenfalls komplett betroffen ... doch Anschlusskabel-Fehler?
    Beim durch messen war alles ok ... *amkopfkratz*


    Die rot markierten Bereiche sind betroffen ...